Sign in to follow this  
Woopert

Just a few questions regarding Blender and Unity

Recommended Posts

Oh, I don't think that's what I meant. Here's another screenshot. I highlighted the edges that I want to change. Basically I want them to go from being basic edges to being solid tubes. How would I go about taking the edges I made by using the F key and make them into actual tubes with geometric depth?

Thanks

3MfmQ9C.png?1

Share this post


Link to post
Share on other sites

If you patch up the holes(shift+select each triangle and press F. This will need to be done for each triangle individually) you can then add the wireframe modifier to create your lattice/truss. Another way would have been to seperate each edge from eachother and convert the whole thing to a curve object. You could then push that out by increasing the depth parameter under the curve settings and setting fill to Full.

Blenders tools work mostly with polygons and dont usually know what to do with just plain edges and verts. You do have the skin modifier that does exactly that but thats more for laying out organic shapes and wont give you the result youre looking for here.

Edited by landeTLS
  • Like 1

Share this post


Link to post
Share on other sites

Thanks mate, that was really helpful. :) I'm having some issues with the wireframe modifier though. There's some issues where the edges and faces meet. Pictures below.

Thanks

h5AAngE.png?1

jL5pesm.png?1

Share this post


Link to post
Share on other sites

Not sure whats going on there. But try recalculating the normals. Go into edit mode select all with A and ctrl+N. If that does not work you may have too many interconnected edges for the wireframe modifier to do its thing

Share this post


Link to post
Share on other sites

Did you check the "boundary" option on the wireframe modifier to see if it made a difference?

Also check the normals on the faces before you added the wireframe to make sure they're pointing the right way.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks all, I solved the problem though :) To explain what I did wrong in case anyone else makes this mistake, I only created faces on the bottom half of triangles. Turns out you need to create triangles all the way around for it to work. Oh, and I did try the boundary option. Didn't do much but once I figured out what was wrong I didn't even need it. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this