Felbourn

Project Odyssey: adventures getting home from an alternate dimension

Recommended Posts

BTW I barely recognized your youtube account with the beard.:'D

Share this post


Link to post
Share on other sites
Thanks for the quick fix but the .craft is still invalid.

I used the validator utility of the KSP Mod Admin to find that the missing parts are RCS has show on the picture below:

I hope this is helpful.

I think you're missing those from the Aerojet mod (see my mod list for a link).

Share this post


Link to post
Share on other sites
I think you're missing those from the Aerojet mod (see my mod list for a link).

You're right. Thanks for the support.

I'm using the c# file to build the game and maybe it's not the last version but I can modify it. :wink:

Share this post


Link to post
Share on other sites
You're right. Thanks for the support.

I'm using the c# file to build the game and maybe it's not the last version but I can modify it. :wink:

I'll update the file Monday with new C# and parts etc.

Share this post


Link to post
Share on other sites

The engineering team has been working on a new 3.75m diameter lifter. They were going to call it the Titan but later changed their mind and called it the Gorgon.

The test launch had two radial strap-on solid boosters.

n2NEHse.png

Then once it was tested they used it to launch the first module of a new space station.

4GDeFpT.png

This one had four strap-on boosters because the module was so heavy.

The new station will be called Odyssey Station, and here it is headed for orbit.

rAzBTpo.png

And here it is coasting to apoapsis to finish the initial orbit.

YfHIeJi.png

Back on the ground, the crew is training in a surface facility.

keLimY9.png

thWWUO4.png

This is a look just inside the hatch, toward the rear.

ynRe1uF.png

The crew is coming in from the front common berthing docking port.

n5oHi6E.png

They will train down here for a few weeks before going into orbit to meet the real station.

hGyUQZM.png

Kesla heads to the front while giving the others a tour.

r4pBX6m.png

P0KcqoX.png

The module in orbit has meanwhile finished its insertion and is orbiting nicely.

BC5cXZ7.png

Sailing off to the dark side...

y6f09sO.png

Watch the saga continue

The dropbox link at the head of this thread has been updated with new craft files.

Edited by Felbourn

Share this post


Link to post
Share on other sites

I like the KSS. Amazing works for the interior. It's a pity we can't have IVA like that.

May I ask you to update the .zip file with the missing custom config for TextureReplacer?

Share this post


Link to post
Share on other sites
I like the KSS. Amazing works for the interior. It's a pity we can't have IVA like that.

May I ask you to update the .zip file with the missing custom config for TextureReplacer?

Textures need to be pulled from their source to avoid copyright infringements. :(

Share this post


Link to post
Share on other sites
Textures need to be pulled from their source to avoid copyright infringements. :(

Thanks for the answer but I think I've found a problem in one of your welded (i suppose) part.

The game stuck on loading of FelbournOdysseyCore raising the Exception:

[Exception]: NullReferenceException: Object reference not set to an instance of an object

The part.cfg seems ok. I'm missing something?

Share this post


Link to post
Share on other sites

Very likely a missing part or mod or bad DLL version. This is why I said in the video that it's really hard to do this. :) You need to analyze the file to determine the missing parts, install the right mods, maybe even use the C# code to know what you need. I don't have enough time to play, make videos, have a life, AND debug the system from a viewer's point of view. I almost didn't release my files just so that I would not have people get stuck. Hopefully you will be able to analyze this and maybe even be able to help others. Or at the very least post what you discover so I can relay the info to anyone else who asks.

Share this post


Link to post
Share on other sites
Very likely a missing part or mod or bad DLL version. This is why I said in the video that it's really hard to do this. :) You need to analyze the file to determine the missing parts, install the right mods, maybe even use the C# code to know what you need. I don't have enough time to play, make videos, have a life, AND debug the system from a viewer's point of view. I almost didn't release my files just so that I would not have people get stuck. Hopefully you will be able to analyze this and maybe even be able to help others. Or at the very least post what you discover so I can relay the info to anyone else who asks.

I'll try to do that, thanks for all the info. :)

Edit: I found the problem. Looking at the part.cfg and output log for a more detailed stack trace of the exception, I've found some problem related to the functon "ReplaceTexture".

the problem was here:


MODEL
{
model = LLL/Parts/FuelTank/LLL2x1/model
position = 0.65, 3.192169, 0.1072112
scale = 1,1,1
rotation = 0,90,0
texture = model000,LLL/Parts/FuelTank/LLL2x1/FUEL
}

I changed this to


MODEL
{
model = LLL/Parts/FuelTank/LLL2x1/model
position = 0.65, 3.192169, 0.1072112
scale = 1,1,1
rotation = 0,90,0
texture = LLL/Parts/FuelTank/LLL2x1/FUEL
}

There are 2 occurrence of this that have to be changed (in line 54 and 62).

(God bless my Software Engineer work :sticktongue:)

Hope this help.

Edited by Glaivas
Problem solved(?)

Share this post


Link to post
Share on other sites
I'll try to do that, thanks for all the info. :)

There are 2 occurrence of this that have to be changed (in line 54 and 62).

(God bless my Software Engineer work :sticktongue:)

Hope this help.

I must have that model in my install while you don't?

Good job finding that!

Share this post


Link to post
Share on other sites
I must have that model in my install while you don't?

Good job finding that!

Can be some welding bug? Because the problem was in %KSP%\GameData\Felbourn\Parts\Modules\Odyssey Core\part.cfg file

Share this post


Link to post
Share on other sites
What mod is the capsule on your Hydra II from?

It's from Near Future

Edited by Glaivas

Share this post


Link to post
Share on other sites

All that time and baited breath waiting for and watching Gateway, and you explain it in 5 sentences. . . :0.0:

Share this post


Link to post
Share on other sites

Two otherwise unidentifiable crew are headed to the showers after their latest training exercises while discussing how Valentina wants to give everyone new uniforms to improve morale. A happy side effect is everyone would be easily identifiable after that too. ;)

yNOM0mI.png

They also discuss how the Kethane scanning is going as they turn the corner into the shower room.

EwAZAvx.png

Meanwhile, Valentina is pacing back and forth while waiting for the new suits to be ready.

M4TzYLE.png

She takes them the the guys after they are ready.

Al3pR8F.png

Everyone is excited to see what she has come up with.

g47qoST.png

She starts handing them out one by one.

EQuY8gy.png

Kranz will be white as the commander.

1aOHV3b.png

Bob will be black and second in command.

OjUWaVk.png

Jeb and Bill are yellow for sub commanders.

HSIOo0P.png

Neil and Kesla are blue for science and medical.

KzEMaHr.png

She and Joseph are dark orange for engineering.

1ZhwJw6.png

We also launched the life support module for the Odyssey Stastion.

NP7x7rw.png

It ran out of fuel before it could reach the station, so we needed to send a refueling ship.

qAn9spg.png

It was basically a Centaur upper stage with a docking port. However, it did not have enough mono, so we made another with more mono and launched it to meet the first one.

8s9G5xM.png

The docking port was moved up and the mono was placed under it, inside the Centaur fairing.

Ec0d1Di.png

This one performed perfectly.

ptdlEoM.png

It docked to the first and transferred over all its fuel before reentering.

AfjwRox.png

THe second one then docked to the module and refueled it, before reentering as well.

IcvFKVu.png

That gave us the delta-V needed to meet up and dock the life support module to the rest of the station.

NdlPGNt.png

NTNkbZt.png

Share this post


Link to post
Share on other sites

Due to the fuel shortage from not having any ground crews to help run refineries, we're trying a solid rocket as the first stage of the lifter taking up the next Odyssey Station Module.

1pAHpes.png

This is the airlock that will allow us to EVA for external repairs and cleanup.

bQxottT.png

Down on Alternate Kerbin, Valentina and Joseph are testing some lander designers in the Test Bay.

CwuT5PO.png

Bob comes by to see how they're doing.

a2CEZYM.png

They talk about landers, Kethane extraction, refining, fuel, and that sort thing when suddenly an alarm goes off.

l9iKUks.png

It rings out all across the facility, including in Kranz's office where Kesla and Jeb have joined him in a meeting.

vtFEYBr.png

They call up the viewer to see what's going on. A massive surge of anomalies has opened wormholes and brought dozens of asteroids through.

5vZsZs7.png

They also see Hadfield has come back and is still alive! Joseph realizes that he must be trapped by a temporal anomaly that is moving slower than the local time, thus keeping him alive longer relative to this time stream.

xIpI8An.png

We'll be planning a rescue mission for Hadfield. Meanwhile, the airlock has made its way to the station.

0IrAT8m.png

It takes a long time, but we finally get it docked.

zi7Wusk.png

The door sits right beside the aft docking port, where Hydra craft come in.

9Wjv9uD.png

Finally, Bob checks in on the new Kethane drill prototype.

kWFgC9D.png

This is a very small version of the one that will really be used to extract fuel from Duna to provide power and get everyone back.

n3xk9Tn.png

Watch as the saga continues:

Share this post


Link to post
Share on other sites

Thanks for all the tutorial related of this series. I love this series, every episode is so interesting. I learned a lot from you and your craft.

You will update the zip file in the future?

Share this post


Link to post
Share on other sites

Thanks for the update.

I see you use a mod called EngineThrust but I cannot find it. What mod is this?

Thanks for the reply on youtube. I found that: is form honeyfox Engine Thrust Controller used in the Space Shuttle Solid Rocket Booster Replica.

Edited by Glaivas

Share this post


Link to post
Share on other sites

Some missing PART files were added to the dropbox link.

Share this post


Link to post
Share on other sites

Thanks for updating the zip with missing part.

I have an error when the game load constellationBNTR part raising a NullReferenceException.

Here the log:


(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

PartLoader: Compiling Part 'BahaConstellation/Parts/BNTR/part/constellationBNTR'

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

PartLoader Warning: Variable ThermalAnim not found in Part

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

Added sound_rocket_hard to FXGroup running

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

LiquidH2 not found in resource database. Propellant Setup has failed.

(Filename: C:/BuildAgent/work/d3d49558e4d408f4/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

NullReferenceException: Object reference not set to an instance of an object
at ModuleEngines.SetupPropellant () [0x00000] in <filename unknown>:0

at ModuleEngines.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0

at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Part.RequestResource (.Part origin, Int32 resourceID, Double demand, Int32 requestID) [0x00000] in <filename unknown>:0

at Part.RequestResource (Int32 resourceID, Double demand) [0x00000] in <filename unknown>:0

at ModuleGenerator.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at Part.RequestResource (.Part origin, Int32 resourceID, Double demand, Int32 requestID) [0x00000] in <filename unknown>:0

at Part.RequestResource (Int32 resourceID, Double demand) [0x00000] in <filename unknown>:0

at ModuleGenerator.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

I prepare the ksp directory running the .cs program and I think is something in custom engine.cfg because if i comment the lines dedicated on writing the customization for that part, the game run correcly.

Do you have any advice for resolving this problem?

Edit: Found the problem. I think you have missing to add RealFuels mod part in the .cs program.

Edited by Glaivas

Share this post


Link to post
Share on other sites

@Glaivas

I use the same CS file and program to "recreate" my GameData folder several times per day as I make changes. If there were a problem with it then I'd be getting the same null ref. It must be something you're not getting copied, perhaps from the source folders. That resource comes from the Resource.cfg in the Felbourn directory.

Share this post


Link to post
Share on other sites

This is probably weeks too late, but you can disable the city lights without disabling the clouds. Just delete the /boulderco/citylights directory without touching /boulderco/clouds. This trick is mentioned in the mod thread, but with so many mods it'd be a full time job for you to keep up with all of them.

Share this post


Link to post
Share on other sites
@Glaivas

I use the same CS file and program to "recreate" my GameData folder several times per day as I make changes. If there were a problem with it then I'd be getting the same null ref. It must be something you're not getting copied, perhaps from the source folders. That resource comes from the Resource.cfg in the Felbourn directory.

My fault, I mess up with the version of the zip file. Thanks for your support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now