stupid_chris

[1.1.2+] Kerbal NRAP - MOVED

Recommended Posts

stupid_chris,

Could you look at using a different zipping program for archiving? I run on 64-bit Linux, and I'm getting an

annoying error message when I try to extract the files. I think you're using 7-zip, right? It's doing something

naughty in the process. A Windoze issue, perhaps?

I had this same problem with another mod awhile back (Asteroid Cities)...

Personal update: I just installed the Windows version of the 7-zip 9.36 beta under Wine, to see if that might

fix the problem. No joy. All of my un-zippers seem to be telling me the package is corrupt. I presume this to be

incorrect, though, as others here are apparently extracting the file without difficulty. Suggestions?

Edited by BARCLONE

Share this post


Link to post
Share on other sites
stupid_chris,

Could you look at using a different zipping program for archiving? I run on 64-bit Linux, and I'm getting an

annoying error message when I try to extract the files. I think you're using 7-zip, right? It's doing something

naughty in the process. A Windoze issue, perhaps?

I had this same problem with another mod awhile back (Asteroid Cities)...

Personal update: I just installed the Windows version of the 7-zip 9.36 beta under Wine, to see if that might

fix the problem. No joy. All of my un-zippers seem to be telling me the package is corrupt. I presume this to be

incorrect, though, as others here are apparently extracting the file without difficulty. Suggestions?

Have you tried redownloading it? might have gotten a corrupt download. (Try both downloads from Mediafire and kerbal stuff) I tested the kerbal stuff download with linux, and its giving me no issues. Unzips fine under windows as well.

Share this post


Link to post
Share on other sites
Have you tried redownloading it? might have gotten a corrupt download. (Try both downloads from Mediafire and kerbal stuff) I tested the kerbal stuff download with linux, and its giving me no issues. Unzips fine under windows as well.

Looks like that was the issue. The DL from Kerbal Stuff extracted cleanly. Thanks!

Share this post


Link to post
Share on other sites
Hello. Can anyone give me a link on 0.25 version of this plugin ?

You can find it on KerbalStuff

stupid_chris,

Could you look at using a different zipping program for archiving? I run on 64-bit Linux, and I'm getting an

annoying error message when I try to extract the files. I think you're using 7-zip, right? It's doing something

naughty in the process. A Windoze issue, perhaps?

I had this same problem with another mod awhile back (Asteroid Cities)...

Personal update: I just installed the Windows version of the 7-zip 9.36 beta under Wine, to see if that might

fix the problem. No joy. All of my un-zippers seem to be telling me the package is corrupt. I presume this to be

incorrect, though, as others here are apparently extracting the file without difficulty. Suggestions?

I'm using WinZip 17. Luckily seems like your problem was solved :)

Share this post


Link to post
Share on other sites

There is a small bug when you try to put parts on the side of the test weights. Upon loading of craft, sometimes it will recognize the NRAP with a smaller DIA than it is currenty set and the part would 'sink' inside it. or sometimes it would recognize it as bigger than it appears, so the part would 'float' beside it. Happens with antennas, batteries, mechjeb, etc..

Edited by lyndonguitar

Share this post


Link to post
Share on other sites

Hi stupid_chris!

I've just found this mod and I love it for career mode! It's already saved Jeb's life many times, and for that I cannot thank you enough for keeping this mod going.

However, I think I may have found an issue. At present, I am using the entry VAB. Although the mass adjustment is recognised bythe dV stat, the KSP's own 'Ship Info' displays the mass of the NRAP cone at 10t (the default mass), no matter what adjustment is made. I can see in the part config that the mass it is listed a '10', and this seems to be the only value that KSP is interested in. When I change this value to, say 0.5, I can then launch the vehicle (I was restricted by the 18t limit and could not launch).

A small issue, but one that may be worthy of your attention.

Share this post


Link to post
Share on other sites

PringleMan had requested in the old thread, "I would be interested in seeing a new part added to this mod that is an adjustable balance weight. Sometimes I run into problems with rocket design where I have parts that unbalance my rocket because it would be horribly redundant to have multiples, but you have to in order to maintain a centered CoM.

So a radial adjustable weight would be awesome!"

And I completely second this idea! In addition, a stack-able test weight would also be helpful. Basically, test weights for all purposes! ;)

Once you have the ability to use the test weight for rockets you feel silly not being able to use test weights on other types of craft!

Share this post


Link to post
Share on other sites
Hi stupid_chris!

I've just found this mod and I love it for career mode! It's already saved Jeb's life many times, and for that I cannot thank you enough for keeping this mod going.

However, I think I may have found an issue. At present, I am using the entry VAB. Although the mass adjustment is recognised bythe dV stat, the KSP's own 'Ship Info' displays the mass of the NRAP cone at 10t (the default mass), no matter what adjustment is made. I can see in the part config that the mass it is listed a '10', and this seems to be the only value that KSP is interested in. When I change this value to, say 0.5, I can then launch the vehicle (I was restricted by the 18t limit and could not launch).

A small issue, but one that may be worthy of your attention.

Howdy!

I second what Akinesis said, both in that I love this mod, and I have experienced the mass issue for the launch pad, exactly as Akinesis explains it. Since I mainly use this for payload planning, it's not that big a deal for me, but I *do* see the same behavior.

One question: Do you have any intention of indexing this on CKAN?

And Happy New Year!

Share this post


Link to post
Share on other sites

This is SO useful!! Thanks to all involved! :D

Share this post


Link to post
Share on other sites

One must assume that sufficient bacon is present to be able to keep up this pace of updates....

Cheers.

Share this post


Link to post
Share on other sites

Here we go

Changelog:

April 29th 2015
v1.5.0.3
-Recompiled for 1.0
-Drag cube now set procedurally for resizes.
-Fixed part node orientation

Should work fine, no big changes in sight. Have fun people :)

Share this post


Link to post
Share on other sites

It crashes PatchedConicRenderer for some reason and makes it impossible to revert or go to KSC after launch (exception in PatchedConicRenderer when trying to change scene).

There's an exception just after launch, looks like it happens in/after rendering the drag cube:


[WRN 11:08:53.647] [HighLogic]: =========================== Scene Change : From EDITOR to FLIGHT (Async) =====================
[WRN 11:08:54.925] ApplicationLauncher already exist, destroying this instance
[LOG 11:08:54.929] AddonLoader: Instantiating addon 'NavWaypoint' from assembly 'KSP'
[LOG 11:08:54.956] ------------------- initializing flight mode... ------------------
[LOG 11:08:54.967] Loading ship from file: C:/games/KSPtest/KSP_Data/../saves/testing/Ships/VAB/Auto-Saved Ship.craft
[LOG 11:08:55.041] 0 loaded!
[LOG 11:08:57.231] putting ship to ground: 2.965177
[LOG 11:08:57.236] [0]: Ready to Launch - waiting to start physics...
[LOG 11:08:57.242] [FLIGHT GLOBALS]: Switching To Vessel 0 ----------------------
[LOG 11:08:57.244] setting new dominant body: Kerbin
FlightGlobals.mainBody: Kerbin
[LOG 11:08:57.246] Reference Frame: Rotating
[LOG 11:08:57.249] stage manager resuming...
[LOG 11:08:57.251] Vessel assembly complete!
[LOG 11:08:57.251] stage manager starting...
[LOG 11:08:57.252] all systems started
[LOG 11:08:57.284] DragCubeSystem: Rendering procedural drag for kerbnraptest
[EXC 11:08:57.441] NullReferenceException: Object reference not set to an instance of an object
PatchedConicRenderer.OnDestroy ()

After that there's an exception each time you try to revert or go to KSC:


[LOG 11:17:36.311] [FlightDriver]: Flight State Reverted to Prelaunch.
[LOG 11:17:36.314] Game State Saved as persistent
[EXC 11:17:36.315] NullReferenceException: Object reference not set to an instance of an object
PatchedConicRenderer.OnSceneSwitch (GameScenes scn)
EventData`1[GameScenes].Fire (GameScenes data)
HighLogic.LoadScene (GameScenes scene)
EditorDriver.StartEditor (EditorFacility facility)
FlightDriver.RevertToPrelaunch (EditorFacility facility)
PauseMenu.drawRevertOptions ()
MultiOptionDialog.drawContent (Int32 id)
UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID)
UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style)

Test vessel:

https://dl.dropboxusercontent.com/u/68024714/NRAP-bug.craft

Stock with just NRAP, no other mods, KSP build 830.

Share this post


Link to post
Share on other sites

Very nice, I love making heavy heavy lifters (900t+ payloads) and it's a pain trying to build a simple payload at that weight.

Share this post


Link to post
Share on other sites
It crashes PatchedConicRenderer for some reason and makes it impossible to revert or go to KSC after launch (exception in PatchedConicRenderer when trying to change scene).

There's an exception just after launch, looks like it happens in/after rendering the drag cube:


[WRN 11:08:53.647] [HighLogic]: =========================== Scene Change : From EDITOR to FLIGHT (Async) =====================
[WRN 11:08:54.925] ApplicationLauncher already exist, destroying this instance
[LOG 11:08:54.929] AddonLoader: Instantiating addon 'NavWaypoint' from assembly 'KSP'
[LOG 11:08:54.956] ------------------- initializing flight mode... ------------------
[LOG 11:08:54.967] Loading ship from file: C:/games/KSPtest/KSP_Data/../saves/testing/Ships/VAB/Auto-Saved Ship.craft
[LOG 11:08:55.041] 0 loaded!
[LOG 11:08:57.231] putting ship to ground: 2.965177
[LOG 11:08:57.236] [0]: Ready to Launch - waiting to start physics...
[LOG 11:08:57.242] [FLIGHT GLOBALS]: Switching To Vessel 0 ----------------------
[LOG 11:08:57.244] setting new dominant body: Kerbin
FlightGlobals.mainBody: Kerbin
[LOG 11:08:57.246] Reference Frame: Rotating
[LOG 11:08:57.249] stage manager resuming...
[LOG 11:08:57.251] Vessel assembly complete!
[LOG 11:08:57.251] stage manager starting...
[LOG 11:08:57.252] all systems started
[LOG 11:08:57.284] DragCubeSystem: Rendering procedural drag for kerbnraptest
[EXC 11:08:57.441] NullReferenceException: Object reference not set to an instance of an object
PatchedConicRenderer.OnDestroy ()

After that there's an exception each time you try to revert or go to KSC:


[LOG 11:17:36.311] [FlightDriver]: Flight State Reverted to Prelaunch.
[LOG 11:17:36.314] Game State Saved as persistent
[EXC 11:17:36.315] NullReferenceException: Object reference not set to an instance of an object
PatchedConicRenderer.OnSceneSwitch (GameScenes scn)
EventData`1[GameScenes].Fire (GameScenes data)
HighLogic.LoadScene (GameScenes scene)
EditorDriver.StartEditor (EditorFacility facility)
FlightDriver.RevertToPrelaunch (EditorFacility facility)
PauseMenu.drawRevertOptions ()
MultiOptionDialog.drawContent (Int32 id)
UnityEngine.GUILayout+LayoutedWindow.DoWindow (Int32 windowID)
UnityEngine.GUI.CallWindowDelegate (UnityEngine.WindowFunction func, Int32 id, UnityEngine.GUISkin _skin, Int32 forceRect, Single width, Single height, UnityEngine.GUIStyle style)

Test vessel:

https://dl.dropboxusercontent.com/u/68024714/NRAP-bug.craft

Stock with just NRAP, no other mods, KSP build 830.

... That's weird, I used *your* code to rerender the drag cube :/

Share this post


Link to post
Share on other sites

Oh hey, cool, this will be useful for when I make two-mode craft, ones that have a main rocket for forward propulsion and another set of rockets for landing/takeoff. That way I don't have to use the same engine on the other side or otherwise use a bunch of random stuff on the other side of whatever I'm using for engine pods.

Lolwut at the impact resistance.

Also, uh, I guess according to e-dog, theres a rather bad bug with this atm?

Edited by smjjames

Share this post


Link to post
Share on other sites

Found the problem.

Changelog:

April 30th 2015
v1.5.0.4
*Hotfix*
-Fixed the bug where the DragCube rendering would break stuff during flight loading

Shouldn't be any more problems now. Enjoy people!

Share this post


Link to post
Share on other sites
Found the problem.

Changelog:

April 30th 2015
v1.5.0.4
*Hotfix*
-Fixed the bug where the DragCube rendering would break stuff during flight loading

Shouldn't be any more problems now. Enjoy people!

Cool, thanks.

Also, just wondering out of curiosity, what is NRAP an acronym for?

Share this post


Link to post
Share on other sites
Cool, thanks.

Also, just wondering out of curiosity, what is NRAP an acronym for?

I'm inviting you to look at the OP :P

Share this post


Link to post
Share on other sites
It stand for "New Rocket Asssement Programme" . It's says it on the pod

DUURRRRPPPPP!

lol

Why didn't I see that before, heh.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now