Proot

[1.1.2] KSPRC - Renaissance Compilation: artworks remake [V-0.7 Pre Release 3]

Recommended Posts

Hello all, I put the folders in my GameData folder, but I don't see much of a difference than stock. I only have Kerbal Engineer as my other mod. My Kerbin doesn't have clouds and my Mun doesn't look like the video in the first post. Thanks for any advice.

Also, is this pack different than just installing each mod on its own? Thank you!

Share this post


Link to post
Share on other sites

Is anybody else experiencing extreme fps drops on the mun? seems to freeze every seconds or so. running  an I7-5820k, Gtx 980, 16g ram.

Share this post


Link to post
Share on other sites
2 hours ago, Slye37 said:

Is anybody else experiencing extreme fps drops on the mun? seems to freeze every seconds or so. running  an I7-5820k, Gtx 980, 16g ram.

If the fps drops happens only when moving the camera and getting kerbin in and out of view try to temporally delete the kerbin textures in "GameData\KSPRC\PluginData" and try again after restart the game.

These textures are glorious but a small fps drop is the price to pay for them every time they load, I still prefer to have them and pay the price anyway but if that is your problem you can swap those textures with smaller ones or edit them.

Happened to me even with an ssd, (not a big problem anyway but is good to know what is causing it)

Share this post


Link to post
Share on other sites
3 hours ago, Slye37 said:

Is anybody else experiencing extreme fps drops on the mun? seems to freeze every seconds or so. running  an I7-5820k, Gtx 980, 16g ram.

Maybe is the texture reflections, disable it click in the texture replace icon on the space center view

sry my english

Share this post


Link to post
Share on other sites
4 hours ago, Slye37 said:

Is anybody else experiencing extreme fps drops on the mun? seems to freeze every seconds or so. running  an I7-5820k, Gtx 980, 16g ram.

It is lighting trouble. In my I7 8gb 4gbvram the same. How to terminate this problem:

1. in scatterer menu disable Ocean: light compatiblity (do it in main menu - press F10 and turn off)

2. change the distance to draw texture in distant object (button in game main screen...) 

3. kill lines in KSPRC.cfg:

Spoiler

@Body[Sun]
    {
        Particles
        {
            Particle
            {
                target = Sun
                texture = KSPRC/Terrain/sunflares
                minEmission = 1
                maxEmission = 1
                lifespanMin = 40
                lifespanMax = 60
                sizeMin = 5000
                sizeMax = 8000
                speedScale = 0.0005
                rate = 0.015
                randVelocity = 0, 0, 0
                Colors
                {
                    color1 = 1.000, 0.950, 0.840, 0.750
                    color2 = 1.000, 0.990, 0.800, 0.750
                    color3 = 1.000, 0.960, 0.820, 0.750
                    color4 = 1.000, 1.000, 0.900, 0.750
                    color5 = 1.000, 0.970, 0.900, 0.750
                }
            }
        }
    }

sorry for my poor english

ps^if enybody knows what else must be turn off (or deleted) to normal game speed please write .

Edited by *MajorTom*

Share this post


Link to post
Share on other sites
11 hours ago, *MajorTom* said:

It is lighting trouble. In my I7 8gb 4gbvram the same. How to terminate this problem:

1. in scatterer menu disable Ocean: light compatiblity (do it in main menu - press F10 and turn off)

2. change the distance to draw texture in distant object (button in game main screen...) 

3. kill lines in KSPRC.cfg:

  Reveal hidden contents

@Body[Sun]
    {
        Particles
        {
            Particle
            {
                target = Sun
                texture = KSPRC/Terrain/sunflares
                minEmission = 1
                maxEmission = 1
                lifespanMin = 40
                lifespanMax = 60
                sizeMin = 5000
                sizeMax = 8000
                speedScale = 0.0005
                rate = 0.015
                randVelocity = 0, 0, 0
                Colors
                {
                    color1 = 1.000, 0.950, 0.840, 0.750
                    color2 = 1.000, 0.990, 0.800, 0.750
                    color3 = 1.000, 0.960, 0.820, 0.750
                    color4 = 1.000, 1.000, 0.900, 0.750
                    color5 = 1.000, 0.970, 0.900, 0.750
                }
            }
        }
    }

sorry for my poor english

ps^if enybody knows what else must be turn off (or deleted) to normal game speed please write .

Well, to get my KSP to run quickly (~80-100% physics time), I installed KSPRC then had to remove Scatterer and everything EVE related.

Share this post


Link to post
Share on other sites

OP is updated with the 0.7 Pre-Release 3. Several problems should be solved, others not yet. New exciting things are coming for the final release...

  • Like 5

Share this post


Link to post
Share on other sites
5 minutes ago, Proot said:

OP is updated with the 0.7 Pre-Release 3. Several problems should be solved, others not yet. New exciting things are coming for the final release...

I just downloaded it 20 min ago and came back to say how wonderful it looks! Off to download again lol.

Thank you very much for your efforts!

 

Edit: Looks like I got 0.7 just in time. Thanks again :)

Edited by Bleddyn
  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Proot said:

OP is updated with the 0.7 Pre-Release 3. Several problems should be solved, others not yet. New exciting things are coming for the final release...

not found file 404 in spacedock=

 

Not Found

The requested URL /Proot_4811/KSPRC_-_Renaissance_Compilation_artworks_remake/KSPRC_-_Renaissance_Compilation_artworks_remake-0.7_PreRelease_3.zip was not found on this server.


Apache/2.4.7 (Ubuntu) Server at cdn.spacedock.info Port 80

Share this post


Link to post
Share on other sites
3 hours ago, *MajorTom* said:

not found file 404 in spacedock=

 

Not Found

The requested URL /Proot_4811/KSPRC_-_Renaissance_Compilation_artworks_remake/KSPRC_-_Renaissance_Compilation_artworks_remake-0.7_PreRelease_3.zip was not found on this server.


Apache/2.4.7 (Ubuntu) Server at cdn.spacedock.info Port 80

Try the Curse the only stable !!!

Share this post


Link to post
Share on other sites

Downloaded it from SpaceDock right now, no problem

@Proot for individually updating included mods without waiting for a new KSPRC bundle I just want to confirm the changes I've found. DistantObject, EVE and Kopernicus are all the same as if they were downloaded separate. Scatterer has modified configs and sunflare. TextureReplacer has your own .cfg and also textures for suits, heads and skybox.

Did I miss anything?

Edit: Whooo! What a gorgeous looking piece of work Proot! Praise upon praise. Some things I noticed, that may be known issues but I didn't see you post any:

2bewlTql.jpg

There's a seam on Minmus running from pole to pole

0Qjn5hbl.jpg

Is Jool still a WIP because procedural gas giant clouds aren't available yet? It looks... weird. That may sound like a personal opinion but really its like Jupiter with a green tinge, which isn't really a proper representation of Jool

A6tHVbwl.jpg

Duna glows from the night side - it's the only body that does this. It may just be a Map View issue (though the atmosphere for Duna for Stock Visual Enhancements doesn't have a glow)

Eeloo and Laythe atmospheres flicker but that also may just be a Map View issue that Scaterrer has, I know it's got a few problems with Map View)

So much detail in the terrain I had to take my custom changes to the game's settings.cfg LOD distance from 18 down to 12 in order to get an acceptable FPS (24, not bad!) and green clock time.

Like what I'm seeing!

Also is it possible to get back the Mun glow? I forget which visual pack that was from but Mun is so dark at night now...

Edited by Gaiiden
  • Like 1

Share this post


Link to post
Share on other sites

This is the first time I can actually play with it :) Though I did have to take out a few stuff :D

- deleted the kerbin textures in "GameData\KSPRC\PluginData"

- deleted all volumetric effects for clouds.

- disabled shadows for dark and top clouds.

- disabled godrays and shadows from Scatterer.

And it still looks stunning with 70 mods or so. In fact, I quite like having the game at around 30 fps or so, since I don't get those stupid garbage collection stutters. 

Share this post


Link to post
Share on other sites

Man it looks so cool.. But at low fps :D

I was wondering if it's possible to delete clouds from in game view, but not from map view?

or a way to make them really simple so it wont hurt my all fps?

Edited by qromodynmc

Share this post


Link to post
Share on other sites
28 minutes ago, qromodynmc said:

Man it looks so cool.. But at low fps :D

I was wondering if it's possible to delete clouds from in game view, but not from map view?

or a way to make them really simple so it wont hurt my all fps?

You could try disabling the volumetric clouds. Go into the game and press Alt-0 to bring up the EVE UI, find the relevant cloud layers and disable the volumetrics. Sorry I can't offer a more comprehensive guide on how to do so, but if you just look around the UI, I'm sure you'll find what I'm talking about :) 

  • Like 1

Share this post


Link to post
Share on other sites
45 minutes ago, MrMeeb said:

You could try disabling the volumetric clouds. Go into the game and press Alt-0 to bring up the EVE UI, find the relevant cloud layers and disable the volumetrics. Sorry I can't offer a more comprehensive guide on how to do so, but if you just look around the UI, I'm sure you'll find what I'm talking about :) 

Thanks! I'll check it out.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks to @Gaiiden (roger all that) and @drswagboss: great pics there!!

About the rest: would be much more useful if you tell me your specs and info about your problems (with debug info or even your logs if possible) than if you flood the thread with messages about how you cut or mix the mod. Deleting things randomly and make me to read about how you do it don't helps me in any way. As example: for me Eve planet works pretty fine with four layers filled with volumetrics, while Kerbin have FPS drops with just 3 layers. So is not so simple as to delete one thing or another.
But, in any case, you could do all this in another thread, in "Add-on Discussions". Imho It'd be much more polite and you could giive us "room" here for the relevant info.

  • Like 3

Share this post


Link to post
Share on other sites

Just wanted to let you know that I'm seeing at least 6 more frames when I launch stuff, nothing changed, with OPM-VO, and the ocean reflections are working, along with higher res clouds! Great job!

  • Like 1

Share this post


Link to post
Share on other sites

Proot, u.....
I'm almost crying cause of this beauty :D

And i love those "scratches" on the screen when looking into the sun (on 2nd screen).
..and those shadows!!!

But the outermost Image shows some horizontal scratches(right and left of the lensflare) on my sides. Its no dealbraker, but do u have any idea how to avoid them?

Edit: default (think its DX9) Engine; 5760x1080; maximum graphic settings

 

 

Edited by Speadge
  • Like 3

Share this post


Link to post
Share on other sites
7 hours ago, Speadge said:

But the outermost Image shows some horizontal scratches(right and left of the lensflare) on my sides. Its no dealbraker, but do u have any idea how to avoid them?

Edit: default (think its DX9) Engine; 5760x1080; maximum graphic settings

 

You are using an impressive but quite unusual resolution. I assume you have 3 monitors, so you must go to the folder ...GameData/scatterer/sunflare/ and then open "sunflare.cfg". Find this:

//Ghost1.png
ghost1SettingsList1
{
	Item = 0.24,0.5,1,1
}

Then change it to this:

//Ghost1.png
ghost1SettingsList1
{
	Item = 0.24,0.166,1,1
}

Notice that the only value you are changing is the second one, form 0.5 to 0.166. That is the aspect ratio for the scratched texture. You will change it from 16.9 (single screen) to your config (16:9 x 3).

I think that it should do the trick, but I don't know how it gonna look after the change. :wink: Good luck!

Edited by Proot
  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the awesome mod man !

Edited by k0spwn
Problem solved

Share this post


Link to post
Share on other sites
1 hour ago, k0spwn said:

Hi, I installed the mod and the game crash on startup after ModuleManager patch...  I'm using : BetterBurnTime, Chatterer, EngineLightning, RasterPropMonitor, Kaboom, KER, HyperEdit, MechJeb2, RCS Sounds, RealPlume Stock, SmokeScreen, TakeCommand, Transfer Window planner, Tweak Scale, Sounding Rockets, WheelSounds, Richell's planet pack

 

I'm not posting the log file because I don't know if this is the thread to do it but If yes, I'll post it as soon as I can :D

You are probably trying to play in 32bit mode. Try with 64bit instead.

Share this post


Link to post
Share on other sites
Just now, Proot said:

You are probably trying to play in 32bit mode. Try with 64bit instead.

It's all ok, It was just a mod causing bugs... But thanks anyway for reply :D

 

  • Like 1

Share this post


Link to post
Share on other sites
On 5/26/2016 at 2:46 PM, qromodynmc said:

Man it looks so cool.. But at low fps :D

I was wondering if it's possible to delete clouds from in game view, but not from map view?

or a way to make them really simple so it wont hurt my all fps?

The clouds are beautiful...but I can't run them either. They halve my fps. What I've done is remove the ksprc clouds from kerbin (keep the auroras) and keep only the stock EVE clouds. The newest EVE clouds look great in my opinion, and seem to have a far smaller fps hit.

Share this post


Link to post
Share on other sites

@Proot

Hi there,

First off, this is great work.

Second, I already have scatterer, EVE and texture replacer. If I want to install KSPRC do I need to remove them first?

Cheers,

Pete

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now