Proot

[1.1.2] KSPRC - Renaissance Compilation: artworks remake [V-0.7 Pre Release 3]

Recommended Posts

7 hours ago, Speadge said:

Can u tell me where to get those distance lasers and how to add them to a kOS script?

 

regards

I'm in the middle of updating the mod he's using, LaserDist, which I abandoned a year and a half ago.  The source is on GitHub and I just updated it for modern KSP, but it hasn't been released because I want to fiddle with the attachment points on the model a bit (everything else seems to be working again, but I want the attachment point set in stone before it gets out into the public so I don't have to worry about grandfathering in old vessels when I change it.)

Source Github: https://github.com/Dunbaratu/LaserDist

I'm mostly re-releasing it because Waz took the old code base and made a few edits to get it working with recent versions of KSP, and sent me a few private msgs about what edits he had to make.

And, with Unity5, Squad seems to have done some sort of changes that got rid of the problem that frustrated me before - that of having different parts of the game in disagreement about "where they are". since they haven't all been updated yet during the FixedUpdate cycle.

 

 

Edited by Steven Mading

Share this post


Link to post
Share on other sites

happy to know that u are doing progress here and not bothering with old bugs anymore. Its great when ppl, especially modders find their way back and support their old projects.
although, I'd like to wait for the final release since I'm sure I'm not capable of adding some constructive feedback for the mod right now.

So thank you, @Steven Mading & also @Waz :wink:

Ok, enough offtopic (since it kinda belongs to this "bad-alien-boulder-are-destroying-rover"-topic :wink:

 

14 hours ago, karamazovnew said:

That looks like GemFX. It's a pain to set up, but it doesn't affect framerates at all. You can get very interesting results with it. Even with the default settings I remember screaming out in amazement the first time the game loaded. Honestly, maybe Proot can take a look at it and work his magic with it as well.

Not so hard to set up at all. @JayS_NL created a nice preset (v2) for it... with a lil know-how you dont even need to install the whole runtime, but just add the dll/config/runtime to ur ksp-folder.

works for several games.

Share this post


Link to post
Share on other sites

I love the mun and minmus textures, but ksprc just lags my game :(. Is there a way to take the textures out and put them into something like texture replacer? 

Share this post


Link to post
Share on other sites
20 minutes ago, Kram45 said:

I love the mun and minmus textures, but ksprc just lags my game :(. Is there a way to take the textures out and put them into something like texture replacer? 

he uses texture replacer... if u check the config in TR folder, u see its loading the textures from KSPRC folder.

 

so if u delete everything that comes with KSPRC but keep TR and those textures ONLY in KSPRC folder, u might be fine

Share this post


Link to post
Share on other sites
1 minute ago, Speadge said:

he uses texture replacer... if u check the config in TR folder, u see its loading the textures from KSPRC folder.

 

so if u delete everything that comes with KSPRC but keep TR and those textures ONLY in KSPRC folder, u might be fine

I use SVE with KSPRC textures in the TR folder. Looks awesome and works very well.

Share this post


Link to post
Share on other sites
4 minutes ago, DJ Reonic said:

I use SVE with KSPRC textures in the TR folder. Looks awesome and works very well.

with kopernicus? (and proots config)

edit: did u delete ksprc folder &tex os did u move them to TR?

Edited by Speadge

Share this post


Link to post
Share on other sites

Kopernicus: yes. Proot's config: I'd have to check when I get home tonight. (I'm at work) I'm planning to replace the SVE cloud config with the KSPRC one, and I need to fiddle with the city lights (both textures show up) but other than that it works great.

Share this post


Link to post
Share on other sites
49 minutes ago, DJ Reonic said:

Kopernicus: yes. Proot's config: I'd have to check when I get home tonight. (I'm at work) I'm planning to replace the SVE cloud config with the KSPRC one, and I need to fiddle with the city lights (both textures show up) but other than that it works great.

so u want to replace SVE textures with proots AND the clouds? so whats left? CityLights are way better in KSPRC, .. for ME!

if u dont use proots kopernicus config, it way work smoother, but u miss the physic clutter like the stones then :(

 

Share this post


Link to post
Share on other sites
1 hour ago, Speadge said:

he uses texture replacer... if u check the config in TR folder, u see its loading the textures from KSPRC folder.

 

so if u delete everything that comes with KSPRC but keep TR and those textures ONLY in KSPRC folder, u might be fine

Ok thanks.

 

Share this post


Link to post
Share on other sites
Just now, Kram45 said:

Ok thanks.

 

welcome
Just give feedback how it turns out. Might be people will really read some posts in the future before asking this again :wink:

Share this post


Link to post
Share on other sites
1 hour ago, Speadge said:

so u want to replace SVE textures with proots AND the clouds? so whats left? CityLights are way better in KSPRC, .. for ME!

if u dont use proots kopernicus config, it way work smoother, but u miss the physic clutter like the stones then :(

 

I'm trying to kitbash everything so I can have KSPRC and Ven's Stock part Revamp without having to delete specific parts and stuff. I love KSPRC, but if I use it as-is I have issues when using VSPR parts, so I'm playing with it to get the best of both worlds.

Share this post


Link to post
Share on other sites

I have a similar issue where KSPRC costs too much performance near Kerbin (especially at launch and re-entry) but I really want to keep the terrain textures for the other bodies. Mun landings are just so pretty. I can run SVE or EVE and Scatterer happily but something in the KSPRC package pushes it over the edge whenever in low-orbit or atmosphere above Kerbin unless I keep the camera pointed above the horizon.

Trying to figure out, through trial-and-error, if I can selectively disable the Kerbin enhancements/textures alone without breaking anything.

Share this post


Link to post
Share on other sites

This is beautiful, but the frame-rate is kinda low (~5fps).

I especially loved the surprise of seeing aurora while deploying a polar orbiting mapper.

Running 1.1.2 64bit on Windows 7 with GTX750M.

Share this post


Link to post
Share on other sites
14 hours ago, Starfire70 said:

This is beautiful, but the frame-rate is kinda low (~5fps).

I especially loved the surprise of seeing aurora while deploying a polar orbiting mapper.

Running 1.1.2 64bit on Windows 7 with GTX750M.

tk4C8wk.jpg

Share this post


Link to post
Share on other sites
On 12/06/2016 at 2:22 PM, Speadge said:

he uses texture replacer... if u check the config in TR folder, u see its loading the textures from KSPRC folder.

 

so if u delete everything that comes with KSPRC but keep TR and those textures ONLY in KSPRC folder, u might be fine

Maybe I misunderstand how things work but I'm pretty sure all the lovely planet work (texturing) is handled by Kopernicus and not Texture Replacer.

Share this post


Link to post
Share on other sites
17 minutes ago, Manwith Noname said:

Maybe I misunderstand how things work but I'm pretty sure all the lovely planet work (texturing) is handled by Kopernicus and not Texture Replacer.

he wouldnt have added a config pointing to his textures for texture replacer then, would he?

Share this post


Link to post
Share on other sites
55 minutes ago, Speadge said:

he wouldnt have added a config pointing to his textures for texture replacer then, would he?

Texture Replacer does a few things beyond just replacing textures. Things like unloading textures from memory, generating mipmaps, adding reflections (though that's not currently used) and so on. All I see in the TR configs is pathing to allow TR to see the folders where certain textures are stored and prevent some from being unloaded (Edit: ...and the suits). If you look at the KSPRC.cfg in the KSPRC folder however, you'll see the Kopernicus setup and it specifically lists and names the files for each celestial body and defines how they should be applied.

 

27 minutes ago, FrancisPT said:

Still worth it to force DirectX 11 or just play with the 64 bits version?

With the latest KSPRC pre release I had to remove my -force-d3d11 command or the game would not load. I noticed that scatterer no longer defaults to using dx11 shaders so this may have caused the problem, though I never got round to testing any further. On the previous pre release, when I switched to DX11 I noticed a small performance gain under certain situations.

Edited by Manwith Noname

Share this post


Link to post
Share on other sites

Well i installed Gemfx out of curiosity. its nice and weird at the same time. i think its good for filming in ksp but not gameplay.  

fi2HYIK.jpg

v63F06C.jpgMqA9Sir.jpg

euJOhlr.jpg

Share this post


Link to post
Share on other sites
On 6/12/2016 at 3:01 PM, Starfire70 said:

This is beautiful, but the frame-rate is kinda low (~5fps).

I especially loved the surprise of seeing aurora while deploying a polar orbiting mapper.

Running 1.1.2 64bit on Windows 7 with GTX750M.

I tinkered a bit and swapped SVE HR in for KSPRC cloud textures and HAD awesome performance but then I decided to tweak a bit more and lost my place. :( Had to reinstall the mods from scratch and swap in SVE HR again. I missed something though because FPS near the ground is still kinda low (2-3 real seconds for every 1 second of Kerbal time). Once I get some altitude and away from the clouds and the ground, the FPS recovers nicely.

I absolutely love the part textures, the lens flare on the sun, and the high res churning aurora textures. :)

One thing that annoys me is the 'CLOUDS EVERYWHERE'. Seriously? I want EVE clouds...not too much, just enough to be interesting, without me wondering whether I am over ocean or land, and without bringing FPS down. I tried swapping them into the clouds.cfg but ended up with no clouds at all. :(

Edited by Starfire70

Share this post


Link to post
Share on other sites

I love it- but I hate it.

 

This mod is kind of like that hot girlfriend that becomes annoying because she is as smart as a worm with down syndrome.

The Mod itself is absolutely gorgeous. If you want not only a bag of eye candy, but a truck size load of eye candy, this is the perfect mod for you.

I am astonished by how good the game looks with it. 

 

However, after some time, it gets annoying. The framerate is reduced by a fair amount, some ground textures are not fitting, say goodbye to that smooth 64x feeling.

Because of some cache-stacking (I think), you get only 10 fps in the ground control map view after a while.

 

Aside from that, I am downloading it the third time now, I can't play without it.

Keep up the good work Proot, this is even better than the astronomers visual pack ever was!

Share this post


Link to post
Share on other sites

my suggestion dont use this mod unless u have good rig my geforce 960  can barely handle this mod.i have over 30 fps most of the time (60 on high enough orbit) . but i can feel lower gpu just can not handle it.i dont think any more optimization wold be  possible. i could be wrong but i think unity just sucks in term of optimization.

ps: laptops are not for this mod at least not the one with low/ meduimish perfomance gtx750. maybe high end expensive gaming laptop but not yours.

Edited by Silent1_87

Share this post


Link to post
Share on other sites

Hi, all. I downloaded this a few hours ago, and I loved it (apart from the fact that I felt the need for a fire extinguisher). But, for some reason, no clouds are appearing. Could it be because I already had EVE installed? Thanks!

Share this post


Link to post
Share on other sites
8 minutes ago, Andem said:

Hi, all. I downloaded this a few hours ago, and I loved it (apart from the fact that I felt the need for a fire extinguisher). But, for some reason, no clouds are appearing. Could it be because I already had EVE installed? Thanks!

Sounds familiar. Try removing the EnvironmentalVisualEnhancements folder from GameData, and replace it with the one from KSPRC, then you'll get clouds...LOTS OF CLOUDS. So many clouds that your rig will slow to 3fps whenever they are onscreen. :wink:

Edited by Starfire70

Share this post


Link to post
Share on other sites
6 minutes ago, Starfire70 said:

Sounds familiar. Try removing the EnvironmentalVisualEnhancements folder from GameData, and replace it with the one from KSPRC, then you'll get clouds...LOTS OF CLOUDS. So many clouds that your rig will slow to 3fps whenever they are onscreen. :wink:

All right, thanks. We'll see in 45 minutes! :D

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.