Proot

[1.1.2] KSPRC - Renaissance Compilation: artworks remake [V-0.7 Pre Release 3]

Recommended Posts

Just now, Speadge said:

it was in proots config already :D - so perhaps he settled someone there... many happy lil proots :D

KSPRC easter egg confirmed? :D

Share this post


Link to post
Share on other sites
9 minutes ago, Speadge said:

did i use a "3" somewhere? :D

Well, if you look at the config, especially at :

_CityOverlayDetailScale
			{
				value = 45
			}

its value is 45... 45... 4+5=9... 9=32 !!

Coincidence? I think not!

Share this post


Link to post
Share on other sites

Unfortunately also here I experienced the framerate dropping from 40 to 15-10 fps

(i7-4700, 16 gb ram,  ge force 850M) 

But... It really looks gorgeous even one frame at a time!!! :P 

The interesting thing is that the last version of EVE or scatterer work flawlessly if installed separately ... Must be the new textures or something else dropping down the framerate... 

Share this post


Link to post
Share on other sites

Glad you like it! Working on the reported issues!

Share this post


Link to post
Share on other sites
1 hour ago, Thomassino said:

Well, if you look at the config, especially at :

its value is 45... 45... 4+5=9... 9=32 !!

Coincidence? I think not!

u sir, u made my day :D

Share this post


Link to post
Share on other sites

How can I go about reducing asteroids in the meantime? I've half a mind to get rid of them entirety. I personally dont asteroid. 

Because I think there responsible for the memory spikes which crash my game. It's not rampant. The game loads, I can play for awhile, but all during then I notice a lot of hand ups. 

One in particular is a significant hang up when timewarping from day to night. The game seems to crash when the sky box pops up. The hang ups occur often in other areas as well and it's like a 50/50 chance. 64bit application with my 16gb of ram can chug through it half the time, but not always. Sometimes the game will not recover from these hang ups and freeze. 

So then go figure I look and see there's gotta be at least one hundred some asteroids around Kerbin. So... Even if that's not the direct cause it can't be helping. So while Proot works on tweaking things what can I do to get rid of asteroids all together?

That being said.... Proot this is really something else. Been playing since .18. It's like a new game. I can't wait to see what you have in mind with Unity 5's new tools. I remember years ago people were asking if KSP would ever rival the fidelity of Space Engine. Were getting close. 

Share this post


Link to post
Share on other sites

So... now this is just a hunch. But maybe... just maybe the thing responsible for my hang ups and crashes is the fact that I was running KSPRC on top of Stock Visual Enhancements... maybe. Lmao! And it loaded! All last night I was playing with both visual packs. Wow... Win64 is quite the beast. So.. don't do what I did.

Share this post


Link to post
Share on other sites
3 hours ago, Proot said:

Glad you like it! Working on the reported issues!

Proot! I hope this can help.   I've done several experiments excluding one by one all the plugins/ shaders.  

It seems that the main culprit for the fps loss is cloudvolumeparticle.Shader and cloudshadow.Shader from EVE

Excluding those I have an instant gain of 15fps,  but clouds do not load.  Other features have little or no impact on fps, not even textures surprisingly. 

The game is not slowing down if I use the original EVE file. 

Share this post


Link to post
Share on other sites

This is fantastic. I'm amazed by how great everything looks. Really, really great.

I have it running on a fresh install of 1.0.5 and the only thing I had to do was force DX11 mode.

For comparison, here are two screenshots of a mining base on Minmus, one taken a couple of months ago in stock KSP 1.0.2 and one taken today in KSP 1.0.5 with the new KSPRC. It is stunning.

 

Share this post


Link to post
Share on other sites

Proot, i have to say. I am incredibly upset you released this while my computer is broken :P But really though, great great work from the pictures I've seen in the thread and I can't wait to try it out myself, once I figure out my computer issue :D 

Share this post


Link to post
Share on other sites
1 hour ago, Nhawks17 said:

Proot, i have to say. I am incredibly upset you released this while my computer is broken :P But really though, great great work from the pictures I've seen in the thread and I can't wait to try it out myself, once I figure out my computer issue :D 

If you can mix your SVE (cloud) performance with Proot's texture - you da man! :)

I'm loving the new lensflare. Gorgeous.

EYVYrmq.jpg

u0YK3ln.png

and the total scatterer package

n25cMSc.jpg

Edited by maseo

Share this post


Link to post
Share on other sites

I'm getting a shimmering effect on coast lines. Is anyone else experiencing this? Wondering if its the fact that I'm using my gpu AA instead of the games.

Share this post


Link to post
Share on other sites

Hi Proot

Thanks for investing the time to make what looks like a fantastic visual mod.

Perhaps others can help me here, but on a 100% fresh install (via steam) with no other mods it seems the scatterer part is not working for me.

I'm on Windows 7 64bit OS running KSP in 32bit. (Tried OpenGL and DX11 arguments but it didn't make any improvement)

I used the link that was posted a page or two ago to download KSPRC as the new version had not been uploaded to Curseforge etc at that stage. Are there issues with that version?

 

Here is an example of scatterer not functioning correctly:

acrTGRb.png

Does anyone know why scatterer might not be functioning?


 

Edited by Eudae55
more info

Share this post


Link to post
Share on other sites
7 minutes ago, Eudae55 said:

Hi Proot

Thanks for investing the time to make what looks like a fantastic visual mod.

Perhaps others can help me here, but on a 100% fresh install (via steam) with no other mods it seems the scatterer part is not working for me.

I'm on Windows 7 64bit OS running KSP in 32bit. (Tried OpenGL and DX11 arguments but it didn't make any improvement)

I used the link that was posted a page or two ago to download KSPRC as the new version had not been uploaded to Curseforge etc at that stage. Are there issues with that version?

 

Here is an example of scatterer not functioning correctly:

acrTGRb.png

Does anyone know why scatterer might not be functioning?

This is known, sorry. For the moment Scatterer doesn't work in the Tracking Station.

Share this post


Link to post
Share on other sites
3 hours ago, Eudae55 said:

Here is an example of scatterer not functioning correctly:

Does anyone know why scatterer might not be functioning?

It's not enabled in the tracking station because it would either take too much memory to enable on all the bodies at once or it will take a few annoying seconds to load a different planet everytime you switch focus.

Share this post


Link to post
Share on other sites
15 minutes ago, blackrack said:

It's not enabled in the tracking station because it would either take too much memory to enable on all the bodies at once or it will take a few annoying seconds to load a different planet everytime you switch focus.

 

3 hours ago, Proot said:

This is known, sorry. For the moment Scatterer doesn't work in the Tracking Station.

Apologies. Forgive my ignorance. Thanks for letting me know.

Share this post


Link to post
Share on other sites

For Scatterer to start working around a body, the Active Vessel has to be within the Load Distance set within the PlanetList.cfg file that can be found in the Scatterer Configs folder. This is why even in Map view Scatterer will still not be working, pretty much, unless you are orbiting the planet you are looking at.

This doesn't seem to get stated enough and you see quite a few posts saying, "Scatter is not working when I installed it" or similar posts. You're not alone, Eudae. :D

Edited by Poodmund

Share this post


Link to post
Share on other sites

Ok, so I just when and did some quick and dirty comparisons between a couple of mods to see how FPS is affected. I compared stock to EVE, scatterer, EVE + scatterer, and KSPRC. All settings were set to max and V-sync was turned off.

In every case the game was run using the 32-bit .exe on Windows 10, the only exception being for KSPRC where I had to use the 64-bit workaround to actually launch anything otherwise I got a CTD with system out of memory in the log. (no other mods, just KSPRC). My specs are i5-4690k @4.0GHz, MSI GTX 970, 16GB ddr3 @ 1866MHz.

Quick summary, scatterer and EVE had an impact on FPS, but it remained at 60+ for the majority of the time. However with KSPRC the FPS rarely made it above 25 but also rarely fell below 25 (according to the in game monitor) although it did feel choppier than 25. Something is causing to framerate to tank, but I'm not sure yet what it is.

The following is an album of images from the four different scenarios. For each I tried to get a shot at launch, in flight and in orbit.

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.