Proot

[1.1.2] KSPRC - Renaissance Compilation: artworks remake [V-0.7 Pre Release 3]

Recommended Posts

Hello !
I just installed KSPRC, but it makes my game crash and close everytime I load an existing save or create a new one...

Is it a known issue ?

 

Share this post


Link to post
Share on other sites
1 hour ago, Chimer4 said:

Ok, so I just when and did some quick and dirty comparisons between a couple of mods to see how FPS is affected. I compared stock to EVE, scatterer, EVE + scatterer, and KSPRC. All settings were set to max and V-sync was turned off.

In every case the game was run using the 32-bit .exe on Windows 10, the only exception being for KSPRC where I had to use the 64-bit workaround to actually launch anything otherwise I got a CTD with system out of memory in the log. (no other mods, just KSPRC). My specs are i5-4690k @4.0GHz, MSI GTX 970, 16GB ddr3 @ 1866MHz.

Quick summary, scatterer and EVE had an impact on FPS, but it remained at 60+ for the majority of the time. However with KSPRC the FPS rarely made it above 25 but also rarely fell below 25 (according to the in game monitor) although it did feel choppier than 25. Something is causing to framerate to tank, but I'm not sure yet what it is.

The following is an album of images from the four different scenarios. For each I tried to get a shot at launch, in flight and in orbit.

 

I've noticed as well. Looks more like the particle clouds that Proot has, which are causing a slowdown. Remove clouds.cfg bumps the speed back up - but makes the game lake a certain 'feel'. I'm editing his file right now to get a nice combo.

1 hour ago, steelthunder said:

Just installed. Planets look great except for lacking clouds. How do I fix?

If you have a boulderco folder, delete it :)

15 minutes ago, turbu said:

Hello !
I just installed KSPRC, but it makes my game crash and close everytime I load an existing save or create a new one...

Is it a known issue ?

 

32bit my friend - wont run KSPRC, atleast without ATM.

Edited by maseo

Share this post


Link to post
Share on other sites

I installed this mod over top of EVA and other components which were installed via CKAN, and the result was no clouds.

I installed this mod carefully to a clean install of KSP and found the performance to be pretty poor:

Specs:

Core i7 4th gen @ 3.2  GHz

16GB RAM

Geforce GTX 765M

Gentoo Linux

 

Any way to dial in some settings to appropriate levels?

Edit: Blowing away scatterer helps immensely. I miss its effects, but it is apparently too much for my system. :|

Edited by FuzzyLlama

Share this post


Link to post
Share on other sites

This looks simply wonderful proot, amazing work.

I am however experiencing massive fps drops, down to the high twenties. Removed the  scatterer folder and forxed DX11 and OpenGL but no joy. Any suggestions anyone (all this was done on a clean install from Steam).

My specs are:

i5 3570k O/c'd 4.3

16GB RAM

GTX970

Am I being too ambitious with this mod even with, IMO, my fairly decent rig? Anything I should dial back?

Thanks!

Share this post


Link to post
Share on other sites
1 hour ago, FuzzyLlama said:

I installed this mod over top of EVA and other components which were installed via CKAN, and the result was no clouds.

I installed this mod carefully to a clean install of KSP and found the performance to be pretty poor:

Specs:

Core i7 4th gen @ 3.2  GHz

16GB RAM

Geforce GTX 765M

Gentoo Linux

 

Any way to dial in some settings to appropriate levels?

Edit: Blowing away scatterer helps immensely. I miss its effects, but it is apparently too much for my system. :|

If you have a boulderco folder, delete it :)

22 minutes ago, NickNaks said:

This looks simply wonderful proot, amazing work.

I am however experiencing massive fps drops, down to the high twenties. Removed the  scatterer folder and forxed DX11 and OpenGL but no joy. Any suggestions anyone (all this was done on a clean install from Steam).

My specs are:

i5 3570k O/c'd 4.3

16GB RAM

GTX970

Am I being too ambitious with this mod even with, IMO, my fairly decent rig? Anything I should dial back?

Thanks!

Remove the clouds from proot's pack (atmospheres folder) and you'll be good. The clouds seem to slow it down on my end.

Share this post


Link to post
Share on other sites

Instead to remove the clouds, try to just delete the file "MM_ReflectionPluginWrapper.cfg", inside Texture replacer folder.

This disables the part reflections (which are per-part and are probably slowing down the performance with any big/complicated craft). Would be cool to have some tests with that change.
BTW, sorry, but I don't know if this is compatible with other packs at all. So for the best and most secure results you should do the "cleanest" installation possible. That means, without previous versions of any of the plugins used, other packs and so on...

 

Share this post


Link to post
Share on other sites
Just now, Proot said:

Instead to remove the clouds, try to just delete the file "MM_ReflectionPluginWrapper.cfg", inside Texture replacer folder.

This disables the part reflections (which are per-part and are probably slowing down the performance with any big/complicated craft). Would be cool to have some tests with that change.
BTW, sorry, but I don't know if this is compatible with other packs at all. So for the best and most secure results you should do the "cleanest" installation possible. That means, without previous versions of any of the plugins used, other packs and so on...

 

Great call. This does improve performance quite a bit, and reduces some weird coloring on solar panels that I noticed.

Share this post


Link to post
Share on other sites

I can confirm there is a noticeable performance boost through removing the ReflectionWrapper.cfg . Thanks for the tip, Proot! 

Edited by E.Nygma

Share this post


Link to post
Share on other sites
1 hour ago, Proot said:

Instead to remove the clouds, try to just delete the file "MM_ReflectionPluginWrapper.cfg", inside Texture replacer folder.

This disables the part reflections (which are per-part and are probably slowing down the performance with any big/complicated craft). Would be cool to have some tests with that change.
BTW, sorry, but I don't know if this is compatible with other packs at all. So for the best and most secure results you should do the "cleanest" installation possible. That means, without previous versions of any of the plugins used, other packs and so on...

 

And might it not be easier to change the update interval if you want to keep reflections, instead of interval 4 of 6 ?

Share this post


Link to post
Share on other sites
11 minutes ago, maseo said:

And might it not be easier to change the update interval if you want to keep reflections, instead of interval 4 of 6 ?

I'm doing the change, but is not so much the interval as the parts calculating each own reflection. If you have just a cockpit is barely noticeable, but if you are running a station or a complicated craft with many engines and so on...

@Proot: is it the same as windowshine or how is it related to it?

It's based on Texture Replacer, by shaw, which has a reflections plugin. Windowsshine uses that same plugin.

 

Share this post


Link to post
Share on other sites

Hey Proot I couldn't help but notice that you didn't re-texture the Radial attachment point in this release. I actually re-textured it myself a bit ago.

 

evjiTjV.jpg

 

If you want the texture and normal map just ask :D - Also I wanted to say that I am very happy to see that you included reflections in your main download! I am honored you're using WindowShine textures :).

Share this post


Link to post
Share on other sites
50 minutes ago, Speadge said:

so windowshine is suffering the same issue then?

No, this is not an issue by itself. Just too heavy, in this context, for most of the machines.

BTW, I'll probably upload a new version during this night, with cloulds and performance improvements and some minor changes more.

 

Share this post


Link to post
Share on other sites
1 hour ago, Avera9eJoe said:

Hey Proot I couldn't help but notice that you didn't re-texture the Radial attachment point in this release. I actually re-textured it myself a bit ago.

 

evjiTjV.jpg

 

If you want the texture and normal map just ask :D - Also I wanted to say that I am very happy to see that you included reflections in your main download! I am honored you're using WindowShine textures :).

Nice.

And also -- I like your new logo/icon!

Share this post


Link to post
Share on other sites
4 hours ago, maseo said:

If you have a boulderco folder, delete it :)

Remove the clouds from proot's pack (atmospheres folder) and you'll be good. The clouds seem to slow it down on my end.

Thank you, I removed the clouds.cfg file from that folder and my fps went from 14-20fps to nearly 100fps!

The game frequently crashes but I think that's just down to the 32bit application?

Edit: Used ' -force-opengl' and it seems to have reduced the RAM to about 2.5GB.

Edited by NickNaks
typo

Share this post


Link to post
Share on other sites
1 hour ago, Beetlecat said:

Nice.

And also -- I like your new logo/icon!

Thank you and thank you! :D - It was time to move away from the Lego Classic Space logo :)

Share this post


Link to post
Share on other sites
13 hours ago, Proot said:

No, this is not an issue by itself. Just too heavy, in this context, for most of the machines.

BTW, I'll probably upload a new version during this night, with cloulds and performance improvements and some minor changes more.

 

@Proot Awesome! I'm looking forward to this (test) release - might speed up things a bit for the stream :)

Share this post


Link to post
Share on other sites
17 minutes ago, maseo said:

@Proot Awesome! I'm looking forward to this (test) release - might speed up things a bit for the stream :)

get some sleep, jay ;)

@Proot are these really performance improvements u were talking about or tradeoffs? Cause i dont want to miss one single pixel ;)

Share this post


Link to post
Share on other sites
1 hour ago, Speadge said:

get some sleep, jay ;)

@Proot are these really performance improvements u were talking about or tradeoffs? Cause i dont want to miss one single pixel ;)

@Speadge no worries - im at work anyways ;-)

@Proot Perhaps to use as a retexture for Kerbin (from space and maybe down low ?

nNGSt2G.jpg

Edited by maseo

Share this post


Link to post
Share on other sites

Proot makes the artwork for stock KSP look like the work of a blind monkey... Simply amazing; I don't know why you havn't been hired on as the art director.

Share this post


Link to post
Share on other sites
3 hours ago, Kokanee said:

Proot makes the artwork for stock KSP look like the work of a blind monkey... Simply amazing; I don't know why you havn't been hired on as the art director.

cause he would have broken the 32bit 4gb limitation on startup already :D

Share this post


Link to post
Share on other sites

Is there any chance you could release a lower resolution version? As much as I love the 8k textures, my computer sure doesn't.

Great mod, and can't wait to see more! 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.