Proot

[1.1.2] KSPRC - Renaissance Compilation: artworks remake [V-0.7 Pre Release 3]

Recommended Posts

On Linux, the required log is called Player.log and can be found in ./home/[username]/.config/unity3d/Squad/KerbalSpaceProgram/ on Mint and I think also on Ubuntu. Cheers and a happy new year, especially to @Proot and thank you for your amazing work!

Edited by E.Nygma
sry, corrected path to log

Share this post


Link to post
Share on other sites
5 minutes ago, barfing_skull said:

I'm not sure what OS you're on, but it might be different between Windows and Linux.  Under Linux, all I get is KSP.log.  I think they're one and the same, but I don't play under Windows.

I even ran

find . -type f -exec stat --format '%Y :%y %n' "{}" \; | sort -nr | cut -d: -f2- | head

to try and find any newer files in my KSP installation directory in case some other log were squirrelled away in there.  I didn't find anything.  I did a brief search, but I don't see if there's some way to launch KSP on the command line with extra logging or debugging?

Cheers,

-BS

Ahh gotcha gotcha. Didn't know that about the Linux version!

Share this post


Link to post
Share on other sites
44 minutes ago, E.Nygma said:

On Linux, the required log is called Player.log and can be found in ./home/[username]/.config/unity3d/Squad/KerbalSpaceProgram/ on Mint and I think also on Ubuntu. Cheers and a happy new year, especially to @Proot and thank you for your amazing work!

Ah, thanks.  I know I'd seen that location once before, just needed to be reminded of where it was.  Interestingly, the error messages there are a little different based on whether I launch it through Steam or not.  I normally DO NOT launch from Steam, due to the overhead of launching that as well as KSP.  However, I've seen other mods that have issues behave differently when I run with Steam, and then without.  In this case, the logs are a little different, but the overall result is the same, a segfault somewhere early in the load process.

First log, with Steam.

http://pastebin.com/zYSMpmsp

Second log, without Steam

http://pastebin.com/JNTunezU

Third log, successful launch, no KSPRC.  I truncated this log because it was huge and Pastebin was choking on the full thing.

http://pastebin.com/KjuCUcwg

 

I'm not sure what the second one means, that's how I usually run it.  Just a SIGSEGV, which is kinda what I suspected.  I don't see any of the libraries in the mod referenced, but I'm guessing that there's some DLL incompatibility between mods in there somewhere that's triggering the SEGV in native code.

Looking through the logs, I haven't had trouble with EVE before (might be interesting to try EVE without KSPRC), but this is the only KSPRC DLL that seems to be mentioned:

Non platform assembly: /home/user/.local/share/Steam/SteamApps/common/Kerbal Space Program/GameData/KSPRC/Plugins/SunFlareLoader.dll (this message is harmless)

I kinda wonder what would happen if we were to stop it from loading that DLL.  I suppose I could just remove the KSPRC folder - see what happens.  I realize the mod might not work correctly, but it would help narrow it down.

Cheers,

-BS

Share this post


Link to post
Share on other sites

Narrowed this down a bit.  I tried removing the directories provided by KSPRC one by one.  The crash doesn't happen (though it seems to hang further along in the loading sequence) if I remove DistantObject.

I tried downloading DistantObject 1.6.4 on its own, and replacing the DLL, then the whole package.  Same result and it crashes.  (The DLL's are the same size but they differ in content).  So, it appears that the problem happens with DistantObject.  I take it this is necessary for KSPRC to run fully?

Cheers,

-BS

Share this post


Link to post
Share on other sites
On 12/30/2015 at 10:34 AM, Thomas P. said:

The workaround is to update Kopernicus

I have updated Kopernicus to the latest version and yet I'm still getting Asteroid spam :/

Share this post


Link to post
Share on other sites

One small step for a man, one giant leap for kerbalkind.

xXmYgDG.jpg

Happy year 2016!

Share this post


Link to post
Share on other sites

Finally got to make videos of the least interesting planets in ksp because of your mod, proot. Thanks again! Here is the video if you wanna check it out.

 

Share this post


Link to post
Share on other sites
11 minutes ago, DaZeInBok said:

Finally got to make videos of the least interesting planets in ksp because of your mod, proot. Thanks again! Here is the video if you wanna check it out.

nice one!

Share this post


Link to post
Share on other sites
8 hours ago, Proot said:

One small step for a man, one giant leap for kerbalkind.

xXmYgDG.jpg

Happy year 2016!

Lol looking at this on my iPhone i almost didn't see it! :P then I looked closer and wow that's a big Mun rock!

Share this post


Link to post
Share on other sites

And he is over it... :cool:

BTW, a very cool video DaZeInBok!

Edited by Proot

Share this post


Link to post
Share on other sites

Is Jool's ring supposed to load as default? I see the texture in Kopernicus' folder. Any code to put manually in cfg?

Share this post


Link to post
Share on other sites
6 minutes ago, SkyKaptn said:

Is Jool's ring supposed to load as default? I see the texture in Kopernicus' folder. Any code to put manually in cfg?

Procedural clouds are not fully compatible with rings (yet).

Share this post


Link to post
Share on other sites
1 hour ago, Proot said:

And he is over it... :cool:

BTW, a very cool video DaZeInBok!

Thanks. Hope to make many more using your mod :D 

Share this post


Link to post
Share on other sites
7 minutes ago, drswagboss said:

There we go

Another great video! I love those overflights!

You mind if I put these videos in the OP?

Share this post


Link to post
Share on other sites
1 hour ago, Proot said:

Another great video! I love those overflights!

You mind if I put these videos in the OP?

Nope, don't mind at all

Edited by drswagboss

Share this post


Link to post
Share on other sites

@Proot If you were talking about my videos also I don't mind at all, not sure if you were though 

Edited by DaZeInBok

Share this post


Link to post
Share on other sites
Hi everybody ,
is that you must have previously installed all the mods in the zip of this ksprc ?

Share this post


Link to post
Share on other sites

No, actually its better if you have none of those mods installed, they all come packed with the zip...

Share this post


Link to post
Share on other sites

I'm sorry if someone already asked it but I couldn't find an answer , how do I disable 3d clouds?

Share this post


Link to post
Share on other sites

Im having a problem with this mod on the MAC. when i have everything installed into the save file i can get to the main menu but when i go to the space center my game crashes

basically i did some trial and error and found the problem in the KSPRC folder under Atmospheres. i think the problem has something to do with tor1, tor2, and vulclouds textures. 

does anyone know how to fix this?

@Proot

Edited by justspace103

Share this post


Link to post
Share on other sites
13 minutes ago, WPENG730 said:

I want to use this mod SO BADLY BUT IT RUNS OUT OF MEMORY EACH TIMEEEEEEE

:'(

THEN CONVERT TO X64 AND STOP USING CAPS :P

X64 Workaround

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.