Jump to content

Hailing Frequencies (aka HELP!)


Schmulky
 Share

Recommended Posts

Hi! My name is Seth. I'm running KSP 0.23, I haven't upgraded to ARM yet. I enthusiastically support KSP and everything it's trying to accomplish, but a few particular bugs really...bug me.

First there's the general floppiness of large craft, which everybody seems to complain about and nobody seems to have reliably fixed yet without resorting to the debug panel. I do want realism, but you'd think I was flying an ornithopter! If I'm wrong about there being no fixes, please please do tell!

Sometimes parts that should go together just don't want to. I often find that if I click enough times and at the right angle (I have found no pattern by which to predict a workable camera angle for a difficult attachment) I can cajole the computer into doing what I want it to, but I don't enjoy spending up to ten minutes trying to connect things. It's even worse when trying to fill a B9 cargo bay, which seems only to accept long chains of Mk1-2 Command Pods with one docking port at the front of the first pod. I assume/hope I'm overlooking something incredibly simple here...

As mentioned I've installed B9 Aerospace, and naturally I love it. Perhaps the biggest problem, though, is my SABREs are constantly overheating. Precoolers or no, struts and trusses or no, after about 45 seconds of vertical flight at full throttle they explode. They last a bit longer horizontally - sometimes even up to five minutes if I play the throttle just right, but any lower and I wouldn't have a shot at space anyhow. Spacing the engines out sometimes works, but sometimes exacerbates the problem. Each flight is different - sometimes the proximal engines fail first, sometimes the distal ones. I tried installing a B9 fix from here http://forum.kerbalspaceprogram.com/threads/66020-B9-0-23-fixes

and tried following the instructions here: http://www.reddit.com/r/KerbalSpaceProgram/comments/1we7r2/psa_how_to_get_sabre_engines_b9_aerospace_working/, but to no avail. I'm really down on my knees about this one - at my stage of familiarity with the game I really prefer a single type of engine on my airplanes so I can focus on fuel management and ascent profiles. RAPIERs are okay, but nothing beats a few SABRE Ms! Until they explode.

I also understand that using B9 engines renders the COM ball invisible or something... is there a fix?

Penultimately, is there a decent mod for building spaceports on other planets? Launching from the Mun, or even Duna would be a godsend.

Lastly, I'm quite eager for any tips on landing gear placement so as to avoid tail scraping.

Thank you in advance to everyone who's going to help me get my aeronautical act together! I can't wait to get into deep space and test out the bussard ramjet I've been itching to download from the SpacePort...

Link to comment
Share on other sites

One last question - sorry - why do rovers keep flipping and how do you fix it? I've tried low center of mass, ans a wide wheelbase and track, but the none of it seems to work. Downward thrusters is unrealistic and I must be doing it wrong, because it generally tends to exacerbate the problem, SAS or no...I've tried making a completely armored rover, but mass aside it's still annoying when they roll. Any pointers?

Link to comment
Share on other sites

-Floppiness was fixed in 0.23.5 (ARM), but Kerbal Joint Reinforcement fixes that if you have an earlier version (which you do).

-B9? Um... that's not my division. You'd have to ask someone else.

-As for part weirdness and connection issues, try hitting "W" to rotate 90 degrees, and then "S" or SPACEBAR to rotate it back. That often works for me.

-And landing gear: Put them slightly behind your CoM, then just *tap* "S" to nose-up slightly. You'll pivot on the landing gear, making takeoffs much easier. Try to just wait for the plane to take off by itself; if it was designed well it should.

Other than that, you seem to be pretty well off. Hope you have some good times!

Link to comment
Share on other sites

I run .23 because mechjeb works properly on it also its easier to install B9.

Mechjeb works just fine on .23.5, I use it all the time

One last question - sorry - why do rovers keep flipping and how do you fix it? I've tried low center of mass, ans a wide wheelbase and track, but the none of it seems to work. Downward thrusters is unrealistic and I must be doing it wrong, because it generally tends to exacerbate the problem, SAS or no...I've tried making a completely armored rover, but mass aside it's still annoying when they roll. Any pointers?

Rovers are alittle tricky, but you have to remember that they actually go very fast.

Real life rovers move really slow. The Curiosity rover moves some 200meters per day.

So you're flipping because you are going relativly fast on a low gravity world

Link to comment
Share on other sites

Mechjeb works just fine on .23.5, I use it all the time

Rovers are alittle tricky, but you have to remember that they actually go very fast.

Real life rovers move really slow. The Curiosity rover moves some 200meters per day.

So you're flipping because you are going relativly fast on a low gravity world

but mechjeb just hates me (Whispers)*Im pretty sure its a real AI thats holding a grudge against me for all the kerbals ive turned into mush by smashing them into the mun*

Link to comment
Share on other sites

I've upgraded or whatever - indeed the floppiness is fixed! Wonderful.\

I've tried the Extraplanetary Launchpads mod (several versions, apparently the one on the SpacePort isn't the most recent?) and I'm still struggling to get the thing working. Currently when I start a ship building the progress bar just hangs at zero. I think debug mode is enabled? The code "debug = True" wasn't in the launchpad2/part.cfg document when I found it so I put the line in, but nothing changed! Adding on filled rocketparts and/or metal bins seems to change nothing, nor does varying the size of the ship I try to construct. Any pointers?

Parts are still finicky with the B9 pack. Overheating remains a problem, but I have gotten better at playing the throttle!

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...