godarklight

DarkMultiPlayer 0.3.4.0 [KSP 1.8]

Recommended Posts

To be clear, multiperson crafts are not in 0.1.4.1 right?

Edit: Answered on IRC

Also thankyou for your continued and speedy progress, we have been enjoying not randomly exploding near eachother.

Edited by Spider0804

Share this post


Link to post
Share on other sites

@ScriptKitt3h: Can you start KSP, and then upload your KSP_folder/KSP_Data/output_log.txt file to pastebin and link it here?

After you have done that, It should be quite easy to figure out what the problem is ;). To fix it, you will likely have to delete DarkMultiPlayer/Plugins/Data/servers.xml and saves/DarkMultiPlayer/servers.xml (Although that's actually my settings file...)

@InfiniteDice: I'd rather not break curses rules - If they don't want to host exe's that's fine with me, My build server instantly updates anyway :)

@wased89: That's normally caused by trying to update DMP when KSP is running.

@Spider0804: Permissions are coming for 0.1.5.0. Everything is coming in 0.1.5.0 (I want to kind of "finish" DMP) :P

EDIT: DMPUpdater for the server messed up - It's fixed now

Edited by godarklight

Share this post


Link to post
Share on other sites

I have been unable to get the server->client syncing program to work. Will that be included with 0.1.5.0 so we can keep mod files synced or will that never be implemented? I keep getting exceptions thrown and I can't really find a read me or manual for it.

Share this post


Link to post
Share on other sites

@DLWittet - DMPUpdater must run while KSP is closed, I'll catch that exception and print out an error message saying so. That only updates DMP though...

I'll have to port over KMPModClient to DMP sooner or later - It's an automatic mod syncer that works out of a mod cache folder (which means there's no redistribution problems as you still have to download them yourself).

@Everyone - DMP appears to be a little more popular than I thought it would have been. As plenty of other servers are available now, I'm taking down my 3 that were running on my home connection :P.

If you want your career points transferred to another server - PM or catch me on IRC ;)

Edited by godarklight

Share this post


Link to post
Share on other sites

Thanks Godarklight. Your multiplayer is pretty stable and I've gotten lots of mods on it, plus everything was pretty straightforward. It's awesome enough to hold us over until official multi-player is released.

Is there any way to have commands in the command line to reload settings and mod control file? It's annoying to have to shut down the server to reload those. Other than that, an in game server browser would be nice but that's more fluff.

*Edit*

And how do you spectate again? I had issues before 1.4.1 but haven't had a chance to try again in 1.4.1

Edited by DLWhittet

Share this post


Link to post
Share on other sites

@DLWhittet: "It's awesome enough to hold us over until official multi-player is released." - That's my plan too, The only reason why DMP exists is because I like playing multiplayer. When KSPM comes out, DMP will be hopefully completely obsolete. I wouldn't hold my breath though for KSPM ;).

"reload settings and mod control file": Currently, not at the moment. I'll probably end up changing so it reads the mod file every time someone connects instead, but remember, if you change the mod file there's a good reason for a server restart (The parts should be required mods, etc).

I initially wanted to be able to press on the server in the game and have it say "5/20 players online" type of thing, but that would be a seperate connection & message, which I'd have to handle pretty specially, so I decided against it.

To spectate, just try to fly the same craft someone else is flying.

Edited by godarklight

Share this post


Link to post
Share on other sites
@ScriptKitt3h: Can you start KSP, and then upload your KSP_folder/KSP_Data/output_log.txt file to pastebin and link it here?

After you have done that, It should be quite easy to figure out what the problem is ;). To fix it, you will likely have to delete DarkMultiPlayer/Plugins/Data/servers.xml and saves/DarkMultiPlayer/servers.xml (Although that's actually my settings file...)

Ok, I'll see what I can do.

EDIT: So if those .xml files are the cause, will they be replaced automatically by DMP?

Edited by ScriptKitt3h

Share this post


Link to post
Share on other sites

Found the problem:

[2.488009] DarkMultiPlayer: XML Exception: System.IO.IsolatedStorage.IsolatedStorageException: Could not find a part of the path "C:\Users\JMAN_2\Desktop\DMP\GameData\DMPClient\GameData\DarkMultiPlayer\Plugins\Data\servers.xml".

I should bring up a message saying DMP has been installed in the incorrect place (It should be KSP_folder/GameData/DarkMultiPlayer, not KSP_folder/GameData/DMPClient/GameData/DarkMultiPlayer)

Share this post


Link to post
Share on other sites
Found the problem:

[2.488009] DarkMultiPlayer: XML Exception: System.IO.IsolatedStorage.IsolatedStorageException: Could not find a part of the path "C:\Users\JMAN_2\Desktop\DMP\GameData\DMPClient\GameData\DarkMultiPlayer\Plugins\Data\servers.xml".

I should bring up a message saying DMP has been installed in the incorrect place (It should be KSP_folder/GameData/DarkMultiPlayer, not KSP_folder/GameData/DMPClient/GameData/DarkMultiPlayer)

Ok, thanks!

Share this post


Link to post
Share on other sites

How come no connection window is popping up for me? I have version 0.23.5.459.

Share this post


Link to post
Share on other sites

I am building a space station in orbit and it's getting really difficult to deal with since the game keeps skipping (syncing) every 5 or so seconds and its making everything jump at once... how can I get around this so that I can dock things safely?

EDIT: Aaaaaand there goes the power supply my power station for the third time.... For some reason when I pull up the debug for DMP, and I' m watching the current error, which syncs every 5 seconds, and I switch to my station, it doesn't sync up every 5 seconds, the error just keeps going and going, but when I switch to another craft the error resets after 5 seconds like normal?

Edited by wased89

Share this post


Link to post
Share on other sites

@wased89: I've changed the way the subspace rate is chosen in dev, it should be much more uncommon in 0.1.5 ;)

EDIT: Apparently my internet goes down randomly in the night - As MrFreake's server seems to be very reliable, I may shift DMP's home to that instead. I'll give you guys updates if it goes ahead :)

Edited by godarklight

Share this post


Link to post
Share on other sites

I might have to wait until 1.5 to come out until i can dock again.. ETA on 1.5 release date?

EDIT: Getting DEV now and going to reboot up all my stuffs... what all do you have summed up for for 1.5?

Edited by wased89

Share this post


Link to post
Share on other sites

@wased89: Dev is still compatible with release, you can try using the dev version now (Nothing critical has gone in yet).

Share this post


Link to post
Share on other sites

Nope, even with the dev version the current error continues to go up on my ship as it nears the station and it jumps to sync every time it hits 5000ms. It's a slower process now, but it's still there and its still deadly... What now?

Edited by wased89

Share this post


Link to post
Share on other sites

It's a very nice project! But I am REALLY missing the loading of vessels in the SPH/VAB... I can only "save" crafts by transfering them to the subassemblies.

And I don't know why, but I often get disconnected. Is the fault of my slow internet connection? (up to 4Mbit/s download [normally 1,25], up to 0,6MB/s upload [normally 0,18)?

I think so.....

Trailers

Share this post


Link to post
Share on other sites
And I don't know why, but I often get disconnected. Is the fault of my slow internet connection? (up to 4Mbit/s download [normally 1,25], up to 0,6MB/s upload [normally 0,18)?

I think so.....

My buddy was getting constant disconnects, and he's on the LAN with me, so seems to be a deeper issue, there.

Share this post


Link to post
Share on other sites
My buddy was getting constant disconnects, and he's on the LAN with me, so seems to be a deeper issue, there.

hmm. Now it goes. I only got disconnected because of creating an already existing subspace? no idea... but at least its better now, without changes.

It seems also, that others can load their crafts except me (at least they share it and fly it afterwards). Any idea? I am up-to-date ;)

EDIT: While flying out of atmosphere, the engines sometimes suddenly stop to go full throttle right after it again. During that time I loose up to 100m/s DeltaV..... And once I got warped too, with engines on out of atmosphere. As a result my rocket exploded.. It's kinda fun but still needs to be updated. I can't get to Minmus for a base like this! ^^

Edited by Trailers
Another problem

Share this post


Link to post
Share on other sites

My rockets do the same sometimes when I'm out in space, they will cut throttle then restore it from half as it was cutting, it runs a bit slow because idk why. But the debug menu says it is running at 1.5x warp speed.

Share this post


Link to post
Share on other sites

OK, so this is pretty much game breaking for me.... The game keeps syncing every 5 seconds and trying to dock becomes almost impossible as the ships wants to be inside the station and ends up blowing things up, as well as trying to get kerbals to maneuver around it is impossible and got a kerbal stuck inside the station where the game told him to **** off and go home... he is now de-orbiting and re-entering. Why is this happening and how can I fix it? I pretty much can't play the game until this issue gets fixed...

Share this post


Link to post
Share on other sites

@Trailers/wased89: DMP subspaces require everyone to be in sync, but I've obviously underestimated how badly KSP lags on other computers (as I have a GTX760).

After 0.1.4.1 came out, the first changes in dev were how the subspace rates were requested (DMP guesses a little better now), how slow a subspace can run (Down from 0.5x to 0.3x), and changing from the average rate to the slowest rate in the subspace.

Basically, in the next verison, your game is going to have to be able to run at least 0.2x (0.3 subspace rate/1.5x warp) real speed, instead of 0.44x speed (0.66x due to a bug in request subspace speed / 1.5x warp).

Share this post


Link to post
Share on other sites

Been using DMP on a private server with some of my mates and having lots of fun. Things mostly work good with occasional hiccups. Can you explain what the various warpmode's listed in the DMPServerSettings file are?

Share this post


Link to post
Share on other sites

@Gristle: You made me double check my readme :). https://github.com/godarklight/DarkMultiPlayer/blob/master/README.md#warpmode

I should probably implement SUBSPACE_SIMPLE and MCW_LOWEST for the next release...

EDIT: 0.1.4.2 is available on DMPUpdater and my build server. It should allow the subspaces to run slower, so you shouldn't have as many problems launching / docking.

Edited by godarklight

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.