godarklight

DarkMultiPlayer 0.3.5.2 [KSP 1.9]

Recommended Posts

"

  • Forward the DMP default Port (6702) in your Router

"

I have no idea what that means or where to even start. Can I get a lead?

Also, if I host a server, can another pc plugged into the same router play on that server?

 

Thank you!  Really wanna play some KSP!

Share this post


Link to post
Share on other sites

is there a way to connect to me and a friend using hamachi, i've succesfully done it with kmp but i just cant seem to get it to work with dmp

Share this post


Link to post
Share on other sites

bananashavings - currently no, there is no way to do shared science - although you can copy science from one profile to another, it won't stay in sync.

n174rm - Me too, maybe one day when multiplayer comes out we'll be able to play it without so many explosions :D

Deizelpunk - No reason that I could give, it should Just Work (TM)

Zrux - Your router is a computer, when people on the internet try to connect to your address, they connect to your router and it says "What? I'm not running DMP, go away!". Port forwarding makes the router redirect all requests for DMPServer (really TCP port 6702) to your computer. Unfortuneatly it's different for every router, so I can't give much advice apart from check www.portforward.com - the basics are the same on each machine, you need port TCP 6702 to your internal address (usually looks like 192.168.x.x). And yes - you don't need port forwarding if they are connecting from within the same network, just type the internal address.

thegoog23 - Same as any other game, just type their hamachi address, port 6702 as per usual as far as I know, but I'd seriously recommend port forwarding instead.

Share this post


Link to post
Share on other sites

Hi everyone,

I'm playing around with this because it looks potentially like one of the most awesome things ever...

I can get a server up and running for local play, which is all I'm trying to do.  But I'm having trouble setting any options using the DMPServerSettings.txt file.  I make the file but when I run the server it seems to just delete the server settings file.  I *assume* I've just got the syntax wrong, but there are no examples of correct syntax that I've been able to find.  For example, trying to set it up for a career mode game I've tried each of the following:

gamemode=CAREER
gamemode CAREER
gamemode=2
gamemode 2

but none of those work.  Can anyone post a few code snippets of correctly written DMPServerSettings.txt files?  Obviously, the thing I'm most interested in is setting it for career mode, but other things would be handy for me and for other noobs as well.

Share this post


Link to post
Share on other sites
6 hours ago, gleedadswell said:

I can get a server up and running for local play, which is all I'm trying to do.  But I'm having trouble setting any options using the DMPServerSettings.txt file.  I make the file but when I run the server it seems to just delete the server settings file.  I *assume* I've just got the syntax wrong, but there are no examples of correct syntax that I've been able to find.  For example, trying to set it up for a career mode game I've tried each of the following:

I installed DMP a week ago too, but for me there is no DMPServerSettings.txt, only a config under /Config/Settings.txt with the following lines:

# gameMode - Specify the game type.
gameMode=CAREER

 

In carrier mode there is a bug that keeps decreasing your reputation under some circumstances,

so I wrote a dirty little power shell script to keep the reputation from decreasing: http://pastebin.com/y88r3Qqh

 

Also hi thread, I'm new :P

Share this post


Link to post
Share on other sites
On 20/03/2016 at 2:24 AM, CptPonk said:

I installed DMP a week ago too, but for me there is no DMPServerSettings.txt, only a config under /Config/Settings.txt with the following lines:

# gameMode - Specify the game type.
gameMode=CAREER

Awesome!  How did I not notice that directory?

The script looks useful, but I'm in Linux so I don't think there's a straightforward way to use Power Script.  If I was feeling ambitious I'd rewrite your script in bash, but I'm swamped with other things.  I think for now I'll call the declining reputation a "difficulty setting".

Thanks!

Share this post


Link to post
Share on other sites

Hello and thanks for a great mod!

I'm pretty newbish to running servers but I'm renting one and wonderd, how whould I go about adding parts mod to the server?

I have a mod, underneath, that I want to intall on the server. Do I need to upload every single file into the right folder on the server?

Thanks for any help!)

Edited by Tuskusson

Share this post


Link to post
Share on other sites

In your game at the main menu you have tab with DMP->options. there is generate whitelist button(DMPModControl.txt)....it generates txt file in your game folder. Just put it in server folder and replace the old file. And there you have modded(added parts) to server! :)

Edited by Toonu

Share this post


Link to post
Share on other sites

I've been watching the streams for KSP 1.1 and I only have one question:

 

Will you be updating DMP for 1.1 when it comes out, and will 32-bit players be able to play with 64-bit players?

 

I really want to restart my server again, and with the massive performance boost having multiple players in the same area shouldn't cause as much lag anymore, plus we can use more mods with the 64-bit edition.

Share this post


Link to post
Share on other sites

@jm764 I'll update DMP for 1.1, and DMP is platform indepentant, so it will run on both 32 and 64bit as it has in the past already. I'm not a part of the QA team however, and I only have KSP on the KSP Store if they decide to do this public beta thing, so I may not be able to push an actual update until after 1.1 comes out.

Share this post


Link to post
Share on other sites
1 hour ago, godarklight said:

@jm764 I'll update DMP for 1.1, and DMP is platform indepentant, so it will run on both 32 and 64bit as it has in the past already. I'm not a part of the QA team however, and I only have KSP on the KSP Store if they decide to do this public beta thing, so I may not be able to push an actual update until after 1.1 comes out.

Ah that's good to hear. I'll have to ask Squad if possible, but if you want and have steam I can share my KSP copy with you so you can develop the mod during the 1.1 beta.

 

^_^

Share this post


Link to post
Share on other sites

i don't know if somone already asked this, but i was wondering why i can't save a modded ship. i want to build a massive space station with modded parts, but i can't leave the parts in orbit

Share this post


Link to post
Share on other sites
1 hour ago, Plecy75 said:

i don't know if somone already asked this, but i was wondering why i can't save a modded ship. i want to build a massive space station with modded parts, but i can't leave the parts in orbit

you need to recreate modlist so you parts are not getting deleted...

Share this post


Link to post
Share on other sites

I've done the initial port to the KSP 1.1 pre-release, from now on unstable will be KSP 1.1 support ;), however, this is nearly completely untested (Fixed compile errors, add parts, connect, launch, disconnect, sync again - vessel there).

1.1 support starts at commit 041dad7b5b290d64134442845f4a9b2623e8bcab

For those that are running the pre-release - you may want to get in touch in #DMP (the chat thing on my build server, or if you're familiar with irc, the server is esper) or leave any comments of strangeness here.

Edited by godarklight

Share this post


Link to post
Share on other sites
On 3/30/2016 at 10:49 AM, godarklight said:
 

I've done the initial port to the KSP 1.1 pre-release, from now on unstable will be KSP 1.1 support ;), however, this is nearly completely untested (Fixed compile errors, add parts, connect, launch, disconnect, sync again - vessel there).

1.1 support starts at commit 041dad7b5b290d64134442845f4a9b2623e8bcab

For those that are running the pre-release - you may want to get in touch in #DMP (the chat thing on my build server, or if you're familiar with irc, the server is esper) or leave any comments of strangeness here.

Very excited, thank you for supporting the mod!

Share this post


Link to post
Share on other sites

Hey @godarklight, did someone go and declutter the screenshot repository on Mega?

Cause I can't find any of my screenshots from my previous two DMP usernames.

Share this post


Link to post
Share on other sites

If anyone's bored, I've got a basic 10-slot KSP 1.0.5 server running at seekay.asuscomm.com:6702. It's on a Raspberry Pi 2 Model B and I'm trying to see if it can actually run the server properly. Any help would be appreciated :)

Allowed (but 100% optional) mods are Kerbal Engineer, Kerbal Alarm Clock, Editor Extensions and Transfer Window Planner. KER's Engineer Chips have been disabled to avoid part discrepancies between players since KER is an optional mod.

Edited by CaptainKorhonen

Share this post


Link to post
Share on other sites
On 3/30/2016 at 8:49 AM, godarklight said:

I've done the initial port to the KSP 1.1 pre-release, from now on unstable will be KSP 1.1 support ;), however, this is nearly completely untested (Fixed compile errors, add parts, connect, launch, disconnect, sync again - vessel there).

1.1 support starts at commit 041dad7b5b290d64134442845f4a9b2623e8bcab

For those that are running the pre-release - you may want to get in touch in #DMP (the chat thing on my build server, or if you're familiar with irc, the server is esper) or leave any comments of strangeness here.

Awesome work, godarklight! I was able to build the unstable branch at that commit number and tested the server and client using KSP 64 bit build 1184 (local network server on my laptop). All around it works pretty well. Only time I saw things get wonky was when physics warping with a high part count ( x > 350). Some of the KSP UI turned blank white and all right click menus were missing buttons - had to restart KSP to set things back to normal (although the orbits of crafts escaping from Kerbin changed drastically after the restart). I did export a save into a universe instead of starting from scratch (so perhaps that's partly to blame), but overall it behaves in a far more stable manner than I would have predicted. While I haven't tested piloting multiple crafts on different client computers within a  ~1 km radius of each other, for an initial port, I'm pleasantly surprised with how functional everything is. Will be testing later tonight as well - I'll try to pay more attention to the debug log this time:). Thanks for the great work!

Edited by punster

Share this post


Link to post
Share on other sites

I've run into a bit of a problem with the 1.1 build. When trying to exit a building, or enter the VAB it's throwing a NullRefrenceException and not allowing me to enter the VAB or exit any of the buildings. I'm on build 1183 if that helps. Any help would be appreciated, thanks!

Share this post


Link to post
Share on other sites

That is a problem of remottech not of dmp as far as i have read in the forums...

 

By the way godarklight:

I would appreciate it if you could add the option to make the server tick faster ( i think it s frames per second for the server which is by the last info i have 5 per seconds?) in the cfg file...

You have done that for one guy in private and I had asked you half a year ago if you could add these option to the cfg file as i can read here in the forums.

Would be nice if anyone of us could have these option :-)

No pressure here only a little humble whish of a gamer and admirer of you work ! :-)

 

Sorry for the red colour but I want to catch your eye with this one ;-)

Edited by Nightmare

Share this post


Link to post
Share on other sites

@Nightmare That's yet another thing I really should have added to DMP :P. It's simple enough that I should be able to add it to DMP however, but I'd rather have KSP work if I'm going to play it. My experience with KSP 1.1 hasn't been all that great so far: https://www.youtube.com/watch?v=aK-FguO2dOY

 

EDIT: I also released DMP 0.2.3.0, compiled against KSP 1.1. It's pretty much only the initial port, but having something out there is better than having nothing out there. Let me know how it goes :wink:

Edited by godarklight

Share this post


Link to post
Share on other sites

I'm having an issue with the latest version. A friend of mine has a server running, and when I connect to it after signing off, I don't see anything in the Tracking Station. How do I fix this?

Share this post


Link to post
Share on other sites
7 hours ago, Pyromaniacal said:

I'm having an issue with the latest version. A friend of mine has a server running, and when I connect to it after signing off, I don't see anything in the Tracking Station. How do I fix this?

I experienced this too, but was able to find a work around. Just toggle one of the Filters in the Tracking Station at the very top. All existing craft should refresh/reappear (it does for me). I suspect its an interface bug with one of the changes made with 1.1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.