Lack

[1.1] SXT - Lack's Stock Extension [SXT-25-10APR16] - Basic 1.1 compatibilty

Recommended Posts

What are the requirements for the Bear Turboprop, their power seems to decrease the faster I go....

P.S. I don't have alot of knowledge on plane engines so please don't call me an idiot.

Share this post


Link to post
Share on other sites
7 hours ago, Table said:

What are the requirements for the Bear Turboprop, their power seems to decrease the faster I go....

P.S. I don't have alot of knowledge on plane engines so please don't call me an idiot.

This isnt very strange, Prop engines blow air backwards at a certain speed, proppeling themselfs forward. lets say they push the air back at 100 m/s. if you are moving at 90 m/s the respective speed of the air beeing pushed backwards would be 10 m/s, meaning that if the engine would have a stationary thrust of 100 KN it would now be 10 KN (the speeds at power here are just an example)

Share this post


Link to post
Share on other sites
28 minutes ago, Jelle_Panda said:

This isnt very strange, Prop engines blow air backwards at a certain speed, proppeling themselfs forward. lets say they push the air back at 100 m/s. if you are moving at 90 m/s the respective speed of the air beeing pushed backwards would be 10 m/s, meaning that if the engine would have a stationary thrust of 100 KN it would now be 10 KN (the speeds at power here are just an example)

+ I dont know if this is true for the mod, this is just how it works in real life =P

Share this post


Link to post
Share on other sites

Hey, I'm playing RP-0 right and it's been kind of... crashing a lot.  I've decided to try and remove some of the "recommended mods" in the hopes that having less installed could help improve stability.

I currently have 16 GB of DDR3 on my computer, I'm wondering... does this mod help improve load times even if one has tons of RAM?  Or are the benefits really just for people who have very little RAM?  Because if it's the former... I really don't need it, do I?

Share this post


Link to post
Share on other sites
On 4/19/2016 at 4:27 PM, OrbitalBuzzsaw said:

What? there's no download for SXT25, only a source code...

The source code is the files.

Share this post


Link to post
Share on other sites
22 minutes ago, PTNLemay said:

Hey, I'm playing RP-0 right and it's been kind of... crashing a lot.  I've decided to try and remove some of the "recommended mods" in the hopes that having less installed could help improve stability.

I currently have 16 GB of DDR3 on my computer, I'm wondering... does this mod help improve load times even if one has tons of RAM?  Or are the benefits really just for people who have very little RAM?  Because if it's the former... I really don't need it, do I?

This mod adds lots of (awesome) parts, but reuses stock textures so it uses relatively little RAM. If your crashes are due to running out of RAM you'd be better off removing a parts pack that has more textures, especially visual effects.

Share this post


Link to post
Share on other sites

As I said, I have 16 GB of RAM, so I doubt that's the problem.  While the game is running it shows me using less than 8 GB.  I worry that the 16 or so mods that were recommended by RP-0 might just be causing problems for the game.  I want to try removing them 1 by 1 and see if that helps, but before I do that I want to clarify what they each do.

Edited by PTNLemay

Share this post


Link to post
Share on other sites

So, uh, tried using the TK-M1 wheels to make a KSC runabout.  Interesting things resulted... as soon as the wheels touched the runway, everything that wasn't wheels or command pod exploded and the surviving wheels and truck cab were propelled at ludicrous speed toward the mountains.  If the craft was fortunate enough to land wheels down, regardless of the velocity, it would propel off again at mach 6 in a random direction.  I made it almost halfway across the starting continent before it finally landed upside down and put everyone out of their misery.  Repeated this a few times, even created one with landing legs just to see if that was the problem.  When I raised the legs, as soon as the wheels came in contact with the ground, it was off to the races again.

Might be an issue with the wheels, is what I'm saying.

Edited by JJE64
typo

Share this post


Link to post
Share on other sites
2 minutes ago, JJE64 said:

Might be an issue with the wheels, is what I'm saying.

Not surprising, basically everything wheel-related broke with 1.1.

Share this post


Link to post
Share on other sites
2 hours ago, PTNLemay said:

As I said, I have 16 GB of RAM, so I doubt that's the problem.  While the game is running it shows me using less than 8 GB.  I worry that the 16 or so mods that were recommended by RP-0 might just be causing problems for the game.  I want to try removing them 1 by 1 and see if that helps, but before I do that I want to clarify what they each do.

Are you running 1.1 or 1.0.5? 

Share this post


Link to post
Share on other sites
1 hour ago, Andem said:

Are you running 1.1 or 1.0.5? 

1.0.5.

Though even as I'm thinking this over, I think I'm running into memory bugs.  I had two of these just today.

Quote

mono.dll caused an Access Violation (0xc0000005)
  in module mono.dll at 0023:1011940a.

Error occurred at 2016-04-23_222838.
D:\9 - Games & Saves\KSP-RO\KSP.exe, run by Philippe.
58% memory in use.
0 MB physical memory [0 MB free].
0 MB paging file [0 MB free].
0 MB user address space [176 MB free].
Write to location 02000000 caused an access violation.

Which makes no sense to me.  I should have GBs of memory to spare... 

Edited by PTNLemay

Share this post


Link to post
Share on other sites
3 hours ago, PTNLemay said:

Which makes no sense to me.  I should have GBs of memory to spare... 

to move further along Andem's line of questioning - are you using a 64-bit workaround when playing in 1.0.5?

Share this post


Link to post
Share on other sites

@PTNLemayassuming that you don't use the x64 bit hack with 1.0.5, you are going to have problems with the 3.5 GiB memory ceiling of KSP. No amount of physical RAM can overcome this problem. With KSP 1.1 all these memory problems will be gone (until you reach your physical RAM limit).

Edited by Phineas Freak

Share this post


Link to post
Share on other sites
15 hours ago, Phineas Freak said:

With KSP 1.1 all these memory problems will be gone (until you reach your physical RAM limit).

Assuming he's not using a x64 workaround with v1.0.5 I'd like to clarify that v1.1 won't solve his memory issues if he still uses the 32-bit client

Edited by Gaiiden

Share this post


Link to post
Share on other sites
On 23/04/2016 at 11:35 PM, JJE64 said:

So, uh, tried using the TK-M1 wheels to make a KSC runabout.  Interesting things resulted... as soon as the wheels touched the runway, everything that wasn't wheels or command pod exploded and the surviving wheels and truck cab were propelled at ludicrous speed toward the mountains.  If the craft was fortunate enough to land wheels down, regardless of the velocity, it would propel off again at mach 6 in a random direction.  I made it almost halfway across the starting continent before it finally landed upside down and put everyone out of their misery.  Repeated this a few times, even created one with landing legs just to see if that was the problem.  When I raised the legs, as soon as the wheels came in contact with the ground, it was off to the races again.

Might be an issue with the wheels, is what I'm saying.

and 

@Trekky0623

Yeah, the wheels are broken (As it mentions in the release notes for SXT25, there's a reason it's only 'basic' compatibility  ¯\_(ツ)_/¯  ). I didn't set up the Unity configs for the wheels (my own attempts were less than successful), so they're broken for the time-being. At least until I can have a proper go at fixing it myself, but given my recent luck with Unity I'm tempted to give it a rest for now. I managed to completely mess up my entire project trying to update to the 1.1 part-tools and then 'fixing it', and lost everything when I though 'huh, perhaps Unity 5 editor is the answer'. Apparently it isn't. Fortunately I'd purchased a new HDD a few weeks back and past-me had had the common-sense to make a backup of the project-folder then. 

 I don't think CAKN displays patch-notes, though. If it doesn't that's a bit of a bugger because I can't really say 'fair warning'.I might have to put a 'part-disabler' config in till they're fixed.

@Table+ @Jelle_Panda

Jelle Panda's right, it set up in a similar way in the mod, so as your airspeed increases your ability to generate thrust diminishes. The curves used for it are likely not entirely perfect, they're more on the 'guesstimate' side of things (I made replicas of real aircraft with the engine in FAR and then tweaked until things like max speed were about right.

Share this post


Link to post
Share on other sites
28 minutes ago, Lack said:

I managed to completely mess up my entire project trying to update to the 1.1 part-tools and then 'fixing it', and lost everything when I though 'huh, perhaps Unity 5 editor is the answer'.

 

My heart stopped for a minute here. Glad the gods of backup were on your side ^^

Question: do you plan on fixing / redoing the 3.75m engine for the Saturn V? I loooove this engine. On previous version I just removed the part disabler for it, but now It is utterly broken (the nozzle is missing).

Share this post


Link to post
Share on other sites

@Gaiidenthere will be absolutely no reason to use the x86 version of KSP 1.1 with RSS/RO/RP-0 (and the amount of physical RAM that @PTNLemayhas installed clearly indicates that there will be no problems using the x64 KSP version). But this is getting off-topic now.

@Lacksince we have a Ranger-like probe core, would it be possible to include a foldable solar array (non-retractable after use and non-rotating) for it? Something like the original Ranger solar array.

Share this post


Link to post
Share on other sites

can you remove your mk3 ramp and large jet engine from the "Old Parts" or somehow make them not show up in the parts panels please, since those parts now exist in stock KSP? It's frustrating to pick the addon one when I want to pick the stock one.

Share this post


Link to post
Share on other sites
14 minutes ago, StevieC said:

can you remove your mk3 ramp and large jet engine from the "Old Parts" or somehow make them not show up in the parts panels please, since those parts now exist in stock KSP? It's frustrating to pick the addon one when I want to pick the stock one.

You could delete the part.cfg files for them and they won't show up in game. Though if they are stock now I don't see a need for @Lack to keep them.

Share this post


Link to post
Share on other sites

I have to have this mod in my game for me to play the game, hope the update comes out soon!

Share this post


Link to post
Share on other sites

Is there any way to make the IVA for the truck cockpits (cabs?) not have the helmets on?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.