Lack

[1.1] SXT - Lack's Stock Extension [SXT-25-10APR16] - Basic 1.1 compatibilty

Recommended Posts

Did the same as @Vlad Lastname said. Works.

@PTNLemay, edit your .json file on CKAN folder, find the "SXT" part, under v25.1 change the repo's path, as mentioned by Vlad. Worked like a charm for me too! It installed via CKAN normally and everything works. Quote me if you find any trouble.

(* remember to uncheck the 'auto-repo-update' thing under CKAN Options tab before doing this. You can re-check the option after performing the install)

Hope the dev fixs this quickly :P

Share this post


Link to post
Share on other sites
22 minutes ago, d.frison said:

 edit your .json file on CKAN folder,

Is there a special way of doing this?  I tried to open it with NotePad but it freezes and crashes Windows Explorer.

Share this post


Link to post
Share on other sites
1 hour ago, PTNLemay said:

Is there a special way of doing this?  I tried to open it with NotePad but it freezes and crashes Windows Explorer.

Oh, this kind of files are way too "heavy" for NotePad or WordPad.

Besides, if you plan to mess with this kind of thing (editing config files etc), I recommend you download a little program called "NotePad++" for windows. Then just right-click the file to open it with NP++. Then find and edit the lines of code I said before. This program is somewhat a little more complex then the default NotePad, but once you get used to it, it's also waaay more powerful. That's gonna do the trick for you! Enjoy it :)

Share this post


Link to post
Share on other sites

Lack,

Any chance you would think about uploading SXT to www.spacedock.info ?

It is Kerbalstuff 2.0, basically.

Edited by minepagan

Share this post


Link to post
Share on other sites
On 4/30/2016 at 8:08 AM, Whovian41110 said:

Why doesn't the AN-225 cockpit have a closing animation?

@Lack

Share this post


Link to post
Share on other sites

Is anyone else getting a weird bug where the propeller only plays sound in one ear?

Share this post


Link to post
Share on other sites

Just got a weird bug with TG-T2 Wheel block where whenever the wheels made contact with the ground the physics freaked out and sent the truck as a whole flying. Only when the wheels touched the surface though. I have the the most recent download of the mod and I have KSP 1.1.2. Any thoughts? 

Share this post


Link to post
Share on other sites

@Jmullin Welcome to the forums!  The way wheels work in KSP changed a lot in 1.1, so wheels from older mods are almost always guaranteed to be broken.

Share this post


Link to post
Share on other sites

This mod is amazing. One thing though, can you make KC-8 Passenger cabins without doors? and one that has doors on both sides? that would be awesome. I repeat, this mod is amazing!

Share this post


Link to post
Share on other sites

@Lack

On 04/10/2016 at 8:20 AM, Lack said:

@Creideiki

Glad to hear you're enjoying the parts. I've got RPM support for some of the cockpits, but I don't plan on adding it to some of the older (generally early tech-tree) plane cockpits with analogue dashboards.

The ASET avionics props do have loads of very lovely analogue flight instruments. I remember there was a module manager patch before that let you have a steady "upgrade" path from all analogue instruments to modern glass cockpit with the standard Mk. 1 in career mode. But I think that died with KerbalStuff (and the revamp of the Mk. 1). But yeah, RPM glass cockpit might not be good for some of them ("He-111 with satnav? Now this will have an impact on the war effort!").

 

I know you don't take direct requests for parts, but I'd like to ask if you'd think about giving us the cockpit+nose of the beautiful Avro Lancaster (B Mk X; since that's the model of the one I can go take photographs of; VR-A is a sexy plane, and boy is it amazing to see her fly...)? Since we already have the wonderful He-111 cockpit (I swear I'm trying to glue that and the Otter cockpit on everything...; 'cause who doesn't wany an He-111 in space?), and the Merlins to power the thing (and the Mk3 cargobays to deliver all of the ordnance science). But it might be a bit redundant what with having the MRBL-8 for our Mk3 strategic bomber science delivery vehicle purposes.

Share this post


Link to post
Share on other sites
On 5/5/2016 at 7:00 PM, Gojira said:

Is anyone else getting a weird bug where the propeller only plays sound in one ear?

This is a problem apparently floating around almost every single mod that has props in it.  Firespitter and KAX are both experiencing it and you've now confirmed that SXT is as well.  Someone in the FS thread recently posted some info they tracked down that might (or might not) be related to it.

Share this post


Link to post
Share on other sites
On 4/30/2016 at 1:43 PM, d.frison said:

@PTNLemay, edit your .json file on CKAN folder, find the "SXT" part, under v25.1 change the repo's path, as mentioned by Vlad. Worked like a charm for me too! It installed via CKAN normally and everything works. Quote me if you find any trouble.

(* remember to uncheck the 'auto-repo-update' thing under CKAN Options tab before doing this. You can re-check the option after performing the install)

Hello! I'm not PTNLemay, but I'm having the same problem and I'm quoting you because I've found trouble. 

I changed my .json file's repo path for SXT to the correct link as you advised, and I'm still running into the same problem. Do I need to change anything else on that file for my changes to stick, or to be valid? 

I couldn't find the 'auto-repo-update' setting under CKAN options... that might have something to do with it. Please advise.


Also, if you don't mind, please explain to me what "repo" means so I can stop feeling sheepish. :)

Thanks!

EDIT: I fixed it! Now I'm just stuck with the same error for Taerobee, and can't find a stable mod release for it... Any pointers?

Edited by MitchS
Added picture of error. Then fixed broken picture of error, but apparently didn't. Can you guys see my picture, or is it just me?

Share this post


Link to post
Share on other sites

hey i get a NRE on sxtefan during loading, it just hangs there and loads no further. im using the latest test build, and modular fuel tanks. im just posting this too see if its a simple mistake, if i have too ill post logs when it cant be figured out.

Share this post


Link to post
Share on other sites

You don't have enough of Firespitter. You need Firespitter's resources.

Share this post


Link to post
Share on other sites
On 5/14/2016 at 0:24 PM, NathanKell said:

You don't have enough of Firespitter. You need Firespitter's resources.

ok.

Share this post


Link to post
Share on other sites

What's wrong with the friendly yellow truck? In 1.1.2, it has a nasty habit of flinging itself high into the air just a second or two after materializing on the runway.

Share this post


Link to post
Share on other sites
21 minutes ago, Phineas Freak said:

@Christoph Lipkathe wheel parts have not been updated yet for KSP 1.1 and thus they are completely broken.

Dammit, that's a pity to hear. I was banking on the Friendly Yellow Truck as an efficient means to go places at the KSC to do some science. Looks like I'm still stuck with the Lame Duck approach (read: wingless plane; not enough science points for rover wheels yet).

Any ETA for a fix?

Share this post


Link to post
Share on other sites

hey does the mk3mk2 ramp work? the cargo ramp that also adapts too mk2 size? i downloaded the minipack, and i installed it as normal, but it still doesent work. (atleast, i dont see it) 

Share this post


Link to post
Share on other sites

could i request a patch for UKS? (mainly adding habitation to the crewtanks?

also maybye adding NFE/kerbalatomics modules to the nuke engines.

i would be happy to write the patches myself as soon as i work through some other compatablility patches im doing for myself.

Share this post


Link to post
Share on other sites

also, you could switch to using intake atmo for electric fans instead of FScoolant.

Share this post


Link to post
Share on other sites

@toric5, if you do write that UKS patch pls send it my way. :)

Edited by Vrana

Share this post


Link to post
Share on other sites

FYI - three of the prop engines will throw NREs in the editor and in flight under circumstances I can't figure out (they won't do it if only SXT is installed on otherwise Stock game).

Here's a patch that solves whatever the incompatibility is with another of the 78 mods I'm using - don't know exactly why (went and looked at other props that worked, they had these elements and SXT ones didn't):

Spoiler

@PART[SXTJ213|SXTPWR2800|SXTNK12M]
{
    @MODULE[FXModuleAnimateThrottle]
    {
    dependOnEngineState = True
    dependOnThrottle = True
    }
}

 

Share this post


Link to post
Share on other sites
4 hours ago, AccidentalDisassembly said:

FYI - three of the prop engines will throw NREs in the editor and in flight under circumstances I can't figure out (they won't do it if only SXT is installed on otherwise Stock game).

Here's a patch that solves whatever the incompatibility is with another of the 78 mods I'm using - don't know exactly why (went and looked at other props that worked, they had these elements and SXT ones didn't):

  Hide contents

@PART[SXTJ213|SXTPWR2800|SXTNK12M]
{
    @MODULE[FXModuleAnimateThrottle]
    {
    dependOnEngineState = True
    dependOnThrottle = True
    }
}

 

This is due to an edge case stock bug.  As it stands, dependOnEngineState default to false, which means that the animation depends on the vessel's main throttle, however, trying to access that causes NREs in the editor.  Setting dependOnEngineState to true is really better anyway.  I can provide more info on what the parameters are and how to use them if need be.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.