Lack

[1.1] SXT - Lack's Stock Extension [SXT-25-10APR16] - Basic 1.1 compatibilty

Recommended Posts

Hey Lack, just felt the need to ask since I haven't seen much on this lately...... What's the latest concerning the KSC++ overhaul you were working on a while ago?

Share this post


Link to post
Share on other sites

Lack, I stopped in to see what you've been up to lately, and apparently you've been busy. That Mk3 tail ramp...those cockpits, those parts....(drool)

WhooHoo_zpse1ed0aa2.gif

I tried hitting the rep button repeatedly, but it only worked once. Well done!

Share this post


Link to post
Share on other sites

Can you please host this mod on a different website than "kerbalstuff" because the download is extremely slow then completely stops.

Share this post


Link to post
Share on other sites

I'm curious, could we get some high-cap inline batteries added? I've been using the ones from Near Future Electric (removing the nuclear stuff and capacitors) but I think they could be implemented nicely in SXT.

Share this post


Link to post
Share on other sites

im getting an issue with several SXT parts.

basicaly for instance if i scale the Kossak command cockpit down to 1.25 and if i at any point do a "revert to launch" it rescales the part to 2.5

unsure if its is just visual or also mass and resources.

anybody encouter this issue?

ALso. i have wierd red and white textures on some parts. but i dont have any texture mods...

Share this post


Link to post
Share on other sites

Tweakscale issues are not going to be SXT's fault. SXT doesn't include a built-in scaling feature, it's a parts pack. ;)

Lack, I *definitely* took note of that new canopy (you can guess which I mean :P ). Sweet! :)

Share this post


Link to post
Share on other sites

Lack, here's my first spaceplane with your Mk3 cargo ramp:

X-21atnight_zps7dc5e8ac.png

Doesn't quite have enough rocket fuel to get beyond suborbital around Kerbin, but it works nicely around Laythe which is what I designed it for...it takes off and lands vertically so it can support surface ops on any Laythe island that has a spot level enough to land on.

Thanks again Lack :)

Edited by Raptor9

Share this post


Link to post
Share on other sites

Not sure if this is a problem with Kerbal stuff or here but Kerbal stuff says that the mod is outdated for the KSP version .90 recently released while here it seems to say its compatible with .90. Which one is wrong?

Glorious Mod by the way :)

Share this post


Link to post
Share on other sites

Probably not what LLL's 2.5m cargo bay was really meant for, but I'm a fan of lateral thinking! Say hello to the new Cougar class lander and her accompanying Badger rover!

cargobay-mistakes.jpg

He's a little basic, but it's hard to fit anything fancy in a 2.5m circle :P

...notice the stupid engine placement on the lander. Extending the legs blocks the thrust :(

Share this post


Link to post
Share on other sites

Hmm, can there be a MK3 Tail bay version that have increased vertical clearance? Would works well with the MK2 cargo:

i8bZBm9zGhQVn.png

For some truly monstrous rovers, we do need that little more space...

Would also works when flipped too, using the MK2 cargo as a ramp.

Edited by RainDreamer

Share this post


Link to post
Share on other sites

Hmm, just a question about the Dontstayputnik antennas... I'm trying to launch a really bare-bones satellite (don't have fairings unlocked yet) and the antennas don't like staying attached... I'm trying to figure out if this is because FAR doesn't find my placement aerodynamic enough... or because RemoteTech's MaxQ decides it's time for the antennas to fall off now... and I mean, the antennas look pretty aerodynamic... do you think changing the MaxQ value in the RT config would solve my problems?

Share this post


Link to post
Share on other sites

I've launched them unshielded with FAR and they haven't fallen off. I know that's only one datapoint and I can't remember what FAR calculated the Q actually was, but if there's a separate MaxQ in RT it does sound quite possible it's that one.

Share this post


Link to post
Share on other sites
I've launched them unshielded with FAR and they haven't fallen off. I know that's only one datapoint and I can't remember what FAR calculated the Q actually was, but if there's a separate MaxQ in RT it does sound quite possible it's that one.

Yeah, it seems especially like it's that, since all 4 antennas fall off pretty uniformly... I think the MaxQ is straight up copied from the Communitron 16... which is made to break when extended in the atmosphere... however these antennas neither extend, nor do they have the aerodynamic issue of sticking straight out (they are bent and that metal attachment point looks pretty solid)... so I think the MaxQ should realistically be at least double the stock antenna... (really, the atmospheric constraints RT adds is a whole bunch of artificial difficulty easily negated the second you unlock their atmospheric antenna...).

In fact, now that I think about it... these antennas are more aerodynamic than the atmospheric antenna RT gives you...

Share this post


Link to post
Share on other sites
Yeah, it seems especially like it's that, since all 4 antennas fall off pretty uniformly... I think the MaxQ is straight up copied from the Communitron 16... which is made to break when extended in the atmosphere... however these antennas neither extend, nor do they have the aerodynamic issue of sticking straight out (they are bent and that metal attachment point looks pretty solid)... so I think the MaxQ should realistically be at least double the stock antenna... (really, the atmospheric constraints RT adds is a whole bunch of artificial difficulty easily negated the second you unlock their atmospheric antenna...).

In fact, now that I think about it... these antennas are more aerodynamic than the atmospheric antenna RT gives you...

Someone else had this problem a few weeks back, and removing the MaxQ was suggested. Here's the config I have for the next version of SXT, but I haven't tested it myself yet.

RT2MM.cfg - http://pastebin.com/pX1A1HsF

I'll answer the rest of the comments at some point in the next day or two, but here's some screenshots of another part I was messing around with a few days back

Javascript is disabled. View full album

Been messing around with DCS world, so had a go with the Su-27, the in-game flight of this craft is roughly similar. The Heuy's fun, and the cold start is a lot easier than the Black Shark (even though I miss how easy that was to fly). Plus, roughly half of my landings are survivable with it now. Could really do with some pedals though.

Share this post


Link to post
Share on other sites

When I right-click the AJE Williams FJ44 turbofan the vessel weight switches to NaN and I can't launch. I then have to remove and re-add the part.

Share this post


Link to post
Share on other sites

Thanks for the great mod Lack.

I'm having a little problem with the wheels form the trucks mod. For some reason they drop down trough the ground, and because of that the vehicles rides really close to the ground. Is there any way to fix this, and also is there a way to increase the height of the wheels so that the vehicles could also be used for some off-road driving and not only on the relatively flat terrain.

g4zhWqCl.png

Share this post


Link to post
Share on other sites
Hmm, can there be a MK3 Tail bay version that have increased vertical clearance? Would works well with the MK2 cargo:

http://i.minus.com/i8bZBm9zGhQVn.png

For some truly monstrous rovers, we do need that little more space...

Would also works when flipped too, using the MK2 cargo as a ramp.

this is a very good idea!!

Share this post


Link to post
Share on other sites
Someone else had this problem a few weeks back, and removing the MaxQ was suggested. Here's the config I have for the next version of SXT, but I haven't tested it myself yet.

RT2MM.cfg - http://pastebin.com/pX1A1HsF

Shouldn't SXTAntenna have the MaxQ removed then as well? :P

Share this post


Link to post
Share on other sites
Thanks for the great mod Lack.

I'm having a little problem with the wheels form the trucks mod. For some reason they drop down trough the ground, and because of that the vehicles rides really close to the ground. Is there any way to fix this, and also is there a way to increase the height of the wheels so that the vehicles could also be used for some off-road driving and not only on the relatively flat terrain.

http://i.imgur.com/g4zhWqCl.png

Try rotating the wheels in the SPH chap. Generally speaking wheels have to be connected "the right way up" and it's not always obvious what that is.

Share this post


Link to post
Share on other sites
Shouldn't SXTAntenna have the MaxQ removed then as well? :P

Heh, nice catch, thanks (and this is why I should really should test my configs for other mods).

@_Rade & AlphaAsh,

The wheels come as one piece, so they should be the right way up. I've had this one or two times, they can sometimes be a bit finickity about the terrain when they launch and 'fall through' the terrain. Unity only really recognises colliders at the point of contact. I didn't set up those wheels in Unity, SMCE was nice enough to do them (bad things happen when I try to make wheels, I've had them end up 'insta-fraggin' Kerbin on contact and being frictionless ice-skates).

Could try adding a launch stabiliser and then dropping it down.

@mecki,

Which one is the 'AJE Williams FJ44', AJE changes all the names. Although I should probably run through all the engines to make sure the electric module is updated.

Edit: Guessing it's the small 0.625m one, it's the only engine with the old module setup, here's a fix.

https://dl.dropboxusercontent.com/u/39086055/electricchargefix.zip

@Spacepetscompany,

Nothing new, sadly there's only so much time in the day for mods and I spent that updating LLL and working on SXT.

@Raptor9,

Thanks! Which movie that gif from actually, I can't quite place it. I like the screenshot as well, don't suppose you've got any of it working on Laythe, I'd be interested in seeing them.

@Thatstatue,

They were just having network problems I think, working fine now.

@Ruedii,

Possibly, but they're not high priority (since I tend to just use the NFE ones on the rare occasion that I need a lot of electricity outside of LLL).

@trekfan42,

Nothing wrong with the config for tweakscale. SXT-19 is missing a '2' in the electric charge module of the Kossak, which might be doing something.

Go to

/GameData/SXT/Parts/Hull/Osaul/RadialCockpit.cfg

and change

RESOURCE

{

name = ElectricCharge

amount = 200

maxAmount = 00

}

to

RESOURCE

{

name = ElectricCharge

amount = 200

maxAmount = 200

}

@Jazzyjaz99,

Heh, the one here is correct. The mod just didn't really need updating to work with 0.90.

@eddiew,

Nice, and I like the rover; always like to see screenshots.

Edited by Lack

Share this post


Link to post
Share on other sites
@Raptor9,

Thanks! Which movie that gif from actually, I can't quite place it. I like the screenshot as well, don't suppose you've got any of it working on Laythe, I'd be interested in seeing them.

I have no idea what movie, I just think it's funny, ha ha; but I'm sure if you look at Bradley Cooper's filmography you'd jog your memory. Regarding the Laythe SSTO, I'm still progressing through the career mode, haven't even made it to Duna yet, let alone Jool's SOI. EDIT: I used hyperedit to briefly make sure it could fly in Laythe's atmosphere, which marks the only time I have ever seen Laythe in my own KSP, even though I've been playing since 0.13.

It did occur to me that if I replaced the Mk2 cargo bays (which hold the VTOL engines) with just LFO tanks, it should be able to make it into Kerbin orbit (at the tradeoff of needing a runway :sticktongue:). Whether or not it can bring a 2.5m module with it as well, I'll find out this weekend. Curse my job!

Nice Su-27 too, I'm a heavy DCS user as well, so I made this a while back:

X-7BlendedWing-FuselageFlightTest_zps5203a3e5.jpg

I call it the FA-7 Warhawk...inspired by the Su-27, but with the firepower of an A-10 :cool: (Even Jeb approves)

FA-7Firing30mm_zpsdd1fe20d.png

EDIT: When/if you release that new part, I guess a redesign will be in order ;)

Cheers

Edited by Raptor9

Share this post


Link to post
Share on other sites

I ended up editing the cfg files in order to rescale the wheels and make them little bit bigger. They will still occasionally drop trough the ground, but because the wheels are bigger its not as noticeable as it was before. Trickiest part was to readjust the attach nodes, so that the wheels would properly align with the other parts.

One other problem I've noticed is that when you EVA and get back into the vehicle or stop the vehicle using the brakes, the wheels will somehow get jammed and stop moving for about 10 seconds. They will still turn left or right they will not move, and then after a short time they will start working again.

In the screenshot the truck have been standing on that slope, with no brakes engaged, for at least 20 seconds before it started moving down the slope.

3bxuPlQl.png

Share this post


Link to post
Share on other sites

Anyone getting texture corruption (plain white with red splotches) with some parts (primarily centrifuge but also airbags) when using Active Texture Management?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.