dtobi

[.24.2] DISCONTINUED July-27- Asteroid Cities V2.0

Recommended Posts

Is water supposed to show up in the right click menu if I right click on an asteroid? Cause it isn't.

It should show up if module manager found and loaded the asteroid config file. Are module manager and the cfg file present?

Share this post


Link to post
Share on other sites
Is water supposed to show up in the right click menu if I right click on an asteroid? Cause it isn't.

Yes. If module manager and the asteroid.cfg are present, the asteroids should contain 1000 water before scanning and even more after scanning.

Share this post


Link to post
Share on other sites
Is greenhouse compatible with interstellar mod?

Not right now. I don't use interstellar. I take patches, of course.

Share this post


Link to post
Share on other sites

Four posts? Dude. There's an edit button.

As for the greenhouse...what the heck does that have to do with KSP Interstellar? KSPI doesn't even have a life-support system. At all.

Share this post


Link to post
Share on other sites

This mod is working great for me and I'm running 70+ mods. Nice work on the parts and I really appreciate your work to make asteroids have more end-game.

Thanks

Share this post


Link to post
Share on other sites

Downloaded this (won't get to try it out until the weekend), but had a brief look at your part.cfg files. I am wondering whether you for some reason intentionally left most of the node sizes at 1, both for the grapples and the regular nodes even though the parts are either size0 (0.625m) or size2 (2.5m) ?

Still looking forward to trying it soon though :)

Share this post


Link to post
Share on other sites

Which module manager version am I supposed to use? I have the asteroid.cfg file and it appears to be fine.

Share this post


Link to post
Share on other sites
Downloaded this (won't get to try it out until the weekend), but had a brief look at your part.cfg files. I am wondering whether you for some reason intentionally left most of the node sizes at 1, both for the grapples and the regular nodes even though the parts are either size0 (0.625m) or size2 (2.5m) ?

Still looking forward to trying it soon though :)

The probe sized ones should be fine. The others I fixed just now. Thanks for the hint. Enjoy and post some pic if you build something, that would be great!

Share this post


Link to post
Share on other sites
Which module manager version am I supposed to use? I have the asteroid.cfg file and it appears to be fine.

Not sure. So far all I tried worked fine. I'm a bit clueless here, I have to admit. Ain't ther no resource at all in the asteroid?

Share this post


Link to post
Share on other sites

Ok, my bad I had 2 versions of MM installed and when I got rid of the older one it worked. Thanks for the great mod.

Share this post


Link to post
Share on other sites
Would you please stop accusing Asteroid cities to cause the crash until you have conclusive facts?

No one else but you seems to have the problem. For example, I am running it on two different instsllations (clean one and heavily modded) without any issues. Have you tried a clean install with just Asteroid cities? I'd bet it will run just fine. Once you keep adding more mods it will then break again. Memory is most often the problem.

I strongly doubt that your crash is caused by this mod becsuese it uses quite little memory and does nothing fancy. In fact its routines don't even run anything noteworthy during KSP startup (in contrast to many graphical mods). So please be reasonable and stop pretending things you can't prove properly.

I did not mean to accuse but i am not kidding that this happens and i have tested to prove that this mod was the immediate cause...

i will test again to see if it was a bad a download or something else that caused it

Edit: i apologize for my accusations and wish to retract my original statement as it now working and must have been a bad download the whole time... i am sorry

Edited by Helix935

Share this post


Link to post
Share on other sites
As for the greenhouse...what the heck does that have to do with KSP Interstellar? KSPI doesn't even have a life-support system. At all.

iirc KSPI also defines a Water resource. If they're defined differently, they could get all fighty and cause weird game issues.

Share this post


Link to post
Share on other sites
iirc KSPI also defines a Water resource. If they're defined differently, they could get all fighty and cause weird game issues.

KSPI defines it with the name LqdWater. They aren't the same.

Edited by phoenix_ca

Share this post


Link to post
Share on other sites

Strangely, the mini klaw doesn't seem to work for me, yet the big one does.

Share this post


Link to post
Share on other sites
Strangely, the mini klaw doesn't seem to work for me, yet the big one does.

Can you post a picture? Maybe you have installed it the wrong way around. Others had that problem as well.

Share this post


Link to post
Share on other sites
Can you post a picture? Maybe you have installed it the wrong way around. Others had that problem as well.

*facepalm* It seems to bethe problem, it deployed way too behind the node to be effective... Didn't go through the thread, i think you should add a photo with hot it's placed on the ship.

Share this post


Link to post
Share on other sites
I did not mean to accuse but i am not kidding that this happens and i have tested to prove that this mod was the immediate cause...

i will test again to see if it was a bad a download or something else that caused it

Edit: i apologize for my accusations and wish to retract my original statement as it now working and must have been a bad download the whole time... i am sorry

Thank you for verifying that. And sorry for the somewhat harsh words. I'd like to explain that a bit.

It takes quite some time to create and test a mod. I might not be the fastest modder but this thing has eaten almost three weeks of my spare time. I generally try to create something of OK quality so I test quite a lot. I do that because first of all, I enjoy the parts myself and want to share that. However I also want the mod to be successful. I like it to get feedback, to see pictures with my parts , etc...

What I really want to avoid is the stigma of bad quality because it will prevent the mod from being successful and my work will be wasted. I wouldn't download another mod when people say it crashes the game. And I would probably remember. These things stick.

So people really need to be careful when making unjustified statements about mod quality because it kills the only thing a modder gets for his work: The joy of seeing other people using it. And that in turn kills motivation and in effect will reduce the willingness of people to spend evening after evening to create a mod.

What you did is to tell people this mod causes crashes and you did so without any sign off doubt. That's why I reacted that way. I hope you understand my position.

Thank you for checking again and thank you for clarifying that this mod is not the source of your crash. If you now could also put that information to your other thread that still says asteroid cities crashes the game, I'd be all happy.

Tobias

Share this post


Link to post
Share on other sites
The probe sized ones should be fine. The others I fixed just now. Thanks for the hint. Enjoy and post some pic if you build something, that would be great!

I previously played around a bit with the stock grabber, upscaling it to 2.5m (x,z only) for my purposes. While doing so I was under the impression that the ModuleGrappleNode:nodeType parameter follows the sizing of the docking ports (I might be totally wrong there!); if that's the case, then the small grabber would probably be a size0 and the large one size2. I changed it to size2 for my upscaled part and it was working well and appeared to be less wobbly - but again, really only guessing there.

So anyway, about those stock grabbers - they are actually the reason why I got interested in your mod. I have a support vessel for capturing D/E class asteroids, and it has 15 functional "pods" which I attach to the asteroid (12 "gyros" for rotation, 2 power/lighting towers to provide power to the SAS modules, and 1 general purpose large docking port). It went through several iterations, because I have experienced terrible lag with that craft, maybe 3 fps in the VAB as seen in the first image. First I thought it was due to the number of parts (~200 in the first version), so I created a welded part for the gyros and optimized some other areas, but still no luck. Eventually I found out it is just the ** stock grabbers - removed them, and I am back to 20+ fps. And now replaced them with your parts and fps are still good :-)

Javascript is disabled. View full album

(Showing just the craft without the launcher; the other parts are from RLA stockalike, and a 2.5m downscaled z-pinch-fusion engine; launch boosters are attached at the sides where there is nothing attached now...)

So even without having flown this version into space yet, just the FPS improvement is already a big success. And I am sure the parts will work :)

Edited by Kiwa
spelling/grammer

Share this post


Link to post
Share on other sites
Testing my new asteroid scout, based on the Rosetta Philae Lander!

http://imgur.com/a/hAosC

If I have time, it will launch this weekend!

Great! Actually, the philly legs were inspired by Philae...

Edited by dtobi

Share this post


Link to post
Share on other sites

A new update is out.

* The refinery and greenhouse now stop consuming resources when one inout resource runs out.

* The refinery and greenhouse now stop consuming resources when their internal storage is full.

* Both open and close when the operation starts and stops.

Share this post


Link to post
Share on other sites

Here is a picture of how to use the Philly Grabber:

8DEBDMv.jpg

uy6dZ6f.jpg

Share this post


Link to post
Share on other sites
Great! Actually, the philly legs were inspired by Philae...

4th photo in the album, are those phillies upside down ?

EDIT: yup they are. I think the illustration is clear

Share this post


Link to post
Share on other sites
Downloaded this (won't get to try it out until the weekend), but had a brief look at your part.cfg files. I am wondering whether you for some reason intentionally left most of the node sizes at 1, both for the grapples and the regular nodes even though the parts are either size0 (0.625m) or size2 (2.5m) ?

Still looking forward to trying it soon though :)

The probe sized ones should be fine. The others I fixed just now. Thanks for the hint. Enjoy and post some pic if you build something, that would be great!

Did this make it into the V0.3 release? I'm still seeing "nodeType = size1" in the cfg for the 2m Klaw.

Share this post


Link to post
Share on other sites

I was afraid they would be upside down. So maybe a redesign of the generator block in the power/lighting towers is in order (the cone with the 8 embedded RTGs); but I do want to keep it close to the grabber for the weight balance, as some of my earlier attempts at asteroid control/utility pods ended up oscillating a lot, even when I tried to strut them to the asteroid using KAS struts. Or I could keep using stock grabbers for those, hmm... but the lag of even two of those is actually noticeable. (Also added a screenshot of one of those early, wobbly pods - sorry if they're a bit small in the image.)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.