dtobi

[.24.2] DISCONTINUED July-27- Asteroid Cities V2.0

Recommended Posts

What is the correct way to use the water to fuel refinery? I've docked my spacecraft to an asteroid with the clamp connected to a refinery connected to a fuel tank. I have 16000 electric charge. What am I doing wrong?

Can't you start the refinery from the right click context menu? It also needs water and there must be space in its liquid fuel and oxidizer tanks.

Share this post


Link to post
Share on other sites

No I can't. I click start with 0 fuel in the refinery's tank. but it doesn't work. There's a little bit of fuel in the analyst's tank which is attached to the roid now.

Share this post


Link to post
Share on other sites
No I can't. I click start with 0 fuel in the refinery's tank. but it doesn't work. There's a little bit of fuel in the analyst's tank which is attached to the roid now.

Strange. Some more questions. The analyzer tool worked? How much water is left in the asteroid? Can you post a screen shot of the debug console output, too? (Alt F12, debug) scroll down to the end and activate the refinery. Do you use a life support mod. If so, which?

Screenshots of your craft on the asteroid would also help.

Thanks.

Edited by dtobi

Share this post


Link to post
Share on other sites

dtobi,

I'm still having explosions during the ascent phase when using the refinery, still in the 6 km to 8 km region. I'm also seeing this NRE repeated hundreds of times from >>>about<<< the moment of the explosion:

(Filename: /BuildAgent/work/d3d49558e4d408f4/artifacts/LinuxStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

isac:False

(Filename: /BuildAgent/work/d3d49558e4d408f4/artifacts/LinuxStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

Packing Asteroid Refinery Debris for orbit

(Filename: /BuildAgent/work/d3d49558e4d408f4/artifacts/LinuxStandalonePlayerGenerated/UnityEngineDebug.cpp Line: 53)

NullReferenceException

at (wrapper managed-to-native) UnityEngine.Transform:INTERNAL_CALL_TransformDirection (UnityEngine.Transform,UnityEngine.Vector3&)

at UnityEngine.Transform.TransformDirection (Vector3 direction) [0x00000] in <filename unknown>:0

at ActiveJoint.getControlOrt (Vector3 refAxis, PartSpaceMode mode) [0x00000] in <filename unknown>:0

at ActiveJoint.applyCoordsUpdate () [0x00000] in <filename unknown>:0

at ActiveJoint.onPartPack (.Part p) [0x00000] in <filename unknown>:0

at EventData`1[Part].Fire (.Part data) [0x00000] in <filename unknown>:0

at Part.Pack () [0x00000] in <filename unknown>:0

at Vessel.GoOnRails () [0x00000] in <filename unknown>:0

at OrbitPhysicsManager.LateUpdate () [0x00000] in <filename unknown>:0

(Filename: Line: 4294967295)

isen:True

Is anyone else using "Active Texture Manager" and "Environmental Visual Enhancements"???

Share this post


Link to post
Share on other sites
dtobi,

I'm still having explosions during the ascent phase when using the refinery, still in the 6 km to 8 km region. I'm also seeing this NRE repeated hundreds of times from >>>about<<< the moment of the explosion:

Is anyone else using "Active Texture Manager" and "Environmental Visual Enhancements"???

Yes, I'm not getting large numbers of NREs though. *Something* is throwing NREs in my install, however. Also, I'm having mad-trouble getting the 2.5m klaw to actually attach to an asteroid. On a C-class asteroid I've managed to attach a greenhouse, after about an hour of kerfuffle and rotating around the asteroid until it arbitrarily decided it would attach. My klaw 'sinks' into the asteroid aswell.

EDIT: Okay, so upon inspection the 2m klaw actually says 'release/free pivot/control from here' when I am in proximity to an asteroid - it just doesn't *actually* dock. I had a quick perusal of the cfg and found a few values that were different between the philly/2m klaw/ARM klaw. For the sake of experimentation I made the values of the 2m klaw the same as the ARM klaw and increased the node size to size2 (following the logic that if it's effectively a mobile docking port then a 2m docking port would be size2.) but still not joy. I tried clicking 'control from here', 'free pivot' and 'release' while the klaw was quasi-docked and well... It needs a picture really.

t83e9dol.png

In short, the 2m klaw went a bit nuts. It was revolving at that angle. When I locked the pivot the rotation stopped but now it's stuck in that position.

I'm suspecting some sort of interaction but haven't nailed anything down yet. If I figure out what's going on I'll report.

Edited by Milkshakefiend
Addition

Share this post


Link to post
Share on other sites

Fantastic work @dtobi! This is likely to be another main stay in my savegames just like your engines!

Share this post


Link to post
Share on other sites

Well, I don't understand what happened, but I managed to get a refinery launched tonight. Earlier I had one explode and trigger a bunch of NREs, but this time the launch went smoothly. Now I'm chasing down an asteroid I landed a probe on a couple of "days" ago.

I think KSP itself still has a lot of "gotchas" internally... ;.;

Addendum: The "claw" worked properly, the refinery is successfully docked, and it is now converting resources into fuel and oxidizer. This is going to open up a whole new way to explore the system. With the ExLP mod, I can now build my long-range ships in space and fuel them up without having to launch massive ships from Kerbin. And, with every new asteroid having such massive resources, it virtually unlimited.

Thanks, dtobi!

Edited by BARCLONE

Share this post


Link to post
Share on other sites
Also, am I right when I say that the 2m claw is upside-down in the editor?

It works for me if I put it at the bottom of the stack. Think about how the stack should look when it's "standing vertical" on the surface of the asteroid. You can attach a normal-orientation 2.5m decoupler to the bottom (surface contact area) easily to connect it with your carrier stage.

What you have to think about during the approach is, you're not trying to dock with it, you're landing on it. I know KSP "pretends" these asteroids are "ships" for the sake of being playable, but it just works better if you think of asteroids as "really small moons". And, these parts are not quite the same as those found in the stock ARM pack. Think of this new claw as a landing base pad instead of an "asteroid grabber"...

If you're playing with MechJeb, though, don't try to use the landing guidance auto pilot (LGAP). Just back yourself onto it (Smart A.S.S >> TGT >> TGT-) at 0.4 m/s and you'll get a lock most of the time. Remember to arm the claw before making contact...

Edited by BARCLONE

Share this post


Link to post
Share on other sites
And flipping it doesn't work?

It should... In theory... Don't see any reason why flipping it should cause a problem, at least not right off.

Share this post


Link to post
Share on other sites

I see there are people who are able to mine water from asteroids. Could it be a bad download? My efficiency is always 0 with 16000 ec and 2 large solar panels.

Share this post


Link to post
Share on other sites

A new Version is uploading.

NEW: Command bunker and better performance.

PEUyPbj.jpg

Edited by dtobi

Share this post


Link to post
Share on other sites
Nice, will the command bunker have an IVA or is it too soon?

It already has one :-) But it is only accessible after the bunker has dug into the asteroid. Before the crew capacity is 0. It has a probe core, though, so you can control it wothout kerbals inside.

Share this post


Link to post
Share on other sites

Well it definitely looks like a bunker! Downloading now...:)

Share this post


Link to post
Share on other sites

Can you add a siphon that will pick up water if we splash down? It would be perfect for Laythe Missions.

Share this post


Link to post
Share on other sites
Can you add a siphon that will pick up water if we splash down? It would be perfect for Laythe Missions.

I might add some parts for Laythe. I have some inflatable things and some nice heat shields but I am not sure where to put them. I also considered making a water intake but right now I am still focusing on asteroids.

Things that are next are:

a) Ice melting tool so we can have frozen asteroids.

B) Crew bunker for 8-10 kerbals

c) Asteroid social lab - it will produce science if you have more than 20 or 50 kerbals living in your city.

d) whatever comes to my mind.

Share this post


Link to post
Share on other sites

this is fantastic! thank you for sharing this! if i may add an idea/request, would you consider adding a 'garage' of sorts to store parts inside and out(as in use KAS) or something like the vts mmu? also maybe a dedicated powerplant/solar array?

Share this post


Link to post
Share on other sites

Updated but still doesn't work. I get 'Efficiency is dropping 0 while running. Something is wrong. Shutting down generator.' in the log whenever I click start. Pictures are posted on page 16.

Share this post


Link to post
Share on other sites
Updated but still doesn't work. I get 'Efficiency is dropping 0 while running. Something is wrong. Shutting down generator.' in the log whenever I click start. Pictures are posted on page 16.

This message means that you ran out of one of the input resources. Do you have eclss or interstellar installed? Can you post a mod list. Maybe some other mod has a different water definition active.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.