cybutek

[1.3 & 1.2] KSP-AVC Add-on Version Checker Plugin 1.1.6.2 - MiniAVC - KSP-AVC Online (2016-10-13)

Recommended Posts

cybutek    775

KSP-AVC Plugin 1.1.6.2

KSP Add-on Version Checker

This system is a spawn from Tyrope's endevours on this thread.

After seeing the moderate take-up of a .version file format and the subsequent enthusiasm fall off. My thoughts were that a true .version system had to be created for it to even have a chance to sticking around. Not just for plugin developers and users which could type up a JSON file by hand in seconds, but also the artists and parts creators as well. It is all well and good to have external applications which manage your mods, but there has to be a more integrated solution for wide spread use. This is where my KSP-AVC plugin comes in, as it does all of the .version file checks from within the game. If any issues are found, they will be displayed to the player in a convenient way. An extention of the .version file has also been made to include an optional download field for use with this plugin.

NOTE: Version 1.1.5 works in all 1.0 versions of KSP. Use 1.1.6 for KSP 1.1 and later.

FOR DEVELOPERS...

Have a question or require some help? Leave a message in this thread or PM me.

If you wish your add-on to have KSP-AVC support even if the player does not have the KSP-AVC Plugin installed, you may use MiniAVC. Just bundle the .dll in with your mod and version files. Because of the bundled nature, the player will be given the option to allow update checking on the first run. If the player does disable update checking, it will continue to run in local mode assessing game version compatibility. MiniAVC will always run from the most up-to-date version which has been bundled with any of the installed add-ons. If a player has KSP-AVC Plugin installed, MiniAVC will automatically be disabled to allow the KSP-AVC Plugin to run.

For more information read the online readme file.

Get MiniAVC Here!

Please not that if hosting a version file yourself, it must be encoded in UTF-8 without a Byte-Order Mark.

The source code and project is part of the same repository on GitHub as KSP-AVC Plugin.

Licensed under GNU General Public License v3

Additionally

This software searches through only the KSP GameData directory and subfolders.

This software contacts the internet to check if add-ons have newer versions available. Data is only read from the internet and no personal information is sent.

This software has the ability to open up a browser window to what is set in the DOWNLOAD field of the remote version file.

All remote destinations set in version files are up to the respective add-on developers and I hold no responsibility for how these features are used.

 


KSP-AVC Online

Easy Versioning for Everyone!

As I see it, the way to get proper versioning to go mainstream has to be that it is easy. This means super easy for everyone no matter what their skills are. It shouldn't matter if you're a programmer, artist, content creator, parts developer. You have the right to version your add-on in a simple and convenient way. With complete compatibility with the KSP-AVC plugin as well as any other 3rd party software which conforms to the .version file standard.

ksp-avc.cybutek.net

 


 

 

DONATIONS

Completely voluntary, absolutely amazing, and really does help me out a lot!

btn_donate_LG.gif

 

Edited by cybutek

Share this post


Link to post
Share on other sites
Azimech    5925

I like it!

And for hosting ... Maybe Dropbox?

Share this post


Link to post
Share on other sites
cybutek    775
And for hosting ... Maybe Dropbox?

Would of worked, but there's no actual .version files. The information in the database is dynamically encoded into JSON as and when required. It'll have to be PHP5.5 & MySQL complient. :D

Share this post


Link to post
Share on other sites
cybutek    775

Can't believe that I forgot to actually include a screenshot of the plugin in action. All sorted now :confused:

Share this post


Link to post
Share on other sites
Tyrope    5

I approve of this project and any other projects that wish to use this style of .version files.

Cybutek: We should talk regarding combining efforts.

Share this post


Link to post
Share on other sites
Starstrider42    238

One suggestion and one question:

Suggestion: could you please make it so that the log messages say which file is being parsed? It's hard to find problems (or even to know if they're in your file or somebody else's) otherwise.

Question: how do you indicate that a mod is compatible with, say, both KSP 0.23.0 and KSP 0.23.5?

Thanks!

Edited by Starstrider42

Share this post


Link to post
Share on other sites
Justin Kerbice    135

Sounds great, hope modders will start to use it.

Some more fields to add IMHO:

type (plug-in/part/mixed=plug-in + part)

depends (modX use plug-in from modY, if modY if upgraded, warning may be displayed)

Share this post


Link to post
Share on other sites
cybutek    775
One suggestion and one question:

Suggestion: could you please make it so that the log messages say which file is being parsed? It's hard to find problems (or even to know if they're in your file or somebody else's) otherwise.

Thanks for pointing out that problem with the log messages. They were not showing up due to the way threading works. I've sorted out that problem and have made them fairly verbose to help with any .version file debugging.

Question: how do you indicate that a mod is compatible with, say, both KSP 0.23.0 and KSP 0.23.5?

I'm working on that by allowing KSP_VERSION_MIN and KSP_VERSION_MAX fields. The plugin works on the assuption that all KSP_VERSION fields are optional, so just leaving them out completely will default it to assume the add-on will work with everything.

I'll aim to get an update out later today with these changes :)

depends (modX use plug-in from modY, if modY if upgraded, warning may be displayed)

Including dependancies would be an extremely nice feature, but this area will have to be thought out carefully.

Share this post


Link to post
Share on other sites
Starstrider42    238

Thanks for your quick response. One more feature request:

When 0.24 comes out, there will likely be a transition period when I'm supporting both 0.23.5- and 0.24-compatible versions. Can there be a way to say "version X is the latest for 0.23.5, but version Y is the latest for 0.24"? That way people who are delaying upgrading to 0.24 won't get an (incorrect) warning about not having version Y.

Share this post


Link to post
Share on other sites
cybutek    775

I have released version 1.0.1 of the plugin including the following changes:

- Added minimum and maximum KSP version support.

- Updates will only be shown if the remote version is compatible with the installed version of KSP.

Share this post


Link to post
Share on other sites
Ippo    712

Hi cybutek, what's the status of this project? Is it still being worked on?

Share this post


Link to post
Share on other sites
cybutek    775
Hi cybutek, what's the status of this project? Is it still being worked on?

Yes this project is still active and I am making use of it with my other mods... There just hasn't been much in the way of bugs or reasons for updates :)

Share this post


Link to post
Share on other sites
Ippo    712

Ok, so I'll see to add the .version file in my next release! :)

EDIT: where can I find some specific documentation about the formatting and the available fields? Can I have a revision field for the version, too? two numbers ain't gonna cut it for me :/

Edited by Ippo

Share this post


Link to post
Share on other sites
cybutek    775
Ok, so I'll see to add the .version file in my next release! :)

EDIT: where can I find some specific documentation about the formatting and the available fields? Can I have a revision field for the version, too? two numbers ain't gonna cut it for me :/

There's a breakdown of how the .version file should be formatted in the ReadMe file. Also all versions use the normal formatting, 'major.minor.patch(revision).build'.

Share this post


Link to post
Share on other sites
Ippo    712

Oh, I saw it on curse (I had only looked on github).

DangIt will support it as soon as 0.24 is out ;)

Last thing: <ad> Would you consider uploading also to kerbalstuff? </ad>

Share this post


Link to post
Share on other sites
zengei    97

Is there a way to bring up the UI manually? I had to edit a .version file so I could see the UI and make sure it was working.

Share this post


Link to post
Share on other sites
Dale.s    0

Is there a way to verify this is working? I know i have 2 outdated mods atm (kerbal engineer and realchutes) but i dont get a popup. To try and test i changed the AVC version file to:

{"NAME":"KSP-AVC Plugin","URL":"http://ksp-avc.cybutek.net/version.php?id=2","VERSION":{"MAJOR":1,"MINOR":0,"PATCH":0},"KSP_VERSION":{"MAJOR":0,"MINOR":24}} - Patch = 0 instead of current 2 and i still dont get any popup.

Reading threw KSP.log i find the general loading stuf, then i get this:

[LOG 21:59:39.399] [KSP-AVC]: Starting Add-on Population.
[LOG 21:59:39.400] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version "NAME" = Kerbal Engineer Redux
[LOG 21:59:39.400] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version "URL" = [url]http://ksp-avc.cybutek.net/version.php?id=1[/url]
[LOG 21:59:39.401] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version "DOWNLOAD" = [url]http://kerbal.curseforge.com/ksp-mods/220285-kerbal-engineer-redux[/url]
[LOG 21:59:39.402] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version "VERSION" = 0.6.2.5
[LOG 21:59:39.403] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version "KSP_VERSION" = 0.24
[LOG 21:59:39.404] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version "KSP_VERSION_MIN" is not valid or missing. (optional field)
[LOG 21:59:39.404] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version "KSP_VERSION_MAX" is not valid or missing. (optional field)
[LOG 21:59:39.408] [KSP-AVC]: GameData\Engineer\KerbalEngineerRedux.version fetched remote version file at [url]http://ksp-avc.cybutek.net/version.php?id=1[/url].
[LOG 21:59:39.409] [KSP-AVC]: [url]http://ksp-avc.cybutek.net/version.php?id=1[/url] "NAME" = Kerbal Engineer Redux
[LOG 21:59:39.410] [KSP-AVC]: [url]http://ksp-avc.cybutek.net/version.php?id=1[/url] "URL" = [url]http://ksp-avc.cybutek.net/version.php?id=1[/url]
[LOG 21:59:39.411] [KSP-AVC]: [url]http://ksp-avc.cybutek.net/version.php?id=1[/url] "DOWNLOAD" = [url]http://kerbal.curseforge.com/ksp-mods/220285-kerbal-engineer-redux[/url]
[LOG 21:59:39.412] [KSP-AVC]: [url]http://ksp-avc.cybutek.net/version.php?id=1[/url] "VERSION" = 0.6.2.7
[LOG 21:59:39.413] [KSP-AVC]: [url]http://ksp-avc.cybutek.net/version.php?id=1[/url] "KSP_VERSION" = 0.24
[LOG 21:59:39.413] [KSP-AVC]: [url]http://ksp-avc.cybutek.net/version.php?id=1[/url] "KSP_VERSION_MIN" is not valid or missing. (optional field)
[LOG 21:59:39.414] [KSP-AVC]: [url]http://ksp-avc.cybutek.net/version.php?id=1[/url] "KSP_VERSION_MAX" is not valid or missing. (optional field)

So it seems to have found one out of date addon, but i dont get a popup at all?

Share this post


Link to post
Share on other sites
Addle    107

FYI, I added support to Protractor Continued when I took it over. There was a pull request on the original repository from vosechu, which I pulled in and updated. So thanks, vosechu.

Share this post


Link to post
Share on other sites
cybutek    775
So it seems to have found one out of date addon, but i dont get a popup at all?

That's very odd... It has indeed found an out of date addon, so should bring up the popup. Are there no other problems in the log? Could you upload the whole log file somewhere for me to view?

Share this post


Link to post
Share on other sites
cybutek    775

Yes I will be updating it... I've only just found out that Squad released a new version of KSP. Although it's probably telling you that KSP-AVC was built for 0.24 and not 0.24.1, it will work as intended still.

Share this post


Link to post
Share on other sites
cybutek    775

*Face Palm*

I've just uploaded for 0.24.1 to curse... Guess I'm going to have to re-build and re-package.

edit: Just waiting on the version for 0.24.2 to be reviewed and made available on curse.

Edited by cybutek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now