Biotronic

[0.90] TweakScale - Rescale Everything! (v1.50 - 2014-12-24 10:40 UTC)

Recommended Posts

SUGGESTION: Allow height and width to be independently adjusted.

Why would I want that?

1) I want to lengthen a tank to increase it's fuel capacity, but not its width.

2) I have a service pod mod in which I want to decrease its width (to fit on a narrower rocket) but keep the height so that it stores the same parts within.

Just a thought. As I previously mentioned, this is a Must Have mod. I'm glad that you recompiled/tested it with KSP 0.24 so soon after release. Thanks.

Sounds like you need Procedural Parts.

Share this post


Link to post
Share on other sites

So when I update this to 1.23 (or in the future) should I replace the scale.dll in IR with the newest version I download from here? Or is the IR scale.dll different internally (other than version number) than the scale.dll distributed here?

Share this post


Link to post
Share on other sites
So when I update this to 1.23 (or in the future) should I replace the scale.dll in IR with the newest version I download from here? Or is the IR scale.dll different internally (other than version number) than the scale.dll distributed here?

The IR scale.dll is different internally. Replacing it with a different version will usually break more things than it fixes.

Share this post


Link to post
Share on other sites

Between tweakscale updates and IR updates and removing KAS from stock parts I am ~so far~ not getting nullrefs galore.

Share this post


Link to post
Share on other sites
Between tweakscale updates and IR updates and removing KAS from stock parts I am ~so far~ not getting nullrefs galore.

Whee! (dang ten chars)

Share this post


Link to post
Share on other sites

I just installed the newest TweakScale and, uh, it doesn't seem to work at all. When I right-click on parts that should be tweakable, there's no option to rescale them. What logs or other information would you want to see to diagnose the issue?

Edit: my bad, looks like I had installed another mod incorrectly, and there was an older version of TweakScale in my GameData folder. Sorry for cluttering up the thread.

Edited by HawkW
figured out the source of the problem.

Share this post


Link to post
Share on other sites
Any word on the mass scaling? Am I just using the wrong format for my definitions?

There seems to be a bug in the handling of per-scaletype exponents.

Share this post


Link to post
Share on other sites
There seems to be a bug in the handling of per-scaletype exponents.

...and fixed. 1.24 also fixes Kolago's problem with node sizes.

Oh, and an unmentioned addition in 1.23 (will add it to the front page one of these years):

    Resources
{
!amount = 3
maxAmount = 3
}

That exclamation mark means TweakScale should only use relative scaling. This is occasionally very useful, and potentially fixes many problems where values are incorrectly scaled upon duplication.

Share this post


Link to post
Share on other sites

Is it an bug that RCS trust don't scale with size or is it not implemented? (0.24 / x64 / Win7)

Share this post


Link to post
Share on other sites

TdZ7xxr.png

I just upgraded from 1.21 to 1.24.

This is a picture of 2 Illuminator Mk1 lights that have spontaneously blown up to super-size-- they were originally placed on the nose of a small scanning satellite, but now they are so big you cannot see the craft at all. The satellite still works perfectly.

Share this post


Link to post
Share on other sites
...and fixed. 1.24 also fixes Kolago's problem with node sizes.

Oh, and an unmentioned addition in 1.23 (will add it to the front page one of these years):

    Resources
{
!amount = 3
maxAmount = 3
}

That exclamation mark means TweakScale should only use relative scaling. This is occasionally very useful, and potentially fixes many problems where values are incorrectly scaled upon duplication.

AWESOME! thanks! Time to go rewrite all my scaletypes.

Share this post


Link to post
Share on other sites
http://i.imgur.com/TdZ7xxr.png

I just upgraded from 1.21 to 1.24.

This is a picture of 2 Illuminator Mk1 lights that have spontaneously blown up to super-size-- they were originally placed on the nose of a small scanning satellite, but now they are so big you cannot see the craft at all. The satellite still works perfectly.

Could you upload KSP_Data/output_log.txt somwhere and link it? Without that, it's kinda hard to figure out what's causing the nullrefs.

Share this post


Link to post
Share on other sites
Could you upload KSP_Data/output_log.txt somwhere and link it? Without that, it's kinda hard to figure out what's causing the nullrefs.

Output Log I am guessing it has something to do with IR_Tweakscale and it being based on Scale 1.22 instead of 1.24.

Usually I keep a standalone copy of the newest tweakscale loaded and just tell any packaged version that comes with another mod not to load so that I do not end up with more than one version. Should I be keeping the extra copies with different versions instead? Does IR_Tweakscale also need to be there or should it be removed to prevent conflict with the primary Tweakscale installation?

Share this post


Link to post
Share on other sites

I'll... uh... I'll just um leave this here. Impressive mod interaction going on. IKEA would be proud.

https://www.dropbox.com/s/tzsh4gim77wkb2m/vab_explosion_output_log.txt

https://www.dropbox.com/s/b1fto5rqykoz2dc/explodeycraft.jpg

Not a single part in there was ever changed from stock values when it was built in 1.22 or 1.23. I just loaded the craft in 1.24.

Share this post


Link to post
Share on other sites

I'm getting the classic "engines firing in the VAB error" with TweakScale 1.24 and KSP 0.24 Mac 32 bit. I've triple-checked that TS is installed correctly in stock KSP, and the error does not occur with TS 1.23. Loading an engine in the VAB results in a UriFormatException. Here's the stack trace from my log for the UriFormatException:

UriFormatException: URI scheme must start with a letter and must  consist of one of alphabet, digits, '+', '-' or '.' character.
at System.Uri.Parse (UriKind kind, System.String uriString) [0x00000] in <filename unknown>:0
at System.Uri.ParseUri (UriKind kind) [0x00000] in <filename unknown>:0
at System.Uri..ctor (System.String uriString, Boolean dontEscape) [0x00000] in <filename unknown>:0
at System.Uri..ctor (System.String uriString) [0x00000] in <filename unknown>:0
at TweakScale.PathEx.MakeRelativePath (System.String fromPath, System.String toPath) [0x00000] in <filename unknown>:0
at TweakScale.Tools.KSPRelativePath (System.String path) [0x00000] in <filename unknown>:0
at TweakScale.Tools.Logf (System.String format, System.Object[] args) [0x00000] in <filename unknown>:0
at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0
at Part.ModulesOnStart () [0x00000] in <filename unknown>:0
at Part+.MoveNext () [0x00000] in <filename unknown>:0

screenshot0.jpg

Share this post


Link to post
Share on other sites

I literally taught myself to mod by doing this manually on a part-by-part basis though the configs. Nice work!

Share this post


Link to post
Share on other sites

I am having a similar problem as Smurfalot in my game. In my case there are 6 radial Xenon tanks that have been supersized. Maybe other things, too, but I can't see anything except the xenon tanks. :D

I have no NullRefs at all while this is happening, so I didn't save my output.log.

This is the tweakscale off of one of the affected tanks out of the save file. I see a few new parameters compared to 1.22. Do these look alright? The part is supposed to be stock size. Is there possibly a problem with the scale.dll in IR overriding this one or something? Going by the changed module to 1.24 parameters, it seems that the new dll is indeed loading and running.

				MODULE
{
name = TweakScale
isEnabled = True
tweakScale = 100
currentScale = 100
defaultScale = 1.25
defaultName = -1
isFreeScale = False
version = 1.24.0.0
defaultTransformScale = (1, 1, 1)
tweakScale_UIEditor
{
controlEnabled = True
minValue = 25
maxValue = 400
incrementLarge = 37.5
incrementSmall = 3.75
incrementSlide = 0.001
}
EVENTS
{
}
ACTIONS
{
}
}

Share this post


Link to post
Share on other sites
I am having a similar problem as Smurfalot in my game. In my case there are 6 radial Xenon tanks that have been supersized. Maybe other things, too, but I can't see anything except the xenon tanks. :D

I have no NullRefs at all while this is happening, so I didn't save my output.log.

This is the tweakscale off of one of the affected tanks out of the save file. I see a few new parameters compared to 1.22. Do these look alright? The part is supposed to be stock size. Is there possibly a problem with the scale.dll in IR overriding this one or something? Going by the changed module to 1.24 parameters, it seems that the new dll is indeed loading and running.

				MODULE
{
name = TweakScale
isEnabled = True
tweakScale = 100
currentScale = 100
defaultScale = 1.25
defaultName = -1
isFreeScale = False
version = 1.24.0.0
defaultTransformScale = (1, 1, 1)
tweakScale_UIEditor
{
controlEnabled = True
minValue = 25
maxValue = 400
incrementLarge = 37.5
incrementSmall = 3.75
incrementSlide = 0.001
}
EVENTS
{
}
ACTIONS
{
}
}

I am not 100% sure, but I suspect it is the conflict between 1.22 in IR and the new 1.24 Tweakscale. I will take a look at my save to see if anything stands out.

Edit: I am just guessing, but if you look at where it says the "currentScale = 100" I think that might be the problem--

Edit2: Yep that was the problem, I went into my save file and adjusted the tweakScale and currentScale on the offending parts back to "= 1" instead of "= 100" and they went back to normal.

Edited by Smurfalot

Share this post


Link to post
Share on other sites

When there are two different versions of TweakScale installed they will misbehave. During 0.23.5 it was stable because there wasn't a whole lot of changes to TweakScale so there was a nice calm for a while. Now that 0.24 is out there have been changes left and right. once TweakScale is stable things will start to behave again. In the meantime I'm debating on bastardizing a version of TweakScale that is custon ONLY to IR in order to get things working again but right now I'm having issues with the code in DupeChecker.cs that is within TweakScale.

Share this post


Link to post
Share on other sites

Alright. Can I revert to 1.22 then temporarily? Or are those new parameters going to mess things up if i do so? I'm particularly worried about the scale being 100, LOL.

Share this post


Link to post
Share on other sites

I'm not going to do a thing and hold off for an update from Biotronic.

Share this post


Link to post
Share on other sites
Alright. Can I revert to 1.22 then temporarily? Or are those new parameters going to mess things up if i do so? I'm particularly worried about the scale being 100, LOL.

I had the same issue with some supersized radial monoprop tanks.. Revert to 1.22 appears to have re sized them back down

Share this post


Link to post
Share on other sites

I went through and edited my persistence file, replacing the occurrences of tweakScale = 100 and currentScale = 100 on existing craft with the correct numbers -- 1.25 for radial xenon, radial monoprop, and a B9 RCS thruster block also affected. No other parts on existing ships were affected by the incorrect scale during the upgrade, and new vessels with the affected parts are fine.

I also moved the Infernal Robotics dlls as sirkut said to try here. The vessels save correctly and load fine after fixing the bad module parameters and doing the IR fix.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.