Jump to content

[0.90] TweakScale - Rescale Everything! (v1.50 - 2014-12-24 10:40 UTC)


Biotronic
 Share

Recommended Posts

Am I right in thinking that attachment points do not scale along with the rest of the part? I am making a part with a rather large scale range, but the smaller sizes are obscured by their attachment points.

Edit: apparently they do scale, but there is a bottom limit.

Edited by Camacha
Link to comment
Share on other sites

Before I go and upload an output log in regards to something strange, has anyone else ever encountered where you rescale something in the VAB and SPH, launch the vehicle and then the next time you load up the vehicle a part or sometimes a few parts are back to their original scale?

Link to comment
Share on other sites

Before I go and upload an output log in regards to something strange, has anyone else ever encountered where you rescale something in the VAB and SPH, launch the vehicle and then the next time you load up the vehicle a part or sometimes a few parts are back to their original scale?

Yes, this is similar to the issue I have. I noticed something today though.

The same issue happened to me again, but this time, I don't even have TweakScale installed. So I suspect this is a different bug not at all related to TweakScale.

Link to comment
Share on other sites

Thought I should make this bug known:

Tweakscale interferes with a part's "mirrorRefAxis" parameter (if it has one) in it's part config. If you ever have a wing or some other part that is flipped upside down on one side when you mirror it, and it has Tweakscale... that's the reason... Removing the Tweakscale module from the part fixes it.

Would be nice if this was fixed!

Link to comment
Share on other sites

I'm starting to get worried this is abandoned, it's been a long while since any updates or word from the author.

and I'm sorry to say that it seems lots of people are having issues with it, myself included.

Sometimes resized parts scale back to their original size between SPH and runway or VAB and pad, attachment nodes move to the wrong places sometimes when using symmetry with rescaled parts.

I really hope this isn't abandoned or that someone will try and iron out these bugs that have cropped up in the latest version as it's one of the more essential mods. :(

Link to comment
Share on other sites

I figured this might assist some, so here are my findings:

Recently I found that each time I pick up an air intake (stock or mod e.g. B9), the creator will go completely nuts, not allowing to click any button in game and eventually forcing me to shut down the client. I asked about it somewhere else, and somone suggested either TweakScale or KSP Interstellar as the source. As Tweakscale itself acted rather odd lately, I launched the client once without it. Problem absolutely solved.

Since i'm not the type to delve in the configs or spend hours finding a costly solution, a simple removal of the mod will fix it all.

Unfortunate, says my 7m diameter Energia replica.

Link to comment
Share on other sites

Hi Biotronic ! I have a problem with duplicate MM patch entries for Structural Intake from SPP pack (now shipped under Squad's folder).

It has same entry in "SpaceplanePlus_TweakScale.cfg" and "Squad_TweakScale.cfg" :


@PART[IntakeRadialLong]
{
MODULE
{
name = TweakScale
type = surface

}
}

This causes TweakScale to throw a warning in debug log, and in my KSP install with full set of mods also causes scaled parts to revert to 100% scale on craft launch (in vanilla KSP parts stay scaled on launch).

Which entry should be deleted ?

PS:This is not the only mod that suffered from duplication, MFT also has this (posted in appropriate thread).

Link to comment
Share on other sites

Hi Biotronic ! I have a problem with duplicate MM patch entries for Structural Intake from SPP pack (now shipped under Squad's folder).

It has same entry in "SpaceplanePlus_TweakScale.cfg" and "Squad_TweakScale.cfg" :


@PART[IntakeRadialLong]
{
MODULE
{
name = TweakScale
type = surface

}
}

This causes TweakScale to throw a warning in debug log, and in my KSP install with full set of mods also causes scaled parts to revert to 100% scale on craft launch (in vanilla KSP parts stay scaled on launch).

Which entry should be deleted ?

PS:This is not the only mod that suffered from duplication, MFT also has this (posted in appropriate thread).

How can MFT have duplicate TweakScale references? The mod includes no parts that could be TweakScaled...

Link to comment
Share on other sites

I have a couple of bugs to report. Every so often when launching a craft, the command pod will be shrunk a little bit (enough to annoy me), however it will still be attached by the set node. Also sometimes when loading a craft in the editor freescaled parts will be scaled up to 140%.

If I need to add anything else please tell me.

Link to comment
Share on other sites

Congratz on your job. I guess you took your scale tweaking to a professional level eh ;)

I hope you find the time to relax soonish and after that, maybe give this mod a bit of an update. I love it and it really changed the way I build ships. Playing without it feels wrong now.

If you do find the time, I have a couple of logs of a game crash that may or may not be cause by TweakScale. The friendly supportforum crew pointed their fingers at this mod when I posted my logs there.

http://forum.kerbalspaceprogram.com/threads/106923-Random-crash-without-message?p=1662687#post1662687

Link to comment
Share on other sites

Hello everyone! I'm not dead, and have not abandoned TweakScale yet. I've just gotten my job back (for now), and it's crunch time. That means less spare time than I'd prefer.

On the positive side, I can post our

and an announcement.

Congrats on the job Biotronic, no worries, real life comes first

glad to hear your still working on this mod as it's one of my favourites :)

Link to comment
Share on other sites

hello, I have a question. I'm using tweakscale in my mod for wings and is also compatible with FAR. If increase or decrease their size using tweakscale, it automatically changes the aerodynamics values or some specific command is needed?

This is the configuration I use in the MOD:

SCALETYPE

{

name = GilB9Shuttlewings

freeScale = false

scaleFactors = 0.5, 0.75, 1.0, 1.25, 1.5

scaleNames = Micro, Small, Medium, Large, Giant

defaultScale = 1

}

Link to comment
Share on other sites

hello, I have a question. I'm using tweakscale in my mod for wings and is also compatible with FAR. If increase or decrease their size using tweakscale, it automatically changes the aerodynamics values or some specific command is needed?

This is the configuration I use in the MOD:

If you're also adding the MODULE{} named TweakScale to your parts, and then using that SCALETYPE within the module, you may not have to do anything extra. If I remember correctly, TweakScale already handles various aerodynamic values (you can check for their variable names in ScaleExponents.cfg), but I'm not positive.

That SCALETYPE as it stands however won't do anything that tweakscale doesn't already to to the aerodynamics of the part, just FYI.

Edited by AccidentalDisassembly
Link to comment
Share on other sites

Guys, is there any way I can stop TweakScale from automatically rescaling my stuff? I want it to rescale only when I want to, however, sometimes when I put a medium sized part on a small sized part, it gets shrinked automatically.

Link to comment
Share on other sites

It seams that the problem with parts resizing upon reloading is that the root part defaults to it's original size. To avoid this, make the root part an item that you don't plan to resize, and it seems to work nicely. Need to test it out when going back to a ship in space or on another planet and see if the work around also works.

Link to comment
Share on other sites

I was handed *yet* another logfile from some one having major issues with their ksp, so bad I didn`t have a clue where to start looking for the problem...

https://www.dropbox.com/s/115h1do5cu72z4g/output_log.txt?dl=0

After skimming through it and bashing my head about every mod and the game freaking out, I saw a tweakscale error, as usual these days, and suggested to delete tweakscale, as usual, and the game returned to perfect working, as usual.

When is enough enough?

Since the auto scaling tweakscale is causing problems across the board every where, 1.45 was the last stable version and after that people started complaining about the auto part reverts, blowing up ships and general game/mod freaking out creating all sort of problems.

Not funny anymore that you need to ask a person who has problems "do you have tweakscale installed?" at wich they say yes and after deleting it the problem goes away.

Can we get a 1.44/1.45 version compiled for 0.90 so that we can start to recommend it again to everyone instead of warning not to use it? pretty please?

Link to comment
Share on other sites

I just ran into this problem when going back to a craft in orbit.

Note: x32 KSP install.

PartModule is null.

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

NullReferenceException: Object reference not set to an instance of an object
at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Parsing vector2

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing double

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing vector2

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing double

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing vector2

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing double

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing vector2

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing double

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing vector2

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing double

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing vector2

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Parsing double

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

NullReferenceException: Object reference not set to an instance of an object
at TweakScale.TweakScale.OnStart (StartState state) [0x00000] in <filename unknown>:0

at Part.ModulesOnStart () [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at PartJoint.SetupJoint (Vector3 jointPos, Vector3 jointOrt, Vector3 jointOrt2, Int32 size) [0x00000] in <filename unknown>:0

at PartJoint.create (.Part child, .Part parent, UnityEngine.Transform nodeSpace, Vector3 nodePos, Vector3 nodeOrt, Vector3 nodeOrt2, Int32 nodeSize, AttachModes mode) [0x00000] in <filename unknown>:0

at PartJoint.Create (.Part owner, .Part parent, .AttachNode nodeToParent, .AttachNode nodeFromParent, AttachModes mode) [0x00000] in <filename unknown>:0

at Part.CreateAttachJoint (AttachModes mode) [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Stu-putnik Mk - II Debris Unloaded

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Stu-putnik Mk - II Debris Unloaded

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...