Biotronic

[0.90] TweakScale - Rescale Everything! (v1.50 - 2014-12-24 10:40 UTC)

Recommended Posts

Anybody here have issues with parts returning to their default size when they switch scenes, such as returning to a previous vessel? Also sometimes when loading them in the VAB, or from subassemblies.

Share this post


Link to post
Share on other sites
How can i turn off the function of automatically setting size of parts?

There is a more permanent solution (that i prefer, even if it means a little bit more work on a craft) : find

GameData\TweakScale\plugins\PluginData\Scale\config.xml

file and edit "Autoscale" and/or "Scale chaining" items to 0 (i set both to 0, and it works for me). After that restart KSP and it will no longer rescale parts from component list after attaching them to the craft.

Share this post


Link to post
Share on other sites

With fresh KSP .90 and only Tweakscale installed, Mk3 cargo bay texture does not load. Appears all white. Even with Module Manager removed.

Edited by inigma

Share this post


Link to post
Share on other sites
With fresh KSP .90 and only Tweakscale installed, Mk3 cargo bay texture does not load. Appears all white.

Stock bug in KSPs tga loader. Reloading from the debug menu or installing ATM fixes it.

Share this post


Link to post
Share on other sites

For whatever reason, the tweakscale file for the B9 parts isnt working. None of the B9 parts are available to be scaled. Anyone else experienced this?

Share this post


Link to post
Share on other sites
Stock bug in KSPs tga loader. Reloading from the debug menu or installing ATM fixes it.

Thank you. I don't see a reload option in the current debug menu.

Share this post


Link to post
Share on other sites

how do I add a MM config to a whole mod? I want to make all Laztek parts scaleable. His parts are not 3.75 like they should be

Share this post


Link to post
Share on other sites
Anybody here have issues with parts returning to their default size when they switch scenes, such as returning to a previous vessel? Also sometimes when loading them in the VAB, or from subassemblies.

I get this as well. Procedural Parts doesn't do that though.

Share this post


Link to post
Share on other sites

I think it's time I realize I do not play KSP enough, and do not have the time necessary to continue this project. It hurts me to the core, but I believe it's better that I accept it and inform you guys. I'd love it if someone would be willing to carry the torch.

The licence should be permissive enough for anyone to just pick it up, but since this is the official thread at the moment I'd like to add a link in the OP if anyone decides to continue the development.

It's been great you guys, and it saddens me to do this, but it's better this way.

Share this post


Link to post
Share on other sites
I think it's time I realize I do not play KSP enough, and do not have the time necessary to continue this project. It hurts me to the core, but I believe it's better that I accept it and inform you guys. I'd love it if someone would be willing to carry the torch.

The licence should be permissive enough for anyone to just pick it up, but since this is the official thread at the moment I'd like to add a link in the OP if anyone decides to continue the development.

It's been great you guys, and it saddens me to do this, but it's better this way.

Thanks for all the time you've put into this, it's made my KSP experience so much better!

Share this post


Link to post
Share on other sites
I think it's time I realize I do not play KSP enough, and do not have the time necessary to continue this project. It hurts me to the core, but I believe it's better that I accept it and inform you guys. I'd love it if someone would be willing to carry the torch.

The licence should be permissive enough for anyone to just pick it up, but since this is the official thread at the moment I'd like to add a link in the OP if anyone decides to continue the development.

It's been great you guys, and it saddens me to do this, but it's better this way.

Thanks for your work Biotronic, best of luck with your new job

Share this post


Link to post
Share on other sites

Thanks for maintaining it and for all your time spend in development. And thanks for permission for anyone with enough skill, willpower and enough free time to continue development. I hope that someone will be able to continue this mod, until then we have to figure out how to manage without it.

Cheers.

Share this post


Link to post
Share on other sites

Thanks Biotronic for all the efforts you did to let this great add-on available to the community. Pity time is never enough for all the things we love.

Share this post


Link to post
Share on other sites

Hello to all, and thanks for this mod....

I am trying to use this with a docking port and need some help. I have created a new MM config, example from top;

SCALETYPE

{

name = CMES_Parts

freeScale = false

scaleFactors = 0.25, 0.35, 0.5, 0.55, 0.59, 0.6, 0.65, 0.7, 1.0, 1.4, 2.0, 2.8, 4.0

scaleNames = 25%, 35%, 50%, 55%, 59%, 60%, 65%, 70%, 100%, 140%, 200%, 280%, 400%

defaultScale = 1.0

}

@PART[PC_InflateHeatshieldLxx]

{

MODULE

{

name = TweakScale

type = CMES_Parts

defaultScale = 1

}

}

But when I rescale, the part sizes as it should but all values (Roll - Pitch - Yaw Torque, and all of the Acquire range, force , etc) values get thrashed / corrupted.

The default size has correct values, but when the 'tweak' happens they get corrupted and never go back to original values.

any hints, ideas or comments?????

thanks again for mod and help.

cheers.

Share this post


Link to post
Share on other sites

I'm having a problem with tweakscale... when I load a tweaked craft from the tracking station and sometimes loading from the launch pad or runway, the craft disintegrates. No explosions, it just flies apart. I figured this out by removing 1 mod at a time until the problem went away. Tweakscale is one of my favorite mods... please help!!!

These are the other mods I was using with Tweakscale:

Mechjeb

Movie Time

Procedural Fairings

Impossible Inovations

Kerbal Foundries

Fuel Tanks Plus

BD Armory

I hope someone can help me since Biotronic no longer supports this mod.

Share this post


Link to post
Share on other sites
I think it's time I realize I do not play KSP enough, and do not have the time necessary to continue this project. It hurts me to the core, but I believe it's better that I accept it and inform you guys. I'd love it if someone would be willing to carry the torch.

The licence should be permissive enough for anyone to just pick it up, but since this is the official thread at the moment I'd like to add a link in the OP if anyone decides to continue the development.

It's been great you guys, and it saddens me to do this, but it's better this way.

It's been an awesome mod, Bio! Sorry to hear, but real life is real life. :D Hope you can make it back someday soon!

Sorry to hear. I wonder if any of the other mod makers whos mods are dependent on Tweakscale will adopt this orphaned project. :) I informed the Infernal Robotics thread.

Share this post


Link to post
Share on other sites

Question, is there anyway I can modify an existing TWEAKSCALEEXPONENTS using module manager?

Edit, also is there anyway to repond to a tweakscale resize?

Edited by FreeThinker

Share this post


Link to post
Share on other sites
Question, is there anyway I can modify an existing TWEAKSCALEEXPONENTS using module manager?

@TWEAKSCALEEXPONENTS[MyModuleKind] {
floopRate = 3
MyStructure {
!ambulation = 2
}
}

Just the same as with any other cfg. If there are specific problems you want addressed,

Edit, also is there anyway to repond to a tweakscale resize?

The opening post contains information on how a mod can be informed of TweakScale rescaling, in the 'Advanced Features' section. I was also toying with the idea of simply looking for functions called TweakScalePrescale and TweakScalePostScale, but no code has been written to support this idea.

Share this post


Link to post
Share on other sites

I don't know if TweakScale is supposed to do this, but everytime I add a part of the "wrong" size, it automatically scales the part which I would really like it to not do. Is there any way to disable this?

EDIT: Nevermind. Was digging in the TweakScale directory and found the thing in the config.

Edited by BavarianBozzz

Share this post


Link to post
Share on other sites

After i docked with my space station i saw this a lot in the log.

[EXC 17:26:47.582] NullReferenceException: Object reference not set to an instance of an object

TweakScale.Hotkeyable.op_True (TweakScale.Hotkeyable a)

TweakScale.TweakScale.Update ()

Anyone also had this behavior?

EDIT: After reloading the game, this error doesn't show up anymore.

Edited by BlackSoldierB

Share this post


Link to post
Share on other sites
After i docked with my space station i saw this a lot in the log.

Anyone also had this behavior?

EDIT: After reloading the game, this error doesn't show up anymore.

I've had 100,000+ instances of that error (I think) when messing around with KAS stuff, but couldn't pin down the exact circumstances...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.