Jump to content

[1.1.0] Flight Manager for Reusable Stages (FMRS x1.1.0 [Experimental])


Recommended Posts

On 2/20/2017 at 6:21 PM, linuxgurugamer said:

I just tried it, worked for me, so I think I need some more information.

Can you detail the timeline, or, better yet, make a video?  I'm sure that I'm not doing the the same as you , and it's probably affecting the outcome.

This time it happened when going back to main craft. Here's the video:

Spoiler

 

and here are the fresh files:

https://drive.google.com/open?id=0B3LbssxbT8LFOGR3N3BfZjcwbE0

Link to post
Share on other sites
21 hours ago, kendoka15 said:

This time it happened when going back to main craft. Here's the video:

  Reveal hidden contents

 

and here are the fresh files:

https://drive.google.com/open?id=0B3LbssxbT8LFOGR3N3BfZjcwbE0

What is your desktop size?  I'm trying to verify what I'm reading in the log file.

Also, can you please try to duplicate this with a minimal install?  Just KSP, FMRS, and ModuleManager

I'm seeing some indications in the log file that you have one or more older mods installed, would like to eliminate the possibility of a mod conflict.

Specifically, there are some references to KSPUtil, which shouldn't be there in a clean 1.2.2 install.

One think I noticed is that on my test, I have a slightly later version of thee KSPSteamCtrlr than you do.

 

Link to post
Share on other sites
2 hours ago, eberkain said:

I get a couple KSPUtil errors in my clean install of 1.2.2

Interesting, but......

I can reliably reproduce the crash.  It seems to be a a timing issue, the more mods I have installed, the more stable it is.  The crash occurs when it's the only installed mod

I also know which line it is, but that doesn't seem to help me, everything looks good so far, I haven't yet figured out what's missing

I'll do what I can, but this may take a while

For anyone interested, the  line is:

FlightDriver.StartAndFocusVessel(loadgame, load_vessel);

 

Link to post
Share on other sites

Well, Malah just sorted out a problem, where using QuickSTART to directly go to a flying vessel removed all contracts from the game:

On 10.2.2017 at 11:30 PM, Malah said:

@Liquid5n0w & @Jebs_SY Thanks for yours reports, I've found the error. I've seen that QuickGoTo hadn't this issue, but it also has a go to last vessel ... both mods use the same function but QuickGoTo reloads the savegame file and QuickStart used the savegame already loaded and KSP seems to don't like that :wink:

I know this is different, but maybe it is a similar direction and can help debugging?

Edited by Jebs_SY
Link to post
Share on other sites

Status update:

I'm pretty sure I've identified the problem, and it's inherent in the way the mod was written:

The Save/Load system in KSP is rather delicate, and is being abused rather badly by this mod.  What seems to be happening is that the mod does a save, and then immediately does a load.  The problem is that it loads the new file before the old one is done saving.  This is why it works better when there are more mods installed, because they are artificially adding a delay between the save and the load. 

This is going to take a few days to sort out

Link to post
Share on other sites

I don't know if you still need this information but:

Same crash with one kerbal. As to my desktop size, my main monitor is 1440p and my two others are 1080p. What's a bit weird is I only have FMRS and MM installed, nothing else.

Link to post
Share on other sites
7 hours ago, linuxgurugamer said:

Status update:

I'm pretty sure I've identified the problem, and it's inherent in the way the mod was written:

The Save/Load system in KSP is rather delicate, and is being abused rather badly by this mod.  What seems to be happening is that the mod does a save, and then immediately does a load.  The problem is that it loads the new file before the old one is done saving.  This is why it works better when there are more mods installed, because they are artificially adding a delay between the save and the load. 

This is going to take a few days to sort out

I love that last part where you think it can get sorted out.  I've always loved the idea behind this mod, its just never worked great when I've tried it out. 

Link to post
Share on other sites

Ok.  I have a solution, but need to test it on a larger save.

Can someone post a large save file, from  a stock game?  One which is over a meg in size would be ideal, I would like some which are also smaller, say, 300-500k in size.

Thanks

Link to post
Share on other sites

And the answer is: 

There needs to be about a 2/3 second delay inserted before doing the load.  I've run into this before, and just came across some code in FMRS which does this for jumping to the Space Center and Tracking Station, but doesn't have it for loading a save.  My fix does that.

And, I also recalled running into this in another mod as well (one which I wrote myself :-)    )

I still would like to test this with some contributed saves

Link to post
Share on other sites
On 2/23/2017 at 6:24 AM, linuxgurugamer said:

Interesting, but......

You got me curious.  If I pull everything out of my game data directory but Squad, I do get a couple KSPUtil errors on loading.   I went to my steam folder, deleted everything and refreshed the game cache to download a new copy.  And bam, no errors on load....  Best I can say is if you are working with a patched copy of the game then there must be something somewhere that didn't get removed properly with the update.  

Link to post
Share on other sites
1 hour ago, XPi2 said:

How can we deactivate the Debug Window? I don't manage to clean it from my hud.

Right now, you can't.  There is still a lot to do on this mod, mainly related to the window.  I'm still identifying the functionality of the toolbar button in different scenes, and want to make it more user-friendly.

On 2/24/2017 at 3:55 PM, kendoka15 said:

I don't know if you still need this information but:

Same crash with one kerbal. As to my desktop size, my main monitor is 1440p and my two others are 1080p. What's a bit weird is I only have FMRS and MM installed, nothing else.

and that is where it showed up the most.  The more mods installed, the less chance of the crash

Link to post
Share on other sites
3 minutes ago, linuxgurugamer said:

Right now, you can't.  There is still a lot to do on this mod, mainly related to the window.  I'm still identifying the functionality of the toolbar button in different scenes, and want to make it more user-friendly.

and that is where it showed up the most.  The more mods installed, the less chance of the crash

Could that be because the mods created the required delay?

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...