SIT89

[1.1.0] Flight Manager for Reusable Stages (FMRS x1.1.0 [Experimental])

Recommended Posts

closing the FMRS window, either by clocking the X or the toolbar icon, doesn't allow you to open it again. The toolbar icon will change from red to green but the window no longer shows up. Running 32-bit 0.24.2, latest everything

also, would it be possible to keep objects in physics range loaded? It would be cool to see all my boosters falling together instead of just the one I switched to

Edited by Gaiiden

Share this post


Link to post
Share on other sites
closing the FMRS window, either by clocking the X or the toolbar icon, doesn't allow you to open it again. The toolbar icon will change from red to green but the window no longer shows up. Running 32-bit 0.24.2, latest everything

also, would it be possible to keep objects in physics range loaded? It would be cool to see all my boosters falling together instead of just the one I switched to

Are you landed/ on the launchpad or during flight?

If you close the window during flight the plugin deactivates.

You can reset it when you are landed or again on the launchpad.

There is a bug in the game itself.

If you load a ship under an altitude of 22 km, the objects which would be in physics range will be deleted by the game, like they where not in physics range.

http://bugs.kerbalspaceprogram.com/issues/2429

If you load a ship over the 22km the nearby vessels will be there.

Share this post


Link to post
Share on other sites

Ah ok, yes I was in flight when it happened. Too bad about the bug hopefully Squad gets to that at some point. Thanks!

Share this post


Link to post
Share on other sites

Does this work well with StageRecovery?

EDIT: Wait, or is it it's own thing?

Edited by tygoo7

Share this post


Link to post
Share on other sites

When I recover some stages come with a NaN fund value and it breaks my save completely. Can't see funds or pay for anything; anyone know a fix?

Share this post


Link to post
Share on other sites

updated needed, well either this or Vessle Viewer, but I need Vessle Viewer for RPM/JSI (RPM has an open unused button, this might be cool in IVA/EVA). Id like to keep this installed but can't and OMG the hours it took me to track this problem down. lol

When you go to the launch pad FMRS and Vessle Viewer are conflicting over their tool bar buttons and Vessle Viewer button opens the FMRS window. If you click FMRS the words go from green to red on the button and then the Vessle Viewer window will open and Vessle Viewer works, no problem. BUT if you revert flight, recover vessle, or go back to the space center the game breaks and the exit buttons will not work. I hope this is something that can be resolved easy because Id like to put this back into my game. I am running 64bit and I have a TON of mods, almost have all of them I wanted working now, just a couple more to go and I can start playing again.

Thanks, let me know if there is any other files or info you need, Id be glad to help anyway I can.

Share this post


Link to post
Share on other sites
When I recover some stages come with a NaN fund value and it breaks my save completely. Can't see funds or pay for anything; anyone know a fix?
updated needed, well either this or Vessle Viewer, but I need Vessle Viewer for RPM/JSI (RPM has an open unused button, this might be cool in IVA/EVA). Id like to keep this installed but can't and OMG the hours it took me to track this problem down. lol

When you go to the launch pad FMRS and Vessle Viewer are conflicting over their tool bar buttons and Vessle Viewer button opens the FMRS window. If you click FMRS the words go from green to red on the button and then the Vessle Viewer window will open and Vessle Viewer works, no problem. BUT if you revert flight, recover vessle, or go back to the space center the game breaks and the exit buttons will not work. I hope this is something that can be resolved easy because Id like to put this back into my game. I am running 64bit and I have a TON of mods, almost have all of them I wanted working now, just a couple more to go and I can start playing again.

Thanks, let me know if there is any other files or info you need, Id be glad to help anyway I can.

Would be great if you could check the "write debug messages to log file" option in the settings, recreate your bugs and send me the log file.

This would make it a lot easier to me, to find out what's exactly happening.

Thank you!

Share this post


Link to post
Share on other sites

I'll do that the next time I'm on Kerbal, problem is the NaN fund recovery issue still persists without this plugin.

Share this post


Link to post
Share on other sites
Would be great if you could check the "write debug messages to log file" option in the settings, recreate your bugs and send me the log file.

This would make it a lot easier to me, to find out what's exactly happening.

Thank you!

Ok, I can do that for you but not right this second. I finally got all my mods back on, except this on, and I have a couple little errors im dealing with. I should finish today, and soon, so maybe tomorrow or the next day I can get that posted for you.

Share this post


Link to post
Share on other sites

This looks really cool. I worry, though, about how (ie. whether) it'll work with DarkMultiPlayer (which even seems to have difficulty with the stock "revert to..." functions).

I realize that getting this to play nice with DMP as it is now is nigh impossible, so I guess what I'd like to suggest is if SIT89 and godarklight could work together to get the two mods to interact peacefully. Chances are that getting DMP to work with something like this will iron out some of the remaining problems and instability with DMP.

Share this post


Link to post
Share on other sites

I was just thinking today that I need a mod like this for my Eve harvesters (which would have a drop-away VTOL section). I love this!

Share this post


Link to post
Share on other sites
closing the FMRS window, either by clocking the X or the toolbar icon, doesn't allow you to open it again. The toolbar icon will change from red to green but the window no longer shows up. Running 32-bit 0.24.2, latest everything

I'm having this same problem. :P

Share this post


Link to post
Share on other sites
I'm having this same problem. :P

My answer on Gaiiden's post:

Are you landed/ on the launchpad or during flight?

If you close the window during flight the plugin deactivates.

You can reset it when you are landed or again on the launchpad.

Share this post


Link to post
Share on other sites
My answer on Gaiiden's post:

Thanks. I noticed that after playing with it for a while. Great mod! :)

Share this post


Link to post
Share on other sites

I just wanted to let you know, I have not forgotten about ya. Sry, my computer had problems and I had to replace parts and upgrade a bit. I am still having the problem but, now, im not sure its just your mod or what. I have a lot going on... so getting back to where I am ready to work on this with everything else is just going to take me some time. So far, what I can tell you for sure is it seems to be a conflict between the toolbar buttons for VesselView, Navball, and ScanSat. JPI might have something to do with it too... So I am having to go threw and double check ALL these freakn configs. I guess my point is this may just be my problem because of MY config settings so, whenever I can get threw all these files Ill let you know.... even if everything works lol

Share this post


Link to post
Share on other sites

How does this mod play with Real Solar System? (specifically, the 6.4x Kerbin config) Are there any known issues? Obviously, this is where reusable stages would be the most valuable when playing in Career Mode (as a lot more rocket has to be staged off to reach orbit with a decent payload...)

Regards,

Northstar

Share this post


Link to post
Share on other sites

Epic!

Opens up a whole world of possibilities for spaceplanes - now you do not even need to have to design in the capability to circularize.

Share this post


Link to post
Share on other sites

I seem to have uncovered a major bug in the latest version.

When loading up craft that decoupled while the main engines were offline, the main ship will stay loaded instead of disappearing or flying off. As a result of this, if it had any Kerbals on board, and undergoes re-entry, the mod thinks you killed Kerbals that are actually alive...

I have it documented in this video I uploaded to YouTube as part of my KSP 0.24.2 RSS 6.4x Career Mode Let's Play series:

You can find the relevant footage at 38:57 in the video. Bob Kerman was actually quite alive and well, and in orbit in a ship, at the time that FMRS penalized me for supposedly killing him... (and since I am now about to kill him much, much later- through the aftermath of a one way Mun landing with TAC Life Support, I will soon be penalized for killing Bob a second time..)

Regards,

Northstar

Edited by Northstar1989

Share this post


Link to post
Share on other sites

Another bug to report, unfortunately:

XiJ1lML.jpg

I've had difficulty with a lower stage being considered the "Main Vessel" (rather than the actual payload- the silvery tank on the vessel under thrust in this screenshot) in a number of my vessels. This seems to happen when the root part was a fuel tank, rather than a command pod or probe core.

This bug has prevented me from launching a (mostly empty) fuel depot to orbit simple because there was no way I could figure out to get the fuel depot in circular orbit into the main save... (when the upper stage detached from the payload, the upper stage was considered the probe- so I couldn't simply land the upper stage on Kerbin and hope that would somehow allow me to keep the fuel depot in orbit...)

If it's of any relevance, I attached the upper+lower stages as a single subassembly to the payload (I had it saved as a well-tested reusable launch platform), but the payload was built first before attaching them in the VAB.

Regards,

Northstar

Edited by Northstar1989

Share this post


Link to post
Share on other sites

Another major bug to report- often, when switching back to the main vessel (either manually, or automatically after recovering a dropped stage) it will be endowed with a random rotation (not so serious for a spacecraft most of the time, but likely fatal for a plane). On top of that, the game occasionally doesn't remember the joint positions of the main vessel- leading to the vessel imploding/ partially self-destructing when switched to. This seems to occur more often after a large number of dropped stages have been recovered in a single launch (4 in my save where this kept happening- 3 radial SRB's and a lower stage.)

Regards,

Northstar

Share this post


Link to post
Share on other sites

Update v0.2.01 released

change log:

compiled with 0.25 x64

stock toolbar support added

"Jump back to Separation" button is now dependent to the settings in the debug toolbar (Quicksave & Quickload)

all non staged vessels are all listed as separtated (no more undocked listings)

recovery message now lists parts and resources

after separtion the main vessel can be changed for 10 sec ("Focus Next Vessel", "Focus Prev Vessel")

bug fix: kerbal in main vessel killed, while flying separated stage, leads to rep loss in main save

bug fix: closing the plugin using the toolbar kicks you not to the main save

bug fix: reading empty save file entrys = nullreference exception

If you encounter any bugs:

Please check the "write debug messages to log file" option in the settings, recreate the bug and send me the log file.

Thank you!

Edited by SIT89

Share this post


Link to post
Share on other sites

I think I found a bug.

After landing with my mission, I stopped FMRS then goes back to the KSC, but I wasn't able to click any of the buildings neither exiting to the main menu... It's as it avoid me to click on it, as it do in flight to avoid going back to the space center.

Share this post


Link to post
Share on other sites

Thanks for your reports!

The bug with the killed Kerbals has been fixed in v0.2.01.

Another bug to report, unfortunately:

I've had difficulty with a lower stage being considered the "Main Vessel" (rather than the actual payload- the silvery tank on the vessel under thrust in this screenshot) in a number of my vessels. This seems to happen when the root part was a fuel tank, rather than a command pod or probe core.

This bug has prevented me from launching a (mostly empty) fuel depot to orbit simple because there was no way I could figure out to get the fuel depot in circular orbit into the main save... (when the upper stage detached from the payload, the upper stage was considered the probe- so I couldn't simply land the upper stage on Kerbin and hope that would somehow allow me to keep the fuel depot in orbit...)

If it's of any relevance, I attached the upper+lower stages as a single subassembly to the payload (I had it saved as a well-tested reusable launch platform), but the payload was built first before attaching them in the VAB.

I have added a function, which allows you to change the main vessel, within 10 sec after separation.

Just switch to the vessel which should be the main vessel.

Another major bug to report- often, when switching back to the main vessel (either manually, or automatically after recovering a dropped stage) it will be endowed with a random rotation (not so serious for a spacecraft most of the time, but likely fatal for a plane). On top of that, the game occasionally doesn't remember the joint positions of the main vessel- leading to the vessel imploding/ partially self-destructing when switched to. This seems to occur more often after a large number of dropped stages have been recovered in a single launch (4 in my save where this kept happening- 3 radial SRB's and a lower stage.)

I am afraid i can't do anything against that.

The plugin doesn't effect the physics of the game.

It uses the quicksave and quickload function of the game to switch between the stages.

I think I found a bug.

After landing with my mission, I stopped FMRS then goes back to the KSC, but I wasn't able to click any of the buildings neither exiting to the main menu... It's as it avoid me to click on it, as it do in flight to avoid going back to the space center.

Please check the "write debug messages to log file" option in the settings, then try to recreate the bug and send me the log file.

This makes it a lot easier for me to understand what is going wrong!

Thank you!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.