SIT89

[1.1.0] Flight Manager for Reusable Stages (FMRS x1.1.0 [Experimental])

Recommended Posts

Same issue here, KSP OS X v0.90 and FMRS v0.3.01. Successfully do a mission, carry out the contract and get the in-flight message to say the contract was completed. Then when you get back to the space centre, the contract is still in the contracty-buildingy-thingy and it's as if you haven't flown the mission.
Transmitting science during flying a dropped vessel won't return you all science points.

Contracts can´t be completed while controlling a dropped vessel.

From the OP (original post). A tad unfortunate, but later there may be a fix. It could possibly be to how you *may* be able to exploit the game if implemented.

Share this post


Link to post
Share on other sites

Question regarding this mod:

How are crashes or unexpected behaviors handled with this system?

What I mean is, what happens if I crash when I'm recovering my primary stage? Is the system capable of picking up where it left off, or does it fall back to safe state?

Share this post


Link to post
Share on other sites

To those experiencing the issue of loosing mission progress when recovering a craft: I found a workaround - instead of clicking the recover button on the ground, go to the space center and recover from the tracking center (or the main screen if you're near the KSC).

Share this post


Link to post
Share on other sites
From the OP (original post). A tad unfortunate, but later there may be a fix. It could possibly be to how you *may* be able to exploit the game if implemented.

This isn't what he's saying, I have this bug too. Looking at the logs, it seems that whenever you recover a craft, doesn't matter if you actually used multiple crafts, it seems to be moving the time back to launch before cashing in stuff. At least it's saying that it's recovered from the launchpad.

I have a feeling it's StageRecovery and this mod fighting over removal rights that's the cause, but I haven't tested it yet.

Edited by Crimor

Share this post


Link to post
Share on other sites
This isn't what he's saying, I have this bug too. Looking at the logs, it seems that whenever you recover a craft, doesn't matter if you actually used multiple crafts, it seems to be moving the time back to launch before cashing in stuff. At least it's saying that it's recovered from the launchpad.

I have a feeling it's StageRecovery and this mod fighting over removal rights that's the cause, but I haven't tested it yet.

I accepted a "Test solid fuel booster while landed at Kerbin" mission. Regardless of what I tried, if FMRS was active, it always auto-reverted when I left the vessel (recover, return to space center, even following an explosion that killed Jeb was undone). Unless StageRecovery has some serious problems with leaving bits of itself behind, I can confirm this isn't a FMRS/SR conflict. I had StageRecovery earlier, but I deleted it and the save I'm using now never had it.

Share this post


Link to post
Share on other sites
I accepted a "Test solid fuel booster while landed at Kerbin" mission. Regardless of what I tried, if FMRS was active, it always auto-reverted when I left the vessel (recover, return to space center, even following an explosion that killed Jeb was undone). Unless StageRecovery has some serious problems with leaving bits of itself behind, I can confirm this isn't a FMRS/SR conflict. I had StageRecovery earlier, but I deleted it and the save I'm using now never had it.

Just to confirm, you're not also using Kerbal Construction Time, are you? If you are, then clicking on the launchpad/runway to start a flight creates a simulation, which would result in that sort of behavior.

For everyone who is reporting bugs, if you include your output_log.txt file (per the How to Get Support thread) then SIT98 will be much more likely to be able to help you. Us lurkers could even take a look and solve your problems even if the author of a mod is AWOL.

Share this post


Link to post
Share on other sites
To those experiencing the issue of loosing mission progress when recovering a craft: I found a workaround - instead of clicking the recover button on the ground, go to the space center and recover from the tracking center (or the main screen if you're near the KSC).

Good to know.

This isn't what he's saying, I have this bug too. Looking at the logs, it seems that whenever you recover a craft, doesn't matter if you actually used multiple crafts, it seems to be moving the time back to launch before cashing in stuff. At least it's saying that it's recovered from the launchpad.

This. The error happens even with SSTO's. i.e. I send up the one vessel, don't recover any parts because there is no staging, perform the contract, land, and recover the entire vessel, and the contract still doesn't get done, despite getting the message in-flight saying that the contract was done properly.

- - - Updated - - -

For everyone who is reporting bugs, if you include your output_log.txt file (per the How to Get Support thread) then SIT98 will be much more likely to be able to help you. Us lurkers could even take a look and solve your problems even if the author of a mod is AWOL.

A log spanning the acceptance of a contract, construction of the vessel, launch, etc. and recovery, would make for a pretty big log file. Did you want all of it?

(I'm no longer using FMRS anyway... so someone else will have to provide their logs)

Share this post


Link to post
Share on other sites

A log spanning the acceptance of a contract, construction of the vessel, launch, etc. and recovery, would make for a pretty big log file. Did you want all of it?

(I'm no longer using FMRS anyway... so someone else will have to provide their logs)

Any log is infinitely times more helpful than no log. I have personally looked at log files that were in excess of 50 megabytes. Something as short as loading the game, accepting a contract, performing a flight, and recovery would actually be fairly short and can be done in a minimum of about 6 scene changes. The most important part, if you can't include a full log, is the scene where the error happens. If you can easily recreate the problem with a "slimmed down" version of a play session, then that does make it easier/clearer.

Now, I can't speak for every mod author as to whether they'll accept large log files. I might have an easier time looking at them because I've got a program that breaks them down by scene and displays the number of errors in each. But any file + a descriptive description of what you did and what the error is can make bug fixing go from taking days (mostly trying to recreate the issue) to taking 5 minutes (fixing the one line of code that is causing the issue).

The issue as described sounds like an NRE during saving of the persistence, which will have a definite entry in the log file but is only speculation by me as to the cause. I haven't used FMRS before, nor do I know how it works internally, so I don't know if that's even a possible bug for it. I don't imagine the fix is particularly difficult if it is that. Kerbanomics also has a bug that will cause similar issues.

Share this post


Link to post
Share on other sites

I just ran in to the bug with career/mission progress not saving. I was doing one of those 'fly to Jeb's passage and take a crew report' missions around KSC, in a rocket powered plane. Only staging present (and activated) was parachutes (so 2 stages total, engine and chutes). I had two such missions running that required visiting 3 sites each. I'd partially completed both missions in this one flight and had landed with chutes. The mission-sub-items were ticked, with appropriate messages saying I'd achieved them. However, after hitting recover (top of screen, not space centre) once I landed, despite the messages still being there I had no recorded progress against the items in the mission-control, and no reward for any of the achievements (should have been 3 lots of about 9000cr). FMRS was armed and active, but there were no stages to trigger it. I have quite a few mods running, including KCT and StageRecovery, but I've only noticed this career issue since installing FMRS. KSP .90x32, log file below (I think it's been running since I accepted the missions):

https://www.dropbox.com/s/jlln3qhuit83lkr/output_log.zip?dl=0

Share this post


Link to post
Share on other sites
I just ran in to the bug with career/mission progress not saving. I was doing one of those 'fly to Jeb's passage and take a crew report' missions around KSC, in a rocket powered plane. Only staging present (and activated) was parachutes (so 2 stages total, engine and chutes). I had two such missions running that required visiting 3 sites each. I'd partially completed both missions in this one flight and had landed with chutes. The mission-sub-items were ticked, with appropriate messages saying I'd achieved them. However, after hitting recover (top of screen, not space centre) once I landed, despite the messages still being there I had no recorded progress against the items in the mission-control, and no reward for any of the achievements (should have been 3 lots of about 9000cr). FMRS was armed and active, but there were no stages to trigger it. I have quite a few mods running, including KCT and StageRecovery, but I've only noticed this career issue since installing FMRS. KSP .90x32, log file below (I think it's been running since I accepted the missions):

https://www.dropbox.com/s/jlln3qhuit83lkr/output_log.zip?dl=0

I and many other are experiencing this bug too. You can get around it by actually recovering from the space center - click the space center button at the top of the screen (the one in the pause menu tends to cause inconsistent results in my experience), then go to the tracking center and recover the vessel and no progress will be lost. For good measure I also quicksave before each recovery too but this strategy hasn't failed me yet.

Share this post


Link to post
Share on other sites

Seeing blowfish posting here, I think it's worth a mention that in order for Kerbal Konstructs to make recovery possible from custom bases, it temporarily replaces the KSC instance as the active space centre at the time you recover in the flight scene and then puts the KSC back as the active space centre after the recovery. I'm just wondering if Kerbal Konstructs is a common mod in use amongst those hitting this particular bug in FMRS.

Share this post


Link to post
Share on other sites
Seeing blowfish posting here, I think it's worth a mention that in order for Kerbal Konstructs to make recovery possible from custom bases, it temporarily replaces the KSC instance as the active space centre at the time you recover in the flight scene and then puts the KSC back as the active space centre after the recovery. I'm just wondering if Kerbal Konstructs is a common mod in use amongst those hitting this particular bug in FMRS.

Nope, I had it and not using anything that should mess with KSC.

Share this post


Link to post
Share on other sites
I just ran in to the bug with career/mission progress not saving. I was doing one of those 'fly to Jeb's passage and take a crew report' missions around KSC, in a rocket powered plane. Only staging present (and activated) was parachutes (so 2 stages total, engine and chutes). I had two such missions running that required visiting 3 sites each. I'd partially completed both missions in this one flight and had landed with chutes. The mission-sub-items were ticked, with appropriate messages saying I'd achieved them. However, after hitting recover (top of screen, not space centre) once I landed, despite the messages still being there I had no recorded progress against the items in the mission-control, and no reward for any of the achievements (should have been 3 lots of about 9000cr). FMRS was armed and active, but there were no stages to trigger it. I have quite a few mods running, including KCT and StageRecovery, but I've only noticed this career issue since installing FMRS. KSP .90x32, log file below (I think it's been running since I accepted the missions):

I tried to take a quick look at the log to see if anything stuck out to me, but I don't know FMRS' typical output. Assuming the last change from Flight to SpaceCenter you did was the recovery with issues, KCT is reporting that all the parts were recovered and said it saved to persistence.

Some other things worry me though. You have, and I kid you not, 5 different versions of ModuleManager installed ranging from 2.5.0 to 2.5.8. Additionally, something is seriously up with your copy of PreciseNode because in all of your flights you have minimum 1447 NullReferenceErrors being repeated. That's far below the typical ones I saw which were between 8000 and 36126(!!). That's for one flight scene. I'd be very surprised if that didn't impact performance. Unfortunately I couldn't tell what version of PreciseNode you have.

I wish I could be of more help :/

Share this post


Link to post
Share on other sites
I and many other are experiencing this bug too. You can get around it by actually recovering from the space center - click the space center button at the top of the screen (the one in the pause menu tends to cause inconsistent results in my experience), then go to the tracking center and recover the vessel and no progress will be lost. For good measure I also quicksave before each recovery too but this strategy hasn't failed me yet.

Sometimes recovery from the space centre works, sometimes not.

Here's another one. This time I was testing some equipment on the launch pad (FMRS triggered when I tested an escape tower, but that's all). I recovered from the space centre, but no career progress was recorded.

https://www.dropbox.com/s/w3z3kmrzctex8bo/output_log2.zip?dl=0

Share this post


Link to post
Share on other sites

I'm hitting a wall here every time I try and do a lunch from a plane it keeps registering the solid rocket booster as the main mission part.

How can I fix this or will I not be able to use fairing and attach the probe node to the ship I know that will fix it but not being able to use fairings with FAR and deadly reentry is a problem in an of its self.

And is kind of unrealistic...

Isn't RMRS suppost to be limited to controllable parts to stop this kind of thing from happening, or is that the Stage Recovery mod hummm.

In8Srfc.jpg

Y8yCci3.jpg

also having the ejection force pushing it fowards helps counteract the drag which would make it smash into the back of the plane. further more it just makes structural sense to link the biggest most solid part of the rocket to the plane so if possible fix pleas.

Edited by etheoma

Share this post


Link to post
Share on other sites

yup, this seems to be very buggy in career, for example, launched a craft, returned to the space centre, and there was the craft on the launchpad. (before that, during the testing phase, if i lqaunched than reverted to the VAB, it would create a duplicate of the craft on the launchpad for free, meaning i now have several thousand more funds before i realized that i was getting funds from it. (it was a cheap craft, but it was unreliable to say the least...)

Share this post


Link to post
Share on other sites

Update v0.3.02 released

change log:

bug fix: Recovering main vessel leads into mission progress loss

If you encounter any bugs:

Please check the "write debug messages to log file" option in the settings, recreate the bug and send me the log file.

Thank you!

- - - Updated - - -

I'm hitting a wall here every time I try and do a lunch from a plane it keeps registering the solid rocket booster as the main mission part.

How can I fix this or will I not be able to use fairing and attach the probe node to the ship I know that will fix it but not being able to use fairings with FAR and deadly reentry is a problem in an of its self.

The craft which you want to put into orbit has to be your main vessel.

You can also switch the main vessel til 10s after separation. Just use the keys "Focus Next Vessel" and "Focus Prev Vessel".

Share this post


Link to post
Share on other sites
Update v0.3.02 released

change log:

bug fix: Recovering main vessel leads into mission progress loss

Can confirm this issue is now fixed on my install.

Thanks! :)

Share this post


Link to post
Share on other sites

I had an issue similar to toric5 that seems to reproduce pretty well:

1. Launch craft, separate stages as normal

2. Dock to another craft once in orbit

3. Return to stages, land normally

4. Click 'Return to Main Mission' after landing last stage

At this point I end up on the launch pad with another version of my pre-craft launch. The docked craft doesn't exist and what I docked to doesn't have it. I can recover everything for a profit, which isn't right :D

I went through this many times and eventually figured out that if I dealt with the stages, then docked back on the main mission, everything would be fine.

Share this post


Link to post
Share on other sites
....

At this point I end up on the launch pad with another version of my pre-craft launch. The docked craft doesn't exist and what I docked to doesn't have it. I can recover everything for a profit, which isn't right :D

Had this same issue last night. It appears that docking the payload before returning the stages is causing issues.

Share this post


Link to post
Share on other sites
Update v0.3.02 released

change log:

bug fix: Recovering main vessel leads into mission progress loss

If you encounter any bugs:

Please check the "write debug messages to log file" option in the settings, recreate the bug and send me the log file.

Thank you!

- - - Updated - - -

The craft which you want to put into orbit has to be your main vessel.

You can also switch the main vessel til 10s after separation. Just use the keys "Focus Next Vessel" and "Focus Prev Vessel".

Ah that wasn't the problem I was having anyway it seems to work now when I change the root part so w.e. as long as it works I don't particularly care.

Thanks for trying to help anyway. And the update you did fixed it because I tired changing the root part before so you helped anyway.

Edited by etheoma

Share this post


Link to post
Share on other sites

I've a weird problem which might be connected to KAC or I'm unable to use the plugin properly. This are the order of actions I did:

  1. I started a craft A with one stage in orbit
  2. I started a second craft B with one reusable stage and a stage in orbit
  3. I land B's stage and switch back to the stage in orbit using FMRS (back to main mission)
  4. I switch to craft A stage using KAC to do some stuff
  5. I switch to the Space Center
  6. And then the problem happens: FMRS puts me at the between step 3 and 4 and I'm in control of B's craft in orbit. I also get a message that I should've used the button on FMRS.

Now why did that happen? Because I switched craft using KAC or because FMRS was enabled when I executed step 4? It also seemed that it considered B's craft as the main mission for the craft A stage in orbit. Not that it's a problem (so I at least didn't lost the step 2 and 3) but just strange.

Share this post


Link to post
Share on other sites

Found an issue with mod compatibility. If using TimeWarpRotation Fix, it breaks this mod completely unless manually disabling the artificial gravity window in that mod's config. If you use the newer version of that "PersistentRotation", the in game toolbar allows you to toggle the "artificial gravity" window that it comes with. The issue lies in the fact that both mods share the same window, so if the artificial gravity window is open it takes the place of the FMRS window (it always trumps it). This window is semi-integral to the other mod, but the newer version allows for both mods to co-exist to some degree, but I'm not sure why they would both share a window. I don't know how to enable the debug save to log option, so if someone helps me with this I'll edit this with a link to a log file (although, I checked the in-game debug menu and watched as I toggled the artificial gravity window and it didn't generate a log for that action).

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.