SIT89

[1.1.0] Flight Manager for Reusable Stages (FMRS x1.1.0 [Experimental])

Recommended Posts

This mod broke my game.

Specifically:

1)  When used with MechJeb, and letting MJ fire the engines at maneuver nodes, the vessel would drift off the node marker when down to the last 0.2 - 0.6 m/s.  The engine would continuously burn non-stop.  Auto-rendezvous was impossible.

2)  KSP is notorious for CTD when modded; I can accept that.  However the rate of CTDs increased significantly when this mod was installed.

Upon removing the mod, all the above went away.  I liked the features that this mod provides, but not when it breaks the game.  Perhaps, YMMV, but as for me...

Edited by Apollo13

Share this post


Link to post
Share on other sites

Hi, I can't seem to get this mod to work properly. The mod works fine for the very first flight for each save, but then it simply stops doing anything. Every flight adds a new button to the toolbar, but none of these buttons actually open the widow. When pressing the buttons i do occasionally get a "No Target" on my screen.

Share this post


Link to post
Share on other sites

Bug report: I had a spacecraft (let's call it A) in kerbin orbit before I installed FMRS. I then launched spacecraft B, which had a recoverable booster. Once B was in orbit, I went back, landed the booster, and returned to B. I then flew B to the Mun, landed, and came back to Munar orbit. I then landed A and recovered it. When I recovered it, I found myself back with B, in orbit, before the Mun mission.

Share this post


Link to post
Share on other sites

Hi Sit89,

cheers to you! definitely one of the most valuable mods for KSP. Unbelievable, this has been your first mod for KSP. Exactly what I needed to throw manned pods or unmanned probes off a plane...and of course also for many other purposes. Works perfect, thnx! 

Share this post


Link to post
Share on other sites

hi i dont think this mod is working for me. i have a spaceplane, with a probe mounted on a radial seperator , and the root part set too be the probe. when i decouple, the FMRS gui immediatly closes out, for no reason, and i have to re-enable it to get the gui. also, even though the root is the probe, the focused vessel still seems to be the spaceplane, even after seperation. any help?

Share this post


Link to post
Share on other sites

the auto cut off didnt work for me. i separated and the first stage smashed into my second stage, sending it tumbling, and continued flying til it ran out of fuel. (i have the auto cut option in the settings checked)

Share this post


Link to post
Share on other sites

Hey all,

I downloaded this mod yesterday and everything was working fine until I launched a satellite and attempted first stage recovery.  As soon as I preformed my boostback, the game became incredibly laggy and the landing failed for some reason that I cannot explain.  I tried to jump back to my main vessel, but the mod would not let me.  Now, this is affecting all my flights.  Is there a way to fix this?

Thanks

Share this post


Link to post
Share on other sites

To add to the issue, I am finding similarities in all my flights.  Before, when I would revert to my first stage, the second stage would disappear from the game because I continued with it into orbit.  Now, the second stage does not disappear when I revert to my first stage. 

Share this post


Link to post
Share on other sites

This mod doesn't seem to work very well with the KerbalConstructionTime mod's simulation mode, not sure if that can be fixed or not but thought I would mention it.

Thanks for an awesome mod, really appreciate the work :)

EDIT: Upon playing further I've realized the simulations do usually work, I'll have to try and see if I can reproduce the problem where the simulation broke out into the real game while using FMRS. Other than that I'd really like if possible to see stages to be persistent even while jumping between FMRS separation events. For example if I land each side of a 3 core rocket (think spacex falcon heavy) and say I land the first one right on the pad, well then logically I shouldn't be able to land the other one on the pad, but I can.. and after the main mission is completed I'm not even sure what the game would do because then both stages would exist at the same time and possibly in the same space, mostly it would just look cool landing next to the other stage though! Anyway thanks again for the mod, it's super useful as I'm now landing all my lower cores and saving lots of $

Edited by bradleyjh

Share this post


Link to post
Share on other sites

Is it possible to have the states of separated stages saved for the event of a crash? When KSP crashes I start it back up again only to have those boosters completely gone, the landed ones and main mission (in orbit) are fine but I still had another two boosters to land which is around 90k funds lost because KSP crashed.

Switching to the orbiting main mission or the landed booster shows FMRS red/disabled, is there no way to have the state of the separated boosters saved in a more persistent way that can be loaded and relinked with the main mission after the game has closed and reopened even if it's a sudden close (crash) as the saving would happen at the time of separation so shouldn't really need to be done again which means even if the game crashes those states should still be there in the file, not sure why it does load back up.

Hopefully this is something that can be fixed, but hopefully 64-bit support makes crashes a lot less common! This is probably my favourite mod but it's so frustrating to lose boosters due to a crash xD

EDIT: Upon testing I've realised that FMRS states are removed even if you go to the space centre from the main mission and then back, it would be really nice if the states were saved and linked to the main mission until the user decides to close the FMRS window on the main mission, so regardless of if you go to the space centre or even close KSP, the states will remain there until the user closes FMRS for that specific mission/main craft. This would fix the issue with crashing causing the losses too, just a thought! :)

Edited by bradleyjh

Share this post


Link to post
Share on other sites

This mod was brought to my attention in regards to a challenge I posted. Must say, it is such a simple concept to use save-game forks to accomplish this but works brilliantly!  Kudos, @SIT89!

Share this post


Link to post
Share on other sites
On 5/10/2015 at 4:43 PM, Keymaster89 said:

I have a serious issues with this mod... i don't know why but when i launch my last rocket, around at 4500-5000m the plugin turn off, and i can't do anything to turn it back on...

I tried to make it a manned rocket, but the issue keep happen.

i checked the flight report, the rocket is still in one piece, but at 5000m in flight out of the launchpad, no matter what, the plugin turn off and become unresponsive...

The only thing that is different from my previous rockets are the presence of the "twin boars" boosters...

I'm having this same issue, has anyone been able to identify the problem or a workaround?

Edit: I did some troubleshooting and I think I found the problem. Seems to be some kind of UI conflict between this mod and http://forum.kerbalspaceprogram.com/index.php?/topic/107774-105-critical-temperature-gauge/, which I installed recently, that makes the FMRS window vanish after the ship reaches a hot enough temperature. I think FMRS was still running (the button stayed green/white) but without the window I couldn't use any of the mod's functions. Figuring out why they are conflicting is beyond my abilities, but I'm happy enough with FMRS working like it should after I uninstalled the other mod.

Edited by riskyjubles

Share this post


Link to post
Share on other sites

Surprised that there isn't a lot of talk on this page :) FMRS is an awesome mod, hope it gets some more attention! I wonder if it's ever been a Modding Monday candidate?

Share this post


Link to post
Share on other sites

Unless the original author starts maintaining the mod again, it seems unlikely. I'd like it to be updated as well, though.

Share this post


Link to post
Share on other sites
1 hour ago, MinimumSky5 said:

Unless the original author starts maintaining the mod again, it seems unlikely. I'd like it to be updated as well, though.

Did they stop maintaining it? Shoot!

It must have been updated since November, since that's when 1.5 came out. (Edit: Yep, Dec.1.)

Any chance someone else will pick it up? (Edit: I'm willing to help, if @SIT89 or someone can tell me where to start.)

Edited by JacktoseIntolerant

Share this post


Link to post
Share on other sites

SIT89 hasn't officially dropped it, but if a developer stops work for 5 months, its normally a bad sign. That said, they did say that they would be taking a bit of a hiatus, so we may hear from them in the next few days.

Share this post


Link to post
Share on other sites
On 3/26/2016 at 2:01 AM, riskyjubles said:

I'm having this same issue, has anyone been able to identify the problem or a workaround?

Edit: I did some troubleshooting and I think I found the problem. Seems to be some kind of UI conflict between this mod and http://forum.kerbalspaceprogram.com/index.php?/topic/107774-105-critical-temperature-gauge/, which I installed recently, that makes the FMRS window vanish after the ship reaches a hot enough temperature. I think FMRS was still running (the button stayed green/white) but without the window I couldn't use any of the mod's functions. Figuring out why they are conflicting is beyond my abilities, but I'm happy enough with FMRS working like it should after I uninstalled the other mod.

As Sarbian pointed out above, @SIT89 used a certain number to identify the UI window... I ran across the same issue with the Temperature Gauge mod and NavUtilities mod.... They all use the same number, which should be different, or a wildcard, to identify the window...So all three fight for the same "display", and only one can show at a time using the same number. IIRC, this is hard coded into the plugins, so its not something the average user can fix...

I posted about this in both the Temp. Gauge & NavUtilities threads... I think it was also Sarbian who posted a better explanation on the NavUtilities thread...

Edited by Stone Blue

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.