DMagic

[1.10.0] SCANsat [v20.2] -- Real Scanning, Real Science, at Warp Speed! [July 7, 2020]

Recommended Posts

Having an issue with ScanSat offering me the contracts. I recently unlocked the Hi-res scanner in the tech tree so I'd like to scan Kerbin, Mun, and Minmus. But no matter how many contracts I decline the SCANsat contract won't come up to do this. I have the latest ScanSat version v16.0 and latest Contract Configurator v1.11.3. No obvious errors in the CC config screen.

How should I resolve this?

Share this post


Link to post
Share on other sites

Version 16.1 is out; get it on Space Dock.

It is updated for KSP 1.1.2, adds a feature that will allow for Kerbalism support, and fixes an issue that prevented the windows from being opened after exiting the Mission Control building.

Share this post


Link to post
Share on other sites
26 minutes ago, DMagic said:

Version 16.1 is out; get it on Space Dock.

It is updated for KSP 1.1.2, adds a feature that will allow for Kerbalism support, and fixes an issue that prevented the windows from being opened after exiting the Mission Control building.

Thank you. Ckan is ready. o/

Edited by PauloRazen

Share this post


Link to post
Share on other sites

I'm not quite sure where to post it, and this is my second stop.:

There is some weird mumbo jumbo if it comes to coexistence of three mods:
DeepFreeze Contunued
ScanSat
Kerbal Planetary Base Systems

Namely it goes about the KSPedia assets:

 

Quote

KSPediaController: Compiling KSPedia databases
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

KSPediaController: Compiling 4 KSPedia databases
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

The AssetBundle 'file://P:\GRY\SteamLibrary\SteamApps\common\KSP 1.1.2 - testing\GameData\Squad\squadcore.ksp' can't be loaded because another AssetBundle with the same files are already loaded
 
(Filename:  Line: 308)

NullReferenceException: Object reference not set to an instance of an object
  at KSPAssets.Loaders.AssetLoader+<>c__DisplayClass50_0.<LoaderRoutine>b__0 (UnityEngine.AssetBundle b) [0x00000] in <filename unknown>:0

  at System.Linq.Enumerable.First[AssetBundle] (IEnumerable`1 source, System.Func`2 predicate, Fallback fallback) [0x00000] in <filename unknown>:0

  at System.Linq.Enumerable.FirstOrDefault[AssetBundle] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0

  at KSPAssets.Loaders.AssetLoader+<LoaderRoutine>d__50.MoveNext () [0x00000] in <filename unknown>:0
 
(Filename:  Line: -1)

If you combine all three mentioned mods KSPedia borks out without any actual content and that message shows up in logs. The weird thing is that it only happens if all three are present. Is there a chance you could take a closer look if this is just a coincidence on my end, or does something nasty happens with KSPedia assets? Thanks in advance.

Share this post


Link to post
Share on other sites

Most likely covered WAY back in the thread, so I apologize if this has been asked and answered recently. With the MapTrack part long since deprecated, is there a way to get all vessels currently in orbit to show on the small map? Some kind of MM config file or the like? I sorta dislike having only my active mappers and the active ship showing - from a 'realism' point of view, I'd want all my ships to be aware of all other ship's positions, and would think that would be a easy way to handle that situation.

Share this post


Link to post
Share on other sites

Hi @DMagic, I don't know if it was proposed before. There's a certain demand for a feature to hide or blur away the details of planets in the map and tracking station view before they were scanned. It was a game killer for many people that they could view planets in all their detail right from the start. I know, it was a game killer for me when I accidentally pressed 'Tab' in map view and saw Duna with all its features, then tabbed though all the planets to get to my vessel and spoiled everything. Would it be possible to force a simple overlay to hide a planets features and enable the altimetry scanner with ability to erase that overlay.

This would add much to a sense of discovery in the game, especially when combined with something like Research Bodies. What do you think about this?

G6XLtIL.jpg

Edited by Enceos

Share this post


Link to post
Share on other sites
1 hour ago, Enceos said:

Hi @DMagic, I don't know if it was proposed before. There's a certain demand for a feature to hide or blur away the details of planets in the map and tracking station view before they were scanned. It was a game killer for many people that they could view planets in all their detail right from the start. I know, it was a game killer for me when I accidentally pressed 'Tab' in map view and saw Duna with all its features, then tabbed though all the planets to get to my vessel and spoiled everything. Would it be possible to force a simple overlay to hide a planets features and enable the altimetry scanner with ability to erase that overlay.

This would add much to a sense of discovery in the game, especially when combined with something like Research Bodies. What do you think about this?

G6XLtIL.jpg

I second that! Great idea :)

Share this post


Link to post
Share on other sites

@Enceos That's a mock-up? It's easy to envision a system like this, but very tricky to actually implement.

I've seen this idea come up several times, and I spent a lot of time trying to come up with something that would work. It will take someone a lot smarter than me to make something that I would consider worthwhile.

 

The obvious first thing to try is to use the overlay maps like the resource system does. SCANsat uses these extensively for all of its overlays and you can see that they work well. But when applied to actual visible maps there are several problems.

 

The overlays are fully lit:

Unlike the standard map, all sides of the planet are fully lit up; there are no shadows. This obviously doesn't work. There are probably ways of mucking around with the shaders to make the overlay use shadows, but that leads to the next problem.

All of the other overlays, the stock resource map, SCANsat overlays (but not the stock biome maps, I think) use that same layer:

When you apply a texture to the resource overlay map it replaces whatever was there before. So if someone wants to view a resource overlay you would have to intercept that texture, then layer it on top of your fuzzy visible map texture.

The overlay does nothing to hide the normal map:

The normal map for most planets actual gives a lot of detail. Even if you add an opaque low-resolution visible map, the high-resolution normal map makes things look surprisingly similar to the regular map.

 

So the resource overlay has lots of problems, why not just go down to the visible map texture itself?

We can easily get to the Scaled Body renderer and access its properties. From there it's not hard to get both the visible map ("_MainMap") and the normal map ("_BumpMap"). We can just get rid of the normal map, and that makes things look a lot fuzzier.

With the visible map we can generate a low-resolution map that actually matches the regular map (instead of doing something silly, like including dozens of pre-generated map textures) using TextureScale. To do this, though, we first have to go through the somewhat tedious process of making the unreadable texture that we get from the renderer into a readable object. This involves swapping around several textures and can lead to memory problems, which we'll get to later.

In the end we can take the regular planet map and convert it into a low-resolution, fuzzy texture, with no detail from the normal map. It actually looks really good, like what you expect from distant images of other planets. And if you want to go a step further it's easy to convert the fuzzy color map into a black and white map. (I would love to show pictures of all of this; I'm pretty sure I got a lot of them, but they seem to have all been lost in the shuffle of changing drives, deleting unused data, and KSP updates...) There are some cases where the planet doesn't actually have a color map, like Kerbin, just a black and white texture that gets converted into the map we see through the shader. Through lots of fiddling we can get from the black and white map to the regular map, but it all tends to behave very strange.

 

So if all we wanted was a full replacement of the high-resolution map with a fuzzy, low-resolution map, on a single planet, this might work.

But to get to what that mock-up is showing means we would have to combine the high-resolution map with our fuzzy map. This means we have to juggle multiple, possibly very large, textures, and keep using those to update the texture that we actually see. Normal maps are tricky, too. They don't behave as well when re-scaled, and if you introduce sharp transitions (from a blank texture to the high-resolution texture, say along a mountain range) it looks very ugly, like a deep canyon or wall just formed.

 

Now take all of that and figure that you need to apply it to possibly two or three celestial bodies at the same time. You can't be looking at a fuzzy Ike map, while Duna looks perfectly clear in the background. All of this adds up to severe memory and performance issues. Juggling six or so large textures (possibly 2, 4, or 8k, at 8, 32, or 130MB or RAM per texture) can get really nasty. Making those textures readable, and updating them is also a big drag on memory and the CPU. I can imagine a way where making the actual low-resolution map isn't necessary, where you just apply some type of randomizer to the colors on the high-resolution map, but you would still have to keep a readable copy of that map around, and you would still have to deal with the normal map.

 

So replacing the regular map with a low-resolution texture is fairly easy. But doing anything other than an instant-scan type of thing, where the entire planet is revealed as soon as you scan it, is a lot trickier. I certainly wouldn't add a feature like that to SCANsat, and I don't think it's a very interesting mechanism by itself.

Share this post


Link to post
Share on other sites

@DMagic Thanks for perfectly describing the roots of the problem. I was hoping there was an empty layer above the current resource overlay, which we could use. The resource system was developed by @RoverDude, maybe he can help...

The fuzzy map texture and instant reveal upon researching looks like a feature for Research Bodies, definitely not SCANSat.

P.S. I made a pull request for Orbital Science on Github.

Edited by Enceos

Share this post


Link to post
Share on other sites

Well, the instant scan idea would be fine with me; I honestly wouldn't mind it snapping from one to the other.

Share this post


Link to post
Share on other sites

So, I have SCANsat running from the beginning of a new career starting with the release of version 1.1.  I am now running KSP 1.1.2 and most current version of SCANsat. I use ckan to keep me up to date.  I have received exactly two scan missions one was for Kerbin and the other for Minimus both Radar scans.  The minimus contract completed successfully. The Kerbin contract never completed the satellite just disappeared from the game.  I only have partial data of the kerbin radar scan. Probably only 40% of Kerbin.  Here is my issue. I have not seen another scan contract.  I am more than half way through the tech tree.  Am I just screwed because the Kerbin scan did not complete?  I really do not want to start the career over.  Do I just need to show some patience? Should I just do the radar scan of Kerbin anyway even though I don't have a contract?

Share this post


Link to post
Share on other sites

@Tossy64 The hi-res scan contracts will only rarely be generated for the Kerbin system. They are only offered as two or three star contracts, and the three star contracts aren't offered for anything in the Kerbin system.

@Lucky Spacer They should be offered as long as you have less than 70% of a planet scanned. There is also no real progression built in; a scan contract of Kerbin is not required for a scan contract of Duna to be offered.

I'm not sure if duplicate contracts will ever be offered. If the first one failed for some reason, you might not get another. That said, if you have vessels just disappearing, then SCANsat contracts are the least of your problems.

You can check the ScanSatOfficial contract type in the Contract Configurator window to see if it shows some problem. But I'm not aware of any reason why contracts would stop showing up, other than just having too many different types. Maybe this pack needs to have some weighting attached to it.

@Enceos I saw that, I'll add it to the next version. Thanks.

Share this post


Link to post
Share on other sites

Regarding the map obscuring thing.. instead of a resource overlay, could it be implemented as clouds, like many of the graphics packs add?  It doesn't get around the instant removal, but you could require a user-configurable percentage scanned (1%, 50%, 80%, 100%) in order to remove them.  Or maybe just have five sets of static cloud textures and change them when the altimeter transmits. 100% (blocks everything), 75% (lets you see through a little bit), 50%, 25%, 0% (completely clear).

I don't know if you can have multiple cloud layers, or dynamically change them.

Share this post


Link to post
Share on other sites
On 5/3/2016 at 11:58 AM, DMagic said:

I'm not sure if duplicate contracts will ever be offered. If the first one failed for some reason, you might not get another. That said, if you have vessels just disappearing, then SCANsat contracts are the least of your problems.

 

I think the reason the Sat disappeared is a save game reload issue.  Weird thing is that I still have scan data and no Sat.  I have had no other disappearing vehicles.  Thanks for the very prompt reply.  I really like this Mod.

Share this post


Link to post
Share on other sites
On 5/3/2016 at 1:19 AM, Enceos said:

Hi @DMagic, I don't know if it was proposed before. There's a certain demand for a feature to hide or blur away the details of planets in the map and tracking station view before they were scanned. It was a game killer for many people that they could view planets in all their detail right from the start. I know, it was a game killer for me when I accidentally pressed 'Tab' in map view and saw Duna with all its features, then tabbed though all the planets to get to my vessel and spoiled everything. Would it be possible to force a simple overlay to hide a planets features and enable the altimetry scanner with ability to erase that overlay.

This would add much to a sense of discovery in the game, especially when combined with something like Research Bodies. What do you think about this?

G6XLtIL.jpg

FYI Orbital Survey Plus is looking into adding this kind of feature. It seems a lot more doable with the system it uses. I am super excited to play with that kind of mechanic for planet packs.

Share this post


Link to post
Share on other sites

In other news, I found a sweet new color palette to use for Moho:

mPaxqOs.png

Taken from the new Mercury maps from the USGS:

OjqvZIY.png

I need two more color palettes now (they arranged in rows of three and now I have 10), if anyone has any ideas.

Edited by DMagic

Share this post


Link to post
Share on other sites

Hi Scansat modders.

First off, just want to say that I love this mod. It's so useful to have the mapping system for navigation!

Unfortunately I've been having problems with the mod after the latest update 1.1.2.

Maps, parts, and menu buttons are still available, but all of the scanners no longer deploy after right clicking on the part and selecting "Start X Scan". Anything I can do to help troubleshoot?

Share this post


Link to post
Share on other sites
1 hour ago, the Monkeys Uncle said:

Hi Scansat modders.

First off, just want to say that I love this mod. It's so useful to have the mapping system for navigation!

Unfortunately I've been having problems with the mod after the latest update 1.1.2.

Maps, parts, and menu buttons are still available, but all of the scanners no longer deploy after right clicking on the part and selecting "Start X Scan". Anything I can do to help troubleshoot?

Works fine for me :/

Are you timewarping or something?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.