Jump to content

[1.10.1] SCANsat [v20.4] -- Real Scanning, Real Science, at Warp Speed! [September 9, 2020]


Recommended Posts

5 hours ago, Waltert said:

I don't know if this has been covered before. I have tried searching but I couldnt find anything that helped.

Im on ksp 1.8.1 with Scansat 18.14 and MKS 1.3. Amongst MANY others.

Ive done full scans with all 3 scansat parts, but nothing with the btdt scanner. I have the stock surface scanner on my rover below. I have also got a m700 in orbit.

For the resources on the big map and the planet overlay, I cant see the MKS specific resources.  I can see some, I have Ore, Alumina, Mopedantte,blutonium, explodium etc. Which I believe are coming from part of the Wildblue line, and the scansat ones; biome, terrain, are fine.

For the resouce scan settings, I have biome lock on, the other 3 are ticked off (require narrowband, disable stock and instant scan). 

Is there something else I need to do. That Ive missed?

Many thanks

Open the WBI resource settings, change to CRP compatible mode, restart KSP.

Link to post
Share on other sites

Does Scansat limit the number of scan contracts I can actively have?

I upgraded Mission control to unlimited and I maxed out on scan contracts and cant take anymore until one finishes.

I have 8 Scan contracts active, most being "Low versions" of various scans and the ones offered are the "High Versions"

I have no issues accepting other contracts from other agents so its not a Mission Control limit at all.

Link to post
Share on other sites
2 hours ago, syngen said:

I had a look at this.  It was already set to CRP. 

Then change it to something else, and change it back. ;) 

You're seeing the WBI resources, not the CRP resources.

Link to post
Share on other sites
16 hours ago, DStaal said:

Then change it to something else, and change it back. ;) 

You're seeing the WBI resources, not the CRP resources.

So I've tried this this morning, switched to classic, restarted, switched back to CRP restarted, and still no luck. 

Ive realised, this means Im not seeing the resources for interstellar either.

I dont if this helps with the issue. I can still see all the resources when Im in command of the m700 scanner craft. I can see the overlay on the planet.  This is obviously subpar compared to the glorious SCANsat.

Edited by Waltert
Link to post
Share on other sites

I'm having a lot of performance issues using SCANsat 20.1 in KSP 1.8.1 with JNSQ: time warping in the tracking station is noticeably slower when multiple scans are being done to more than one planet/moon at once and the zoom map is phenomenally slow to load, causes the entire game to freeze and/or crash and the BG scatter markers are less clear than they used to be (I distinctly remember them having black outlines before). I think the zoom map is actually causing my entire PC to freeze when it's trying to load as it goes completely unresponsive for several seconds.

There are no errors in the logs so I can't tell what might be causing this. Previous versions of SCANsat (with and without JNSQ) did load the zoom map slowly but they could still load the entire map in the time that I'm seeing the first two stripes appear at the bottom and I could zoom in beyond 20x without the game crashing.

Link to post
Share on other sites
On 7/4/2020 at 5:23 PM, Waltert said:

So I've tried this this morning, switched to classic, restarted, switched back to CRP restarted, and still no luck. 

Ive realised, this means Im not seeing the resources for interstellar either.

I dont if this helps with the issue. I can still see all the resources when Im in command of the m700 scanner craft. I can see the overlay on the planet.  This is obviously subpar compared to the glorious SCANsat.

Is tgis more likely to be a Wild Blue problem than a scansat one? Should I be posting this over on there?

Would deleting the classic resource template files stop it using the wronf resources ir just stop the game altogether?

Link to post
Share on other sites

SCANsat version 20.2 is out; get it on Space Dock.

This version should work in any KSP from 1.8 to 1.10.x.

There was a memory leak related to the visual map textures that has been fixed and you should see less memory usage in general related to visual maps. Some compatibility issues with Kopernicus related to SCANsat visual maps and the scaled space (map view) planet textures have been fixed.

A new feature has been added to the zoom map that lets the map remember the last-used zoom level and apply that whenever the map is opened again, it is found in the top-left corner of the map, the small magnifying glass icon.

Scanning coverage indicators have been added to the big map. These indicate both the total scan coverage percentage for the selected celestial body for each scanner, and the scanning coverage at the mouse position when the mouse is inside the map (let me know if anyone has issues with the text colors on these bars).

Old SCANsat parts should be available in the VAB/SPH in existing saved crafts.

Some other minor issues have been addressed, the PluginData folder for the settings file will be generated if it is missing, and the French translations have been updated (thanks don_vip).

 

New zoom level "remember" toggle in green in the top-left:

bAVC1wH.png

 

New scanning coverage indicators in the big map:

UtkXoNZ.png

The scanner type is indicated on each bar. The grey fill color indicates scanning coverage for that scan type on the selected celestial body. The scan type text color indicates coverage at the mouse position when the mouse is inside the map (the text is white when the mouse is not in the map). You can hover the mouse over the coverage bar to see a tooltip with the scanning cover percentage.

Edited by DMagic
Link to post
Share on other sites
4 hours ago, DMagic said:

SCANsat version 20.2 is out

Thanks very much for continuing the development of SCANsat.

CKAN asks to delete PluginData\Setttings.cfg when I install.  Do you recommend doing so for an existing save?

Link to post
Share on other sites
6 hours ago, Brigadier said:

Thanks very much for continuing the development of SCANsat.

CKAN asks to delete PluginData\Setttings.cfg when I install.  Do you recommend doing so for an existing save?

Definitely not, it's a little annoying that it asks this.

@HebaruSan is there a way to tell CKAN not to generate this warning?

Link to post
Share on other sites
12 hours ago, DMagic said:

A new feature has been added to the zoom map that lets the map remember the last-used zoom level and apply that whenever the map is opened again, it is found in the top-left corner of the map, the small magnifying glass icon.

Awesome. Thanks for adding this!

Link to post
Share on other sites
2 hours ago, DMagic said:

Definitely not, it's a little annoying that it asks this.

@HebaruSan is there a way to tell CKAN not to generate this warning?

Thanks for flagging this use case for me. I've started a code fix on the CKAN side.

If you don't want to wait, you could put a dummy.txt file in PluginData in the ZIP, but obviously that's not ideal.

Link to post
Share on other sites

@SkiRich I think the max is 10 active contracts. But I haven't tested that, I'll have to look into it.

You should be able to adjust it by changing this line in the contract file: https://github.com/S-C-A-N/SCANsat/blob/release/SCANassets/Resources/Contracts/ContractPackScanSatOfficial.cfg#L8

@DStaal @syngen @Waltert I'll have to look into how resources are handled there. It's possible that SCANsat is missing resource definitions if they are being changed at some point after KSP starts up.

@jimmymcgoochie I haven't seen or heard other reports of this type of performance or crashing issue. I did quite a bit of testing with JNSQ in 1.8 for the latest version and didn't have any problems. There is the potential for certain planet packs to have slower map generation performance than others, as that is dependent on the complexity of the terrain that is generated (for instance, the stock Mun has much slower terrain map performance than other stock planets because of how the craters are generated), but that is generally relatively mild, and shouldn't lead to crashing. It's possible that you are having memory issues related to the problems that were fixed in the latest update, try version 20.2 to see if it improves things.

@HebaruSan Thanks for looking into it. I leave out the settings file so that new updates don't override any existing files.

Link to post
Share on other sites

From the OP:

Quote

When the Instant Resource Scan option is toggled off in the settings menu SCANsat resource overlays will only be generated by standard SCANsat scanning.

Has this, or any other, option been removed from the S.C.A.N Settings dialog or am I just not looking in the right place?

Would it be onerous or difficult to implement tooltips in the Settings dialog?  For example, I have no idea what impact changing Mechjeb Target Selection has and the meaning of Load Landing Target.  These options aren't covered in the topic OP.

Link to post
Share on other sites
1 hour ago, DMagic said:

@DStaal @syngen @Waltert I'll have to look into how resources are handled there. It's possible that SCANsat is missing resource definitions if they are being changed at some point after KSP starts up.

Check with @Angel-125 - This type of behavior is a known result of a corrupted WBI/Pathfinder install, and I'm not sure SCANsat is doing anything wrong.

Link to post
Share on other sites
47 minutes ago, DMagic said:

@Brigadier

 Xy4ALv4.png

 

Doh!  It appears I'm just not looking carefully enough :blush:.  Thanks for pointing it out.  Some more questions:

  1. Did the Instant Resource Scan option, referenced in the topic OP, get removed?
  2. The tooltip for Load Landing Target says it works only in a flight scene with a valid MechJeb vessel.  What's a "valid MechJeb vessel"?
  3. The tooltip for Resource Biome Lock says it circumvents the requirement for stock surface scans.  Is this with the option enabled or disabled?
  4. The All Scanning active setting "Toggles all SCANsat scanning".  Just to be clear, does this mean what I think it does and with this option disabled, only the active vessel conducts a scan?
Link to post
Share on other sites
12 minutes ago, Brigadier said:

Doh!  It appears I'm just not looking carefully enough :blush:.  Thanks for pointing it out.  Some more questions:

  1. Did the Instant Resource Scan option, referenced in the topic OP, get removed?
  2. The tooltip for Load Landing Target says it works only in a flight scene with a valid MechJeb vessel.  What's a "valid MechJeb vessel"?
  3. The tooltip for Resource Biome Lock says it circumvents the requirement for stock surface scans.  Is this with the option enabled or disabled?
  4. The All Scanning active setting "Toggles all SCANsat scanning".  Just to be clear, does this mean what I think it does and with this option disabled, only the active vessel conducts a scan?

1. Still there, just like the image indicates, it's only available when stock scanning is not disabled.

2. A vessel with a MechJeb module with the landing guidance function enabled.

3. Resource Biome Lock toggled on means the biomes must be scanned from the surface for full accuracy.

4. All scanning means all scanning, there is no distinction between background vessel scanning and active vessel scanning. All scanning is performed through a single function, disabling this option will turn off that function.

Link to post
Share on other sites
3 hours ago, DMagic said:

@SkiRich I think the max is 10 active contracts. But I haven't tested that, I'll have to look into it.

You should be able to adjust it by changing this line in the contract file: https://github.com/S-C-A-N/SCANsat/blob/release/SCANassets/Resources/Contracts/ContractPackScanSatOfficial.cfg#L8

@DStaal @syngen @Waltert I'll have to look into how resources are handled there. It's possible that SCANsat is missing resource definitions if they are being changed at some point after KSP starts up.

@jimmymcgoochie I haven't seen or heard other reports of this type of performance or crashing issue. I did quite a bit of testing with JNSQ in 1.8 for the latest version and didn't have any problems. There is the potential for certain planet packs to have slower map generation performance than others, as that is dependent on the complexity of the terrain that is generated (for instance, the stock Mun has much slower terrain map performance than other stock planets because of how the craters are generated), but that is generally relatively mild, and shouldn't lead to crashing. It's possible that you are having memory issues related to the problems that were fixed in the latest update, try version 20.2 to see if it improves things.

@HebaruSan Thanks for looking into it. I leave out the settings file so that new updates don't override any existing files.

That cfg was it, thanks.  Upped it to 14, which seems about right for my playstyle.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...