Jump to content

[1.10.1] SCANsat [v20.4] -- Real Scanning, Real Science, at Warp Speed! [September 9, 2020]


DMagic
 Share

Recommended Posts

Just to jump in on what ToxicFrog said.

Remotetech in my opinion is one of the biggest FPS killers.

I am running about 200 mods and it runs "OK" but if I add remotetech then i can just forget it the FPS is terrible.

Its a known problem that remotetech can cause huge fps loss.

I have moved to commnet contstilations and if one day remotetech gets an update and performance improvements you best believe im back to remotetech.

 

So @ToxicFrog remove remotetech and try again I bet its that mate.

Link to comment
Share on other sites

Removing RT was the first thing I tried, no dice. But it gets worse depending on how many satellites I have running Scansat hardware and removing Scansat fixes it.

After more testing, though, it looks like it's a bad interaction between Scansat and Space Dust -- disabling either one returns my FPS to normal. And Space Dust doesn't even work in this install, I only have it because it's a dependency of Far Future. So that gets the axe and I can keep scanning. :)

Link to comment
Share on other sites

3 hours ago, ToxicFrog said:

Scansat orbiter took my framerate from 80-100 to 20, and setting up three reduced it to multiple seconds per frame. It's a shame because I love scansat's maps but it makes the game effectively unplayable.

https://github.com/KSP-RO/RP-0/wiki/Recommended-Extra-Mods - I wonder if you're hitting the issue that makes SCANSat sort of not quite recommended in RP-1:

Quote

SCANsat - The SCANsat "visual mapping" feature added in v20.x consumes an extreme amount of memory when used with RSS (Often in excess of 32 GB). If you are using SCANsat, you should disable visual maps by going to the Gamedata/SCANsat/PluginData/Settings.cfg and setting VisibleMapsActive to false.

I've never tried this to see what it does or if it helps.

Link to comment
Share on other sites

Hi there, 
after years of hiatus I just restarted KSP and this is one of the must to mods for me (or at least it was).
so I downloaded the latest version I found , BUT the parts are not showing up on the tech tree. (I  already unlocked a few statges where parts are supposed to be) 

the toolbar icon is there and it all seems to work well. BUT the parts are missing. 

what am I doing wrong ? 
thank you so much in advance

Link to comment
Share on other sites

@Psykikk Did you install manually or with CKAN? Try starting a sandbox game (with a different name), and see if the parts then show up. In a sandbox game, *all* parts *should* be present right from the beginning.

Also make sure you have only *one* copy of the current ModuleManager.dll file in your GameData folder

If that doesnt work, then read this topic and post your KSP.log:

 

Edited by Stone Blue
Link to comment
Share on other sites

so after I reinstalled with CKAN it "seems" to work. thanks for that. 

BUT

wait a hot minute: did they change the old parts ? 

the RADAR scanner in my parts list looks like a normal radio dish, while the one on the github parts list looks the one I was searching when I came back to KSP.

most parts thathave scansat in their names in my game I do not remember ever seeing. and none is listed on the github parts list
 

Edited by Psykikk
edits..duh
Link to comment
Share on other sites

On 11/25/2022 at 3:13 AM, Psykikk said:

wait a hot minute: did they change the old parts ? 

the RADAR scanner in my parts list looks like a normal radio dish, while the one on the github parts list looks the one I was searching when I came back to KSP.

most parts thathave scansat in their names in my game I do not remember ever seeing. and none is listed on the github parts list

SCANsat v20.0 replaced the old parts with much cooler looking ones by Nertea. That was released back in May 31, 2020.

It looks like the part list in the Github readme was never updated with these.

Link to comment
Share on other sites

20 hours ago, TelluriumCrystal said:

SCANsat v20.0 replaced the old parts with much cooler looking ones by Nertea. That was released back in May 31, 2020.

It looks like the part list in the Github readme was never updated with these.

thanks, I thought / figured as much. I perefered the old style altimeter (that extended) but I guess it is what it is :-) 
 

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...
  • 4 weeks later...
1 hour ago, Vl3d said:

Why don't the Lo (low resolution) maps go to 100% if the HI (high resolution) maps are completed first?

This.  I file this in the same "illogic" category as rescuing a kerb in a location or orbit  he could only have reached while gaining X experience points, but he starts from scratch when joining your team.  I could see a demerit for getting stranded, but demoted to newbie seems a bit severe

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...