DMagic

[1.7.3] SCANsat [v18.13] -- Real Scanning, Real Science, at Warp Speed! [August 21, 2019]

Recommended Posts

Is it supposed to be possible to see resources in the zoom window? I can't seem to do it.

Edit: Never mind. Just found the "Zoom Requires Narrow Band Scanner" setting.

Share this post


Link to post
Share on other sites
Anyone else have any issue with activating scanners causing FAR to constantly update voxels for the vessel? This is on latest dev build of FAR and scansat. I have a heli with the first altimetry scanner. After I active it and even after the animation stops playing FAR continues to update the voxels for the ship which should only happen during an animation. It makes flight pretty much impossible with constant lag from FAR. I dont know what the cause would be other than some call happening when the radar scan is engaged that triggers FARs voxel updates. Even after then retracting and stopping the scan the updates continue to happen every few seconds from FAR. Just wanted to see if anyone else has this issue before I investigate further.

Never got an answer on this.

Share this post


Link to post
Share on other sites
Never got an answer on this.

It might be better to report it in the FAR thread with exact steps to reproduce it, starting from a fresh KSP install.

Share this post


Link to post
Share on other sites
Never got an answer on this.

It's probably a side-affect of the dumb way that SCANsat uses ClampForever instead of Clamp at the end of the animations. This causes the animations to continually play through the final frame of the animation instead of just stopping. It's probably time to fix that issue...

Share this post


Link to post
Share on other sites
What resource scanning settings are you using? Did you actually scan the planet?

It will probably work fine. Unless there is some major problem I won't update this version. I'll hopefully update the dev version in a day or so. After that it shouldn't take long to update to the next major release.

With 1.0.3/1.0.4 my stock Ore scanner no longer has the ScanSAT options, just the stock instant-scan. It looks like the Orbital Science mod resource scanner parts also lost their ScanSAT options for me. The high/low/multi scanners seem to work fine though.

Share this post


Link to post
Share on other sites
It's probably a side-affect of the dumb way that SCANsat uses ClampForever instead of Clamp at the end of the animations. This causes the animations to continually play through the final frame of the animation instead of just stopping. It's probably time to fix that issue...

Glad to hear the issue is known then. That always my biggest worry that I have some mystery crazy issue lol. Looking forward to v13 would you be able to get this issue fixed with that update? Thanks!!

Share this post


Link to post
Share on other sites

Hey DMagic,

I am having the following issue:

http://i.imgur.com/fFakbLC.png

The problem, specifically, is the 2nd grid appearing in the top right.

My system specs and modlist are as follows:

Linux Mint 64bit

KSP v1.0.4 64bit

New gamesave as of today

I use CKAN to install all my mods.

KSP.Log

https://mega.co.nz/#!cF0RBQBS!VG8TwTAGAzWSmBz5wG4qejKcPOP4y9st7uqe1yvVn2I

Output log

https://mega.co.nz/#!QV1HUBbJ!q7lqpAaWcaUwZcgvOyUU8h9N8yhZDjD4hOkYs-Q5YLw

List of my mods:

http://i.imgur.com/clo63be.png

http://i.imgur.com/KuUyve7.png

http://i.imgur.com/ZZOtSBz.png

Steps to reproduce:

-Start a new game

-Try to open the scansat map

Please let me know if you need any more information or if this is the wrong place. Thanks!

Edited by OddFunction

Share this post


Link to post
Share on other sites

Does the grid move with the map? Does it appear by the big map in the flight scene? Does it go away when you turn off the grid overlay?

I don't see any specific errors with SCANsat. There are quite a few FAR errors, along with scattered NRE's from various other sources. But I don't know why anything would cause the grid lines to be drawn twice like that.

Share this post


Link to post
Share on other sites

Does the grid move with the map?

Yes, it follows me everywhere. Only if I have ScanSat's 'button' open though.

Does it appear by the big map in the flight scene?

The grid does not appear in the tracking center view.

The grid does not appear in flight, either on the big map (m key) or off. Seems to only occur when I'm looking at the space center, not in flight.

Does it go away when you turn off the grid overlay?

Yes.

I mostly posted just to see if you knew right away what it could be; don't spend any time on this. I am upgrading to your Dev version soon because it looks so awesome, so this non-gamebreaking grid-glitch will be fine until then.

Thanks for your time!

Edited by OddFunction

Share this post


Link to post
Share on other sites
I mostly posted just to see if you knew right away what it could be; don't spend any time on this. I am upgrading to your Dev version soon because it looks so awesome, so this non-gamebreaking grid-glitch will be fine until then.

Thanks for your time!

I found it. Thanks for pointing this out, I don't use the grid lines much so I guess I somehow never noticed it.

I sort of understand why it was happening, but I have no idea why it only affected the space center map. In any event, the next release will have a fix for it.

Share this post


Link to post
Share on other sites

SCANsat version 14.0 is out; get it on Kerbal Stuff.

The resource scanning system has received a major overhaul. Options are available to replace most of the stock surface scanning mechanisms. The available resource scanning options can be changed in the new resource settings window.

Planetary resource, terrain and biome overlays can now be generated and are controlled by the new overlay window.

There are a number of other changes and bug fixes; see the GitHub documentation and the first post for the complete change log and more details.

A few examples are shown below.

Partially scanned resource overlay (the grey background intensity can be adjusted, along with map quality settings):

0JBSFbB.png

Terrain overlays (tooltips can be turned off):

kXsL20Q.png

Modified zoom map use in place of the stock resource map (the terrain map is slightly lower quality than standard SCANsat maps, but much faster to generate):

xjEDybF.gif

Scanning ground tracks (the overlay doesn't automatically update as this suggests, it would be too slow):

casTBeW.gif

Various planetary overlay examples:

Javascript is disabled. View full album
Edited by DMagic
Details on pictures

Share this post


Link to post
Share on other sites

Hey DMagic: THANK YOU!!!

This update is -amazing-, loving the way it replaces the stock mechanics.

Share this post


Link to post
Share on other sites

I can but only add my voice to the chorus of thanks you have done some astounding work

Share this post


Link to post
Share on other sites

Upgraded to the dev version a few days ago and then this one this morning.

In both versions I can't seem to get Resource scanning working, at least with my current ScanSats that all have the M700 Survey Scanner. I'm not entirely clear on exactly what all the settings do exactly, I'm probably doing something stupid.

Settings are as follows:

Resource Biome Lock - Checked

Instant Resource Scan - Unchecked

Requires Narrow Band Scanner - Unchecked

Disable Stock Scanning - Checked

From the info on the OP might it be the "Resource Biome Lock"?

Does that mean you have to land a suface scanner before the orbital ones will work?

Share this post


Link to post
Share on other sites
In both versions I can't seem to get Resource scanning working, at least with my current ScanSats that all have the M700 Survey Scanner. I'm not entirely clear on exactly what all the settings do exactly, I'm probably doing something stupid.

...

From the info on the OP might it be the "Resource Biome Lock"?

Does that mean you have to land a suface scanner before the orbital ones will work?

What do you mean by not getting resource scanning to work? Do you have Module Manager installed? It is necessary for resource scanning.

For the resource settings see here.

Using the surface scanner works exactly the same is with stock resource scanning; you will get less accurate results for resource abundance until you scan each biome from the surface, or you can turn off the resource biome lock and ignore that aspect of it completely.

Share this post


Link to post
Share on other sites
What do you mean by not getting resource scanning to work? Do you have Module Manager installed? It is necessary for resource scanning.

For the resource settings see here.

Using the surface scanner works exactly the same is with stock resource scanning; you will get less accurate results for resource abundance until you scan each biome from the surface, or you can turn off the resource biome lock and ignore that aspect of it completely.

Ok have done some more testing and it appears to be a quirk of the vessel in question.

The sat in question has an M-700 scanner and is currently in a 200km polar orbit around Ike. Whatever the general ScanSat settings, the "Start Resource Scan" does not appear as an option for the part. The only option displayed is "Deploy / Retract Scanner". As far as I can see there no reason for the option to be missing. A fresh copy of the sat sitting on the launchpad however does not seem to have any issues so potentially it only affects probes I sent on their way prior to updating ScanSat. I have a few more but they are all in transfer orbits over the sun so not in a position to test.

Share this post


Link to post
Share on other sites
Ok have done some more testing and it appears to be a quirk of the vessel in question.

The sat in question has an M-700 scanner and is currently in a 200km polar orbit around Ike. Whatever the general ScanSat settings, the "Start Resource Scan" does not appear as an option for the part. The only option displayed is "Deploy / Retract Scanner". As far as I can see there no reason for the option to be missing. A fresh copy of the sat sitting on the launchpad however does not seem to have any issues so potentially it only affects probes I sent on their way prior to updating ScanSat. I have a few more but they are all in transfer orbits over the sun so not in a position to test.

I'm guessing the existing scanners don't get the new SCANsat resource scanning module added to the part. You might need to relaunch your scanners unless DMagic can fix this in an update.

Or be very good at savefile editing.

Share this post


Link to post
Share on other sites

DMagic, I gotta say, this is just a magnificent update. SCANsat has always been wonderful, a cut above, but you've really outdone yourself here. This is just top notch, and I think everyone agrees.

For one tiny suggestion, could we get a single toolbar button for the overlay? Toolbar options are the SCAN dropdown, small map, and big map, but I can imagine the overlay being something people might want to save a click to access.

Share this post


Link to post
Share on other sites

The Karbonite and MKS ground based scanners still don't work and show as being too high, and yes I did test without SCANsat and they work fine without it. Using version 14.

Edit: I know it's a nighttime shot, but the craft itself isn't the important thing.

Edit2: I decided to play around with the MaxAbundanceAltitude numbers and found that in order for it to work and show with SCANsat, they need to have a value of 2, at minimum. So, um, I'm not sure if this is neccesarily a bug with SCANsat or a bug with MKS/Karbonite.

screenshot9_zpsysg5qqlh.png

Edited by smjjames

Share this post


Link to post
Share on other sites
DMagic, I gotta say, this is just a magnificent update. SCANsat has always been wonderful, a cut above, but you've really outdone yourself here. This is just top notch, and I think everyone agrees.

For one tiny suggestion, could we get a single toolbar button for the overlay? Toolbar options are the SCAN dropdown, small map, and big map, but I can imagine the overlay being something people might want to save a click to access.

Yeah, I'll probably get around to adding another toolbar button for that.

The Karbonite and MKS ground based scanners still don't work and show as being too high, and yes I did test without SCANsat and they work fine without it. Using version 14.

For some reason I thought that I had fixed that, but apparently not. I guess the solution here is to stop relying on those garbage right-click menus (I really, really hope that making PS4 version forces them to come up with something better than this), use the SCANsat instruments display instead.

Another thing, I'm not entirely sure what to do about Karborundum. It's not a SCANsat resource, and there is no way to display or scan for it using SCANsat. I haven't tried using it so I don't know how it works with the stock scanning mechanism, but my understanding was that you aren't supposed to be able to scan for it from orbit, you have to be very close. Does it show up on stock resource overlays at all, or is it just scanned for using a narrow-band-type scanner?

Share this post


Link to post
Share on other sites
Yeah, I'll probably get around to adding another toolbar button for that.

For some reason I thought that I had fixed that, but apparently not. I guess the solution here is to stop relying on those garbage right-click menus (I really, really hope that making PS4 version forces them to come up with something better than this), use the SCANsat instruments display instead.

Another thing, I'm not entirely sure what to do about Karborundum. It's not a SCANsat resource, and there is no way to display or scan for it using SCANsat. I haven't tried using it so I don't know how it works with the stock scanning mechanism, but my understanding was that you aren't supposed to be able to scan for it from orbit, you have to be very close. Does it show up on stock resource overlays at all, or is it just scanned for using a narrow-band-type scanner?

You'd have to ask RoverDude about the karbonundrum as I don't use Karbonite+, the Karbonite scanner and analyzer simply have the capability to cover both.

Share this post


Link to post
Share on other sites

DMagic you have excelled yourself I am so loving the options you have put into scansat with pallete selections and the way that it loads the map its just totally awesome its a must have mod congratulations on a really polished mod

Share this post


Link to post
Share on other sites

Does the orientation of the antenna have any influence?

I.e. whether it is actually pointing at the planet, not pointing at the planet at all or at a certain angle with regards to the flight direction?

Or is the scan region simply determined by drawing a line between the ship and the center of the planet?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.