DMagic

[1.7.3] SCANsat [v18.13] -- Real Scanning, Real Science, at Warp Speed! [August 21, 2019]

Recommended Posts

That's because Eve lacks both biomes (aside from water/surface) and anomalies.

Unless he changed it and I didn't notice, they'll still scan, it'll just come up as static. Which isn't entirely useless, as you can still get science for it.

There's a mod that adds biomes to planets that don't have them though.

Share this post


Link to post
Share on other sites

cool thanks yep i got the static

was unsure if it was like that due to lack of biomes or maybe lack of correct installation on my part so i thought id ask

luckily i was able to get a bit of science out of that mission so it was not a wast of time

thanks again to all for the patients and understanding and big up again to the new caretaker of this awesome mod

Share this post


Link to post
Share on other sites

Don't suppose anyone else has an issue in pre-existing savegames where upgrading from the previous version (b5) causes the R & D Center to close? I'm trying to fix my savegame so I can actually use science I'd get from my upcoming Duna missions.

Share this post


Link to post
Share on other sites
Don't suppose anyone else has an issue in pre-existing savegames where upgrading from the previous version (b5) causes the R & D Center to close? I'm trying to fix my savegame so I can actually use science I'd get from my upcoming Duna missions.

This is a general issue with the upgrade to 0.23.5, I think. I don't think it's related to SCANsat in any way. I don't know if there is actually a fix, though.

- - - Updated - - -

cool thanks yep i got the static

was unsure if it was like that due to lack of biomes or maybe lack of correct installation on my part so i thought id ask

luckily i was able to get a bit of science out of that mission so it was not a wast of time

thanks again to all for the patients and understanding and big up again to the new caretaker of this awesome mod

edit: I'm a dirty, dirty liar who doesn't know what he's talking about! SHAME!

Edited by technogeeky

Share this post


Link to post
Share on other sites
This is a general issue with the upgrade to 0.23.5, I think. I don't think it's related to SCANsat in any way. I don't know if there is actually a fix, though.

Funny, I've been running 24.5 for awhile now and this save hasn't had that issue until I accidentally overwrote the b5 version of SCANSat with the v6. I've tried removing SCANSat entirely, and all related bits from the persistence file, reinstalling v6, or b5, all to no avail. Suppose I'll just have to wipe the save and start over again...*sighs*

Share this post


Link to post
Share on other sites
The static happens because you are going to (or already have) run out of electric charge. Deploy your solar panels.

An empty biome map also generates static.

Share this post


Link to post
Share on other sites
Funny, I've been running 24.5 for awhile now and this save hasn't had that issue until I accidentally overwrote the b5 version of SCANSat with the v6. I've tried removing SCANSat entirely, and all related bits from the persistence file, reinstalling v6, or b5, all to no avail. Suppose I'll just have to wipe the save and start over again...*sighs*

Don't delete anything. There are threads on how to convert a sandbox save to a career save (I think). Check them to see if there is something in your persistent file that can be changed to fix it.

I'm not sure how SCANsat could cause this problem by itself though.

Share this post


Link to post
Share on other sites
An empty biome map also generates static.

I feel like I should be embarrassed to have to be told this about my own mod, but damn it -- I don't want to *really* cheat and see planetary bodies I haven't reached myself in game yet. :(

And since I've only gotten to Kerbin and its moons, I wouldn't know.

Share this post


Link to post
Share on other sites

I would like to say thank you for such an awesome mod! I have scanned about 80% of kerbin and 100% of the mun (now to go and actually GET that science!) And i am fully enjoying it.

Share this post


Link to post
Share on other sites
Don't delete anything. There are threads on how to convert a sandbox save to a career save (I think). Check them to see if there is something in your persistent file that can be changed to fix it.

I'm not sure how SCANsat could cause this problem by itself though.

It was a career save from .23, and I took the required steps to ensure it remained playable after Steam decided to update to .23.5 without my consent. It ran fine, still a Career save, until now. Given that the only thing that changed was overwriting the older SCANSat with the newer one, it is a logical place to start looking.

Share this post


Link to post
Share on other sites
..after Steam decided to update to .23.5 without my consent..

You gave it your consent when you didn't change the 'always keep this game up to date' option in the properties tab. It seems a logical thing to do if you don't want to keep it updated.

Share this post


Link to post
Share on other sites
You gave it your consent when you didn't change the 'always keep this game up to date' option in the properties tab. It seems a logical thing to do if you don't want to keep it updated.

Actually, I had changed that prior to Steam updating KSP for me. It did it anyway. Not the first time Steam has ignored this setting, and I doubt it will be the last.

I'm beginning to wish that there was a way to turn in my Steam key and return to the regular (non-Steam) version of KSP. Stuck with it now, though as it's a one-way process.

Share this post


Link to post
Share on other sites
Actually, I had changed that prior to Steam updating KSP for me. It did it anyway. Not the first time Steam has ignored this setting, and I doubt it will be the last.

I'm beginning to wish that there was a way to turn in my Steam key and return to the regular (non-Steam) version of KSP. Stuck with it now, though as it's a one-way process.

Do you have a backup prior to and after the bug happened? If you have both and you package them up (zip) and private message me a link, I can take a look.

As for it being SCANsat's fault or not, I really can't say.

And can you detail the precise sequence of events (if you can remember)? Are you saying it went:

  1. start 0.23 savegame
  2. play some, save where a vessel has SCANsat v5 sensors on it
  3. upgrade to 0.23.5
  4. fix 0.23.5 R&D bug
  5. load again, it works
  6. save, still has a vessel with SCANsat v5 sensors on it
  7. load now, R&D broken

Or:

  1. start 0.23 savegame
  2. play some, but no vessels have ssv5 sensors on it
  3. upgrade to 0.23.5
  4. load again, it works
  5. add a vessel with SS v5 sensors on it
  6. save, vessel included
  7. load now, R&D broken

Or, if it's some other sequence, please state it.

Share this post


Link to post
Share on other sites

Unfortunately, I do not have a backup of the save, only its current state.

As for the order in which things have happened, it's a bit complicated. Steam updated from .23 to .23.5.464 even though I'd told it to not automatically update KSP. It did this the same day that .23.5.464 came out. The resulting sequence of events is more like:

1. Steam updates .23 to .23.5.464 ignoring the change to update preference I made. I don't really even remember if I had SCANSat for .23, or if I'd gotten around to launching any vessels with its parts.

2. Fix .23.5 R & D bug

3. Play for awhile, adding, removing, and trimming various mods. No issues noted with the savegame. Note that awhile in this case means from the time I got everything going after the update to .23.5.464 to the point I'm at now where the R & D closed on me.

4. Overwrite SCANSat b5 with SCANSat v6, some vessels had b5 parts on them.

5. Two sets of SCANSat parts appeared in the VAB/SPH, and I needed to unlock one set in R & D. I did so.

6. Even after doing so, the new parts still told me they needed unlocked in R & D.

7. I terminated the one vessel I had with SCANSat b5 parts on it, and removed them from every craft file I could think of in preparation for completely uninstalling SCANSat and reinstalling it to remove the duplicate parts.

8. Said reinstall process was completed and included running KSP with SCANSat completely removed (to clear the parts off the unlocked lists in the persistence file...as usually works with other mods).

9. After SCANSat reinstalled, R & D issue crops up.

10. Check persistence file to see if the R & D bugfix from step 2 has come unglued...it hasn't...notes that SCANSat parts still listed in the unlocked parts lists, many of them with duplicate entries.

11. Removed said entries. All SCANSat parts should now need to be unlocked in R & D.

12. R & D issue unresolved.

I will be sending a PM in a moment with a link to the persistence file I do have.

Link sent, check your PMs.

Found a quicksave that should be from before the R&D Issue. Zipped up and link sent via PM.

Edited by Einarr
Found a quicksave.

Share this post


Link to post
Share on other sites
Unfortunately, I do not have a backup of the save, only its current state.

As for the order in which things have happened, it's a bit complicated. Steam updated from .23 to .23.5.464 even though I'd told it to not automatically update KSP. It did this the same day that .23.5.464 came out. The resulting sequence of events is more like:

1. Steam updates .23 to .23.5.464 ignoring the change to update preference I made. I don't really even remember if I had SCANSat for .23, or if I'd gotten around to launching any vessels with its parts.

2. Fix .23.5 R & D bug

3. Play for awhile, adding, removing, and trimming various mods. No issues noted with the savegame. Note that awhile in this case means from the time I got everything going after the update to .23.5.464 to the point I'm at now where the R & D closed on me.

4. Overwrite SCANSat b5 with SCANSat v6, some vessels had b5 parts on them.

5. Two sets of SCANSat parts appeared in the VAB/SPH, and I needed to unlock one set in R & D. I did so.

6. Even after doing so, the new parts still told me they needed unlocked in R & D.

7. I terminated the one vessel I had with SCANSat b5 parts on it, and removed them from every craft file I could think of in preparation for completely uninstalling SCANSat and reinstalling it to remove the duplicate parts.

8. Said reinstall process was completed and included running KSP with SCANSat completely removed (to clear the parts off the unlocked lists in the persistence file...as usually works with other mods).

9. After SCANSat reinstalled, R & D issue crops up.

10. Check persistence file to see if the R & D bugfix from step 2 has come unglued...it hasn't...notes that SCANSat parts still listed in the unlocked parts lists, many of them with duplicate entries.

11. Removed said entries. All SCANSat parts should now need to be unlocked in R & D.

12. R & D issue unresolved.

I will be sending a PM in a moment with a link to the persistence file I do have.

Link sent, check your PMs.

Interesting. I can't promise anything, but I will take a look.

There were a variety of changes to the part.cfg files. I could itemize them so we can figure out which, if any, cause this kind of mismatch.

Share this post


Link to post
Share on other sites

In the meantime, I've updated my mods, added some more, trimmed some down, etc and am getting ready to start a new career save. Most of the trimming I do is to remove fuel tanks from mods like KW Rocketry and NovaPunch. I use Procedural Parts, and so do not really need many sizes of fuel tanks cluttering up my parts inventory, taking up RAM, etc.

Hopefully you can get the R&D in my more established save working again, there's a Duna mission pending. You'll notice the Transfer Stage in high Kerbin Orbit, waiting on the transfer window. It's loaded with 3 impact detector probes, and 2 impactors. The manned portion hasn't been launched yet.

Edited by Einarr

Share this post


Link to post
Share on other sites
In the meantime, I've updated my mods, added some more, trimmed some down, etc and am getting ready to start a new career save. Most of the trimming I do is to remove fuel tanks from mods like KW Rocketry and NovaPunch. I use Procedural Parts, and so do not really need many sizes of fuel tanks cluttering up my parts inventory, taking up RAM, etc.

Hopefully you can get the R&D in my more established save working again, there's a Duna mission pending. You'll notice the Transfer Stage in high Kerbin Orbit, waiting on the transfer window. It's loaded with 3 impact detector probes, and 2 impactors. The manned portion hasn't been launched yet.

I don't know if this means anything to you, but I ran a diff which ignores all changes in whitespace, shows the two files in left and right hand-columns, etc.

The command I ran was:

diff --left-column --strip-trailing-cr -bEiy persistent.sfs quicksave.sfs  > diff-columns.txt

Or, if I wanted to inspect only the lines that were actually different


diff --left-column --suppress-common-lines --strip-trailing-cr -bEiy quicksave.sfs persistent.sfs > diff-columns-suppress.txt

Anyway, here is the top of the output (the older quicksave.sfs on the left, the newer persistent.sfs on the right):

(too big for here; see pastebin; i cut out some parts that had identical science entries)

For example, if the divider between the two columns is (, that means that the right column is the same. | means it will show you the differences between the same row. < means the left column has a new row. and > means there is a new row on the right (in this case, in persistent).

Anyway, I don't know what to look for -- I see some changes to SCANsat things in the tech tree. But I see a lot more changes to other plugins (TAC, it looks like) -- and TAC has a whole new Scenario section.

Share this post


Link to post
Share on other sites

I removed TACLS, but did not have the R&D Problem until I dealt with SCANSat.

Share this post


Link to post
Share on other sites

When you say the R&D center is closed do you mean you can't open it from the spacecenter screen? Or that when you collect science data you get the generic, sandbox science results? Or both?

Do you see any errors in the debug menu (alt+F2)? Can you send the ksp.log file (in the main KSP directory)?

Share this post


Link to post
Share on other sites
When you say the R&D center is closed do you mean you can't open it from the spacecenter screen? Or that when you collect science data you get the generic, sandbox science results? Or both?

Do you see any errors in the debug menu (alt+F2)? Can you send the ksp.log file (in the main KSP directory)?

At least the former (when you click R&D from SpaceCenter, it says This Facility is Closed).

Share this post


Link to post
Share on other sites
I feel like I should be embarrassed to have to be told this about my own mod, but damn it -- I don't want to *really* cheat and see planetary bodies I haven't reached myself in game yet. :(

And since I've only gotten to Kerbin and its moons, I wouldn't know.

I've mapped the entire System except for the Sun...although only with the low-res and the biome maps, as I haven't unlocked the SAR yet. It's the first time I've mapped everything at all though, and it's entirely thanks to being able to map at high warp.

I'll admit that my description was unclear, there are two forms of 'static' you can get, which are very easy to tell apart by looking at them but somewhat harder to describe.

The first is the 'out of power' type, which results in animated static that sort-of follows the scanlines and only appears on the small map. You can still kinda see the map through it at parts, because it kinda clears out right behind the scanline for a few moments? Or somesuch.

The second type is the 'nothing to display' type, which you get from biome mapping anything that isn't Kerbin or its Muns, or from Altitude-mapping something with no ground (Jool and the Sun). It's...well, I want to say 'Static' but let's go with 'fixed'. It's clearly randomly generated, as it changes when the map gets redrawn, but it isn't animated. It stays fixed until you do something that causes the map to redraw. It basically looks like a screenshot of what you get out of an old analog TV that's been tuned to a channel that isn't there: random black-and-white dots. It's still helpful because it lets you see where you've scanned so far.

The multispectral will let you turn the scans in for science even when all it can do is a static "map", but the radar will not.

I've yet to manage to 'map' the Sun effectively, as I've yet to figure out a way to circularize at a low enough altitude. (Mechjeb wants 26 THOUSAND m/s to do it. Or was it 28? Whatever.)

Edited by Tiron

Share this post


Link to post
Share on other sites

Is it possible to make is so we can view maps without having to add a part to a craft? I constantly forget that my maps are useless to me unless I add that dang part on

Share this post


Link to post
Share on other sites
I've mapped the entire System except for the Sun...

Yes, the static types are very different.

The small map static is constantly alternating between static and the regular display, that's why the map is still somewhat visible. The nothing-to-see static just generates pixels with a random shade of grey.

From what I can tell it looks like an empty biome map is also supposed to return 0 science, but because the biome system doesn't quite work how damny was thinking it does, this isn't the case. Allowing both cases to return science, as they probably should, seems easy enough to do.

Share this post


Link to post
Share on other sites
Is it possible to make is so we can view maps without having to add a part to a craft? I constantly forget that my maps are useless to me unless I add that dang part on

You can use ModuleManager to do this. The recipe for it is in the first post of the dev thread.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.