DMagic

[1.7.3] SCANsat [v18.13] -- Real Scanning, Real Science, at Warp Speed! [August 21, 2019]

Recommended Posts

I feature I would like so see is a better contour resolution on the zoomed map as is uses the same height resolution as the big map. Preferable a discrete number of levels adjusted for min- and max height from the zoomed map section. But I guess that would require alot more calculations => slower map

This is a start, the difference between the old and new version is pretty obvious:

OEK3YJr.png

The mouse cursor is on the little white patch in the top-left corner, the normal max height for Kerbin is around 6000m.

There is something weird about the discrete palettes that causes the map to blow up about half way through rendering, I'm not sure why, I'll have to look into it more. But the standard, continuous palette works fine. The delay for calculating the new min and max terrain height limits is essentially zero (it does it every time you zoom in/out, or re-center the map), and as you can see, it handles the clamped settings for ocean planets like Kerbin fine.

Other features for version 14.4 include:

An ocean depth meter when splashed down:

X7oBAH3.png

A scanning threshold setting to complete the stock resource scan after a certain level of SCANsat resource scanning:

GyGAKRK.png

A few export-focused options:

2fHYxCG.png

Grey-scale uses a true black-to-white color scale instead of the standard black-and-white option (which uses several discrete shades of grey to construct the map), the text box allows for manually setting the big map width, and there is an option to export a .csv data file. This file writes out: pixel row, column, latitude, longitude, terrain height. Writing out such a file for a really big map is super-slow, but it runs nicely in a separate thread, so there is no noticeable impact (other than not being able to spam the export button, which is probably a bad idea anyway).

Edit:

There we go, the discrete color scheme seems to be working OK, too:

oehdH2k.png

Edited by DMagic

Share this post


Link to post
Share on other sites

Version 14.4 is out; get it on Kerbal Stuff.

This release fixes an issue with science data being returned to the correct part on transmission failure.

It includes the features described a few posts up. It also fixes a few minor bugs. See the full change log below.

Change Log:


Version 14.4 - 2015-11-14
------------------------

- New export functions
- Option to sse a true grey-scale color scheme
- Option to export a .csv file with coordinates and terrain height for each pixel
- Option to manually specify the big map width

- Stock resource scan threshold
- Active when stock resource scanning is disabled
- Set a SCANsat resource scanning threshold level above which the stock resource scan will apply for each celestial body

- Misc and Bug Fixes
- Fix science data return on transmission failure
- Zoom maps use variable terrain height ranges based on the local min and max terrain height
- Add an ocean depth indicator to the instruments window
- Add a distance-to-landing-target indicator on instruments window when within 15km
- Fix drawing the terrain height behind the biome map
- Fix some errors in ground track drawing

Edited by DMagic
typo

Share this post


Link to post
Share on other sites
Grey scale export !!! Yayyyyyyyyyy! :)

It's been an option in the debug version (which I give out to some people when they ask) for a while, along with the ability to specify a map size, and to fill in all of the maps. I just cleaned up how those options were displayed a bit and included them in the regular version (except the last one :D).

Is it possible to add Karborundum to the list of resources, as I see Karbonite is in there already.

I'm not really sure how Karborundum works now, but in the past the idea was always that you couldn't scan for it from orbit and couldn't get maps, you had to scan from very low. So I've always intentionally left it out.

There is nothing stopping anyone from adding in a new SCANSAT_SENSOR type in the SCANsat/Resources/SCANresource file for Karborundum, then adding the matching ModuleSCANresourceScanner module to a part. All of the other resource settings should fill in automatically when those are added and Karbonite+ is installed.

Update:

I just noticed there are a few bugs in the .csv exporter. It looks like the map height and width got switched at some point, so it's only exporting the left half of the map. There is also an error which prevents very large maps from exporting before the timer runs out.

For anyone who wants a working .csv exporter use this version from DropBox.

It is otherwise identical to 14.4.

Be aware that very large maps produce some nasty export files. I tried an 8192 X 4096 map (which took about 7 min to render), the .png file is reasonable, but the .csv file is about 1.1GB. I couldn't open in Excel, notepad++, or notepad (which is able to open files bigger than the other two).

Edited by DMagic

Share this post


Link to post
Share on other sites
The narrow-band scanner can pick up Karborundum, was that part of the SatScan mod or something else? I will dive into the cfg, just hate keeping track of all my changes with updates later ;)

I've added the sensor into the scansat recources .cfg, also a resource in the MKS survey camera and a module in the other scansat cfg (karbonite was there, so added K+ as well under 1048576). Yet I do not get the option under scansat. Did I miss something? Edited by Jimbodiah

Share this post


Link to post
Share on other sites
Got a bug or glitch or conflict with another mod. Since 1.0.5, using the latest SCAN Sat versions, the scanners don't want to transmit their science. SCAN Sat shows 100% on scanning Kerbin and Mun (only two I've used it on), I right click the scanners (radar, SAR, and multispectral), click analyze, the experiment window pops up, but hitting transmit does nothing. No science sent, no drain on the energy as if it were transmitting and not saying so. I am using Remote Tech (both it and Scan are the lastest versions) as well as several other mods, but I did not have this problem with the same mods installed before 1.0.5, They all worked fine together. This is also affecting the stock M700 survey scanner.

Share this post


Link to post
Share on other sites
Science not transmiting is a problem with ScienceAlert. Do you have that mod? If so, there is a patch. You need ScienceAlert-1.8.9 and ScienceAlert-1.8.9-patch1.

Share this post


Link to post
Share on other sites
Yep, that did it. Didn't have SciAlert installed since the 1.0.5 update, but I guess a part of it was still in there. Working now, thanks.

Share this post


Link to post
Share on other sites
[quote name='DMagic']Version 14.4 is out; get it on [URL="https://kerbalstuff.com/mod/249"]Kerbal Stuff[/URL][/QUOTE]

Hey DMagic... just out of curiosity, is 14.4 not compatible with previous versions of KSP (1.0.4, specifically)? I ask because with ScanSat installed, I am unable to exit buildings (I can't even enter the VAB). Loading the Persistent save file doesn't have any effect, and pressing the red "Exit" building doesn't do anything. I am also unable to quit to the main menu. I will post my output.log (and my KSP.log, just in case) file with this post.

Output.log -https://www.dropbox.com/s/7xu2g7ltdrnpnxm/output_log.zip?dl=0

KSP.log -https://www.dropbox.com/s/47zuzz4g49e0azv/KSP.zip?dl=0

Share this post


Link to post
Share on other sites
Old versions of KSP and old versions of SCANsat are not supported. And 14.4 (just like 14.3) does not support old versions of KSP.

Share this post


Link to post
Share on other sites
[quote name='DMagic']Old versions of KSP and old versions of SCANsat are not supported. And 14.4 (just like 14.3) does not support old versions of KSP.[/QUOTE]

Okay, then... thanks for the quick response!

Share this post


Link to post
Share on other sites
Does anyone know exactly what the Been There Done That is for?

Share this post


Link to post
Share on other sites
[quote name='DMagic'][URL]http://i.imgur.com/tybbDap.gif[/URL]

It identifies nearby anomalies.[/QUOTE]

I tried putting it on a rover and driving it around KSC, it didn't seem to do anything. I even went out to the obelisk. The anomalies are already on my map from orbital scan.

Share this post


Link to post
Share on other sites
I have a few quick questions about resource scanning. Running SCANsat 14.4 with Biome Lock and Requires Narrow Band Scanner enabled and Instant Scan and Disable Stock Scanning disabled. I have a probe with a M700 Survey Scanner in a 100km polar orbit of Kerbin.

1) When I am in the Tracking Center and centered on Kerbin, and I click the Resources icon on the far right, I get "no resource data available. You will need to perform an orbital survey first." However if I am focused on the probe with the scanner, go to Map View, and focus on Kerbin the icon works. Is this working as intended?

2) When I am in the Big Map, the Resources dropdown only shows "Ore". Do I need to modify a config file to have it show MetalOre for use with EPL?

Thanks!

Share this post


Link to post
Share on other sites
Seems to have nothing to do with this mod but with a known stock bug.

[url]http://forum.kerbalspaceprogram.com/threads/139435-Orbital-surveys-not-showing-up-in-Tracking-Station[/url]

Share this post


Link to post
Share on other sites
[quote name='Alshain']I tried putting it on a rover and driving it around KSC, it didn't seem to do anything. I even went out to the obelisk. The anomalies are already on my map from orbital scan.[/QUOTE]


Around KSC, KSC is the only thing that shows up. Other places it will walk you in to anomalies meter by meter. It works really slick.

Share this post


Link to post
Share on other sites
[quote name='Alshain']I tried putting it on a rover and driving it around KSC, it didn't seem to do anything. I even went out to the obelisk. The anomalies are already on my map from orbital scan.[/QUOTE]

[quote name='Aethon']Around KSC, KSC is the only thing that shows up. Other places it will walk you in to anomalies meter by meter. It works really slick.[/QUOTE]

I haven't actually tested the BTDT in a long time, but there is no reason it should be having any problems, I'll try it out some time.

You can actually cycle through all of the buildings at the KSC (or any other anomaly with more than one structure) my using the mouse wheel when hovering over the anomaly display.

[quote name='ThirdHorseman']1) When I am in the Tracking Center and centered on Kerbin, and I click the Resources icon on the far right, I get "no resource data available. You will need to perform an orbital survey first." However if I am focused on the probe with the scanner, go to Map View, and focus on Kerbin the icon works. Is this working as intended?

2) When I am in the Big Map, the Resources dropdown only shows "Ore". Do I need to modify a config file to have it show MetalOre for use with EPL?

Thanks![/QUOTE]

As KerbMav said, the first one is a stock bug, the SCANsat overlay works fine in all scenes.

MetalOre is different from MetallicOre? :confused: Out of the box SCANsat only supports stock and CRP resources, but I'll see about adding it to the next version.

Share this post


Link to post
Share on other sites
Sorry if this has already been addressed and I missed it. Does anyone else get the error below logged when starting KSP with this mod installed?

[FONT=courier new]Load(Model): SCANsat/Parts/MULTI/MULTI
Texture 'SCANsat/Parts/MULTI/MULTI' not found![/FONT]

I have [I]GameData\SCANsat\Parts\MULTI\MULTI.mu[/I] present.
But there is no [I]MULTI.dds [/I]or [I]MULTI.png [/I]file. Only [I]MULTI_DIFF.dds [/I]and [I]MULTI_NRM.dds[/I].

The part does appear to be visually correct in the game. Edited by Fwiffo
formatting and additional detail

Share this post


Link to post
Share on other sites
[quote name='KerbMav']Seems to have nothing to do with this mod but with a known stock bug.

[url]http://forum.kerbalspaceprogram.com/threads/139435-Orbital-surveys-not-showing-up-in-Tracking-Station[/url][/QUOTE]

Great, thanks! Yea the SCANsat overlays all work fine so this looks like the stock bug. Thanks for the pointer!

[COLOR="silver"][SIZE=1]- - - Updated - - -[/SIZE][/COLOR]

[quote name='DMagic']
MetalOre is different from MetallicOre? :confused: Out of the box SCANsat only supports stock and CRP resources, but I'll see about adding it to the next version.[/QUOTE]

Well it shows MetalOre on the overlay. When I'm flying my probe with the M700 Survey Scanner I can activate the overlay and toggle back-and-forth between Ore and MetalOre. The overlay and avg amount change accordingly. So it certainly knows what MetalOre is, where it is located on the planet, and the avg amounts of it there are.

It's just on the Big Map that the resources dropdown only shows Ore. I don't have a Narrow Band Scanner up yet so maybe you need that first before the Big Map offers a MetalOre option? That seems weird though...

Share this post


Link to post
Share on other sites
[quote name='ThirdHorseman']Well it shows MetalOre on the overlay. When I'm flying my probe with the M700 Survey Scanner I can activate the overlay and toggle back-and-forth between Ore and MetalOre. [/QUOTE]

It shows MetalOre in the stock overlay window you mean? Any stock planetary resource will show up there.

SCANsat resources require explicit support because it has to know how to store data on which resources have been scanned and where they have been scanned.

You can manually add in new resources by adding an new entry to the SCANresource.cfg file with a new SCANtype, and by adding the matching ModuleSCANresourceScanner to a part, either by adding it to a part's config file or doing so with Module Manager. Examples of which can be found in SCANsat's module manager config folder.

[quote name='Fwiffo']Sorry if this has already been addressed and I missed it. Does anyone else get the error below logged when starting KSP with this mod installed?[/QUOTE]

Thanks for that, it looks like the normal map texture was named incorrectly. I'll fix that in the next update. Edited by DMagic

Share this post


Link to post
Share on other sites
I apologize if this has already been asked but I am using 14.4 scansat with 1.0.5 ksp and I just completed the 85% low res altimetry scan of kerbin but when I try to transmit the data nothing happens. It says I have 27 science. I am in range of the KSC with my communitron 16 but it refuses to transmit any data??? What am I doing wrong please?

You can see from the two images below I am in communications range of the KSC and I have about 26 science to transmit for 100%. When I transmit nothing happens. You can also see that I have a contract to transmit science from space around kerbin and I do not get credit for that either!

[Imgur]([url]http://i.imgur.com/YWdPjNk.png[/url])

[Imgur]([url]http://i.imgur.com/wsXFPBx.png[/url]) Edited by ctbram

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.