DaMichel

[1.3] Kerbal Flight Data (Release 23, 2017-08-14)

Recommended Posts

No it works fine without it. You just cannot toggle KFD on/off without toolbar.

Say, are you using Linux or the x64 version? And i see there are more plugins that fail to load for similar reason. Have you tried to remove all but one of the failing plugins?

Share this post


Link to post
Share on other sites

Updated!

https://github.com/DaMichel/KerbalFlightData/releases/tag/R17pre

For the adventurous, because i didn't have much time to test it. Also i could not test it with nuFAR since i wasn't able to get the dev version running. Have to wait for the official release.

P.S. The temp display is hidden until 1000K before explosion.

P.P.S. @Nathan: the readme, which has all required information, is now included in the plugin folder.

Edited by DaMichel

Share this post


Link to post
Share on other sites

Re: removing the intake data because asymmetric flameouts "are a thing of the past".

I just had an asymmetric flameout...

(pure stock KSP, no mods)

Share this post


Link to post
Share on other sites

Uhm okay. I believe you. My statement comes from a flight where my engines quit simultaneously, several times even. Must have been coincidence. So i guess the intake warning will be back soon. Thanks for reporting.

Share this post


Link to post
Share on other sites

Will this mod display EAS in stock aero?

(Please say yes.)

Share this post


Link to post
Share on other sites

All right all right. I'll try to bring back the intake display. Problem is, i think something has changed. I had some rapiers quit when the old code did not give a warning :( Does anybody know?

@White Owl: Sorry, no.

Share this post


Link to post
Share on other sites

Assorted comments around the forums lead me to think that the RAPIERs may be giving asymmetric flameouts while the turbojets aren't. Haven't confirmed it for certain, though.

Share this post


Link to post
Share on other sites
Assorted comments around the forums lead me to think that the RAPIERs may be giving asymmetric flameouts while the turbojets aren't. Haven't confirmed it for certain, though.

Nada, I've had asymmetric flameouts on the Ravenspear Mk1 (2 turbos and 1 basic)

Share this post


Link to post
Share on other sites

I just wanted to give this simple yet indispensable mod another two thumbs up and a bump while I download the latest version. Keep up the good work!

Share this post


Link to post
Share on other sites
Updated!

https://github.com/DaMichel/KerbalFlightData/releases/tag/R17pre

Also i could not test it with nuFAR since i wasn't able to get the dev version running. Have to wait for the official release.

Cheers for the update. Doesn't work with nuFAR, though, as I guess you already knew. Toolbar button appears fine, but no data. Get this error in the log:


NullReferenceException: Object reference not set to an instance of an object
at KerbalFlightData.DataFAR.GetFARData_Internal (KerbalFlightData.Data data, .Vessel vessel) [0x00000] in <filename unknown>:0
at KerbalFlightData.DataFAR.GetFARData (KerbalFlightData.Data data, .Vessel vessel) [0x00000] in <filename unknown>:0
at KerbalFlightData.DataSources.FillDataInstance (KerbalFlightData.Data data, .Vessel vessel) [0x00000] in <filename unknown>:0
at KerbalFlightData.DMFlightData.LateUpdate () [0x00000] in <filename unknown>:0

Full log's here, if it's any help before the official nuFAR release.

(BTW, in case it was your problem, you need to have Modular Flight Integrator installed for nuFAR to work.)

Share this post


Link to post
Share on other sites

This is a great mod, DaMichel. Very subtle, but supremely necessary addition.

Just wanted to mention that there is a minor incompatibility with Waypoint manager. IVA with an activated target, there is a slight overlap with the active target data, and the flight data.

kWHcUe9.jpg

Share this post


Link to post
Share on other sites

Thanks for the nice comments everyone.

And .. Well this sucks. I might just add a configuration option to set the text location.

Share this post


Link to post
Share on other sites
Thanks for the nice comments everyone.

And .. Well this sucks. I might just add a configuration option to set the text location.

Oh man that would be super awesome! I always have to turn it off in IVA because of waypoint manger. Also Kerbal wind need recompiled for FAR Fanno

Share this post


Link to post
Share on other sites
Does not work with 1.0.2.

button is inactive

That's not really giving enough information to get much in the way of help. Please see here for directions on how to provide the information needed to help with your issue.

Share this post


Link to post
Share on other sites

Yes, please show your output log. I have it working with 1.0.2 here. Haven't tested it with the latest FAR though.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.