Jump to content

Stockalike RF Engine Configs v3.2.6 [01/20/19][RF v12]


Raptor831
 Share

Recommended Posts

@Starwaster Well, I reinstalled RF and Stockalike RF and Real Plume with the latest version of RF Stockalike that you gave me and some engines are still in Fuel Tanks tab. There is 22 of them. All crogenic engines from cryo engines mod, some KW ones and about 10 stock ones. Everything is working fine, just its a bit of a hassle for engines to be in 2 tabs

-EDIT-

And some engines don't have plumes at all. Cryo one don't have and LV-909 doesn't have plumes no matter which proppelant I switch it to.

Edited by Joco223
Link to comment
Share on other sites

On 12/25/2015 at 2:42 PM, speedwaystar said:

@Ryland_k

the fix for this is (or was) hidden somewhere in the RealPlume forum thread. i just looked for it and failed to find it, but luckily (although i'm not using RealFuels atm), i still have a copy of the ModuleManager fix:

@PART[*]:HAS[@MODULE[ModuleEnginesRF]]:BEFORE[RealPlume]
{
   @MODULE[ModuleEnginesRF]
   {
      %RFConfig = TRUE
   }
}

@PART[*]:HAS[@MODULE[ModuleEngines*]:HAS[#RFConfig[TRUE]]]:FINAL
{
   @MODULE[ModuleEngines*],*:HAS[#RFConfig[TRUE]]
   {
      @name = ModuleEnginesRF
   }
}

the important bit is HAS[#RFConfig[TRUE]] istead of HAS[RFConfig[TRUE]] (the hash)

enjoy!

Quick question, and I hope I don't sound rather moronic asking it, but can this fix just be placed into the GameData folder, or do we need to go into the Stockalike configs and replace the incorrect parameters with these corrected ones?

Link to comment
Share on other sites

5 hours ago, Sovek said:

@Raptor831 Is there any chance of getting some of the engines that lost their effects (and sounds) to be fixed, or is there a fix somewhere? The LV-900 in Vens doenst have it, and neither does the upper stage for the 1.875m engine from HGR.

I am the one who did all the engine plumes for this mod. I have fixed quite a few plumes and added many more so here is a zip with the most updated files. If you are using the stock real plume configs delete them. They aren't intended to be used together and I am not going to troubleshoot or try to help anyone using both sets of configs. These are intended to match the fuel being used on the engine the stock config just use whatever plume they want. Next I will only be adding engine plume for engine I use. The fix for engines without effects or sound is to add/make plumes, so if you have engines you want to add effects back to do it yourself. It is not hard just takes some time. Here the tutorial everyone uses to add plumes.

Edited by Svm420
Link to comment
Share on other sites

@Svm420 Ok, I downloaded your configs, took a look at the LV-909b config (LV-900) and its identical to what I have now.

They HAVE configs set up, they just arnt SHOWING up.

Annnnd just to prove that it still doesnt work,

3904E7711A3797CE6A3A3C2B24AA5A86FDAFF81D

Both engines running, at full power, 0 sounds, 0 plume.

Edited by Sovek
Link to comment
Share on other sites

15 minutes ago, Sovek said:

@Svm420 Ahhh, conflicting Config files. It would be nice if CKAN didn't require you to select that in order to install it.

@blowfish  Assuming that doesnt work, I will indeed provide logs. One sec while I check on that.

Let me know if it does not work once that is removed. :) CKAN FTW FTL :rolleyes:

Edited by Svm420
Link to comment
Share on other sites

@Svm420 Nope, no joy on that burn. No sound, no plume. I removed Real Plume from CKAN and downloaded RP from the Github page. Still nothing.

@blowfish I'd love to give you the files, but alas, no mediafire, and I don't have a dropbox account, and its too big for pastebin. Any other ideas?

Edit: Forgot about Google Drive... oops

MM Cache

https://drive.google.com/file/d/0B-2TNgI1Si1wVnRjUXFjT0w1TEk/view?usp=sharing

output_log.txt

https://drive.google.com/file/d/0B-2TNgI1Si1wY3VwbjgxeXFOQnM/view?usp=sharing

Edited by Sovek
Link to comment
Share on other sites

12 minutes ago, Sovek said:

@Svm420 Nope, no joy on that burn. No sound, no plume. I removed Real Plume from CKAN and downloaded RP from the Github page. Still nothing.

@blowfish I'd love to give you the files, but alas, no mediafire, and I don't have a dropbox account, and its too big for pastebin. Any other ideas?

Edit: Forgot about Google Drive... oops

MM Cache

https://drive.google.com/file/d/0B-2TNgI1Si1wVnRjUXFjT0w1TEk/view?usp=sharing

output_log.txt

https://drive.google.com/file/d/0B-2TNgI1Si1wY3VwbjgxeXFOQnM/view?usp=sharing

The problem is that the old engine effects system used by that part is not supported by RealFuels.  In order to get effects, you need RealPlume or HotRockets (and probably RealPlume because HotRockets hasn't been updated in ages).  It does say exactly this in the original post for this thread, just so you're aware. 

Link to comment
Share on other sites

Uh I don't see that you have the configs for the plumes installed on that log... I searched for the word PLUME anywhere in your cache and got 0 results make sure you have the configs installed.

@blowfish I appreciate you are trying to help, but I can handle this I have had the issue with this before.

Edited by Svm420
Link to comment
Share on other sites

Ok, I've solved it. It turns out that you DO IN FACT need the RP Stock Configs or else it wont work. Still doesnt explain why I had the problem in the first place, seeing as how I have the exact same files as from when I started... Oh well.

Link to comment
Share on other sites

1 hour ago, Sovek said:

Ok, I've solved it. It turns out that you DO IN FACT need the RP Stock Configs or else it wont work. Still doesnt explain why I had the problem in the first place, seeing as how I have the exact same files as from when I started... Oh well.

You need GameData/RealPlume/RealPlume-RFStockalike (which as far as I know is distributed with RF-Stockalike), as well as the core RealPlume pack.  What you don't need are the actual RealPlume stock configs (GameData/RealPlume-Stock).

Edited by blowfish
Link to comment
Share on other sites

Ok, for the "missing" plumes, you need SmokeScreen too, which I thought was a requirement of RealPlume. You do need RealPlume, but you probably shouldn't use a config set other than the ones provided in this mod's download. Svm420, as mentioned, did all of those to match the Stockalike engines and their "natural" fuel mixtures. You can use other configs to fill out the ones that weren't included, but it gets harder to troubleshoot the less "stock" your install is.

We've gone over the plume issue before, but to recap:

SolverEngines (which RealFuels is now based on) extends the ModuleEngineFX type of engine. Some older engines (like the LV909) never had MEFX built for them by Squad. And some older mod engines have the same issue. If you have engines such as these installed with RF/Stockalike installed and do not have RealPlume or HotRockets installed, the effects will go away. There's not a lot I can do about that, either, since this mod depends on RealFuels.

And even then, there are 300+ engines in my "database" that would need attention if we were to make RealPlume a dependency. That's just too much for 1 person to have to build and test. They all would need to be checked in-game for plume positioning, since RealPlume only provides FX and default settings that won't necessarily work in every case. @Svm420 has done a great service by offering his time and effort to make a bunch of them. But if anyone else would like to take the time and fill out anything still missing, it'd certainly help a lot.

I'll take the time again to thank the contributors to this mod. They are quite numerous now, so I can't list everyone by memory. But, there is an incomplete list on GitHub: https://github.com/Raptor831/RFStockalike/graphs/contributors  I'd be quite a bit overwhelmed if it wasn't for everyone's help.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...