Beale

[1.8.X] Tantares - Stockalike Soyuz and MIR [19.0][20/10/2019]

Recommended Posts

25 minutes ago, grayal said:

Not sure if anyone else can help with this one. I've search for this on the forums and found some info but no real solution. 

My Tantares Parachutes for Soyuz do not work. 

What i mean by that is this. After deploying, the chute comes out, the craft slows down to about 280 m/s initially then while falling to the full opening altitude itll slow down to about 255 m/s and thats about it. 

Needless to say the craft then hits the ground turning my Kerbals into a lime colored jelly. 

I have tried MANY different variables from pressure to altitude. My reentry angle is fine. More importantly ALL other chutes from stock to other mods work fine. Only tantares seem to be affected. 

They were working prior to a mod install which i suspect was Realchutes. I have removed the realchutes mod but have not tested it yet cuz i had to leave for work. 

Can ANYONE shed any light on this issue?

Does the parachute fully open?

Share this post


Link to post
Share on other sites

Graphically no it does not. Even if i set the opening altitude to max 5000m it doesnt. 

Im suspecting that maybe i will have to (with the addition of realchutes) add a drogue chute to the DM and action group it to open first then action group the mainchute with a drogue cutaway. 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, TK-313 said:

Meanwhile on the crossroads of mods...

WyfrM60.png

Amazing! I love this landing platform.

47 minutes ago, grayal said:

Not sure if anyone else can help with this one. I've search for this on the forums and found some info but no real solution. 

My Tantares Parachutes for Soyuz do not work. 

What i mean by that is this. After deploying, the chute comes out, the craft slows down to about 280 m/s initially then while falling to the full opening altitude itll slow down to about 255 m/s and thats about it. 

Needless to say the craft then hits the ground turning my Kerbals into a lime colored jelly. 

I have tried MANY different variables from pressure to altitude. My reentry angle is fine. More importantly ALL other chutes from stock to other mods work fine. Only tantares seem to be affected. 

They were working prior to a mod install which i suspect was Realchutes. I have removed the realchutes mod but have not tested it yet cuz i had to leave for work. 

Can ANYONE shed any light on this issue?

Could possibly be real-chutes. But, before you just remove that, try deleting the PartDatabase.cfg from the KSP install directory.

A couple of other things that can cause this:

- mods that give the parachute an alternate colour scheme.
- Sometimes the above partdatabase.cfg will be altered by game updates, it seems best to just delete that and it will re-generate.

Hope this helps.

 

Kvant-1 Tug / Polyus FGB forward section.
It's a control core, and a big one too!

FWRF15y.png
8JR6OLj.jpg
CQdptvc.png

Edited by Beale

Share this post


Link to post
Share on other sites

Beale, Thank you for weighing in. 

I love this MOD BTW!!

I have tried the deletion of Partdatabase.cfg as well as physics.cfg plus a wipe of the modulemanager cache. None of this helped sadly. I would love to be able to use Realchutes along with Tantares.

As i mentioned im not sure that realchutes is the issue as i have not yet been home to test. Nor have i tested the Drogue chute then main chute idea. Come to think of it i also have not checked the REALCHUTE settings it applied to the Tantares Soyuz Parachute,. Maybe it reconfigured it as a drogue or something crazy changing its parameters. Ill have to check all that when i get home in a few hours. 

Share this post


Link to post
Share on other sites

Question?

 

Where or how do I add the Escape Launch System to the Soyuz capsule inside the fairing?

 

Does anyone have a picture on how to build or is there a craft file somewhere for it I'm missing?

 

Thanks and Great MOD!

Share this post


Link to post
Share on other sites
45 minutes ago, Kilo60 said:

Question?

 

Where or how do I add the Escape Launch System to the Soyuz capsule inside the fairing?

 

Does anyone have a picture on how to build or is there a craft file somewhere for it I'm missing?

 

Thanks and Great MOD!

I usually attach it to the docking node and offset to match the shape of the fairing. Also, I typically program a LES Jettison/Decouple Node action group.

Share this post


Link to post
Share on other sites

@Beale Trying to edit the old-style Progress tanker compartment .cfg (_Hamal_Control_1) from "RESOURCE{ name = LiquidFuel amount = 63 maxAmount = 63}RESOURCE{ name = Oxidizer amount = 77 maxAmount = 77}" to "RESOURCE{ name = MonoPropellant amount = 140 maxAmount = 140}". No idea what I'm doing wrong, but instead of changing its' resources to monopropellant, it doesn't load in-game at all.

Share this post


Link to post
Share on other sites
Posted (edited)

So... Continuing the parachute woes...

It isnt realchutes.

Im also using Tantares in colors and I have 2 Tantares Soyuz Chutes. The T-V2K and T-SZ.

 

The T-SZ works fine but is only black. 

The T-V2K is the one that isnt working and it is the one that is available in the Tantares color patterns as well as the Tantares in Colors patterns. 

I am removing Tantares in Colors and testing again... WIll advise. 

 

Ok test complete. 

It's fixed now. Sadly it WAS Tantares Now In Colors that was to blame.

Removed that MOD pending it's update and my Soyuz Chute works again. 

Edited by grayal

Share this post


Link to post
Share on other sites
2 hours ago, sslaptnhablhat said:

@Beale Trying to edit the old-style Progress tanker compartment .cfg (_Hamal_Control_1) from "RESOURCE{ name = LiquidFuel amount = 63 maxAmount = 63}RESOURCE{ name = Oxidizer amount = 77 maxAmount = 77}" to "RESOURCE{ name = MonoPropellant amount = 140 maxAmount = 140}". No idea what I'm doing wrong, but instead of changing its' resources to monopropellant, it doesn't load in-game at all.

Sounds okay to me, should look something like this:

PART
{

name = Hamal_Control_1
module = Part
author = Tantares

MODEL
{
   model = Tantares/Parts/PROGRESS/Progress_Control_1
}
scale = 1
rescaleFactor = 1

node_stack_bottom = 0.0,  -0.5375, 0.0, 0.0, -1.0, 0.0, 1
node_stack_top    = 0.0,   0.5375, 0.0, 0.0, 1.0, 0.0, 1

bulkheadProfiles = size1

attachRules = 1,0,1,1,0

TechRequired = advFlightControl
entryCost = 3000
cost = 830

category     = Pods
subcategory  = 0
title        = #LOC_Tantares_Hamal_Control_1
manufacturer = #LOC_Tantares_Manufacturer_TST
description  = #LOC_Tantares_Hamal_Control_1_Description

tags = #LOC_Tantares_Hamal_Control_1_Tags

mass = 0.2125

dragModelType  = default
maximum_drag   = 0.20
minimum_drag   = 0.15
angularDrag    = 2
crashTolerance = 10
maxTemp        = 2000

vesselType = Probe

MODULE
{
	name = ModuleCommand
	minimumCrew = 0
	RESOURCE
	{
		name = ElectricCharge
		rate = 0.05
	}
	hasHibernation = True
}

MODULE
{
	name = ModuleDataTransmitter
	antennaType = INTERNAL
	packetInterval = 1.0
	packetSize = 2
	packetResourceCost = 12.0
	requiredResource = ElectricCharge
	antennaPower = 5000
	optimumRange = 2500
	packetFloor = .1
	packetCeiling = 5
}


MODULE
{
	name = ModuleKerbNetAccess
	MinimumFoV = 10
	MaximumFoV = 80
	AnomalyDetection = 0.24
	DISPLAY_MODES
	{
		Mode = Biome
		Mode = Terrain
	}
}

MODULE
{
	name = ModuleScienceContainer
	
	reviewActionName = Review Stored Data
	storeActionName = Store Experiments
	evaOnlyStorage = False // i.e. can nearby regular vessels also do this, or EVA only
	storageRange = 1.3
	canBeTransferredToInVessel = True
	canTransferInVessel = True
	showStatus = True
}

MODULE
{
	name = ModuleReactionWheel
	PitchTorque = 0.125
	YawTorque = 0.125
	RollTorque = 0.125
	RESOURCE
	{
		name = ElectricCharge
		rate = 0.0075
	}
}

MODULE
{
	name = ModuleSAS
	SASServiceLevel = 1
}

RESOURCE
{
	name = ElectricCharge
	amount = 100.0
	maxAmount = 100.0
}

RESOURCE
{
	name = MonoPropellant
	amount = 100
	maxAmount = 100
}


}
15 hours ago, Kilo60 said:

Question?

 

Where or how do I add the Escape Launch System to the Soyuz capsule inside the fairing?

 

Does anyone have a picture on how to build or is there a craft file somewhere for it I'm missing?

 

Thanks and Great MOD!

Many thanks,

I usually set it up like this:

KPU2R3W.png

The escape tower is propped from the orbital module with some octagonal girders.

Then as @HooHungLow mentions, attach to the abort action group with these actions:

  • trigger fairings,
  • decoupler capsule / OM
  • fire LES

Works 100% of the time 90% of the time :wink: 

 

1 hour ago, grayal said:

Ok test complete. 

It's fixed now. Sadly it WAS Tantares Now In Colors that was to blame.

Removed that MOD pending it's update and my Soyuz Chute works again. 

Thanks for testing that :)

@Drakenex Maybe worthwhile to remove the parachute colours until the bug is fixed? Really unfortunate :( 

Share this post


Link to post
Share on other sites
8 minutes ago, Beale said:

Sounds okay to me, should look something like this:


PART
{

name = Hamal_Control_1
module = Part
author = Tantares

MODEL
{
   model = Tantares/Parts/PROGRESS/Progress_Control_1
}
scale = 1
rescaleFactor = 1

node_stack_bottom = 0.0,  -0.5375, 0.0, 0.0, -1.0, 0.0, 1
node_stack_top    = 0.0,   0.5375, 0.0, 0.0, 1.0, 0.0, 1

bulkheadProfiles = size1

attachRules = 1,0,1,1,0

TechRequired = advFlightControl
entryCost = 3000
cost = 830

category     = Pods
subcategory  = 0
title        = #LOC_Tantares_Hamal_Control_1
manufacturer = #LOC_Tantares_Manufacturer_TST
description  = #LOC_Tantares_Hamal_Control_1_Description

tags = #LOC_Tantares_Hamal_Control_1_Tags

mass = 0.2125

dragModelType  = default
maximum_drag   = 0.20
minimum_drag   = 0.15
angularDrag    = 2
crashTolerance = 10
maxTemp        = 2000

vesselType = Probe

MODULE
{
	name = ModuleCommand
	minimumCrew = 0
	RESOURCE
	{
		name = ElectricCharge
		rate = 0.05
	}
	hasHibernation = True
}

MODULE
{
	name = ModuleDataTransmitter
	antennaType = INTERNAL
	packetInterval = 1.0
	packetSize = 2
	packetResourceCost = 12.0
	requiredResource = ElectricCharge
	antennaPower = 5000
	optimumRange = 2500
	packetFloor = .1
	packetCeiling = 5
}


MODULE
{
	name = ModuleKerbNetAccess
	MinimumFoV = 10
	MaximumFoV = 80
	AnomalyDetection = 0.24
	DISPLAY_MODES
	{
		Mode = Biome
		Mode = Terrain
	}
}

MODULE
{
	name = ModuleScienceContainer
	
	reviewActionName = Review Stored Data
	storeActionName = Store Experiments
	evaOnlyStorage = False // i.e. can nearby regular vessels also do this, or EVA only
	storageRange = 1.3
	canBeTransferredToInVessel = True
	canTransferInVessel = True
	showStatus = True
}

MODULE
{
	name = ModuleReactionWheel
	PitchTorque = 0.125
	YawTorque = 0.125
	RollTorque = 0.125
	RESOURCE
	{
		name = ElectricCharge
		rate = 0.0075
	}
}

MODULE
{
	name = ModuleSAS
	SASServiceLevel = 1
}

RESOURCE
{
	name = ElectricCharge
	amount = 100.0
	maxAmount = 100.0
}

RESOURCE
{
	name = MonoPropellant
	amount = 100
	maxAmount = 100
}


}

Many thanks,

I usually set it up like this:

KPU2R3W.png

The escape tower is propped from the orbital module with some octagonal girders.

Then as @HooHungLow mentions, attach to the abort action group with these actions:

  • trigger fairings,
  • decoupler capsule / OM
  • fire LES

Works 100% of the time 90% of the time :wink: 

 

Thanks for testing that :)

@Drakenex Maybe worthwhile to remove the parachute colours until the bug is fixed? Really unfortunate :( 

LOL

 

Thanks!

Share this post


Link to post
Share on other sites
1 hour ago, Beale said:

The escape tower is propped from the orbital module with some octagonal girders.

Then as @HooHungLow mentions, attach to the abort action group with these actions:

  • trigger fairings,
  • decoupler capsule / OM
  • fire LES

Works 100% of the time 90% of the time :wink:

I usually put an extra decoupler below the fairing, and have abort just activate that decoupler, and the LES.

From that point, the staging takes care of itself and you can just spacebar into a normal-ish recovery.

Share this post


Link to post
Share on other sites

I can't find the old D2, which is what I would like to use. (Sorry if this appears rude)

I was thinking if @Beale will allow it, I would try to make it work in 1.6? because it is the only stockalike D2 I know of, even though it is very old.

Share this post


Link to post
Share on other sites
2 hours ago, Beale said:

Sounds okay to me, should look something like this:

Thanks, this worked.

2 hours ago, Beale said:

@Drakenex Maybe worthwhile to remove the parachute colours until the bug is fixed? Really unfortunate :( 

Drakenex fixed the bug by changing the parachutes' texture switching to using Firespitter rather than stock texture switching, @grayal Do you see stock texture switcher prompts on the parachutes? If so, maybe you're using an older version of TNiC.

Share this post


Link to post
Share on other sites
Posted (edited)
42 minutes ago, Barzon Kerman said:

I can't find the old D2, which is what I would like to use. (Sorry if this appears rude)

I was thinking if @Beale will allow it, I would try to make it work in 1.6? because it is the only stockalike D2 I know of, even though it is very old.

If you are able to find it, absolutely you can do whatever you like with that.
Really, it would be better to make it from scratch though - I am pretty sure the little animation trick I used on that no longer works in KSP and will break the game/camera.

Edited by Beale

Share this post


Link to post
Share on other sites

What are you all doing to get the 2nd stage and decoupling ring to return to earth to prevent the dreaded space junk build up?

Are you all separating the soyuz capsule and orbital module from the 2nd stage before it falls back to earth?

Share this post


Link to post
Share on other sites
Posted (edited)
23 minutes ago, Kilo60 said:

What are you all doing to get the 2nd stage and decoupling ring to return to earth to prevent the dreaded space junk build up?

Are you all separating the soyuz capsule and orbital module from the 2nd stage before it falls back to earth?

Are you launching or returning from orbit? 

If you're launching you can separate your orbital craft from your launch stage before you circularize. Leave the launch stage on a suborbital path and use the orbiter engines to raise your PE above the atmosphere.

Side note: KSP only deletes "on-rails" suborbital junk if it's PE is below 25km. In reality if the PE is in the atmosphere it's going to de-orbit pretty quickly, so I just go in and stop tracking anything that has a PE in the atmosphere - it's not really cheating, it's fixing an issue with how KSP handles junk

If you're trying to avoid space trash when you're returning you can drop your PE into the atmosphere before separating the orbital module and Service module. That way they'll fall to Kerbin.

Edited by Tyko

Share this post


Link to post
Share on other sites

Not sure of the craft, barely uncontrollable, rough ride, adidas space program, so glad to have this spaceship/station in Tantares ! <3

1551832380-220200-20190306011626-1.png

Share this post


Link to post
Share on other sites
2 hours ago, Beale said:

Github

Polyus updates.

lyCChKA.jpg

giphy.gif

Pew pew pew

Share this post


Link to post
Share on other sites
45 minutes ago, DiscoSlelge said:

Not sure of the craft, barely uncontrollable, rough ride, adidas space program, so glad to have this spaceship/station in Tantares ! <3

1551832380-220200-20190306011626-1.png

 

Beautiful...!

 

Is that one of the craft files?

 

 

Share this post


Link to post
Share on other sites
6 hours ago, sslaptnhablhat said:

Thanks, this worked.

Drakenex fixed the bug by changing the parachutes' texture switching to using Firespitter rather than stock texture switching, @grayal Do you see stock texture switcher prompts on the parachutes? If so, maybe you're using an older version of TNiC.

I used CKAN to install TNIC last week. How do i get the new version, I assumed the one i installed was the newest one. 

Share this post


Link to post
Share on other sites
29 minutes ago, grayal said:

I used CKAN to install TNIC last week. How do i get the new version, I assumed the one i installed was the newest one. 

I'd stop using CKAN if I were you.  I've heard about too many issues with it, and some mod creators even dropped support for it.  Installing mods to KSP is just drag and drop into the GameData folder.

Share this post


Link to post
Share on other sites
14 minutes ago, Deltac said:

I'd stop using CKAN if I were you.  I've heard about too many issues with it, and some mod creators even dropped support for it.  Installing mods to KSP is just drag and drop into the GameData folder.

Yeah i have been getting that feeling lately. 

Thanks again to all for your help 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.