Ippo

[1.0.5 - Alpha 6] Dang It! (12 september 2015)

Recommended Posts

Thank you! This is a great idea. I've got it installed and I'll be sure to report any bugs. One suggestion I have immediately would be for the different sized capsules to have different capacities for holding spare parts (not sure how difficult that'd be though). I'm definitely looking forward to the addition of spare part containers and repair stations. I also think it would be cool to have the parts' probability of breaking also be based on how you use it, for instance letting engines start to overheat, getting close to the impact tolerance of parts, or make parts get closer to breaking if you enter the atmosphere with everything in flames.

This is generally for the heavy mod users, but how do you think this would effect re-usable rocket/spaceplane designs and permanent colonies/space stations? I couldn't tell from the description if the aging effects inactive vessels.

Share this post


Link to post
Share on other sites
You have to be close to a command pod or probe and right click: you should see a "Take parts" event in the menu. As above, screenshots later.

Then there must be a problem with me because no menu opens :(

Share this post


Link to post
Share on other sites
Hey, most of my ideas (see p3) made it into this mod!

And on control surfaces: leave them as it is. On a real craft, they are always exposed and always prone to failure.

Dude, I swear to god, I hadn't read your post until this morning O.O

I had seen that thread, of course (that's where I got the regex code), but had stopped reading before you posted your suggestions!

Well, I see that most of the remaining stuff is not only very feasible with what I'm doing, but also fits very nicely in the general philosophy of this mod :)

Share this post


Link to post
Share on other sites
ModuleEnginesFX does exactly the same thing as ModuleEngines, except that it allows for fancier graphical effects. All engines added since 0.23 (i.e., RAPIER, both 3.75m engines, the new SRBs, and the Launch Escape System) use ModuleEnginesFX instead of ModuleEngines. Many mods use ModuleEnginesFX as well.

I just checked: code-wise, it's not a subclass, so the current EngineReliability module cannot work as is. The simples fix will be a separate reliability module for the EngineFX, but there are a grand total of FIVE lines of code that needs to change. It would bother me a lot to duplicate this much code for just five lines, so I will try to get around it using templates (and will fail horribly).

One suggestion I have immediately would be for the different sized capsules to have different capacities for holding spare parts (not sure how difficult that'd be though). I'm definitely looking forward to the addition of spare part containers and repair stations.

This is generally for the heavy mod users, but how do you think this would effect re-usable rocket/spaceplane designs and permanent colonies/space stations? I couldn't tell from the description if the aging effects inactive vessels.

The first point is only a matter of cfg files. Obviously, I haven't written cfg files for single parts yet: I'm using Module Manager to slap the same module onto every command pod, with the same values. You can just add a separate config file for the parts you are interested, like this:


@PART[mk1pod]:BEFORE[DIRandomFailures]
{
// spare parts module with the values you like
}

For the second part: inactive parts do age, but only if they are set to age always. In this case, their age is equal to the mission time, and so it increases also during time warps and when inactive. Currently this only applies to tanks and control surfaces. Of course this prevents permanent space stations (even though, with the current values, the EOL of tanks is around 17 years).

I will comment more on re-using when 0.24 is out: at that point I will be able to see how I can factor the budgets in. If you get any budget back when you recover ships, I will see if it's possible to reduce the recovery value for worn out parts, and the like. Of course, these features are merely theoretical until 0.24 is out.

Then there must be a problem with me because no menu opens :(

Please check this: when you are in the VAB, right click on an engine or a command pod. The LV45 engine should be perfect. When you right click, in the information tab you should see the reliability modules (engines, alternator and gimbal for the LV45). If you don't see them, then the mod is not loaded at all.

If you wanna go the advanced route, press alt + f12, choose the "Database" tab, and open the list of loaded assemblies: you should see a DIRandomFailures.dll in the list.

Share this post


Link to post
Share on other sites
Please check this: when you are in the VAB, right click on an engine or a command pod. The LV45 engine should be perfect. When you right click, in the information tab you should see the reliability modules (engines, alternator and gimbal for the LV45). If you don't see them, then the mod is not loaded at all.

If you wanna go the advanced route, press alt + f12, choose the "Database" tab, and open the list of loaded assemblies: you should see a DIRandomFailures.dll in the list.

Only see gimbal :( However parts do break and show red, also see Spare in the command pod but I cant take them. Do you have any idea on how to fix this ? :(

Share this post


Link to post
Share on other sites
Only see gimbal :( However parts do break and show red, also see Spare in the command pod but I cant take them. Do you have any idea on how to fix this ? :(

I've added screenshots on the first page on how it should look.

Do you have any other mod installed? If you have the gimbal then I don't know. I will investigate and let you know, but for today I can't work on it, so don't expect a fix for a couple of days, sorry :(

Share this post


Link to post
Share on other sites
I've added screenshots on the first page on how it should look.

Do you have any other mod installed? If you have the gimbal then I don't know. I will investigate and let you know, but for today I can't work on it, so don't expect a fix for a couple of days, sorry :(

Yeah the menu from the screenshot is not showing. Here is a list of all the mods I have in case it helps:

Alternative Resource panel 2.2.0.0

Astronomer`s Visual Pack 3.0

Chatterer 0.5.9.3

Docking Port Alignment 3.1

Engineer Redux 0.6.2.1

Enhanced Navball 1.2

Environmental visual Enchantments

Kerbal Alarm Clock 2.7.3.0

Notes 0.9.1

Science Library 1.1

Speed Unit Changer 1.2

Tac Life Support 0.8.0.4

Tac Self Destruct 1.3.1.3

Toolbar 1.7.1

Module Manager 2.1.5 (Note that I tried the version you sent and still no changes so I keep the must recent one)

Share this post


Link to post
Share on other sites

Wouldn't it just be EVILICIOUS~ if sometimes the containment door(inside the command pod holding the spare parts) were to fail, causing you to not be able to grab spare parts?~~~~

Share this post


Link to post
Share on other sites

Not sure if this has been suggested, but I think it would be neat if there was an alarm tone/sound that occurs when the part first fails.

Share this post


Link to post
Share on other sites

1. You probably want to create an Engine wrapper. You can use the very nice one in swamp_ig's KSPAPIExtensions, for example, or model off the barebones one I have in Real Fuels.

2. For many engines, being throttled down is actually rougher on the components than being at maximum throttle, IIRC--throttling rocket engines is hard stuff.

Share this post


Link to post
Share on other sites
Wouldn't it just be EVILICIOUS~ if sometimes the containment door(inside the command pod holding the spare parts) were to fail, causing you to not be able to grab spare parts?~~~~

Refer to this: http://i3.kym-cdn.com/entries/icons/original/000/012/367/evilest.gif

Not sure if this has been suggested, but I think it would be neat if there was an alarm tone/sound that occurs when the part first fails.

Not suggested, but thought of: it will come... whenever :)

1. You probably want to create an Engine wrapper. You can use the very nice one in swamp_ig's KSPAPIExtensions, for example, or model off the barebones one I have in Real Fuels.

2. For many engines, being throttled down is actually rougher on the components than being at maximum throttle, IIRC--throttling rocket engines is hard stuff.

1. I will look into those, thanks for the pointers!

2. Well, that's cool, I didn't know it. I'll search for some info. Both models have their pros and cons, I suppose... how about a U shaped curve? So it works against you whatever you do!

3. BTW, when I saw a name as big as yours in my thread, I kinda expected a scolding :P

Share this post


Link to post
Share on other sites

Ippo: yikes! Hope I've not been running around scolding people...certainly not been trying to, although lately my patience with installation issues isn't what it once was. :]

As I said on your dev thread, I'm following this most keenly! I love random failures (I'm a realism bolshevik, that kinda goes without saying...)

As to engines--it's kinda complex, since really not many rocket engines at all are throttleable. In fact, only a few lower-stage engines and some engines designed for landers are. (The RL-10 was originally designed for the USAF lunar base mission and was thus designed to be throttleable). Throttling an engine is *hard* since it usually decreases Isp (*especially* at sea level; throttling can be done by lowering chamber pressure, but that drastically reduces sea level Isp).

The SSME has a range of about 67% to 109%. The "109%" is just because later engines had a higher max thrust and rather than redo the avionics and gauges they just left 100% at where it originally was. It's run at 109% at liftoff, then throttled down when it no longer needs so high a chamber pressure, and to lower G load for the crew. Higher chamber pressure is generally bad, but running your turbopump etc. at lower than rated RPM is also, IIRC, bad. So a U-shaped curve is probably best.

It's also worth considering whether you want 100% thrust in KSP to be "maximum thrust" or, as it were, "overthrust"--something beyond what the engine is reliably rated for, but something achievable by boosting the turbopumps, say. Then again even in KSP where you can restart them the lifetime of engines is quite short...

Share this post


Link to post
Share on other sites
Ippo: yikes! Hope I've not been running around scolding people

Actually it's more of a "Wait, *THAT* NathanKell!? OH GOD" attitude :D

Then again even in KSP where you can restart them the lifetime of engines is quite short...

I'm sorry, I don't understand: do you mean that I should increase the lifetime of the engines? If this is the case, well, 70 hours of burn time before the EOL seemed quite a lot to me, but of course, the balancing simply hasn't been done yet, so it can still change.

Share this post


Link to post
Share on other sites

Would the aging parts be able to work with MCE's vessel recovery system? I doubt it right now but perhaps if mce tracked individual parts

Share this post


Link to post
Share on other sites

URGENT: I found a über bug in the current build. The age of the parts is plain wrong, simple as that. I temporarily removed the download from GitHub.

If you already installed it, I advise you to delete it and wait for the update.

(THIS is why I called this alpha)

Share this post


Link to post
Share on other sites

Oh. Um. <blush>

Nonono, the life time you have is fine I think; I'm just saying that in the grand scheme of things (compared to a jet engine, say) your average liquid fuel rocket engine has a mayfly's life, even in KSP where you can restart them in orbit etc. Frankly I would expect something more like 10 hours for real life (booster) engines.

Share this post


Link to post
Share on other sites

Just when I was quite bored with my modded KSP I found this.

As soon as it is available, I download it!!!

Also, a suggestion for a failure(affecting SRB): unexpected ignition!

Share this post


Link to post
Share on other sites

Another idea would be that there should be a chance that equipment could have "Manufacturing" flaws which may cause it to fail, IRL that happens alot.And just in time for 0.24 and it's budget system, you could pay money for "Quality Assurance" which will lessen the chances, or even eliminate the chance of initial failure. If you do add any of my ideas in, pm me and let me know. Thanks and keep up the good work, I see potential in this mod. <3

Share this post


Link to post
Share on other sites
Another idea would be that there should be a chance that equipment could have "Manufacturing" flaws which may cause it to fail, IRL that happens alot.And just in time for 0.24 and it's budget system, you could pay money for "Quality Assurance" which will lessen the chances, or even eliminate the chance of initial failure. If you do add any of my ideas in, pm me and let me know. Thanks and keep up the good work, I see potential in this mod. <3

Budget integration will definitely be a thing, but I can't decide anything about until we know exactly how the system works and how we can influence it.

Share this post


Link to post
Share on other sites

Good news, everyone!

As far as I know, the new release should have fixed the aging bug. If you had already downloaded the first version, delete it completely before trying out the new one. You will also notice that the name has changed, both dll and github repo.

If anything goes wrong with this one, please send me the log files to m.ippolito@outlook.com so I can stare at them in despair.

Share this post


Link to post
Share on other sites
Please remove the #0 out of the imgur code.

It had been bugging me for DAYS. Thank you!

(no seriously, I'm not being sarcastic: I was so annoyed and I didn't see what was wrong with it :/ )

Share this post


Link to post
Share on other sites

Hey mate, I tried the new version still have the same issue (Can`t take spare parts on EVA), It shows the engine reliability and stuff, the command pod even has the spare parts. I got to the point of checking the cache on steam (downloaded 10 files), remove all the mods I had and leave only yours still the same issue. I wonder now If there is a problem on my procedure. When you EVA you say to click on the command pod, that means Left click/ Right click with the mouse?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.