Starwaster

[1.2.2] Ioncross Crew Support v1.26.0 (Starwaster's branch) - Jul 7, 2016

Recommended Posts

This is a branching off of Yongedevil's Ioncross Crew Support Plugin which he previously reported he was unable to continue working on. With the loss of the original download on Spaceport, I'm branching it off for the purpose of maintaining it and fixing bugs in it.

Current bugs fixed in this version are the CO2 scrubbers, which should now stay activated if you left them activated. They should no longer revert to a deactivated state.

Future changes are planned to the CO2 scrubbers. A real CO2 scrubber completely eliminates CO2 buildup until it reaches saturation, at which point it ceases to function only then will the part begin to accumulate CO2. I haven't decided what will happen next. Ideally I'd like for there to be two CO2 scrubber types available. One requiring cartridge replacement and one that works via regenerating scrubbers. (regenerating scrubbers can be restored to functionality via electrical charge and are offline during the regeneration cycle)

Latest DOWNLOAD LINK

Alternate download link:

https://github.com/Starwaster/Ioncross-Crew-Support/releases/latest

Github Source & Issue Tracking

 

If you find this mod helpful and want to throw some money away, feel free to click the donate button below!

btn_donate_LG.gif

License:

This work is branched off under Yongedevil's original license found below. Additionally, Yongedevil has granted permission for me to host the original mod.

 

Licence

Modified source code, compiled dll, and configuration files may be distributed provided they attribute the original work to me, yongedevil. However, I request you do not simply re-post the original mod as I prefer it control where it is hosted myself.

Additional License Info:

Anything added by Starwaster post ver 1.1 (toolbar integration, contracts, etc) is licensed under Creative Commons Attribution-ShareAlike 4.0 International License.

Edited by Starwaster
Update for KSP 1.2.2

Share this post


Link to post
Share on other sites

Change Log

1.25.0

  • Compiled for KSP 1.25.0
  • Added tags to parts
  • Added bulkhead profiles to parts
  • Rebranded parts

1.23.0

  • Updated O2 density & cost. (recent changes to how KSP calculated part cost was hideously inflating Ioncross resource part costs)
  • Added RESOURCE_DEFINITION for Light (for the greenhouse part)
  • Cost rebalancing on all parts
  • Updated description with more accurate duration in Kerbal days. (assuming Kerbin time where 1 Kerbin day = 0.25 Earth days)
  • Replaced panel transform. (this part had stopped working properly due to KSP updates)
  • Rescaled to account for added MODEL nodes
  • Added drag cubes to part
  • Changed generators to Ioncross generators
  • Updated default config file
  • Disabled experimental thermals

Changelog for older versions

Spoiler

 

1.22.0

  • Converters and Collectors working properly again (affects recyclers and intakes)
  • EVA life support improvements. All LS functions using FixedUpdate() instead of Update() now.
  • Kerbals on EVA and sitting in command seats or otherwise connected to vehicles will try to use external supplies first. (i.e., Kerbal sitting in rover will use the rover's bottles instead of his suit bottles)
  • EVA LS may have been disabled some time in the recent past. It is definitely active again so be careful!
  • Recyclers functionality has changed. O2 to CO2 ratio is much higher. CO2 is only a  fraction, basically being  a sort of sump tank.
  • Last plugin update for 1.0.5 barring catastrophic bug discovery. (config updates will be backwards compatible)

1.21.0

  • Updated for KSP 1.0.5
  • Known issue: Menu unavailable at this time. If per savegame enabling/disabling is desired then save games must be manually edited and isLifeSupportEnabled set to true or false as desired for enabling or disabling.

1.18.0

  • Added toolbar button to Space Center using new KSP toolbar API (from 0.24.0)
  • Per game enabling/disabling of mod
  • Resource rate / day now respects Kerbin / Earth day settings.
  • Added Contract System framework
  • First Pass resource audit.
  • Reworking of O2 / CO2 based on liters. CO2 capacity higher but so is CO2 generation.

1.17.0 - Unreleased

1.16.4

  • Fixed resource consumption bug (RateBaseMod wrapper returning rateBase instead of rateBaseMod)

1.16.3

  • Fixed EVA resources not being reloaded after game exit.
  • Set recycler ElectricCharge amount / maxAmount to 1 (values of 0 are 'bad')
  • Temporarily restored CarbonDioxide flowMode and transfer to original values while recycler operation verified
  • Pressure cleaned the back.

1.16.2 - Recompiled for KSP 0.24.2 (no other changes; just for compatibility purposes)

1.16.1 -Air Vents now use electricity to increase airflow but are not dependent on it. Air vents will still operate at a reduced state if deprived of power but will still circulate enough air to keep the crew alive

1.16.0 - Updates Ioncross to KSP 0.24.1 compatibility - Tweaks to Air Vents because they weren't providing enough air

1.15.1 - Compiled for 0.24 (for real). 1.12 refactoring reverted. Removed scrubbers/vents config. (release pending)

1.14.0 - Fix for EVAing Kerbals draining all EVA resources from originating ship. EVA resources return to boarded ships. Porkjet Inflatable Habitat support files. Herobrine removed.

1.13.1 -Hotfix for scrubbers and vents issues (config file to add scrubbers/vents)

1.13 - Scrubber inclusion shifted to config file (ModuleManager_AddScrubbersAndVents.cfg) to prevent ModuleManager 2.x.x smashing scrubber data in save files. Plugin update prevents Kerbals from coming back to life after asphyxiation has occured.

1.12 - Starwaster branch off. Refactoring of node saving / loading. (only data types that can't be made KSPField persistent need special OnLoad() / OnSave() handling. Everything else moved to KSPField). Scrubbers being set inactive fixed.

1.11 - Original Ioncross dev version

 

 

Edited by Starwaster
Updating for KSP 1.1.3 update

Share this post


Link to post
Share on other sites

Just realized, long standing issue that always bothered me is still unfixed:

Here is a config file for Module Manager that runs after all others have run and if it finds parts with crew capacity that are lacking life support, it adds it. (up to 10 Kerbals only at this time)

Download will be updated, but I kind of screwed that up and uploaded a second file that apparently has to be reviewed, which isnt how I wanted to do it :(

This file is now part of the official download. All parts with crew capacity up to 10 will have life support added. (because this is being done as a config file and because of limitations with how it works, an arbitrary number had to be chosen and ten separate configs created.)

Edited by Starwaster

Share this post


Link to post
Share on other sites

I'm religious user of this mod so I'm really please your taking the effort keep it up to date. I wanted to myself but I haven't had to the time to even learn where to start!

Share this post


Link to post
Share on other sites
I'm religious user of this mod so I'm really please your taking the effort keep it up to date. I wanted to myself but I haven't had to the time to even learn where to start!

This might sound dumb, but sometimes the best way to learn how to start is .... just to start. Everyone's gotta do 'Hello World' eventually. (so to speak)

Share this post


Link to post
Share on other sites

I put an alternate set of config files up alongside the main download.

The purpose of those is to fix yet ANOTHER scrubber bug. This one is actually related to the latest version of Module Manager.

Symptoms of this bug are that every time something changes one of the modules in one of your save games, the scrubber modules are deleted! When you load the game in they are immediately reinstalled by Ioncross but they are turned off.

The tl;dr of this is that scrubbers don't (usually) get added by config files. They get added to parts when KSP loads up the main menu. The latest versions of Module Manager dynamically manage modules on parts and may delete them under certain circumstances. It does this on a per save game basis to fix a long standing bug of a seriously game breaking nature. Since MM runs before Ioncross it doesnt get a chance to see that the modules actually belong there, etc etc.

Merged the alternate set into the main files. Originally it was just going to be a stopgap measure while I worked on another solution in the plugin, but that's not working out so I decided to just explicitly put the various generator files into the parts with config files (instead of letting the plugin do it dynamically)

Edited by Starwaster

Share this post


Link to post
Share on other sites
@Starwaster - link to your MM config to add life support to all crewed modules is dead. And if you'd like to re-use the life support canisters I made for TAC LS, please do.

That's strange, I wonder what happened to it.

Actually though, I forgot I posted it and it shouldn't matter. There should be one in the main download now.

Unfortunately I can't check because I'm having rather bad luck with computers. My main one is down and my cat threw up on my macbook RIGHT after I got it all set up to continue working on this mod with monodevelop. Keyboard is non responsive now.

Would someone please look in the IoncrossCrewSupport folder and tell me if there is something like 'ModuleManager_Default.cfg' there?

Share this post


Link to post
Share on other sites

Minor update: Final scrubber fix. Merged the 'alternate configs' into the mod instead of them being optional

Share this post


Link to post
Share on other sites

Wow, i'm really not doing so great this past month. Multiple hardware failure's on every computer have, sloppiness in uploading this mod...

The default configuration file that adds life support to crew parts lacking it is not working because i screwed up case sensitivity.

Here's the file again, while the Curse link is being updated:

https://www.dropbox.com/s/qduqb69wvtpccmj/ModuleManager_Default.cfg

Share this post


Link to post
Share on other sites

And, I just realized but the update yesterday also included a fix for Kerbals not properly removing themselves from parts after death. Now it's for keeps. If your Kerbal asphyxiates, he's not going to magically reappear inside the ship, or be available to EVA. But don't think of them as dead. Think of them as.... eating snacks. ​IN ANOTHER DIMENSION.

Share this post


Link to post
Share on other sites

Starwaster,

The ratePerKerbal in the IoncrossBase file, is that per second, per hour or something else?

I'm starting to look at how Ioncross could work with Universal Storage.

Share this post


Link to post
Share on other sites
Starwaster,

The ratePerKerbal in the IoncrossBase file, is that per second, per hour or something else?

I'm starting to look at how Ioncross could work with Universal Storage.

I'm still familiarizing myself with some parts but I'm pretty sure it's per second. (looks like it's being called through OnUpdate() which is called every frame which should then multiplied by deltaTime)

Share this post


Link to post
Share on other sites

Love the concept and its really awsome that you are keeping this mod alive, Starwaster:kiss:.

Want to use this mod in my career, with Mission Controller but when loading the game i get 2 errors in ModuleManager_AddScrubbersAndVents.

Can i ignore them or does this mean scrubbers do not work atm? Tried isolating the mod in a fresh KSP install to check for conflicting kode of some sort, but with no result.

Share this post


Link to post
Share on other sites
Love the concept and its really awsome that you are keeping this mod alive, Starwaster:kiss:.

Want to use this mod in my career, with Mission Controller but when loading the game i get 2 errors in ModuleManager_AddScrubbersAndVents.

Can i ignore them or does this mean scrubbers do not work atm? Tried isolating the mod in a fresh KSP install to check for conflicting kode of some sort, but with no result.

I need to see the error to know if you should be concerned or not. Can you post it here please?

Share this post


Link to post
Share on other sites
Download link below contains a picture of loading screen and KSP loading log =D hope it helps

http://s000.tinyupload.com/index.php?file_id=17269491155630153690

It's probably a parse error. This is why I hate doing this on a Macbook. Just not familiar with the tools I'm having to work with. (ordinary text editor instead of Notepad++ and Monodevelop instead of Visual Studios). Oh, and a slow *** Macbook at that because my cat vomited on the only decent Macbook I have with its I7 core that handles KSP really well and this one struggles under the load... (thanks, Melificent) and oh look! this one is developing a fault in its keyboard too :(

Anyway.

Edit the ModuleManager_AddScrubbersAndVents file and replace the entire contents with the code below. (I'll re-upload the file in a short while)


[FONT=Menlo]@PART
[*]:HAS[@MODULE[IonModuleCrewSupport],!MODULE[IonModuleGenerator]:HAS[#generatorName[CO2Scrubber]]]:AFTER[IoncrossCrewSupport]:NEEDS[IoncrossCrewSupport]
{
MODULE
{
name = IonModuleGenerator
generatorName = CO2Scrubber
generatorGUIName = Scrubber

startOn = True

hideStatusL2 = True
hideEfficency = True
hideOutputControls = True

OUTPUT_RESOURCE
{
name = CarbonDioxide
rateBase = 0
ratePerCapacity = -0.0000031558
effectOnEfficency = 1
}
}
}
@PART
[*]:HAS[@MODULE[IonModuleCrewSupport],!MODULE[IonModuleGenerator]:HAS[#generatorName[AtmoVents]]]:AFTER[IoncrossCrewSupport]:NEEDS[IoncrossCrewSupport]
{
MODULE
{
name = IonModuleGenerator

generatorName = AtmoVents
generatorGUIName = Air Vents

minAtmosphere = 0.5
isAutomaticOxygen = True

hideStatusL2 = True
hideEfficency = True
hideOutputControls = True
hideAtmoContents = True

OUTPUT_RESOURCE_OXYGEN
{
name = Oxygen
rateBase = 0
ratePerCapacity = 0.0000028935
effectOnEfficency = 0
}
OUTPUT_RESOURCE_OXYGEN
{
name = CarbonDioxide
rateBase = 0
ratePerCapacity = -0.0000021039
effectOnEfficency = 0
}
}
}

Share this post


Link to post
Share on other sites

Awsome mate, that did the trick. Thanks alot, and thanks for the quick respond/fix considering your current predicament :D

Share this post


Link to post
Share on other sites

Starwaster - Textmate is free for evaluation (no expiration) and is as full-featured as Notepad++. I highly recommend it. Can sympathize with the "slow MacBook" issue - I'm on a 2009 MacBook since I lost access to my 2013 MBP when I left my previous employer.

Looking forward to seeing what happens with this mod, especially with scrubbers - one of the very few things I *don't* like about TAC Life Support.

Share this post


Link to post
Share on other sites
Starwaster - Textmate is free for evaluation (no expiration) and is as full-featured as Notepad++. I highly recommend it. Can sympathize with the "slow MacBook" issue - I'm on a 2009 MacBook since I lost access to my 2013 MBP when I left my previous employer.

Looking forward to seeing what happens with this mod, especially with scrubbers - one of the very few things I *don't* like about TAC Life Support.

It's been awhile since I used TAC, what's the deal with scrubbers? Or does it just not have them?

Share this post


Link to post
Share on other sites

I've recently added this plugin to my KSP install and mostly like it. But I've noticed something that may be a bug but may also be a "working as intended feature". I've got a small-ish space station that includes a lab and habitation module (both from default game). Currently only a single Kerbal lives on the station so there's plenty of air for him. I recently docked a ship to this station and wanted the pilot to do an EVA to add some modules (also using KAS) to the station. I turned off the O2 feed in the pilot's capsule and disabled crosslink on the docking port. Then had the pilot EVA for about 30 minutes. When I get the pilot back into the capsule and made sure everything was turned back on, I discovered that the hab and lab modules on the docking station no longer had any O2. Do you really have to turn off O2 for every module if you want a Kerbal to do an EVA or did I miss something? I don't want the Kerbals I have living in my space station suffocating just because another Kerbal from a docked ship does a quick EVA.

Share this post


Link to post
Share on other sites

I remember getting this mod in 0.20!

I've never really been into life support mods even up to now though. Good effort maintaining the mod.

Share this post


Link to post
Share on other sites
I've recently added this plugin to my KSP install and mostly like it. But I've noticed something that may be a bug but may also be a "working as intended feature". I've got a small-ish space station that includes a lab and habitation module (both from default game). Currently only a single Kerbal lives on the station so there's plenty of air for him. I recently docked a ship to this station and wanted the pilot to do an EVA to add some modules (also using KAS) to the station. I turned off the O2 feed in the pilot's capsule and disabled crosslink on the docking port. Then had the pilot EVA for about 30 minutes. When I get the pilot back into the capsule and made sure everything was turned back on, I discovered that the hab and lab modules on the docking station no longer had any O2. Do you really have to turn off O2 for every module if you want a Kerbal to do an EVA or did I miss something? I don't want the Kerbals I have living in my space station suffocating just because another Kerbal from a docked ship does a quick EVA.

No, that sounds horribly wrong... I think they take some oxygen with them on EVA. But clearly they're being a bit gluttonous with the oxygen. Maybe they panic when they run out of snacks and start hyperventilating. (jk)

I'll go over the code

Edit: Until I find the cause, go into IonCrossBase.cfg and look for the lines below and change them to 0 for each line


evaAmount = 1
evaMaxAmount = 1

Edited by Starwaster

Share this post


Link to post
Share on other sites

Thank you Starwaster. That resolved the issue, at least until the bug can be fixed.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.