Starwaster

[1.2.2] Ioncross Crew Support v1.26.0 (Starwaster's branch) - Jul 7, 2016

Recommended Posts

Seems to be working fine. Futhermore, I've added water as a resources (0.5 liter/day) and everything seems to be calculating properly.

Share this post


Link to post
Share on other sites

There's a bug that I cannot pinpoint. IonCross is causing the a Kerbal to eject (float) upwards at a sustained rate of about 8 m/s. Like it is gravity in the negative.

Share this post


Link to post
Share on other sites
There's a bug that I cannot pinpoint. IonCross is causing the a Kerbal to eject (float) upwards at a sustained rate of about 8 m/s. Like it is gravity in the negative.

that's a neat trick considering Ioncross doesn't apply forces.

Log files please?

Share this post


Link to post
Share on other sites

I agree. However, troubleshooting which mod it was that was causing the issue, I pulled them off one-by-one (Univ. Storage, DMagic's science/ScanSat, ATM, EVE, MechJeb, Final Frontier, Remote Tech [it is broken, too], Mission Controller, a collection of parts from Near Future, FTMN, and B9 with a greenhouse [Z's], stock-a-like stations, and Chatterer - my core w/IonCross). I had everything stripped down and then re-installed KSP. Unfortunately, I don't have logs since I haven't put IonCross back in, however, you could hear the breathing and the suits rockets (no animation).

The only change to IonCross that I've made, was by adding water as a resource (1.0/liter/day (6hr). I haven't tried a clean install of IonCross.

Share this post


Link to post
Share on other sites
Apropos of nothing, what did you set water's weight/density/whatnot as?

Doesn't really matter since the clean install didn't work either. I'm a little frustrated.

However, I had water set to density of 1.0 and with a volume it should calculate. Btw, why was it set to 0.001 (I may have missed some calculation here).

Edited by Meridius

Share this post


Link to post
Share on other sites

Can confirm the same bug Meridius is having. Kerbals on EVA ignore drag and gravity, but can still walk on the ground if you land and can still use the jet pack. Jet pack has no FX but produces thrust and uses fuel. Right clicking on the Kerbal shows Oxygen at 0.0%.

Starts spamming ArgumentOutOfRangeException's as soon as you EVA. No other issues with the mod.

Log: https://www.dropbox.com/s/ili1601evxab9hw/KSP.log?dl=0

Tested with the latest mod version with the recompiled .dll and MM 2.6.3. No other mods.

Share this post


Link to post
Share on other sites

Thanks, but can you please submit an output_log.txt instead of ksp.log? ksp.log isn't as informative. (if you're on Mac or Linux versions then it's player.log)

Share this post


Link to post
Share on other sites

Yes, only EVA's cause issues. No mod conflicts as far as I can tell.

Everything seems to work just fine otherwise, just have to fix the part nodes. Maybe do some re-balancing and update the part descriptions. A unique texture for the large radial tank would be nice too.

Share this post


Link to post
Share on other sites

Sorry for the delay on this:

KSP 1.0.4 Updates

  • Changed from Update() to FixedUpdate() (should help performance)

  • Renamed IonModuleCollectorAtmosphere to IonModuleCollector. (to fix VAB module description from GetInfo() )

  • Moved initialization for some data structures to OnAwake(). (some fields weren't initializing properly anymore)

  • Converted textures to DDS

Share this post


Link to post
Share on other sites

Can anyone confirm that resources are not being used during when time warping or using another vessel?

Thank you.

Share this post


Link to post
Share on other sites
Can anyone confirm that resources are not being used during when time warping or using another vessel?

Thank you.

I can't because I tested for that. Even tested to make sure that they died when resources exhausted or CO2 buildup was too much.

What parts are you using?

Share this post


Link to post
Share on other sites

There were other problems. Clean install and the mod works perfect.

CKAN support? This is a good mod. I add water as a resource and adds another layer of complexity.

Edited by Meridius

Share this post


Link to post
Share on other sites

I did find a problem that is probably not apparent to anyone: One change that was supposed to have been made in the last update was to use FixedUpdate instead of Update or OnUpdate. The difference is that FixedUpdate (as the name implies) runs at a fixed rate of every 0.02 seconds. (50x a second)

Update however runs every graphics frame update. Considering that graphics frame rate can be over 60x second (my hardware can do 120x second for 3D support) that can make things more expensive in CPU resource use than necessary.

So another update is coming out as soon as Forge approves it.

CKAN... maybe

Share this post


Link to post
Share on other sites
does this work with USI Life Support?

...

I have no idea.

Probably not. Let's think about this for a moment.

You install two life support mods. Each one is going to cycle through parts that have Kerbals in them and try to consume oxygen and generate CO2.

Or maybe one of them consumes generic life support resources; I have no idea what USI actually uses.

But they're both doing this simultaneously so at best you have to carry around two sets of different resources.

Or at worst they both drain the SAME resources. Two mods doing the same work consuming in total twice as much resources.

That doesn't sound like Epic Tiger's Blood Winning to me.

Pick the mod you like using the best and stick with it ;)

Share this post


Link to post
Share on other sites
...

I have no idea.

Probably not. Let's think about this for a moment.

You install two life support mods. Each one is going to cycle through parts that have Kerbals in them and try to consume oxygen and generate CO2.

Or maybe one of them consumes generic life support resources; I have no idea what USI actually uses.

But they're both doing this simultaneously so at best you have to carry around two sets of different resources.

Or at worst they both drain the SAME resources. Two mods doing the same work consuming in total twice as much resources.

That doesn't sound like Epic Tiger's Blood Winning to me.

Pick the mod you like using the best and stick with it ;)

ah well its cause USI only uses "supplies". you run out and after 15 days your kerbals refuse to work.

i was hoping to add oxygen as well so thered be a risk of death, along with the "were out of snacks f-u we no work until we get some snacks"

Share this post


Link to post
Share on other sites
ah well its cause USI only uses "supplies". you run out and after 15 days your kerbals refuse to work.

i was hoping to add oxygen as well so thered be a risk of death, along with the "were out of snacks f-u we no work until we get some snacks"

Ah I see... it would probably be ok then, but be safe and backup your game first.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.