BahamutoD

[1.0+] B.Dynamics - Retracting/vectoring engines etc. v1.2.0 (May 6)

Recommended Posts

First of all massive props for the mod! I love those engines! I still have to try out the crawler but I can't wait...

Now to my problem..

I have a weird bug with your radial engines. The thrust vector seems off. In the editor Everything looks ok but when I thrust the craft starts to spin. Is this a bug with your engines or ksp? Maybe you have a suggestion?

Thanks

http://i.imgur.com/NEpPl6z.png

http://i.imgur.com/S70LbDl.png

This might be a dumb answer but.... I don't see SAS or rcs turned on in the picture. Does it spin when those are turned on? Also did you attach them with the angle snap tool on?

Share this post


Link to post
Share on other sites
This might be a dumb answer but.... I don't see SAS or rcs turned on in the picture. Does it spin when those are turned on? Also did you attach them with the angle snap tool on?

I've had the exact same problem when bahasp engines are present, but I'm not quite sure the mod itself is causing the problem, some other mod, or a misinteraction.

I've had retractable cluster engines thrust to the left for no reason, in symmetrically placed engines in the SPH. For no reason. A ship can be working perfectly, and suddenly it will fire to the side instead of downwards, and no amount of taking those engines off and back on will help it, the only way you can make it work again is making a different ship, placing them, and hoping they don't go nuts. The difference is that in some cases I will see the center of thrust shift to the side on the VAB/SPH, unlike in mightydread's post. Sometimes.

But here is the problem: I've experienced that on STOCK engines as well, on designs where BahaSP engines were present, but not firing:

First there was this design, which contained a bahaSP vector inline within the fairing, but wasn't firing at launch. It worked perfectly for a number of launches, then all of a sudden it would thrust to the side and slam into the ground a few meters in. I double checked everything was symmetrical, all thrust was fine, no controller problems. No matter what I did, the design seemed corrupted. But you could argue that it's a very stupid rocket design and that the weird shape or whatever were messing it up.

But then I had problems with this upper stage as well, which had no bahaSP engines, but retractable RCS blocks. The stage went well up until the after the transmunar injection, after which it would suddenly thrust off to the side. That's where I figured out that if you turned the gimbal in the engine off, and just let the SAS work that problem would disappear.

So maybe the BahaSP parts are doing something to the center of thrust? Maybe the gimballing? Maybe it's a problem with another mod? I have no idea. I have used the inline vector for a lot of flights now and it doesn't seem to have much of a problem, same for the retractable clusters.

Edited by Ottomic

Share this post


Link to post
Share on other sites

FWIW, I've experienced what Otto is talking about as well.

Luckily the part I'm most interested in, the Critter Crawler, seems to work fine.

Share this post


Link to post
Share on other sites

Is there any way to prevent this?

Also, the engine thrust transform gimbals much faster than "wall of gimbals" - visual part.

K4K7Qmd.png

Share this post


Link to post
Share on other sites

Has anybody else run into issues with the ILX-40?

The engine gives the thrust I desire, but seems to have orientation issues.

If you fit it in the SPH/VAB, it points forwards.

If you rotate it to point in the right direction, it vectors in the wrong direction.

Turning left turns right instead.

Other engines seem to function fine, and aerodynamic surfaces rotate as expected.

The placement around the CoM does affect the direction of thrust, but it's always in the mirrored direction.

Share this post


Link to post
Share on other sites

Hi there. So, im running a rather heavily modded install right now for some military vehicle design, and im hving a conflict in mods. Specifically, with this mod, and the adjustable landing gear. Simply, if i use the adjustable landing gear's Dll provided, then this mod ceases to function, and vice versa for this mods BahaAnimationModuules.dll

Is there any known fix for this?

Share this post


Link to post
Share on other sites
Hi there. So, im running a rather heavily modded install right now for some military vehicle design, and im hving a conflict in mods. Specifically, with this mod, and the adjustable landing gear. Simply, if i use the adjustable landing gear's Dll provided, then this mod ceases to function, and vice versa for this mods BahaAnimationModuules.dll

Is there any known fix for this?

Hmm I use both and just used the needs .dll and it ran fine for me. What specifically isn't working?

Share this post


Link to post
Share on other sites
Hmm I use both and just used the needs .dll and it ran fine for me. What specifically isn't working?

TBH, pretty much everything. If i use one Dll, the entire other mod's parts stop working, and vice versa.

Share this post


Link to post
Share on other sites

Hey- I LOVE this mod, it's one of the first I always download- but I was wondering. Any chance I could get a 2.5m version of Critter Crawler? I mean I can scale it up myself, of course, but I was wondering if there was some way we could get a "Heavy duty" version for larger crawlers? It's amazingly useful...

Share this post


Link to post
Share on other sites

I especialy like this mod License, it allows me to integrate it into Installar. You might ask what for, they are already very cool, just imagin want happens when you power these parst with Megajoules instead of crude chemical propellants :cool:

Edited by FreeThinker

Share this post


Link to post
Share on other sites

The spotlight turret is so powerful that it can light up Kerbin from Mun. :P Is it intentional?

Share this post


Link to post
Share on other sites

can you make the vector lighter? its too heavy for stock parts

- - - Updated - - -

The spotlight turret is so powerful that it can light up Kerbin from Mun.

Wow, it can also light the mun from kerbin o_O

Share this post


Link to post
Share on other sites

Hello! I have a weird problem (might be too many mods...^)

I'm positive a few days ago the engines were still working (but I might have used the Landertron ones and only saw the ILX 40 looking one in action)

Now when trying to use the retractable liquid/oxid engines the two big ones

VTx-202 Retractable Engine and ILX-40 Retractable Engine don't receive fuel when put on to fuel tanks (i have to use the fuel line thingy)

the ttr1 works fine for some reason, I have compared the part.cfgs with the notepad++ plugin compare and I wasn't able to change it (tho I tell myself earlier for a short time the VTx worked, but whatever I did i undid and the only thing I can remember was carrycross thingy, which wasn't what made it work.

changing the engine module to the ModuleEnginesFX didn't fix it either, I will probably give them their own fuel reserve and make use of the fuel line thingy.

I dunno, could have InterstellarFuelSwitch, FuelTanksPlus or a mod like that have broken it? I really don't want to use external fuel ducts.

and my tries in fixing it were in vain, since I can't spot an obvious difference between ilx/vtx and ttr that would make the ttr function as fuel receiving but the ilx/vtx not

I've tried a few things from the module and CFG file documentation but to no avail

could CModuleFuelLine help me?[h=3][/h]

Share this post


Link to post
Share on other sites

I've noticed a node issue on the bottom of the critter crawler. Seems like every decoupler I try to put under it will only connect to the bottom node of the decoupler, not the top. Not sure how to fix this, but in the meantime I'll try flipping my probe over and attaching from the top. Only downside to that is getting it flipped around to land could be a bit touchy...

Share this post


Link to post
Share on other sites

I can confirm the issue that user Ghostshark27 posted above. Apparently, the bottom node on the Critter Crawler is "facing the wrong way", resulting in a problem when trying to attach something to said node: it uses the bottom node on the part being attached as well, instead of the top one, making it impossible to create a proper staging sequence using said node (and causing all sorts of nasty clipping if you're trying to attach something taller than a regular decoupler).

Other than that, the CC works perfectly, and I must say it's one of my favourite things: cute, cool, and useful.

Share this post


Link to post
Share on other sites

I discovered another issue with the CC: Apparently FAR's shape detection always treats the claws as deployed. The phantom claws create a bump in the cross section where they "stick out" of the fairing, and show up when debug voxels is turned on.

Edited by Spheniscine

Share this post


Link to post
Share on other sites

Workaround found for the Critter Crawler node issue: edit GameData/BahaSP/Parts/CritterCrawler such that on the line:

node_stack_bottom = 0.0, -0.5483629, 0.0, 0.0, 1.0, 0.0, 1

Add a minus sign to "1.0" so that it's now:

node_stack_bottom = 0.0, -0.5483629, 0.0, 0.0, -1.0, 0.0, 1

As for the FAR thing, the only workaround I know of right now is to make fairings wider (2.125m for PF). This is of course less than satisfactory as wider fairings mean more drag.

  • Like 1

Share this post


Link to post
Share on other sites

Is this mod still being actively developed/managed? If so I would like an update on the transition to 1.0.5 if possible.

BTW this mod seriously rocks. I never even use the stock RCS modules anymore, why bother when these can retract and be aerodynamic when not using them? Also the ILX engines are very useful for re-entry and landing, really they're useful as retrorockets in general. All the more reason why I'd like to see it updated. Hopefully it's as easy as slapping a 1.0.5 version number onto the meta-tag and moving along.

Edited by Auriga_Nexus

Share this post


Link to post
Share on other sites

this is one of the more unique part mods with excellent utility, texture and animations. Would def hope it continues to see support from BD at some point - but I realize he has a lot of mods on his plate these days so might be a while until he comes back around to this one

Share this post


Link to post
Share on other sites
this is one of the more unique part mods with excellent utility, texture and animations. Would def hope it continues to see support from BD at some point - but I realize he has a lot of mods on his plate these days so might be a while until he comes back around to this one

BD lists Adjustable Landing Gear as compatible with 1.0.5, which uses the same custom animation DLL as these parts. The engine configs could use a pass to make sure they're in line with stock thermo updates and other performance factors, but (with personal testing) they work just fine.

  • Like 1

Share this post


Link to post
Share on other sites
can you make the thrust vectoring engine CoM offset like the other engines? its a bit hard to do aircraft with them

Share this post


Link to post
Share on other sites

Hey, Bahamuto, as the Modder-in-Chief on Animations, would you be interested in creating a launch clamp pack?

Share this post


Link to post
Share on other sites

what would be the easiest way to change the color on the flip out engines to white rather than grey 

 

Share this post


Link to post
Share on other sites
6 hours ago, Virtualgenius said:

what would be the easiest way to change the color on the flip out engines to white rather than grey 

 

If you have the software to do so, it's probably just opening the texture for that part (if in doubt, check the part's CFG file for the texture's path) and editing it to what you want. Should be simple-ish if it's just a color change. You could probably sample the colors from the stock parts to color-match. This pack is still using TGA files for the textures (rather than DDS), so as long as you can open, edit and save to that format, it should be doable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now