Addle

[1.0.x] Protractor Continued - Rendezvous Plugin v2.5.1 (May 15th, 2015)

Recommended Posts

Thanks Wololow, I'll take a look and see what's going on as soon as I can.

All of my custom KSP Toolbar items (KER, FAR, CLS) appear twice since I installed this.

This really doesn't sound like an issue with Protractor. I'm not doing anything out of the ordinary with Toolbar. Certainly a new one for me. If you post your output_log.txt I'll take a look, though.

Share this post


Link to post
Share on other sites

just encountered this error

i wasn't using it just popped up while i was testing some rockets

ksp 0.24.2 x32 win7sp1 x64

NullReferenceException: Object reference not set to an instance of an object

at Protractor.ProtractorModule..ctor () [0x00000] in <filename unknown>:0

UnityEngine.GameObject:Internal_AddComponentWithType(Type)

UnityEngine.GameObject:AddComponent(Type)

Part:AddModule(String)

Part:AddModule(ConfigNode)

PartLoader:ParsePart(UrlConfig, ConfigNode)

:MoveNext()

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object

at Protractor.ProtractorModule..ctor () [0x00000] in <filename unknown>:0

UnityEngine.Object:Internal_CloneSingle(Object)

UnityEngine.Object:Instantiate(Object)

PartLoader:CreatePartIcon(GameObject, Single&)

PartLoader:ParsePart(UrlConfig, ConfigNode)

:MoveNext()

(Filename: Line: -1)

here is the complete outputlog

https://www.dropbox.com/s/3j9xk7f505idf8m/protractor_error.rar

Share this post


Link to post
Share on other sites
just encountered this error

i wasn't using it just popped up while i was testing some rockets

ksp 0.24.2 x32 win7sp1 x64

Thanks dtoxic and Wololow. I have some time to take a look at that, today. And I also see the same thing in my log. Doesn't seem to break anything, but one NullRef is one too many.

Share this post


Link to post
Share on other sites
Thanks dtoxic and Wololow. I have some time to take a look at that, today. And I also see the same thing in my log. Doesn't seem to break anything, but one NullRef is one too many.

exactly no one likes NullRefs :)

Share this post


Link to post
Share on other sites

Thanks to everyone who reported that NullRef. That is fixed, and as a bonus, so is a bug that was bothering me with the Advanced mode. The angles and particularly the times were messed up if you tried things like Mun->Kerbin->Duna transfers. That should now work. So much for "Doesn't seem to break anything". :D

You may find this release in the usual place: https://github.com/RealGrep/protractor/releases/tag/v2.4.12

New version 2.4.12 changes:

  • Fixed a NullRef during startup that just happened to also be causing another bug I was trying to fix with the Advanced mode.
  • Updated version number to 2.4.12.

So thanks again! You all rock.

Remember that running KSP-AVC will alert you to any new version releases. Rather useful.

Share this post


Link to post
Share on other sites

Hope this isn't completely off-topic, I've spent a couple of hours trying to figure it out without success.

It seems like the 'adjust delta-V' button accounts for acceleration in the burn time, but not the increase as fuel is spent, is this correct? For instance the acceleration starts at 26m/s2 but ends up at nearly 40 after a burn. The total delta-V is correct but it seems that the burn time ends up being considerably too early given this increasing acceleration. I'm finding my intercepts are spotty which is the problem I'm trying to solve, if there even is one I'm just doing it wrong.

Hope that makes some sense, I can clarify if needed.. Thanks, love the mod!

Edited by gnivler

Share this post


Link to post
Share on other sites

Not sure if this is a problem with the mod or just my own lack of knowledge (still very much a KSP n00b); but my lose access to Protractor every time I revert or load a quicksave. After doing one of these, I no longer see the Protractor window or icon during the rest of the mission nor during any subsequent missions. I'm also only able to see the mod for the first time by pressing ESC.

The only way I've found to bring Protractor back is to completely uninstall and reinstall the mod. In other words, I can only use it my first time after mod installation and then only until a revert or quicksave load.

I'm running the 64 bit KSP if that makes a difference.

Share this post


Link to post
Share on other sites

I guess i got a pbl with Protractor. FPS issue and lag, then KSP crashes.

I check my log (just discover that in KSP support thread), pages and pages of this:

NullReferenceException: Object reference not set to an instance of an object

at UnityEngine.GUI.Button (Rect position, UnityEngine.Texture image, UnityEngine.GUIStyle style) [0x00000] in <filename unknown>:0

at Protractor.ProtractorModule.drawGUI () [0x00000] in <filename unknown>:0

at (wrapper delegate-invoke) Callback:invoke_void__this__ ()

at RenderingManager.OnGUI () [0x00000] in <filename unknown>:0

That's why I guess Protractor put the mess :P I'll remove it and check. ProTractor may not be responsible. Just chasing...

I use KSP 32bits and last Protractor version

Edited by brienne

Share this post


Link to post
Share on other sites
Not sure if this is a problem with the mod or just my own lack of knowledge (still very much a KSP n00b); but my lose access to Protractor every time I revert or load a quicksave. After doing one of these, I no longer see the Protractor window or icon during the rest of the mission nor during any subsequent missions. I'm also only able to see the mod for the first time by pressing ESC.

The only way I've found to bring Protractor back is to completely uninstall and reinstall the mod. In other words, I can only use it my first time after mod installation and then only until a revert or quicksave load.

I'm running the 64 bit KSP if that makes a difference.

I'm having the same problem. The mod only seems to work once, then never again unless I reinstall the mod. The icon just doesn't show up anymore.

Share this post


Link to post
Share on other sites

I never said thanks for the smoke ui update. Thanks. It's the little things.

As for missing icon, use blizzy's toolbar. right-click the toolbar and set visible icons. check, uncheck, and check again visibility for protractor and say okay.

Share this post


Link to post
Share on other sites

Hello! Thanks for the mod, it's really helpful.

A few things on my side:

I tried Oinker's code and steps to do the partless version of the mod to work, but it didn't work. I couldn't get the module to show up in the toolbar.

I'm assuming it won't work since a newer version of Protractor has been released after that code. Thanks for the effort, anyway.

Secondly, I have a question.

It bugs my mind that I don't know if the proper way to conduct a transfer burn is pointing directly prograde, or instead, if I follow a manouver node marker (which usually points reasonably off from the prograde marker), it will work as well as the previous way. Would it? What's the best approach to have here?

I love the possibility the mod brings, giving us enough info, but letting us do the whole job. But at the same time, as trustier as the prograde burn can be, I don't like doing interplanetary burns (yet) without one or two maneuver nodes planned up ahead.

In advance, thank you.

-edit-

After a few tests, I concluded that burning towards a set-up maneuver node not only works, but in my case, even better than just burning directly prograde. Which brings me to my favourite way to use this mod, simply as a Transfer Window dynamic chart, and letting me do the whole maneuver work.

Edited by Kowgan
Additional info, rephrasing old info.

Share this post


Link to post
Share on other sites
I guess i got a pbl with Protractor. FPS issue and lag, then KSP crashes.

I check my log (just discover that in KSP support thread), pages and pages of this:

NullReferenceException: Object reference not set to an instance of an object

at UnityEngine.GUI.Button (Rect position, UnityEngine.Texture image, UnityEngine.GUIStyle style) [0x00000] in <filename unknown>:0

at Protractor.ProtractorModule.drawGUI () [0x00000] in <filename unknown>:0

at (wrapper delegate-invoke) Callback:invoke_void__this__ ()

at RenderingManager.OnGUI () [0x00000] in <filename unknown>:0

That's why I guess Protractor put the mess :P I'll remove it and check. ProTractor may not be responsible. Just chasing...

I use KSP 32bits and last Protractor version

Thanks, I'll take a look at that. This is without Toolbar, right? I may not have seen it just because I use Toolbar, but I don't want that button to be broken, either.

Someone asked me to ask if there's an RPM version of this mod.

Is there?

One is in the works, but it's rather buggy and I need to refactor quite a lot of code to do it well. So don't expect it super soon. But it's being worked on. In short, not yet, but working on it.

I never said thanks for the smoke ui update. Thanks. It's the little things.

You're most welcome!

Share this post


Link to post
Share on other sites

I have got a issue with protractor (2.4.12) disappearing from the tool bar when Warp mode is used. I noticed it's happening when the warp is at maximum: step 7 or 8

The window, if opened before selecting warp mode, does not disappear and is still usable, but the icon disappears from the toolbar and is not selectable any more nor selectable even if you search it in the toolbar menu.

This happens on warping around a planet, Kerbin for the time being, the protractor icon does not disappear on interstellar warp....

Edited by gilflo

Share this post


Link to post
Share on other sites

So, Protractor seems to work fine in 0.25. Only thing is you will require blizzy78's Toolbar. The non-toolbar icon is completely gone, for some reason. But I will look at that issue tonight. I will provide an update recompiled for 0.25 fairly soonish.

Share this post


Link to post
Share on other sites

Ok, I've hopefully solved the issues with the buttons. It's working 100% for me, anyway. Please let me know if you still have issues, of course.

Version 2.4.13 is now available, compiled against KSP 0.25. It can be found in the usual place: https://github.com/RealGrep/protractor/releases

Thanks for the bug reports! You're all awesome.

Share this post


Link to post
Share on other sites
Thank you for the fast update, Addle! You rock! :D

Thank you! I really appreciate it.

Share this post


Link to post
Share on other sites

Version 2.4.14 is out. The major thing of interest (other than perhaps a bug fix or two) is you can now click on the delta-V column and get an estimated burn time. Very helpful for timing your burns properly. Should have been in there ages ago. You can find it and a full list of changes in the usual place:

https://github.com/RealGrep/protractor/releases/tag/v2.4.14

Let me know if you have issues. Enjoy! :)

Share this post


Link to post
Share on other sites

Thanks for the update once more! Nice new feature, but I could swear we had it already.

Which files do we need to add to the KSP GameData folder? Thanks.

Simply smash that "Protractor" folder into your "Gamedata" folder. ;)

Share this post


Link to post
Share on other sites

I must come here again to thank you once more, Addle! Your effort is worth endless funds! Did I tell you rock before? :)

And yes, 0.90 is being as fun as I expected. ;)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.