Addle

[1.0.x] Protractor Continued - Rendezvous Plugin v2.5.1 (May 15th, 2015)

Recommended Posts

I must come here again to thank you once more, Addle! Your effort is worth endless funds! Did I tell you rock before? :)

And yes, 0.90 is being as fun as I expected. ;)

Thanks! It's for people like you that I keep this alive. And me, of course. But I really appreciate it.

I wonder if people will find new use for Protractor with no nodes in the early game. Seems likely. I wanted to add "Who Needs Nodes Edition!" to the thread title, but it didn't fit. But, yeah, who needs nodes! :)

Share this post


Link to post
Share on other sites

Hello,

I think i will stop to use Mechjeb, for Protactor + Engineer redux !

I just want to ask if it will be Ckan ready ?

Thank you for your work

Share this post


Link to post
Share on other sites
Hello,

I think i will stop to use Mechjeb, for Protactor + Engineer redux !

I just want to ask if it will be Ckan ready ?

Thank you for your work

Nice! Thanks, I appreciate it. :)

I will look at getting CKAN up and going with it. Shouldn't be terribly difficult. Just haven't had much time, lately. But look into it, I shall. :)

Share this post


Link to post
Share on other sites

Anybody having the icon disappearing problem again? Mine at some point or another just vanishes, not visible anymore on the toolbar, nor on the options for visible icons on the toolbar, just like it wasn't there.

Share this post


Link to post
Share on other sites

[LOG 23:02:37.265] Acelerador Unloaded

[LOG 23:02:37.267] -------------Saved Protractor Settings-------------

Ding ding ding! :P

"Acelerador" is not the ship I'm launching. That ship is landed at the KSC and I use it for time-warping, it also has a Protractor calculator thingie. Could it be that Protractor somehow loads based on the presence of the part on the wrong ship? So when the ship I'm actually launching gets far enough (hopefully, darn you Jool and your dV requirements!), Protractor gets unloaded?

EDIT: Just to be clear, I'm launching a ship with a protractor in it, while at the same time I have another ship with a Protractor landed nearby. As soon as I get far enough from that ship the icon disappears, which is what happens at 23:02:37.

Edited by Rosco P. Coltrane

Share this post


Link to post
Share on other sites

Yup, can confirm this. That's most likely a bug. As the game unloaded a vessel parked near the launching pad, during another vessel's ascent, the Protractor icon was also gone. I never noticed that while flying away from a station or another in-orbit vessel containing the Protractor module, though. Gotta pay attention to that.

Also, I noticed it isn't a Protractor's exclusive issue. According to my log, it happens to MechJeb as well, and Mechjeb's workaround is to re-add all the buttons back to the GUI, once this happens:

[LOG 23:42:06.129] Untitled Space Craft Unloaded
[LOG 23:42:06.149] -------------Saved Protractor Settings-------------
[LOG 23:42:06.197] [MechJeb2] Adding button for Ascent_Guidance
[LOG 23:42:06.198] [MechJeb2] Adding button for Attitude_Adjustment
[LOG 23:42:06.199] [MechJeb2] Adding button for Custom_Window_Editor
[LOG 23:42:06.200] [MechJeb2] Adding button for Docking_Autopilot
[LOG 23:42:06.200] [MechJeb2] Adding button for Landing_Guidance
[LOG 23:42:06.201] [MechJeb2] Adding button for Maneuver_Node_Editor
[LOG 23:42:06.201] [MechJeb2] Adding button for Maneuver_Planner
[LOG 23:42:06.202] [MechJeb2] Adding button for RCS_Balancer
[LOG 23:42:06.203] [MechJeb2] Adding button for Rendezvous_Autopilot
[LOG 23:42:06.203] [MechJeb2] Adding button for Rendezvous_Planner
[LOG 23:42:06.204] [MechJeb2] Adding button for Rover_Autopilot
[LOG 23:42:06.204] [MechJeb2] Adding button for Settings
[LOG 23:42:06.205] [MechJeb2] Adding button for Smart_A_S_S_
[LOG 23:42:06.205] [MechJeb2] Adding button for Spaceplane_Guidance
[LOG 23:42:06.206] [MechJeb2] Adding button for Translatron
[LOG 23:42:06.206] [MechJeb2] Adding button for Utilities
[LOG 23:42:06.207] [MechJeb2] Adding button for Warp_Helper
[LOG 23:42:06.207] [MechJeb2] Adding button for Delta-V_Stats
[LOG 23:42:06.208] [MechJeb2] Adding button for Jeb_Essentials
[LOG 23:42:06.208] [MechJeb2] Adding button for Jeb_Science
[LOG 23:42:06.209] [MechJeb2] Adding button for Orbit_Info
[LOG 23:42:06.209] [MechJeb2] Adding button for Surface_Info
[LOG 23:42:06.210] [MechJeb2] Adding button for Vessel_Info

And finally... It would be great being able to access the Protractor from the KSC scene, wouldn't it? *wink wink*

Share this post


Link to post
Share on other sites
Yup, can confirm this. That's most likely a bug. As the game unloaded a vessel parked near the launching pad, during another vessel's ascent, the Protractor icon was also gone. I never noticed that while flying away from a station or another in-orbit vessel containing the Protractor module, though. Gotta pay attention to that.

Also, I noticed it isn't a Protractor's exclusive issue. According to my log, it happens to MechJeb as well, and Mechjeb's workaround is to re-add all the buttons back to the GUI, once this happens:

Wow, that's rather interesting. Thanks for the detective work! Certainly seems like a stock bug. But I should be able to work around it like MJ did.

And finally... It would be great being able to access the Protractor from the KSC scene, wouldn't it? *wink wink*

Share this post


Link to post
Share on other sites

Thanks for considering that suggestion, Addle. Your effort is much appreciated, really! Thanks. :)

Share this post


Link to post
Share on other sites

Oh hey, neat! You're still using my idea of the "TI-83 graphing calculator duct taped to the side" idea as the default model, and my tutorial is in the OP! Cool! :) Cheers

Share this post


Link to post
Share on other sites

Thanks so much to Rosco P. Coltrane and Kowgan. I really appreciate your efforts to figure out why that icon was going away. Really strange that it calls OnDestroy for another ship going out of physics range. Maybe a good reason I'm not aware of, but either way, that enabled me to fix it. Sorry it took a little bit, but fixed it is.

I also added CKAN support. I presume the .netkan file will be accepted soon, as I made a pull request. So should be coming along soon, now. EDIT: Yep, the NetKAN people seem to be on the ball, it's there. Enjoy!

Oh hey, neat! You're still using my idea of the "TI-83 graphing calculator duct taped to the side" idea as the default model, and my tutorial is in the OP! Cool! :) Cheers

Indeed, and I *love* that model. XD

Though I've been meaning to update the videos in the OP, so it may not stay there, but thank you for the video and the model suggestion!

I love the users of this mod. You all rock!

That said, new version is up with the fix and .netkan file added to the sources: https://github.com/RealGrep/protractor/releases/tag/v2.4.16

Edited by Addle

Share this post


Link to post
Share on other sites

Well, you know the drill. KSP 1.0.1 was just released, and here's a version recompiled against it, with updated version numbers. The previous one probably works fine, but at least KSP-AVC won't complain. :)

Find it at the usual place: https://github.com/RealGrep/protractor/releases

Enjoy, you beautiful people! <3

Share this post


Link to post
Share on other sites

"You must spread some Reputation around before giving it to Addle again."

Why, oh why?

Thank you for the continuous rock'n'roll, Addle! :)

Share this post


Link to post
Share on other sites

Well!....I thought this one was dead and brushed under the rug! So happy to see it again and updated=)

Thanks for keeping an old favorite alive Addle!! your awesome

Share this post


Link to post
Share on other sites

Thanks for the kind words, everyone. They really are appreciated! <3

Share this post


Link to post
Share on other sites

So Im trying to use the protractor, and Im trying to get out to Mun, and the little Y symbol thingy is just ---- and wont become a number, so im confused

Share this post


Link to post
Share on other sites
So Im trying to use the protractor, and Im trying to get out to Mun, and the little Y symbol thingy is just ---- and wont become a number, so im confused

Ah, I see. Yeah, for moon transfers, the theta symbol (before that phi symbol) is what you want to look at. It won't be adjusted for delta-V, so you want to find out the length of the burn, divide it by 2, and start your burn that long before it hits 0. Click on the theta column header to swap to time, and the delta-V column header to see the estimated duration of the burn.

But you have considerable latitude on the burn timing. Keep a close eye on the closest approach distance, and burn until that gets as close as you want it, or as close as it gets. If there's an inclination difference, get it as close as you can, and do a plane change during the flight to get it all the way close enough.

Hope that's clear and helps you out. If not, well, you also know where you can often find me (on Twitch). :)

Share this post


Link to post
Share on other sites
Is there a way to integrate the protractor icon into the stock toolbar?

Not without code, which is the next thing I plan to implement. So you can expect that to happen in the not too distant future. I figure it's better to fall back to that if Toolbar isn't there than that custom icon I currently have.

Thanks for the input!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.