pingopete

[WIP][1.0.5]* RSS Visual Enhancements (RVE)

Realistically what would you prefer in RVE? -- choose one from each letter  

1,981 members have voted

  1. 1. Realistically what would you prefer in RVE? -- choose one from each letter

    • A) 1 main cloud layer, 1 cirrus layer (Medium/Compromise)
    • A) Low, Medium, High cloud layers (Heavy/Realistic)
    • B) Detail bias towards Land/Atmosphere visuals
    • B) Detail bias towards Orbit/Space visuals
    • C) Realism
    • C) Detail
    • C) CPU accessibility


Recommended Posts

So... THE RVE does not work in version 1.1.2 , because not run EVE GUI (ALT+0)

 
 We'll have to wait for update :(

Share this post


Link to post
Share on other sites
8 minutes ago, Irenicus said:

So... THE RVE does not work in version 1.1.2 , because not run EVE GUI (ALT+0)

 

 We'll have to wait for update :(

The GUI works. No one else has issues. It is ALT+(ZERO). If you are on Linux you may have to use other modifiers (LEFT/RIGHT ALT/CTRL/SHIFT) along with the 0.

Share this post


Link to post
Share on other sites

Since people are wondering about how to get RVE running on 1.1.2, here is how :)

*DISCLAIMER*  This is not supported by Pingopete, or at all recommended, This is just what works for me. Use at your own discretion and please do not complain if it doesn't work, or there are bugs. This is COMPLETELY UNSUPPORTED.

You'll need:

  • Latest version of Scatterer
  • Latest version of EVE
  • RVE  for KSP v1.0.5 for linux64 (others may work but this is what I tried it with)

First install Scatterer and EVE as usual, then drop the scatterer folder into your GameData. This contains the scatterer planet configs for RSS. Finally, drop the RVE folder into your GameData. Currently, texture replacement of Earth isn't working so you are stuck with the stock earth texture, but the cloud layers are working, and scatterer is working. performance is great too.

Share this post


Link to post
Share on other sites
1 hour ago, Rhavoreth said:

*DISCLAIMER*  This is not supported by Pingopete, or at all recommended, This is just what works for me. Use at your own discretion and please do not complain if it doesn't work, or there are bugs. This is COMPLETELY UNSUPPORTED.

 

Anybody with any questions make sure to ping @Rhavoreth with them :)

Edited by stratochief66

Share this post


Link to post
Share on other sites

Hmmm... I am using EVE and Scatter from first post pingopete

https://github.com/rbray89/EnvironmentalVisualEnhancements/blob/fcc42a6c7faafbec1f8656a04e59faa86de8f8c7/x86-EVE-Release.zip?raw=true

I have Win 7 and KSP 1.1.2. (x64) And I can't open EVE GUI. Pressing ALT+ZERO and nothing....:(

Also I have RSS:) 

 

 

Later...

 

Well. I get another version EVE and it is OK. I at last have GUI - ALT+0.

BUT: Now I have another problem... I can`t see any changes... I get altitude over 100 km and I can`t see RVE :(   The Earth (name Kerbin) not change :(

 

 

Edited by Irenicus

Share this post


Link to post
Share on other sites

I was furiously punching the wrong 0 this whole time, apparently you have to press the 0 with brackets not the one on the numpad

Share this post


Link to post
Share on other sites

Now it is ok ^) ALT+0 is working..

 

BUT! I don`t see any change... The Kerbin (Earth... How rename to Earh?)... In GUI I was press apply.. And get altitude over 100 km... It is nothing...

Share this post


Link to post
Share on other sites

In the GUI of EVE it should appear as earth not kerbin, and by default the altitude is 2000 for earthcloudsmain/ 8000 for earthcloudscirrus
And can someone tell me why my Venus is bright as the sun :0.0:!?

Edited by Crazy-Engineer

Share this post


Link to post
Share on other sites

Tell me please... RVE also for Mars? Jupiter? I just look a video above on this topic... Or it is just some test? :)

 

 

PS. RVE still not works... :( I don`t know what a problem... GUI now working... EVE was installed...  Scattered also was installed.. But I flight over 100 km and Earth not change. And Eath have name Kerbin :(

 

Win 7 x64

Edited by Irenicus

Share this post


Link to post
Share on other sites

Here.... Not working :(

 

My KSP folder^

Spoiler

907ac13ec67a.jpg

 

 

 

And the game

 

Spoiler

0d79a20d1b5c.jpg

 

Edited by Irenicus

Share this post


Link to post
Share on other sites
4 hours ago, Irenicus said:

PS. RVE still not works... :( I don`t know what a problem... GUI now working... EVE was installed...  Scattered also was installed.. But I flight over 100 km and Earth not change. And Eath have name Kerbin :(

Make sure you install the latest version of scatterer and EVE first. You'll need V0.0244 of Scatterer and when you get EVE make sure you get the 'AnyCPU-EVE-Release.zip' version of EVE. You don't need the configs, that is what RVE does :). For reference you can get both of them here:

Scatterer: http://spacedock.info/mod/141/scatterer

EVE: https://github.com/rbray89/EnvironmentalVisualEnhancements/releases/tag/EVE-1.1-1

 

Next, install both of those as normal. What you need to do now is find the RVE release with scatterer configs included. I use the latest linux 64 version found

here: https://github.com/Pingopete/RVE-KSP-1.0.4/tree/Linux64/

 

Drop the scatterer folder into the GameData, remember to copy and replace your 'planetsList.cfg'. Then drop the RVE folder into your GameData; this folder is the eve configs you'll need for it to work. Everything should work out of the box like that. No need to use Alt + 0 for anything. Just head to the tracking station to see if you've got clouds on Earth. I installed RSS using CKAN, EVE and Scatterer will have to be installed manually.

Share this post


Link to post
Share on other sites

AAAA!!! It is WORKING!!!! At LAST!!!

 

But... It is version for Linux... WTF? :)))

 

Thank you so much!!!

 

PS Why Sun so small????

 

Spoiler

1988cdde55ee.jpg

 

Share this post


Link to post
Share on other sites
11 minutes ago, Irenicus said:

AAAA!!! It is WORKING!!!! At LAST!!!

 

But... It is version for Linux... WTF? :)))

 

Thank you so much!!!

 

PS Why Sun so small????

 

  Hide contents

1988cdde55ee.jpg

 

Because in 1.0.5 pingopete split development for Windows and Linux as we were memory restricted. Hence the Linux branch has bigger textures we can now use. It's not directly related to the OS, more for tidiness. 

 

For the sundflare go to the scatterer sunflare config and change the according settings as described in the scatterer thread OP. I don't remember out of my head. (Something like dividing the last entry in the line by 10). 

Share this post


Link to post
Share on other sites
Just now, Theysen said:

Because in 1.0.5 pingopete split development for Windows and Linux as we were memory restricted. Hence the Linux branch has bigger textures we can now use. It's not directly related to the OS, more for tidiness. 

 

For the sundflare go to the scatterer sunflare config and change the according settings as described in the scatterer thread OP. I don't remember out of my head. (Something like dividing the last entry in the line by 10). 

 

 

Hmmm... Where is config for Sun? I can`t see....

Share this post


Link to post
Share on other sites
5 minutes ago, Irenicus said:

 

 

Hmmm... Where is config for Sun? I can`t see....

Scatterer/sunflare/sunflare.cfg

as i said, Check the scatterer thread's frontpage, it explains how to change those values. 

Share this post


Link to post
Share on other sites
On 5/4/2016 at 10:45 AM, Irenicus said:

AAAA!!! It is WORKING!!!! At LAST!!!

 

But... It is version for Linux... WTF? :)))

 

Thank you so much!!!

 

PS Why Sun so small????

 

  Reveal hidden contents

1988cdde55ee.jpg

 

Ok im sold...im going to try this myself. I hope I can get the clouds to at least work and the GUI to pull. 

Share this post


Link to post
Share on other sites
On 5/4/2016 at 10:54 AM, Rhavoreth said:

Make sure you install the latest version of scatterer and EVE first. You'll need V0.0244 of Scatterer and when you get EVE make sure you get the 'AnyCPU-EVE-Release.zip' version of EVE. You don't need the configs, that is what RVE does :). For reference you can get both of them here:

Scatterer: http://spacedock.info/mod/141/scatterer

EVE: https://github.com/rbray89/EnvironmentalVisualEnhancements/releases/tag/EVE-1.1-1

 

Next, install both of those as normal. What you need to do now is find the RVE release with scatterer configs included. I use the latest linux 64 version found

here: https://github.com/Pingopete/RVE-KSP-1.0.4/tree/Linux64/

 

Drop the scatterer folder into the GameData, remember to copy and replace your 'planetsList.cfg'. Then drop the RVE folder into your GameData; this folder is the eve configs you'll need for it to work. Everything should work out of the box like that. No need to use Alt + 0 for anything. Just head to the tracking station to see if you've got clouds on Earth. I installed RSS using CKAN, EVE and Scatterer will have to be installed manually.

Thank you!!!!! Finally some decent clouds! <3

Share this post


Link to post
Share on other sites
On 5/4/2016 at 7:54 AM, Rhavoreth said:

Make sure you install the latest version of scatterer and EVE first. You'll need V0.0244 of Scatterer and when you get EVE make sure you get the 'AnyCPU-EVE-Release.zip' version of EVE. You don't need the configs, that is what RVE does :). For reference you can get both of them here:

Scatterer: http://spacedock.info/mod/141/scatterer

EVE: https://github.com/rbray89/EnvironmentalVisualEnhancements/releases/tag/EVE-1.1-1

 

Next, install both of those as normal. What you need to do now is find the RVE release with scatterer configs included. I use the latest linux 64 version found

here: https://github.com/Pingopete/RVE-KSP-1.0.4/tree/Linux64/

 

Drop the scatterer folder into the GameData, remember to copy and replace your 'planetsList.cfg'. Then drop the RVE folder into your GameData; this folder is the eve configs you'll need for it to work. Everything should work out of the box like that. No need to use Alt + 0 for anything. Just head to the tracking station to see if you've got clouds on Earth. I installed RSS using CKAN, EVE and Scatterer will have to be installed manually.

Linux x64 version? Does it work with the KSP x64 version on Windows 10?

Share this post


Link to post
Share on other sites
2 minutes ago, Table said:

Linux x64 version? Does it work with the KSP x64 version on Windows 10?

yes some what. I didn't have any water on Earth. but I may have done something wrong. I didn't try to fix it either

Share this post


Link to post
Share on other sites
1 minute ago, Table said:

Linux x64 version? Does it work with the KSP x64 version on Windows 10?

it was done 2 separate version because Memory limitation what was in Windows version before 1.1 aka linux was have high top texture rez becouse was not care about Memory ... soo in 1.1 not have anymore Memory problem is fine to be use ...

Share this post


Link to post
Share on other sites

Ah, thanks for the response guys.

Will download :) for the time being. I'm really hyped for the next RVE release!

Share this post


Link to post
Share on other sites
On 4.5.2016 at 4:54 PM, Rhavoreth said:

Make sure you install the latest version of scatterer and EVE first. You'll need V0.0244 of Scatterer and when you get EVE make sure you get the 'AnyCPU-EVE-Release.zip' version of EVE. You don't need the configs, that is what RVE does :). For reference you can get both of them here:

Scatterer: http://spacedock.info/mod/141/scatterer

EVE: https://github.com/rbray89/EnvironmentalVisualEnhancements/releases/tag/EVE-1.1-1

 

Next, install both of those as normal. What you need to do now is find the RVE release with scatterer configs included. I use the latest linux 64 version found

here: https://github.com/Pingopete/RVE-KSP-1.0.4/tree/Linux64/

 

Drop the scatterer folder into the GameData, remember to copy and replace your 'planetsList.cfg'. Then drop the RVE folder into your GameData; this folder is the eve configs you'll need for it to work. Everything should work out of the box like that. No need to use Alt + 0 for anything. Just head to the tracking station to see if you've got clouds on Earth. I installed RSS using CKAN, EVE and Scatterer will have to be installed manually.

I followed these steps, and yet I have no clouds. Not really sure where I went wrong. I installed the latest versions of Scatterer and EVE first, then I dropped the Scatterer folder from RVE into GameData, and then I dropped the RVE and EVE folders from RVE into GameData. Did I miss something?

The Scatterer folder from RVE was from the Linux branch, the rest (RVE and EVE folders) from the windows branch. The game did not even want to start loading if I used anything other than the Scatterer folder from the Linux branch.

If only this process was easier (or I was smarter) :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.