Peppie23

[1.1] RemoteTech v1.6.10 [2016-04-12]

Recommended Posts

A little off topic...what mods are you using for kerbin's effects? It looks like astronomers pack from .24 or .25 which was always my favorite...His newer one looks thinner and I look the deep blues and massive amounts of clouds. Thanks!

Astronomer's Pack v3 Beta. He scaled back quite a bit from Interstellar I think. This is a lot more like Edge of Oblivion which was my favorite too.

Share this post


Link to post
Share on other sites
Astronomer's Pack v3 Beta. He scaled back quite a bit from Interstellar I think. This is a lot more like Edge of Oblivion which was my favorite too.

Didn't know he had a new version out. Awesome, thanks!

Share this post


Link to post
Share on other sites
Didn't know he had a new version out. Awesome, thanks!

V3 Beta is old, from before Edge of Oblivion.

Edit for clarity: He first produced "Astronomer's Pack" followed by a v2 and v3 version. THEN Edge of Oblivion. THEN Interstellar. Interstellar v2 was a minor update to the first. His pictures remind you of the old stuff because it was even older. :)

Edited by jofwu

Share this post


Link to post
Share on other sites
okay, but it makes things a lot easier, because you can switch between stuff in completely different direction in the solar system without touching any of your relay satellites

Yeah but it also makes it too easy IMO. I don't know why you would even install RT if you were going to make everything talk to everything.

I do not completely understand, your way building the network seems to be a different approach. I just connect the relay sats within each other with some small antennas and a big dish to point at the active vessel

That is certainly one way and it isn't wrong by any means, but if your active vessel goes behind a planet and your relay satellite isn't within the cone created by targeting active vessel then you will lose communications. I create a small relay around the planet I want to work around with satellites all capable of going back to Kerbin and my average vessel just carries short range antennas (omni's or the DTS-M1) to hop to the local satellites.

yes, for the mun that might work, but not in some weired orbit around kerbin (ex. pe 90km ap 5mm)

Very high elliptical orbits are an exception, but you just have to design your relay network to handle that if you need it. Active vessel is still useful in some cases, that is why it is there, but if you had a local relay network around the planet you are visiting, it wouldn't matter.

also not if you are far away like duna, because the longer range dishes do not have that big of a cone. If you point it to Ike, you hit nothing but a small fraction of its orbit.

Well you can't just use one dish to service them all. Did you see my big "uber" satellite I posted just before you? It has one dish for every planet and they are all different dishes. The less powerful dishes have wider cones for shorter distances like Eve and Duna, while the big mammoth dishes have much narrower cones but the cone has more time to expand going all the way to Jool. The further the cone has to travel, the wider it can expand. You gotta have the right tool for the right job.

And to my wish about that, In this weired orbit I have to be really careful, where I point my antenna, since there is this giant round thing called kerbin in the way and I can only point it to one of the relay sattelites (unless I carry a lot of these antennas) and none of the omnis with enough range survive reentry, so at reentry I must select the correct one or there will be no parachute deployment

That is part of the challenge. I had to land that Eve probe in a similar manner.

which dishes do you use? The ones I have, have a needle-like cone...

As I mentioned above, depends on the planet.

yes, I want to do mid course correction, because my encounters glitch away so often (which is kind of realistic)

In that case you may want to have both. Something targeting the planet, and one targeting active vessel that is a shorter range and will communicate just slightly outside Kerbin's SOI for that correction.

what I do, I am to lazy to build a a network around other planets, I just connect to kerbin directly so I set two long range satellites to kerbin

Like I said, that isn't wrong but you are most certainly going to have blackout periods that way. You say you are too lazy to build a network around other planets, but that makes me think RemoteTech is not the mod you want. Have you seen AntennaRange?

- - - Updated - - -

V3 Beta is old, from before Edge of Oblivion.

I don't think that is true. I mean the Curse Page certainly makes it look like it's a coming version.

Edited by Alshain

Share this post


Link to post
Share on other sites
V3 Beta is old, from before Edge of Oblivion.

Edit for clarity: He first produced "Astronomer's Pack" followed by a v2 and v3 version. THEN Edge of Oblivion. THEN Interstellar. Interstellar v2 was a minor update to the first. His pictures remind you of the old stuff because it was even older. :)

Well that does make sense why I wouldn't hear about it. I guess it's time to install the older version regardless. It looks so much better.

Share this post


Link to post
Share on other sites
Yeah but it also makes it too easy IMO. I don't know why you would even install RT if you were going to make everything talk to everything.

because I still have to build the sattelites and connect them with each other. I only dont like the repetitive work for every probe I build afterwards.

That is certainly one way and it isn't wrong by any means, but if your active vessel goes behind a planet and your relay satellite isn't within the cone created by targeting active vessel then you will lose communications. I create a small relay around the planet I want to work around with satellites all capable of going back to Kerbin and my average vessel just carries short range antennas (omni's or the DTS-M1) to hop to the local satellites.

yes, that it a thing I have to care about if I do that. But I can use the flight computer to do things on the other side

Very high elliptical orbits are an exception,

it happens if to use the oberth effect as much as possible.

but you just have to design your relay network to handle that if you need it.

yes but you have to connect to disctinct satellites during those manouvers and switch aroung several times. And then it can be quite tidous and I mess it up all the time :(

Well you can't just use one dish to service them all. Did you see my big "uber" satellite I posted just before you? It has one dish for every planet and they are all different dishes. The less powerful dishes have wider cones for shorter distances like Eve and Duna, while the big mammoth dishes have much narrower cones but the cone has more time to expand going all the way to Jool. The further the cone has to travel, the wider it can expand. You gotta have the right tool for the right job.

I only have the Communotron 88-88 so far in the tech tree. Why should one dish not suffice to control one vessel?

Like I said, that isn't wrong but you are most certainly going to have blackout periods that way. You say you are too lazy to build a network around other planets, but that makes me think RemoteTech is not the mod you want. Have you seen AntennaRange?

flight computer, or plan your burns that you always face the correct side. I landed on moho with an Ion Probe and solar panels, which had to have a connection and sunlight to be controllable, and I did not use the flight computer.

No I love remote tech, I do not see the point in AntennaRange, It has only three different antennas?

Share this post


Link to post
Share on other sites

Feature request:

I often just put RCS thrusters on my smallest comsats, often giving them up to 1200 delta-v, and have the satellites themselves do the planetary/moon captures. However, this doesn't work well with the RT flight computer, as it only uses conventional engines to do planned burns. Would be nice with a way to tell RT to use RCS to do the burn.

Share this post


Link to post
Share on other sites
Feature request:

I often just put RCS thrusters on my smallest comsats, often giving them up to 1200 delta-v, and have the satellites themselves do the planetary/moon captures. However, this doesn't work well with the RT flight computer, as it only uses conventional engines to do planned burns. Would be nice with a way to tell RT to use RCS to do the burn.

if you use MechJeb, then you can enable RCS to do the burns, wich works just fine ;)

Share this post


Link to post
Share on other sites

Argh I love this mod but once you get to sending stuff to other planets, my orbits just aren't perfect enough. By the time my probes get to jool all my sats are out of sync and don't have 100% coverage anymore. The amount of house keeping on the relay sats is just too much for me to stomich. I wish I could just set them to perfect their orbits by themselves so this doesn't happen.

Share this post


Link to post
Share on other sites

You can easily use Hyper Edit!If you want to set a network of satellites for a planet:

setp 1:put the first satellite in the designated orbit

step 2:find out what is the orbital period (I suggest using Kerbal Engineer and/or MechJeb for that)

step 3:make a simple calculation: ie. Keosynchronous network = 2868750.48m = orbital period of exactly 6 hours.6 hours x 60 minutes x 60 seconds = 21600 seconds.Now divide the result times the number of satellites you want. for example,3 satellites = 6x60x60 = 21600 / 3 = 7200

step 4:make sure that the satellites have the links you want them to have.I'd suggest (for a Mun network) an altitude of 2200000 m and a satellite with an antenna (pointed at Kerbin) and 2 omnis.Another thing I suggest is RemoteTech XF:it allows you to activate antennas even if the satellite/probe has no connection/control so you won't hate to F5 F9 all the time.

hope I helped :wink:

Share this post


Link to post
Share on other sites
Argh I love this mod but once you get to sending stuff to other planets, my orbits just aren't perfect enough. By the time my probes get to jool all my sats are out of sync and don't have 100% coverage anymore. The amount of house keeping on the relay sats is just too much for me to stomich. I wish I could just set them to perfect their orbits by themselves so this doesn't happen.

One thing that helps is to remember that it is the orbital periods that have to match, not necessarily the orbits themselves (although you do not want too much of a variation here too). If all your satellites have orbital periods that are only within ~3s of each other, it is going to take a lot of time to cause significant drift. To fine tune the orbital period, limit the throttle on your engine as low as possible to get maximum precision. If you want to get extra precise, limit the throttle again with the flight computer and burn for something like 0.000001m/s through it, repeatedly. Using those methods, I usually do not return to my comsats after they are set up.

Share this post


Link to post
Share on other sites

So, I have an issue with this. I don't want to make a bug report out of it, because it's probably a local issue, but I was hoping someone here may be able to help me.

I have a sandbox game I want to go 'proper' with, ie: actually play out a actual space program with, but Remote Tech isn't working for me. Latest version (1.7.6) installed, all components load, all dishes there, all view options in map screen are there, but the actual remote tech functionality doesn't work: I can still control probes without any dishes/antennae on them, I cannot see connections between satellites, or the cone of dishes and all other important stuff.

Is this something which is known to happen, and if so: how can I fix it?

Other installed mods:

Kerbal engineer Redux

Intake Build Aid

Transfer Window Planner

Kerbal Alarm Clock

kerbal OS

Stage Recovery aid

RCS Build Aid

EDIT: forgot ship Manifest.

Edited by Rodyle

Share this post


Link to post
Share on other sites
One thing that helps is to remember that it is the orbital periods that have to match, not necessarily the orbits themselves (although you do not want too much of a variation here too). If all your satellites have orbital periods that are only within ~3s of each other, it is going to take a lot of time to cause significant drift. To fine tune the orbital period, limit the throttle on your engine as low as possible to get maximum precision. If you want to get extra precise, limit the throttle again with the flight computer and burn for something like 0.000001m/s through it, repeatedly. Using those methods, I usually do not return to my comsats after they are set up.

Actually deleted the mod, then read this and decided to bother to do it. Got them down to like .2 of a second out

Share this post


Link to post
Share on other sites
So, I have an issue with this. I don't want to make a bug report out of it, because it's probably a local issue, but I was hoping someone here may be able to help me.

I have a sandbox game I want to go 'proper' with, ie: actually play out a actual space program with, but Remote Tech isn't working for me. Latest version (1.7.6) installed, all components load, all dishes there, all view options in map screen are there, but the actual remote tech functionality doesn't work: I can still control probes without any dishes/antennae on them, I cannot see connections between satellites, or the cone of dishes and all other important stuff.

Is this something which is known to happen, and if so: how can I fix it?

Other installed mods:

Kerbal engineer Redux

Intake Build Aid

Transfer Window Planner

Kerbal Alarm Clock

kerbal OS

Stage Recovery aid

RCS Build Aid

I'm getting almost the same problem...All my antennas show links and everything looks normal but I get no connections on all my spacecraft I launch. All my in orbit spacecraft already have good links...weird?

Update: Just found out it's a mechjeb thing...The mechjeb enabled pods and probes aren't working...I have to add a mechjeb case to the parts I want enabled now...will repost in mechjeb

Edited by Lazy8

Share this post


Link to post
Share on other sites

I like to live dangerously, so I upgraded a lot of mods all at once. In particular RT, and eventually also the contract pack and RT contracts.

When loading the save file, immediately had 2 contracts fail and trigger the penalties (jool and eike coverage I guess). Any ideas on what causes that? Should I rollback RT or is this a contract problem?

I'm okay losing those contracts if it's too much of a problem getting them back. It's just that I got 33000 left in the bank, that's not too much. Anyway I need to make a quick decision since I have another important and potentially save breaking update (mks) going better than expected.

Share this post


Link to post
Share on other sites
I'm getting almost the same problem...All my antennas show links and everything looks normal but I get no connections on all my spacecraft I launch. All my in orbit spacecraft already have good links...weird?

Update: Just found out it's a mechjeb thing...The mechjeb enabled pods and probes aren't working...I have to add a mechjeb case to the parts I want enabled now...will repost in mechjeb

Doesn't seem to be a mod issue in my case. I removed all other mods from my install and freshly downloaded RemoteTech and it still doesn't work. I'll try to clean-reinstall KSP tomorrow and see if that fixes it.

EDIT:

Found something which may be co-morbid with my other issues: Remote Tech parts don't show up in my tech tree in carreer mode. For example I have unlocked the stayputnick, but didn't get the Reflectron DP-10.

Edited by Rodyle

Share this post


Link to post
Share on other sites

This seems to be a problem that isn't addressed, though several people have asked about it:

Any probe that does not have the root of the original ship as its own root tends to spin uncontrollably when orienting it with the flight computer. ...?? This makes any kind of separation impossible if, for instance, you want to separate two probes from a single craft. Can we get a fix for this please???

Share this post


Link to post
Share on other sites
Doesn't seem to be a mod issue in my case. I removed all other mods from my install and freshly downloaded RemoteTech and it still doesn't work. I'll try to clean-reinstall KSP tomorrow and see if that fixes it.

EDIT:

Found something which may be co-morbid with my other issues: Remote Tech parts don't show up in my tech tree in carreer mode. For example I have unlocked the stayputnick, but didn't get the Reflectron DP-10.

I just realized I don't have the DP-10 as well..it's missing from my tech tree too.

Share this post


Link to post
Share on other sites
I just realized I don't have the DP-10 as well..it's missing from my tech tree too.

I fixed my issue: the module manager file wasn't copied for some reason. Adding that fixed stuff.

Share this post


Link to post
Share on other sites

Suggestion: Any plans to integrate the mod with tweakscale?

I shortly plan to install outer planets (having freed up some RAM usage) and many of the new planet are beyond the range of the stock dishes. There is a mod to add some dishes which I may use (or set up a relay system of some kind), but ideally I do like to keep my part count down to an minimum.

Thinking along these lines an alternative would be to make the dishes tweakscaleable with mass, electricity consumption and range scaling with the size of the part, perhaps cone angle should remain the same. I'm pretty sure that just simply adding the tweakscale parameter to the part.cfg would take care of the mass . . . maybe the electricity consumption as well but the range is a Remote tech specific parameter so I don't think that would work.

I don't know what would be a reasonable scaling factor for range, I'm guessing such things probably scale with the surface area of the dish?

Thoughts? Difficult, not difficult?

I might look into it myself.

Share this post


Link to post
Share on other sites

I thought the Outer planets mod modifies the dish range of the late tech disches.

Plus I have seen a mod with extra antennas, "Antennas" from DTPhantom.

Another question:

Does somebody know why in real solar system the commands are delayed by the signal delay but the controls are not?

Share this post


Link to post
Share on other sites
Suggestion: Any plans to integrate the mod with tweakscale?

I shortly plan to install outer planets (having freed up some RAM usage) and many of the new planet are beyond the range of the stock dishes. There is a mod to add some dishes which I may use (or set up a relay system of some kind), but ideally I do like to keep my part count down to an minimum.

Thinking along these lines an alternative would be to make the dishes tweakscaleable with mass, electricity consumption and range scaling with the size of the part, perhaps cone angle should remain the same. I'm pretty sure that just simply adding the tweakscale parameter to the part.cfg would take care of the mass . . . maybe the electricity consumption as well but the range is a Remote tech specific parameter so I don't think that would work.

I don't know what would be a reasonable scaling factor for range, I'm guessing such things probably scale with the surface area of the dish?

Thoughts? Difficult, not difficult?

I might look into it myself.

The mod doesn't add any new part, it just clones the biggest RT antenna and give the clones higher range.

I'm not an expert on this, but I think doing that shouldn't increase part count (it doesn't add any new model)

if this turns out to be wrong, I didn't know that, so I'm sorry :D

Share this post


Link to post
Share on other sites

Issue - Loss of power and no recharge from solar panels. I have two large batteries, 8 solar panels, and 1 med. ranged antenna. But in sunlight the solar panels still do not recharge what is being lost. Image is after one revolution around Kerbal. almost 2000 loss of power. Why can't the solar panels keep of with the loss of power. I only have this issue with remote tech installed. I like the idea of this mod, but this issue makes it unplayable. dateposted-public

Share this post


Link to post
Share on other sites
Does somebody know why in real solar system the commands are delayed by the signal delay but the controls are not?

There are pages and pages of people "politely discussing" on the topic. It's a know behaviour, I'm not sure if it's on purpose or a bug.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.