Jump to content

[1.1] RemoteTech v1.6.10 [2016-04-12]


Peppie23
 Share

Recommended Posts

Make sure they have the correct modules being added. There are plenty of examples of this as ModuleManager patches included in the RemoteTech directory.

Yeah, I know how to fork a compatibility config, used to maintain one for B9, AIES and a whole lot of other mods way back during 0.25...

I also figured that it might not be from RT but KSC Switcher, which I installed recently. I don't think it registers the additional launch sites as RT Command nodes (or whatever you call the red dots)... I'll get rid of it and see where that gets me...

Link to comment
Share on other sites

Yeah, I know how to fork a compatibility config, used to maintain one for B9, AIES and a whole lot of other mods way back during 0.25...

I also figured that it might not be from RT but KSC Switcher, which I installed recently. I don't think it registers the additional launch sites as RT Command nodes (or whatever you call the red dots)... I'll get rid of it and see where that gets me...

I don't know if KSC switcher does it, but there's an "RSS Ground Stations" config linked in the OP.

Link to comment
Share on other sites

I don't know if KSC switcher does it, but there's an "RSS Ground Stations" config linked in the OP.

Yeah, KSC Switcher was the problem... Any idea if the Ground Stations config works for non-RSS games?

Edit: Any place I can actually find that config? The link in the OP is to the old RSS thread...

Edit 2: After not finding the config in question, I've set about making one... Will post it in a few...

Edited by BananaDealer
Link to comment
Share on other sites

Has anything happened to break Sounding Rockets compatibility? The 100 km always-on Omni appears in the VAB part info, but I "No Connection" on the launchpad. No other mods but RT and SR.

- - - Updated - - -

Err, never mind. I upgraded to a newer version of Sounding Rockets that no longer have the old version's built in power supply, and hadn't realized I needed to add batteries. Everything's working the way it is supposed to.

Link to comment
Share on other sites

The groundsations config is now in RO itself. It is defined for the real Earth's launch sites and tracking stations, so YMMV.

Yeah... Figured that much. But KSC switcher works without RO and all the additional KSC sites come up in a reasonable spot (i.e- not in the water or below Kerbin sea-level). So I figured forking a config that adds Ground Stations to the extra launch sites shouldn't be too hard/infeasible. I might be wrong since I am having a hell of a time figuring out the hight of each place, since KSC Switcher uses doubles for its' height values...

Anywho, I've got the basic config layout so I'll test it in a few and see what's broken...

Link to comment
Share on other sites

Right. Seems to have worked... Here's a download link if anyone wants it: NonRO_GroundStationsFork.cfg

This config is specifically made for non-RO games, RO probably uses different guids for the Ground Stations.

The config would technically work without KSC Switcher as it just adds Ground Station nodes, but I would strongly recommend using it.

Link to comment
Share on other sites

Right. Seems to have worked... Here's a download link if anyone wants it: NonRO_GroundStationsFork.cfg

This config is specifically made for non-RO games, RO probably uses different guids for the Ground Stations.

The config would technically work without KSC Switcher as it just adds Ground Station nodes, but I would strongly recommend using it.

does anyone have a config that will work with 6.4x kerbin ? mine keeps failing to add my ground stations...

Link to comment
Share on other sites

does anyone have a config that will work with 6.4x kerbin ? mine keeps failing to add my ground stations...

If all that 6.4xKerbin does is make it 6.4 times larger, just multiplying the height values 6.4-times should work... I think. Longitude and Latitude should be the same...

Link to comment
Share on other sites

Right. Seems to have worked... Here's a download link if anyone wants it: NonRO_GroundStationsFork.cfg

This config is specifically made for non-RO games, RO probably uses different guids for the Ground Stations.

The config would technically work without KSC Switcher as it just adds Ground Station nodes, but I would strongly recommend using it.

I would love to use that config but it seems that your download link has some form of privacy measures on it. Do you mind checking it or uploading it somewhere else?

Link to comment
Share on other sites

Hey Peppie. I've got a bit of a question here regarding Ground Stations (such as KSC ZI's in the default config). See, Kerbal Konstructs adds the ability to unlock launch centers in career mode, and we over on the a Kerbinside thread were discussing if it was possible to only enable these tracking stations (that would be placed at certain launch sites) when they were unlocked. Now, I'm not asking you to write a plugin here, but is it possible withy he current version of Remote Tech to enable/disable Ground Stations on demand? Thanks in advance for any answer.

Link to comment
Share on other sites

Hey Peppie. I've got a bit of a question here regarding Ground Stations (such as KSC ZI's in the default config). See, Kerbal Konstructs adds the ability to unlock launch centers in career mode, and we over on the a Kerbinside thread were discussing if it was possible to only enable these tracking stations (that would be placed at certain launch sites) when they were unlocked. Now, I'm not asking you to write a plugin here, but is it possible withy he current version of Remote Tech to enable/disable Ground Stations on demand? Thanks in advance for any answer.

Hi ThatOneBritishGuy,

no it's not possible to enable/disable mission control antennas on demand with our current version, sorry, and i'm not sure if you could add or remove ground stations from our list via a reflection. So, for a feature like that both mods (RemoteTech and Kerbal Konstructs) had to implement this.

Link to comment
Share on other sites

Hi,

Sorry to ask this here but I have a problem with RemoteTech that I can't understand

I'm begining RO and I wanted to launch my first Com Sat, so I attached an Omni antenna and launched my probe

But once in orbit, my sattelite only connect (green line) to some Ground Stations, and refuse to connect to some others

When I click on the Flight Computer, it says "Connection Error, Out of Power", but I have plenty of ElectricityCharge in mybatteries, and connection still work on a few ground stations

What's wrong ?

Here are some screenshot if it can help understand the problem

Sorry again if it's a noob question, but I didn't find any information on this problem in the Player's Guide on remote tech website

8771892015092400002.jpg7479032015092400001.jpg

Link to comment
Share on other sites

*Snip*

Welcome to Kerbal!

Onto your troubles. You need a green line to have a stable connection. Are you sure the antenna has the range to reach a Ground Station from 3,638 km? I'm not sure what RO changes regarding antenna range, but the one you have has like 2Mm (2,000 km) for non-RO games. RO also has some Ground Stations with very limited range (usually island bases), meaning they probably won't be good for higher-orbit satellites.

Also, if you want to make a communications satellite network, have at least 4-6 dishes on them- not just antennas. Antennas can't be directed and don't provide coverage (i.e- they can only receive commands, not transmit them).

Link to comment
Share on other sites

As I recall, no omni antenna which comes with RT2 has a range that would reach from that altitude. You'll need to include a dish and point it at a ground station or use a relay in lower orbit.

Now why it says 'out of power' when you do have power, I don't know.

Link to comment
Share on other sites

Hi there

I have remote tech installed (Using CKAN) but I can't access any sort of "Target" Menu and the ships fly even without antenna!

Thanks

Jayden

First, are you using just the default install, or something like Realism Overhaul as well?

If it's the default install, do you see a big red dot on Kerbin (at KSC) when you are in the Tracking Center or in Map mode?

Link to comment
Share on other sites

First, are you using just the default install, or something like Realism Overhaul as well?

If it's the default install, do you see a big red dot on Kerbin (at KSC) when you are in the Tracking Center or in Map mode?

Also, if you're commanding a crewed vessel, it doesn't require connection to a Ground Station to operate.

Link to comment
Share on other sites

I hate to do this kind of thing but is there any possibility of someone around with the ability to re-merge and commit RemoteTech XF to update it for RemoteTech 1.6.8 as it seems it is not receiving the same kind of support it used to?

I feel dirty making a request. ;.;

hmm yea, shame on you! :D

Have fun: https://www.dropbox.com/s/pcmnv2g3t6fudbs/RemoteTech_XF_v1.6.8.zip?dl=0

Link to comment
Share on other sites

Thank you for your answers !

I think it's a range problem, my probe is a "Guidance Unit (Early), 1m"

Do we have more precise information on Island Ground Station max range ?

Edit: I tried to have a Apopsis of approx 1Mm (Antenna has 4.00Mm range) and still have the same problem

It appears to lose connection when my probe core run out of ElectricCharge, even if there is an external battery

What's strange is that I can still connect to some ground station...

Edit 2: I've tried with a dish antenna, same problem, losing connection on 90% of Ground Station when my probe core run out of ElectricCharge

May I use another probe core ?

Edited by chingham
Link to comment
Share on other sites

First, are you using just the default install, or something like Realism Overhaul as well?

If it's the default install, do you see a big red dot on Kerbin (at KSC) when you are in the Tracking Center or in Map mode?

Hey

Yea I do have a few mods going but there is a big red dot at KSC, just there are no yellow lines going too and from my equipment / un-maned aircraft! I am testing all this is a sandbox mode btw

thanks!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...