Peppie23

[1.1] RemoteTech v1.6.10 [2016-04-12]

Recommended Posts

With the proliferation of "test part flying at Kerbin" contracts that require interesting combinations of speed and altitude, I decided that I wanted to guarantee that a DP-10 would never lose signal. So my first ring of communication satellites became eight Communotron 16s orbiting 175km above the equator. With that spacing, a DP-10 will connect from surface to at least 350 km anywhere along the equator. Maybe overkill, but it saves hassle and power requirements on everything else in LKO.

I did something similar, 10 satellites at 147km/36m orbital period and within 450-500km of each other, they're just Com-16 and solar panels. The problem is that this constellation along with the 3 satellites at 776km/90m orbital period and 2350km from each other (com-16+4 dishes), along with the various scan-sats and constellations around other moons is already pushing me into yellow timewarp when just looking at it.

BPvLEXZ.jpg

I2csN8K.jpg

In the future I simply won't bother with in-atmosphere testing, canceling those missions instead of taking them.

Share this post


Link to post
Share on other sites

mecki there no decent way to have a good polar coverage but u can make it less by the muns sats and minmus sats.

right now ive found that having a minimalist approach is best. more sats u use more ram u use even thou hard to tell it can spike and also less sats mean less chance of mod bugging out lol. besides since kerbin is in a naer perfect orbit around kerbol no one said u cant have a few polar kerbol sats lol

Share this post


Link to post
Share on other sites

3 equidistant equator sats and 3 equidistant polar sats at an altitude of 600-850 would give coverage everywhere on Kerbin for Com-16 probes, but not for DP-10 using atmospheric probes.

As far as I can tell, the minimum number of satellites needed to be able to contact DP-10's anywhere on kerbin is 16 satellites, in 2 rings of 8 com-16s at a +/-30 degree inclination difference from the equator.

But when, why would someone absolutely need to have short range radio contact with the north/south pole at all times.

Share this post


Link to post
Share on other sites

it's not been officially updated for 0.24.x but it is reported as working. Hell, I'm still using the last 0.23.5 release in 0.24.2 and that's been working just fine so far

Share this post


Link to post
Share on other sites

It seems to be working for a lot of people. For me, however, it causes random crashes that don't happen at all when i remove it. So far all the mods i like to use are working save for remote tech, B9, and KAS. And all 3 of those are being reported by some to be working fine for them....perhaps it's the mix of mods I'm using, I dunno. Waiting on official releases for them.

Share this post


Link to post
Share on other sites

got a null reference exception, related to RT2: '>output_log.txt (win64)

ArgumentNullException: Argument cannot be null.

Parameter name: source

at System.Linq.Check.SourceAndPredicate (System.Object source, System.Object predicate) [0x00000] in <filename unknown>:0

at System.Linq.Enumerable.Where[uIPartActionWindow] (IEnumerable`1 source, System.Func`2 predicate) [0x00000] in <filename unknown>:0

at RemoteTech.UIPartActionMenuPatcher.Wrap (.Vessel parent, System.Action`2 pass) [0x00000] in <filename unknown>:0

at RemoteTech.ModuleSPU.HookPartMenus () [0x00000] in <filename unknown>:0

at RemoteTech.ModuleSPU.FixedUpdate () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

And if I remember right, the log flooding with "Look rotation viewing vector is zero" should be also related to RT2. It did not crash at first, but was really lagy.

Edited by acc

Share this post


Link to post
Share on other sites
it's not been officially updated for 0.24.x but it is reported as working. Hell, I'm still using the last 0.23.5 release in 0.24.2 and that's been working just fine so far

Really? I found my RT2 works weirdly. Antennas are not deployed (it works though) and a antenna has three identical toggling buttons.

Share this post


Link to post
Share on other sites

The tripling of the antenna may be due to too many versions of mod manager. Make sure you delete all but the latest version from your game data folder.

Share this post


Link to post
Share on other sites

There still is an incompatibility note on startup, stating that RemoteTech is made for 23.5

Share this post


Link to post
Share on other sites
Really thanks.I'm gonna check that as soon as possible.

Yes, multiple entries of RT2 options in the context menu are basically always just multiple modulemanager dlls. Just search your GameData, you should only ever have exactly one (preferably the newest, 2.2.0 I think).

Share this post


Link to post
Share on other sites

I have a problem. The GUI is pink and doesn't show anything

edit?usp=sharing

Does anyone have a solution.

I am running the 64 bit version of ksp in version 0.24.2.559

with these mods:

Docking port alignment indicator

Kerbal engineer redux

Enhanced Navball

KAS

kerbal joint reinforcement

KSP alternate resourcepanel

module manager 2.2.0

RCS build aid

remote tech 2 (which is the problem I think)

TAC life support

Share this post


Link to post
Share on other sites
I have a problem. The GUI is pink and doesn't show anything

https://drive.google.com/file/d/0B6eXweXZaeY8ajJaWjV2R3FnWFE/edit?usp=sharing

Does anyone have a solution.

I am running the 64 bit version of ksp in version 0.24.2.559

with these mods:

Docking port alignment indicator

Kerbal engineer redux

Enhanced Navball

KAS

kerbal joint reinforcement

KSP alternate resourcepanel

module manager 2.2.0

RCS build aid

remote tech 2 (which is the problem I think)

TAC life support

Are you sure it's not KAS, Kerbal Joint Reinforcement or alternate resource panel? I'd assume ARP is the most related to GUI, and I think KAS is broken for .24.2. Also, KJR is pretty redundant now we have the rigidbody update thingy. Well, good luck. :)

Share this post


Link to post
Share on other sites
Are you sure it's not KAS, Kerbal Joint Reinforcement or alternate resource panel? I'd assume ARP is the most related to GUI, and I think KAS is broken for .24.2. Also, KJR is pretty redundant now we have the rigidbody update thingy. Well, good luck. :)

First of all thank you for replying, second I deleted KAS, the Alternative panel and KJR

but unfortunately it didnt work. anybody anymore ideas.:rolleyes::(

Edited by ocer

Share this post


Link to post
Share on other sites

KAS isn't broken for 24.2 necessarily, but it has been semi-confirmed to throw silent errors for x64.

Share this post


Link to post
Share on other sites

I was having the crashes too, until I nixed this mod.

Kinda stinks I was 4 satellites into a communications network too. :(

Share this post


Link to post
Share on other sites

most of us can say WE NEED MORE INFO THAN THAT Rivvik. there probaly is a 99% chance of either a mod conflict, installed wrong or u using the wrong version. ive played 10 hours with this version and had no problems with it

Share this post


Link to post
Share on other sites

Sorry if someone has already answered this, I looked back through recent posts and couldn't find anything.

Is there a version RT2 that works in 24.2 and 64 bit mode? Working on a new tech tree and want to integrate the parts in my antenna branch. If not, I will work the tree in 23.5 in the mean time.

Share this post


Link to post
Share on other sites
most of us can say WE NEED MORE INFO THAN THAT Rivvik. there probaly is a 99% chance of either a mod conflict, installed wrong or u using the wrong version. ive played 10 hours with this version and had no problems with it

I'm re-installing to sift through, but thats an issue too, it seems almost random. When I made that post, my game worked once I nixed Remotech, then an hour later it crapped out again.

Share this post


Link to post
Share on other sites
how do you guys deal with signal delay when trying to land a probe?

I use kOS to automate it. I hear others turn off the delay.

Share this post


Link to post
Share on other sites
how do you guys deal with signal delay when trying to land a probe?

MechJeb. MechJeb & smart parts are essential to RT2 in my book.

Share this post


Link to post
Share on other sites
MechJeb. MechJeb & smart parts are essential to RT2 in my book.

Isn't MechJeb subjected to signal delay as well? Has this changed since I last looked?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.