Peppie23

[1.1] RemoteTech v1.6.10 [2016-04-12]

Recommended Posts

My game is crashing every time I resume my save. Always at the space center or if it doesn't crash then, it crashes when I select any of the buildings. It did not start doing this until after I put up my first comm sat.

This is a list of mods that I am using,

<snip lots of mods>

They are all updated to their latest version and I am using KSP version 0.24.2 x64. Any help would be great!

Without logs to be certain, the only thing I can see in your list that is known to cause crashes is KSP version 0.24.2 x64.

x64 on windows is not stable. People can't seem to say that often enough. I have even more mods than you, and even with Aggressive Active Texture Management, I run at around 3.3GB memory usage, and in 32bit it is rock solid, no crashes at all. In 64 bit, sometimes it doesn't even load, sometimes I'm fine until I get to the VAB, it has never let me actually launch a ship.

Try again with the 32bit client. Install ATM if you have memory issues, if you can replicate the crashes there, upload logs and someone may be able to see the problem in them :)

Share this post


Link to post
Share on other sites

I'm having a really frustrating problem. I sent out a science mission to Eve, consisting of an orbiter and a return vessel, now separated and both in stable orbit around Eve. Both probes have solid connections via 88-88s to my relay network back around Kerbin, and both have working Communotron 32s, and are in range of each other. Unless I've grossly misunderstood something, I should be able to deactivate the 88-88 on one of the vessels (we'll say the orbiter), and that vessel should remain connected through Comm32[orbiter]->Comm32[return vessel]-88-88[return vessel]->88-88[Kerbin Relay Sat]->KSC. But, doesn't work. if I deactivate the 88-88, I can see in the map view that I'm still connected to the other probe, but the connection doesn't propagate back to KSC, and I lose control.

Any idea?

Share this post


Link to post
Share on other sites
I'm having a really frustrating problem. I sent out a science mission to Eve, consisting of an orbiter and a return vessel, now separated and both in stable orbit around Eve. Both probes have solid connections via 88-88s to my relay network back around Kerbin, and both have working Communotron 32s, and are in range of each other. Unless I've grossly misunderstood something, I should be able to deactivate the 88-88 on one of the vessels (we'll say the orbiter), and that vessel should remain connected through Comm32[orbiter]->Comm32[return vessel]-88-88[return vessel]->88-88[Kerbin Relay Sat]->KSC. But, doesn't work. if I deactivate the 88-88, I can see in the map view that I'm still connected to the other probe, but the connection doesn't propagate back to KSC, and I lose control.

Any idea?

Sounds like what happens when the Kerbin-side relays are targeting "active vessel." If you're controlling the vessel with its dish deactivated, then your "active vessel" dishes aren't targeting the active dish on the other vessel any more.

Share this post


Link to post
Share on other sites
Sounds like what happens when the Kerbin-side relays are targeting "active vessel." If you're controlling the vessel with its dish deactivated, then your "active vessel" dishes aren't targeting the active dish on the other vessel any more.

Oh MAN does that make a lot of sense. Thank you so much for your help. I thought I was losing my mind.

Share this post


Link to post
Share on other sites

Anyone not following the latest kOS developments needs to tune in - Steve and erendrake are making great progress on allowing kOS to directly control any of the toggle switches on parts, as well as get the values of part properties. So you can extend/retract antenna and get their maximum range, for example. no more going through action groups!! Rejoice, my fellow signal delayers

Share this post


Link to post
Share on other sites

Is it feasable to start using Remote Tech quite a bit into my existing career? Does this mean I will lose complete control over my existing satellites?

Share this post


Link to post
Share on other sites

if they have stock antennas on them you just need to EVA and force open them, or retrofit with KAS, but yeah, without all that you will lose control.

Anyway, i'm pretty sure i have found a bug with remotech (maybe not, since this save is heavily modded). When i turn max time warp in vessel mode (doesnt crash in tracking station) game just hangs, and last entries in the debug logs are always remotetech onvesseldestroy asteroid or something like this. http://i.imgur.com/fXZsDOV.png

here is a couple of output logs https://www.dropbox.com/sh/h7s9aob4r97yzmu/AABpGT2uWHDGPbOtgG77V1Gba?dl=0

Share this post


Link to post
Share on other sites

Ah, ok. My sats are all across the solar system, so getting kerbals to them is unfeasable, but they all have their antennae extended. I guess I can make sure the rest of them will work with RT before I install it. Anything else I have to do? I heard of relays...

Share this post


Link to post
Share on other sites
Ah, ok. My sats are all across the solar system, so getting kerbals to them is unfeasable, but they all have their antennae extended. I guess I can make sure the rest of them will work with RT before I install it. Anything else I have to do? I heard of relays...

u will lose those sats. they still be there but antana have very small range and also u need dishes for ranges above 10Mm. imo what u do is if any of them have engines bring them back for cash then install rt2 and play rt2 is well worth the time or lose to play with.

Share this post


Link to post
Share on other sites

Here my Com Relay, as was Wednesday. Today is a bit more complete for Minmus an Mun too.

Now i'm preparing the 3rd layer, the interplanetary Relay. But only for near planets for now.

14808525948_8b3dda531c_o.pngScreenshot 2014-08-21 22.17.22 by Climberfx, on Flickr

Share this post


Link to post
Share on other sites

Feature request: If you have a manned pod with an antenna in range, the manned pod can send an unmanned probe a command.

Share this post


Link to post
Share on other sites
or retrofit with KAS

This has always made things explode in the past. Or just lockup KSP.exe.

Share this post


Link to post
Share on other sites
Feature request: If you have a manned pod with an antenna in range, the manned pod can send an unmanned probe a command.

In current RT2, a manned ship can control an unmanned ship if the manned ship has at least six kerbals on board and a probe core with this function enabled (in stock, the only one enabled is the 2.5m stack probe core).

Share this post


Link to post
Share on other sites
u will lose those sats. they still be there but antana have very small range and also u need dishes for ranges above 10Mm. imo what u do is if any of them have engines bring them back for cash then install rt2 and play rt2 is well worth the time or lose to play with.

Thanks for reply. :)

Share this post


Link to post
Share on other sites
In current RT2, a manned ship can control an unmanned ship if the manned ship has at least six kerbals on board and a probe core with this function enabled (in stock, the only one enabled is the 2.5m stack probe core).

Are you saying that the only probe core that the 6 kerbal crew could command is the "probeStackLarge" because it has "IsRTCommandStation = true" on it? or am I reading that incorrectly?

EDIT* I realized after re-reading that you may mean the vessel that has the 6 kerbals on it requires a 2.5m probe core attached, is that what you meant? (Never attempted this yet as I have been perfecting my Kerbin system management of RT2.

Thanks in advance!

Edited by WololoW

Share this post


Link to post
Share on other sites

Is there currently any way to see multiple satellite cone ranges on a single ship that has multiple dishes or is there a way to toggle which dish cone is currently being shown on the map?

Share this post


Link to post
Share on other sites
Is there currently any way to see multiple satellite cone ranges on a single ship that has multiple dishes or is there a way to toggle which dish cone is currently being shown on the map?

on the map screen just thrun on allo the icons in the lower right u get cone for all the sats that u can see

Share this post


Link to post
Share on other sites
Are you saying that the only probe core that the 6 kerbal crew could command is the "probeStackLarge" because it has "IsRTCommandStation = true" on it? or am I reading that incorrectly?

EDIT* I realized after re-reading that you may mean the vessel that has the 6 kerbals on it requires a 2.5m probe core attached, is that what you meant? (Never attempted this yet as I have been perfecting my Kerbin system management of RT2.

Thanks in advance!

Correct on the edit. The manned vessel must contain a probe core with isRTCommandStation = true. The unmanned ship that you're controlling can have any probe core that works with RT2.

Share this post


Link to post
Share on other sites
is it possible to Hide the connection Lines?

Definitely. Bottom-right on the map view you have the RT2 User Interface, the second button from the right is a switch to let shown alternatively, none, omni, dishes, omni+dishes connections.

Share this post


Link to post
Share on other sites

Quick question:

Is it possible to specify the number of Kerbals to run a mobile mission control, or is it hard coded to 6?

MODULE
{
name = ModuleSPU
IsRTCommandStation = true
}

For example like...

MODULE
{
name = ModuleSPU
IsRTCommandStation = true
minKerbalNumber = 2
}

I'm trying to make a little mobile command truck, as a cheap alternative to a Satellite network.

9f046fc769.jpg

Thanks :)

Share this post


Link to post
Share on other sites

It's hard coded right now they where talking about changing that.

Share this post


Link to post
Share on other sites

just flew an interplanetary satellite up to the skies,

and has No Connection in interplanetary space when pointing at Kerbin

has to point at a specific satellite to get a connection

(have a 3 satellite relay at a 2hr orbit and a GSO satellite; all with one 40Gm dish point at active vessel and 1 communotron 32)

is it intended or have i missed something since the update?

Edited by lammatt

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.