Peppie23

[1.1] RemoteTech v1.6.10 [2016-04-12]

Recommended Posts

Hello,

Is there gone come a MicroSat in RemoteTech 2?

becouse I realy like MicroSat's

Edited by bas

Share this post


Link to post
Share on other sites

Isn't a dish pointed to an omny antenna supposed to double the omni antenna range? If that is the case, I think it is broken in the case the dish is set to point to 'active vessel'

I have four geosat at about 90 deg, each at 2.8 million km orbits. With the geosat on top of kerbin, having a dish pointed to 'active' vessel, the sat at 90deg with a 5Mm omni antenna doesn't get a connection when I am flying it.

Share this post


Link to post
Share on other sites
Isn't a dish pointed to an omny antenna supposed to double the omni antenna range?

Not by default, from what I remember. That's never been true. There's some additive range thing in settings but I thought that only worked on the same vessel.

Share this post


Link to post
Share on other sites

Did anyone else get a strange problem that dish connections are only shown in map view when focused?

just noticed it as I got my second new com sat into Kerbin orbit, and had to link them together with dishes. The main buttons in the right bottom only showed the dish connection when i focus the craft or the celestrial object that is targeted.

The problem only occured as I got my second sat into orbit, with only one it was ok.

I mean the connection cones that were shown in 1.3.3 for all dishes at the same time.

Share this post


Link to post
Share on other sites

That's toggled by the RT2 action bar on the bottom right isn't it (the middle one that looks like a world)?

Share this post


Link to post
Share on other sites
That's toggled by the RT2 action bar on the bottom right isn't it (the middle one that looks like a world)?

I believe yes, my third sat is on its way up, maybe after another game restart it changes again.

Share this post


Link to post
Share on other sites
Did anyone else get a strange problem that dish connections are only shown in map view when focused?

just noticed it as I got my second new com sat into Kerbin orbit, and had to link them together with dishes. The main buttons in the right bottom only showed the dish connection when i focus the craft or the celestrial object that is targeted.

The problem only occured as I got my second sat into orbit, with only one it was ok.

I mean the connection cones that were shown in 1.3.3 for all dishes at the same time.

I have the exact same problem. I have three sats in high Kerbol orbit with ten dishes, two pointing on the other two sats, one on the active vessel and one on each planet. I also have three sats orbiting Eve, Kerbin, Duna and Laythe with three dishes pointing at the sats I already mentioned and an omni for mission control and local coverage. The relay works normally and the signal travels everywhere, but the communication lines between the three big sats in Kerbol orbit and the Laythe sats are missing if Laythe isn't focused. It is just a visual thing, it doesn't affect anything, I just figured I should report it.

I haven't included a log or a save file cause my save is heavily modded and tweaked by me through module manager(including RT).

Edited by petros_a_l

Share this post


Link to post
Share on other sites
I have the exact same problem. I have three sats in high Kerbol orbit with ten dishes, two pointing on the other two sats, one on the active vessel and one on each planet. I also have three sats orbiting Eve, Kerbin, Duna and Laythe with three dishes pointing at the sats I already mentioned and an omni for mission control and local coverage. The relay works normally and the signal travels everywhere, but the communication lines between the three big sats in Kerbol orbit and the Laythe sats are missing if Laythe isn't focused. It is just a visual thing, it doesn't affect anything, I just figured I should report it.

I haven't included a log or a save file cause my save is heavily modded and tweaked by me through module manager(including RT).

We should commit a bug report in the github. Sadly, for me it is to late for a proper correct reproduction description that can be understood.

Will you, otherwise I do it tomorrow?

Share this post


Link to post
Share on other sites
Is there gone come a MicroSat in RemoteTech 2? I realy like MicroSat's

My LKO relay satellites have an engine and fuel for 1475 dV, one 2.5Mm omni antenna, battery and solar panels, all in less than 150kg, all stock. If using a few mods, I can get them below 100. I'd call that a Microsat.

Share this post


Link to post
Share on other sites

Hello,

I like the MicroSat because it's compact.

If you build yourself a MicroSat it's not so compact.

And I like the design of the MicroSat.

Is there gone come a MicroSat for RemoteTech 2?

Edited by bas

Share this post


Link to post
Share on other sites

This mod is quite simply brilliant!the additional layers of planning and thinking required make something as simple as a free-return slingshot around the moon with a probe infinitely more rewarding. and it adds a little more intricacy to the learning curve too.So happy that this has been brought up to speed for 0.23.5, as this is the first time I have made a serious go at the career mode. Thanks again :)

Share this post


Link to post
Share on other sites

I've been waiting for this for ages! (not really, but it makes it sound more interesting) Brilliant mod and now with 0.23.5 compatibility. What more could I wish for? Well, there goes my social life once again...

Share this post


Link to post
Share on other sites

Is there anyway to execute more complex commands than the flight computer allows? It' pretty limited at the moment, making unmanned lander, etc, difficult.

Share this post


Link to post
Share on other sites
Is there anyway to execute more complex commands than the flight computer allows? It' pretty limited at the moment, making unmanned lander, etc, difficult.

You can do it with the on board computer if needed. I did it a while ago for landing on Eve with a 7+ min signal delay and losing the signal path 2 minutes before atmosphere interface. I programmed in EVERY command for landing it near a set spot on Eve. It was a nightmare but it can be done.

As seen here...

OJXTKTc.jpg

OAupcQv.jpg

Edited by Hodo

Share this post


Link to post
Share on other sites
Is there anyway to execute more complex commands than the flight computer allows? It' pretty limited at the moment, making unmanned lander, etc, difficult.

Try KoS or Mechjeb, they can be used to have an Autopilot.

Share this post


Link to post
Share on other sites

Hodo, how do you toggle stages and action groups?

Alewx, neither of those work with RT when out of signal/delayed?

Share this post


Link to post
Share on other sites
Hodo, how do you toggle stages and action groups?

Alewx, neither of those work with RT when out of signal/delayed?

Q button on the flight computer box. It will open the command box. You can add an additional delay if needed in the commands, like I did in those pictures. I had a 25minute delay at one point because I didn't want it to extend its antenna while it was still travelling mach 2 through the upper atmosphere. Then all you do is hit your action keys as needed, they will show up in the delay action log, and any control changes like turns or pitch changed you should use the SASS buttons on the left of the Flight Computer.

If I had more time I would explain more in depth but currently busy at work and taking a few minutes to see what I can help out with.

Oh one more thing...

All those commands have to be sent WHILE you have signal.

Edited by Hodo

Share this post


Link to post
Share on other sites

Thanks! I'd love more info when you get a chance, I'm particularly interested on doing unmanned Mun landings.

@Devs If kOS integration/built in-scripting isn't possible in the next version, speed and altitude triggered commands would be great! (:

Share this post


Link to post
Share on other sites
Thanks! I'd love more info when you get a chance, I'm particularly interested on doing unmanned Mun landings.

@Devs If kOS integration/built in-scripting isn't possible in the next version, speed and altitude triggered commands would be great! (:

Alright now that I have a few minutes I hope I can explain roughly what I did. Mind you it was a few months ago and I haven't bothered or wanted to try and repeat it, because it took me almost 8 hours of play time to get that ONE landing right. It was a lot of quick save and reloading.

But basically I did one drop where I let it plumet all the way to the ground, timing roughly when it hit each layer of the atmosphere when the chutes should be deployed and when the landing gear should be deployed. I failed to account for the thick atmosphere of Eve and the fact that the craft jettisoned its heatshield with its deorbiting thruster. That was a pain in the butt. But I adapted and overcame. I set my re-entry angle from the start on the deorbital burn, so the PE was set pretty high because it was Eve, any shallower with DRE the probe would have just skipped, any deeper and it would have burned up. But I had to tell the FC (flight computer) to perform the burn at a set delay that I manually put in 15min before the burn node, and told it to burn for the exact m/s needed to achieve the PE I wanted. I then had it jettison the engine and come in heatshield side down... well that didnt work because I screwed up on the building of the probe and had it set to high in the shield so the shield went with the engine. But it survived re-entry, I had to pre-program in the maintain nose up retrograde, until it got to the thick atmosphere, then I let it tumble through the atmosphere to disipate as much of the heat as possible. I also had to tell it to pull in the antennas and solar panels at a certain point. That was the point I could no longer send anymore updates to the probe, and even if I could it would have been to late. I had to make sure that at T-25min to node I had EVERYTHING programmed in the FC before it hit T-15min. Because at that point I would have 3 minutes left to send last minute adjustments, because at that point the probe went on the dark side of Eve and I would lose signal from Kerbin. Everything had to be perfect. It wasn't but it was mostly good, I messed up and the gear didnt come down and one chute burned off of it leaving it 2 which lead to a lopsided landing. Which resulted in it rolling down a hillside for about 100m before stopping on its side. But the solar panels extended while it was tumbling down the hill which tore them off, and the long range satelite antenna was facing the ground. But the omni directional antenna extended at T+5min and worked! So all in all success.

Share this post


Link to post
Share on other sites
Thanks! I'd love more info when you get a chance, I'm particularly interested on doing unmanned Mun landings.

@Devs If kOS integration/built in-scripting isn't possible in the next version, speed and altitude triggered commands would be great! (:

I think kOS integration will take a bit longer than that. It's a complicated feature. You can get altitude-triggered commands from SmartParts, though.

For the record, we have a similar approach to Hodo's as a tutorial. If you're doing everything based on timing, unfortunately, it does require some trial and error.

Share this post


Link to post
Share on other sites

dtobi's smart parts let you set triggers for speed /altitude and things don't they?

I know it's not the same as the feature actually being baked into RT2, but it's available now until the feature is

Share this post


Link to post
Share on other sites

I'll try the dtobi parts, but what I'd like to be able to do is unmanned landings on airless bodies, where parachute's can't be used.

Could a simplified version of kOS integration be done where kOS passes to RT if a script is running, and if yes, signal delay and connection loss is ignored? What about MechJeb integration?

Share this post


Link to post
Share on other sites

I had two satellites in orbit before installing Remote-Tech 2, and now i cant control them.

Can i take a ship up there and doing EVA conect the antennas ? Or should i bring them down and then re-upload with the mod modification?

Share this post


Link to post
Share on other sites
I had two satellites in orbit before installing Remote-Tech 2, and now i cant control them.

Can i take a ship up there and doing EVA conect the antennas ? Or should i bring them down and then re-upload with the mod modification?

I don't think attaching an antenna via KAS is a good idea from memory, or has that been fixed?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.