Eisfunke

Less memory usage by using OpenGL

Recommended Posts

Personally I have gained stability by converting all my textures to .DDS

I tried -opengl and directx9 and 11, just to see but they each had 'issues'. With DDS loader I had no graphical glitches, no flickering and much faster loading.

YMMV.

Share this post


Link to post
Share on other sites

Well, doing this surely helps the active texture management setup as well. FYI.

- - - Updated - - -

You are going to need "-force-opengl" in target of shortcut properties.

Share this post


Link to post
Share on other sites

I tried with the OpenGL 1.0.

I no longer glitc, saving more than one GB of ram, but the options screen you can not see.I tried adding PopupWindow, I managed to see the options page, I made a game, then when finished, I tried again to get back in the options. All Black. Any solution?

Share this post


Link to post
Share on other sites
I tried with the OpenGL 1.0.

I no longer glitc, saving more than one GB of ram, but the options screen you can not see.I tried adding PopupWindow, I managed to see the options page, I made a game, then when finished, I tried again to get back in the options. All Black. Any solution?

I just tried going to game options too. Froze up with loading in the corner. That is probably a bug with Opengl. If you open ksp without opengl, change the values you want, and then restart the game, the values are saved.

Share this post


Link to post
Share on other sites

Ever since 1.0 the -force -opengl flag gives me an error.

Tried on a clean unmodded install and my usual modded version.

This is the error message that pops up:

4RrkoKa.png

Anybody who knows how to solve this? I was really used to the lower memory requirements because of it :D

Share this post


Link to post
Share on other sites

It does seem like KSP 1.0 can't use OpenGL--a serious bummer, it was fixing all my memory issues (at least combined with Active Texture Management).

Share this post


Link to post
Share on other sites
It does seem like KSP 1.0 can't use OpenGL--a serious bummer, it was fixing all my memory issues (at least combined with Active Texture Management).

I'm running KSP 1.0.2 with it. Saving about 400 mb.

Share this post


Link to post
Share on other sites

Opengl cuts my ram usage from 2.1GB on lad to 1.2GB and from 3.7(crash) to 2.4 after hour of flying around.

Share this post


Link to post
Share on other sites
Ever since 1.0 the -force -opengl flag gives me an error.

Tried on a clean unmodded install and my usual modded version.

This is the error message that pops up:

http://imgur.com/4RrkoKa.png

Anybody who knows how to solve this? I was really used to the lower memory requirements because of it :D

-force opengl may not work with HDMI cables. Sometimes it does, sometimes it doesnt. If you have the possibility to use a DVI cable instead the the error will disappear.

Share this post


Link to post
Share on other sites
-force opengl may not work with HDMI cables. Sometimes it does, sometimes it doesnt. If you have the possibility to use a DVI cable instead the the error will disappear.

That might be the problem, strange its just popped up wehn 1.0 launched..

Been using openGL for a long time now.

Too bad, cant switch to DVI sadly..

Share this post


Link to post
Share on other sites

God, this one is so good. I nearly cried. Finally I can load all the mods I want and not crashing every few min. I don't know why this is not an official option in the game option menu. This post should be pinned to the top of the add-on release forum.

Share this post


Link to post
Share on other sites

Best tweak ever.

I run KSP 1.0.2 32 bits on Win7 64 bits with an i5-4460 and a GTX 760.

With Dx, the game was using 2.6Go(on the main menu just after the loading). With OpenGL, I'm around 1.6Go in the same conditions. That 1Go gap seems to stay the same in other situations(loading a savegame, flying for the same amount of time in the same places, building a new rocket in the VAB).

I had some issues with fullscreen, but -popupwindow solved them all, just playing in windowed mode should also do the trick of course.

Share this post


Link to post
Share on other sites

Somehow this fixed a NaN bug at launchpad (or I'm bad at reproducing bugs). How exactly does that work?

Share this post


Link to post
Share on other sites

without opengl: about 8minutes loading the game from double clicking the icon... 240,000K (and going up without soundly process); ran in windowed mode

with opengl: 3 minutes in the loading, before the actual loading screen/squad logo (or even the window's sides panels) shown, the game crashes on every execution; still in windowed mode

WinXPPro sp3

Sapphire Radeon X1650

Single core CPU (intel P4 2.4 mmx)

1GB SD ram

3GB page file

despite the bottom-low-end hardware, I can still do mun missions from launch and back without crashing the game (with 9 other mods currently running)

Share this post


Link to post
Share on other sites

without opengl: about 8minutes loading the game from double clicking the icon... 240,000K (and going up without soundly process); ran in windowed mode

with opengl: 3 minutes in the loading, before the actual loading screen/squad logo (or even the window's sides panels) shown, the game crashes on every execution; still in windowed mode

WinXPPro sp3

Sapphire Radeon X1650

Single core CPU (intel P4 2.4 mmx)

1GB SD ram

3GB page file

despite the bottom-low-end hardware, I can still do mun missions from launch and back without crashing the game (with 9 other mods currently running)

Share this post


Link to post
Share on other sites

Since 1.0.2, I had lost the ability to use several mods that I'd enjoyed for environmental enhancement because of memory issues. This gave me back the clouds. Many beers are owed.

Share this post


Link to post
Share on other sites

Can Anyone Help I try to Run OpenGL for My KSP-32Bit install but it doesn,t make a difference in the RAM, it's like it doesn't run at all, and i have followed the OpenGL instructions exactly.Any answers please

Game info Verson 1.0.2 KSP 32bit ATM Texture re-placer both installed(20+Mods)+no Environmental Enhancements+Lowest Texture Settings

Nomal RAM usage(ATM+Texture re placer installed) on startup is:3.15GB

OpenGL+ATM+Texture re placer RAM usage on Start up is:3.15GB ...:(

Computer Specs Windows 7 Home Premium

Model:Inspiration 570/Processor:AMD Athlon II X3 450 Processor 3.20 GHz

RAM:6.00GB (5.75 GB Usable

System:64-Bit Operating System

Edited by Jeb Likes MOAR

Share this post


Link to post
Share on other sites

I take a bit of a performance hit, going from 45-60fps to 14-15 when I use OpenGL (in normal gameplay). I'm running Windows 7 Home Premium 64-bit on the following hardware:

-AMD Phenom II x4

-AMD R9 290

-8GB RAM

-ASUS M5A87 motherboard

Share this post


Link to post
Share on other sites

Working on open GL

Ram usage about 1.854.580K

but quite low details

realy HAVY moded instalation

using 2 weeks no crash so far somtimes FPS drops but its quite low end computer so its expected

without about 2.358.588K

Edited by sober667

Share this post


Link to post
Share on other sites

have a big performance hit in 1.0.4 when using OpenGL (doesn't matter if Linux or Windows7), heavy modded installation

The performance hit in 1.0.4 spikes at reentry- or aerodynamic effects. Even on a vanilla installation. In 1.0.2 the same craft, the same savegame runns smoothly. Deinstalling Eyecandy helps a little but even with lowest setting massive FPS drop on atmo/reentry effects..

i3770, 16GB RAM, Geforce 970, Windows7 or Linux

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.