Eisfunke

Less memory usage by using OpenGL

Recommended Posts

Lower your monitor resolution, start the game, then put your monitor resolution back up.

I normally run 1900x1200, but need to switch to 1440x900 for a few seconds top launch opengl mode. I can get the game launched by the time Windows reverts me back to 1900x1200 automatically.

How do I change it out side of the game?

Share this post


Link to post
Share on other sites
How do I change it out side of the game?

Look for SCREEN_RESOLUTION_WIDTH and SCREEN_RESOLUTION_HEIGHT in settings.cfg (in the folder with KSP.exe).

Share this post


Link to post
Share on other sites
Look for SCREEN_RESOLUTION_WIDTH and SCREEN_RESOLUTION_HEIGHT in settings.cfg (in the folder with KSP.exe).

Oh, I tried that, and it didn't work.

Edited by SmashingKirby148

Share this post


Link to post
Share on other sites

This came up recently here.

Big thanks to Tankman101, who found he could run KSP at one resolution setting below his maximum, so try deleting your settings.cfg, start KSP and don't use the settings that matches your screen resolution.

Share this post


Link to post
Share on other sites
This came up recently here.

Big thanks to Tankman101, who found he could run KSP at one resolution setting below his maximum, so try deleting your settings.cfg, start KSP and don't use the settings that matches your screen resolution.

Ok, I'll try that. Will I have to use the same resolution after that?

Share this post


Link to post
Share on other sites

Probably, Tankman101 was unable to run KSP at full resolution without experiencing the same error again.

Share this post


Link to post
Share on other sites
This came up recently here.

Big thanks to Tankman101, who found he could run KSP at one resolution setting below his maximum, so try deleting your settings.cfg, start KSP and don't use the settings that matches your screen resolution.

Started KSP after deleting the settings config. Getting the exact same message with the exact same dimensions even though a new config was created upon running the game which has 1280 x 720.

- - - Updated - - -

Wait! Nvm, it's gone. just had to run the game without open gl first. :P

Share this post


Link to post
Share on other sites

Even though I have a 373 MB GameData folder, my computer is always using all of its memory on KSP, so I hope this fixes that so I can record stuff!

Share this post


Link to post
Share on other sites

Hey! I'm experiencing an issue in that when I use "-force-opengl" my game crashes on entering any of the KSC facilities. I haven't really seen a post on this here yet, so I'm hoping someone can help me. Thanks for any help!

Share this post


Link to post
Share on other sites

Hi

I'm under win10, KSP1.04 and nvidia GTX, I used to have AA with opengl on an older KSP/Win version but I don't achieve to have it now. I use Nvidiacontrolpanel without success.

Could someone help me ?

Thanks

Share this post


Link to post
Share on other sites

Also , AFAIK unity's physics is singlethreaded , making i7 with virtual cores suffer (dont know about new 4xxx and 5xxx series , but on older ones disabling hyperthreading helps)

Stuff like moving ksp to ramdisk or separated core does not help a lot, new unity's multithread physics may help.

This is true. I just did a search to see if this was known yet or not. My rendering performance approximately doubled by disabling hyperthreading. Went from eight logical cores to four, and utilizing more than 27% of the CPU now instead of 15%.

I have the i7 4790.

Share this post


Link to post
Share on other sites

I'm using KSP 1.0.4 x86 (32bit) on an x64 machine, running it from steam, and I've seen that it has no loading bar on startup. it generates 'witty' loading hints, but it seems it isn't loading.

EDIT: itr is loading, but Kerbin is purple on start (probably from EVE)

EDIT : All of the menus are missing

Edited by Rory Yammomoto

Share this post


Link to post
Share on other sites

Ever since upgrading to 1.0.4 -force-opengl does nothing for me. I have a 1.08GB GameData folder, half-res textures in settings. Eveyrhting still not converted to .dds by default I did myself. Even so the moment I'm in the Space Centre viewthe game uses 3.1GB of RAM. Regardless of running in OpenGL, DirectX9 or DirectX 11. Previously on 0.90 with RSS and a huge number of part mods(1.6GB GameData folder) my game ran at around 2.8GB of RAM. Any ideas how to fix this?

Share this post


Link to post
Share on other sites

I am trying to not use OpenGL because it gives me some problems can anyone help to solve the problems

1.if I do OpenGL first during the loading I see a black square blocking 1/4 of the loading screen.

2.with OpenGL sometimes If i distturb the loading to much the screen goes black.

3.running in OpenGL if the game starts I can see ksp at 1/4 screen other screen is black.

4.running in OpenGL if I go to settings or credits it would not show it up it just shows the loading screen.

Share this post


Link to post
Share on other sites

Several versions ago I tried OpenGL without much luck. Game performance went down about as much as memory usage. Totally unplayable.
Today I decided to give it another try and to my surprise it actually worked this time. However I lost all anti-aliasing and all shadows. Any ideas (apart from not using OpenGL) on how to get those back.

Edited by Tex_NL

Share this post


Link to post
Share on other sites

I'm running about 49 mods, and it's working fine!

Only problem is the screen turns black sometimes.

Share this post


Link to post
Share on other sites

This is a great idea: better framerate, less crashes, ect. However the areo-dynamics don't work. Then again, for less RAM usage, I couldn't care less.

Share this post


Link to post
Share on other sites

When I try starting openGL in steam it doesn't work, it only crashes on start up. Could someone help me?

Share this post


Link to post
Share on other sites
On 6/14/2016 at 3:33 PM, bigguy4u said:

When I try starting openGL in steam it doesn't work, it only crashes on start up. Could someone help me?

-force-glcore  seems to work.

Share this post


Link to post
Share on other sites

Any idea why using the -force-opengl command line parameter in my KSP-64.exe shortcut would result in the game being rendered in a shifted and reduced size? (as in, the initial loading screen with the Squad Logo and the witty loading comments progress bar is noticeably smaller and shifted toward the bottom/left of my monitor: once game loaded, screen was black [apparently the game's main pane was being rendered below the area of my monitor?])

My rig:

MSI MS-7821 mobo, Intel i5-4690K 3.5GHz, 8GB RAM, Win7 / NVIDIA GeForce GTX 970 3.9GB

My guess is that either my VGA or my game resolution settings (1600 x 900) are not playing nice with the -force-opengl parameter.

I noticed about reduction of initial RAM use by the game of about 100% (drop from 7.9 to 5.4 GB) so I'd like to figure out how to take advantage of this, but graphics stuff is not a strong suit . . .

ADDIT: ah just noticed that " -force-glcore" command . . . might have to try that: also found this:

https://docs.unity3d.com/Manual/CommandLineArguments.html

Edited by Diche Bach

Share this post


Link to post
Share on other sites

Is there any way this could be fixed because I was just opening my save and I just saw THIS...

 

Share this post


Link to post
Share on other sites
13 minutes ago, StickLabs said:

Is there any way this could be fixed because I was just opening my save and I just saw THIS...

You'd have to ask Unity. We should all know by now Squad doesn't look at things that can be blamed on Unity...
As for why Unity doesn't officially support OpenGL on windows: :confused: It's not like OpenGL is unusual or anything.

Share this post


Link to post
Share on other sites
58 minutes ago, steve_v said:

You'd have to ask Unity. We should all know by now Squad doesn't look at things that can be blamed on Unity...
As for why Unity doesn't officially support OpenGL on windows: :confused: It's not like OpenGL is unusual or anything.

Oh, ok.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.