Jump to content

[1.2] USI Survivability Pack (Formerly DERP) [v0.6.0]


RoverDude
 Share

Recommended Posts

On an unrelated note: How do you envision the monoprop fuel cell working?  I'm going through and making a config to add water outputs to my fuel cells (one of their main advantages is that they can feed life support then), but I wasn't sure if that made any sense with this fuel cell.

Link to comment
Share on other sites

The KSP Add=on Version checker states that Firespitter 7.1.5 came with the Survivability Pack and that the current version is 7.2.  A couple of days ago, I attempted to update the Firespitter, but it has an impact on the landing legs.  Should I just keep ignoring it for now?

Link to comment
Share on other sites

As you know I`m a sucker for the Exploration pack, saw GamersCircle play with your D.E.R.P. mod and I just couldn`t resist! :D

Small search&rescue junior tug with KIS containers for repairs and 2 onboard derp escape pods:
 

Spoiler

FE1GuQA.png

With KIS working, a small cargo version to deliver 4 more lifeboats to be attached under the station (heatshield undocks to be redocked on the rear):
 

Spoiler

2vBPO7R.png

...to put it in perspective with the engineer to screw it all into place:
 

Spoiler

gAHA64F.png

 

As always, your mods are awsome! :kiss:

Link to comment
Share on other sites

I didn't see any mention of poor little DERPie in the 1.1 releases, so I went ahead and made a new issue on the git page for DERP for the last point (I'd hate for my comment to get lost in the 1.1 chaos:wink:). I noticed the TACLS Life Boat incompatibility was mentioned May '15, so I didn't add that. As a work around, I just added the resources to the pod straight out, and turned off fuelcrossfeed. Doesn't quite work as elegantly, but it's something I guess.

Cheers.

 

On 3/26/2016 at 0:56 AM, Deimos Rast said:

@RoverDude Greetings - huge fan of your work, I use pretty much all your mods, but far and away, I love the little DERP pod the most. In fact, I just finished "customizing" the entire DERP product line (not that it wasn't already great before, I just like fiddling). Anyway, a few things:

  • What determines which resources "ModuleStoredResource" will accept(I'm assuming that's a custom module of your's, from the Lifeboat.dll as I've seen it no where else)? It will accept Xenon Gas for example, but not Food/Water/Oxygen, which is surprising. If you're open to suggestions, maybe let that be something customizable or worst case, you could peg it to CRP. I could understand if the flow/transfer settings came into play (I also tried Ablator for example), but, well, you get the idea.
  • How does the "LifeBoat" module work exactly? We a have "dampenFactor" and "dampenSpeed"...is that just a general velocity/ dampener (as the second name would suggest)?
  • A suggestion: Connected Living Spaces compatibility to better enable crew transfers (although if your pod works anything like a "deployableHabRestrictor" there could be an issue without an initial crew capacity value)
  • And lastly, I noticed you gave the DERP Pod a "ModuleAblator" (ablativeResource = Ablator), but never actually gave it the Resouce Ablator. I thought maybe you added it in a MM patch, but couldn't find any. You do have a DRE patch, and looking in there I see you giving "ModuleHeatShield" and Resource AblativeShielding to a certain "USI_PodCapsule" (specifically FOR[SrvPack]). The only pod in the SrvPack, the DERP Pod, is part name "DERP_POD."

On the last point, I just want to say I am pretty new to reading configs and patches and such, so I could well be misreading the entire thing. Either way, thanks a ton for all the content you provide and the work you've done.:)

Cheers.

 

 

 

Link to comment
Share on other sites

Hi @RoverDude, first thank you for your amazing work!

I think I found a bug in the latest (0.5.0 for KSP 1.1) release.

It's about the parachute of the DERP Inflatable Escape Pod: when I launch a vessel, it's default state is ARMED. Even if I manage to disarm it before liftoff, its behavior is strange, it get released/damaged upon reentry even if it's set on the upmost stage and NOT activated.

Sorry for not feeding more infos; if I'll have some spare time later this week, I'll dig into this with a reproductible test case and some screenshots.

I'm currently using KSP 1.1.0.1196, latest USI mods (no CKAN!), latest MechJeb release.

To be clear, I'm not asking for a quickfix. I only hope this helps you for a more stable release upon KSP 1.1.

Hope it helps somehow, and thanks again!

- Wulf

Link to comment
Share on other sites

1 minute ago, RoverDude said:

Thanks - did you log a github issue?  That's the best way for me to not lose track of these :)

I don't have a github account (yet) but sure, I can do that. I'll post it on the issue tracker. :wink:

- Wulf

Link to comment
Share on other sites

  • 2 weeks later...

Not sure if this is intentional or not but the DERP solar panels only seem draw power from one side.  It's not a huge deal as I know they are simple, early game solar panels, but they have cells on both sides so I wasn't sure.  There is a chance some weird probe part is blocking them (just not visibly)  I haven't done extensive checking yet with other probe designs (i use CTT and love that I get them early in the tree so I've started using them for probes and as backup power systems).  

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...