Jump to content

[1.2] USI Survivability Pack (Formerly DERP) [v0.6.0]


RoverDude
 Share

Recommended Posts

48 minutes ago, Tarheel1999 said:

Might be a mod incompatibility. I don't recognize the change name tag in your right click menu. Unfortunately the best way to test for this is to take a clean KSP install and just add this mod and its dependencies. You could also look for exceptions in your logs. 

Well, I started a fresh clean install of ksp and copied only the surv pack in and the bags work. I then copied my mods in and now the bags don't work. Can you please tell me what you mean by looking for exceptions? how do I do that? Which log do I need to pull up? 

Link to comment
Share on other sites

Sure. If you scroll down to the logs section of the following link it will tell you where the logs are located. If you put them on Dropbox,  google docs or equivalent and link them here, I'll take a look at them this weekend. You can also search them for "exception" to see if you can find the mod causing a problem. 

 

Link to comment
Share on other sites

13 minutes ago, Tarheel1999 said:

Sure. If you scroll down to the logs section of the following link it will tell you where the logs are located. If you put them on Dropbox,  google docs or equivalent and link them here, I'll take a look at them this weekend. You can also search them for "exception" to see if you can find the mod causing a problem. 

 

Thank you very much. I tried to install Exception Detector mod, but apparently it's not comp with 1.1.3. Here is a link to my output log: 

https://1drv.ms/t/s!AvUWxjgM4SuQhbIw2FqHX3XjyDlXMg

Link to comment
Share on other sites

I took a quick look and you have a bunch of Mods that are failing to load properly. I would do two things to start:

1) Remove Tarsier Space. In the past, Tarsier was known to break other mods. I don't if this has been fixed but it had/has a bad reputation. 

2) Make sure you are up to date on all your mods. 

When I have more time I'll take a deeper look at the logs. 

Edited by Tarheel1999
Link to comment
Share on other sites

If you search for "exception" in the output_log you will see a lot of DLLs are failing to load properly.  One of them is AirbagTools.dll.  This is the dll which enables the functionality of the airbags. My guess is that one of your mods is preventing those mods from loading properly  Unfortunately, I can't tell from your log which mod is causing the incompatibility. KerbalKonstructs might be the problem but I can't be sure. It does state the following in the log:

AssemblyLoader: Assembly 'KerKonConConExt' has not met dependency 'KerbalKonstructs' V0.9
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

AssemblyLoader: Assembly 'KerKonConConExt' is missing 1 dependencies

From looking at the forum post for Tarsier Space, I would no longer recommend removing it outright as I see JPLRepo picked it up and has been maintaining it.  

To try and fix the problem, I would start with removing Kerbal Konstructs to see if this solves your problem.  If it does, redownload KK and see if a reinstall will fix the problem.  If removing KK does not fix the problem you will need to do a binary sort.  Start by removing all mods again and make sure the airbags work.  Then add half of your mods to the install and check again.  If the airbags sill work, remove those mods and add the other half.  Once you find a group of mods that cause a problem, split those mods in half and do this same thing until you find the culprit.  You have a lot of mods installed so it's possible there is more than one incompatibility.

Going forward I was suggest starting from scratch in 1.2 and slowly add mods as you so desire.

Link to comment
Share on other sites

40 minutes ago, Tarheel1999 said:

From looking at the forum post for Tarsier Space, I would no longer recommend removing it outright as I see JPLRepo picked it up and has been maintaining it.  

To try and fix the problem, I would start with removing Kerbal Konstructs to see if this solves your problem.  If it does, redownload KK and see if a reinstall will fix the problem.  If removing KK does not fix the problem you will need to do a binary sort.  Start by removing all mods again and make sure the airbags work.  Then add half of your mods to the install and check again.  If the airbags sill work, remove those mods and add the other half.  Once you find a group of mods that cause a problem, split those mods in half and do this same thing until you find the culprit.  You have a lot of mods installed so it's possible there is more than one incompatibility.

Going forward I was suggest starting from scratch in 1.2 and slowly add mods as you so desire.

Thank you so much. I actually found the culprit. Turns out there was folder labeled Airbags within my USI folder. So that was probably conflicting with the srv pack. :rolleyes: I deleted the airbag folder and now the airbags open right up! Thanks for the help!!!! :P

Link to comment
Share on other sites

On 10/8/2016 at 1:56 PM, RoverDude said:

ummm.... you just deleted part of survivability pack...  the airbags :P

Does this mean I can't do a partial install of parts? I'm planning to put off my 1.2 update for a couple of weeks and in the meantime I was planning on messing around with the floaties from this mod as deployable dinghies for my coastal rescue vehicles.

Sorry if I derail the discussion.

Link to comment
Share on other sites

1 hour ago, Spark Plug said:

Does this mean I can't do a partial install of parts? I'm planning to put off my 1.2 update for a couple of weeks and in the meantime I was planning on messing around with the floaties from this mod as deployable dinghies for my coastal rescue vehicles.

Sorry if I derail the discussion.

You can do whatever you like BUT you shouldn't ask for support if you muck with the files or do a partial install. Doing anything but a complete install voids the warranty. 

Link to comment
Share on other sites

  • 2 weeks later...

In early versions DERP was just 2 parts package (inflatable lifeboat + all-in-one propulsion/service module). It was quite useful to build real emergency pods saving on part count at same time. While now it is interesting to play around with different options, it is much more than 2 parts, so it is not always suits emergency needs.

Okay, let's deny putting everything but engine + monoprop supply. It is now tree parts (lifeboat/service ring/inline monoprop engine), but you will miss electricity and any supplies. So... not even close to old days.

While one can still mod service ring with invisible parts... Are there any plans to bring some pre-packaged version back?

Link to comment
Share on other sites

58 minutes ago, ThirdOfSeven said:

In early versions DERP was just 2 parts package (inflatable lifeboat + all-in-one propulsion/service module). It was quite useful to build real emergency pods saving on part count at same time. While now it is interesting to play around with different options, it is much more than 2 parts, so it is not always suits emergency needs.

Okay, let's deny putting everything but engine + monoprop supply. It is now tree parts (lifeboat/service ring/inline monoprop engine), but you will miss electricity and any supplies. So... not even close to old days.

While one can still mod service ring with invisible parts... Are there any plans to bring some pre-packaged version back?

IMO probably doubtful.  And honestly I'm glad.  While the old DERP setup was fewer parts it was also far less useful.  The base only had just enough monoprop to deorbit the pod at Kerbin and land safely via parachute.  It was useless for any other bodies.  And yes especially using USI MKS there were cases where I've used the Derp from an orbital base around say  the Mun to get a kerbal down to the surface of the Mun.

Link to comment
Share on other sites

Hello. I've just downloaded this mod and have had a bit of fun just messing around with escape pod designs. However I would like to move the escape pod parts to the life support category created by USI LS (which I also have). Is this possible or is there some sort of .dll magic/evil going on? Because I looked in the part descriptions of the USI LS parts and they didn't say 'category = life support' like expected. They just had structural and utility and the like. Anyone know how to change? Thanks,

Benji13. 

Edited by Benji13
Link to comment
Share on other sites

9 hours ago, Benji13 said:

Hello. I've just downloaded this mod and have had a bit of fun just messing around with escape pod designs. However I would like to move the escape pod parts to the life support category created by USI LS (which I also have). Is this possible or is there some sort of .dll magic/evil going on? Because I looked in the part descriptions of the USI LS parts and they didn't say 'category = life support' like expected. They just had structural and utility and the like. Anyone know how to change? Thanks,

Benji13. 

To put things in life support, add the cck-lifesupport tag

Link to comment
Share on other sites

  • 2 weeks later...
On 11/3/2016 at 7:32 AM, MerlinsMaster said:

Hey guys, has anyone had an issue with the DERP pod where you have a kerbal inside, and at some point, the portrait camera is no longer showing up and there is no way to get the kerbal out?  

Yeah, i am having the same problem. It happens if i load a game/vessel with a kerbal inside the pod. The portrait returns if you switch to another vessel within physics range, and then switch back again.

It does not return if you switch to a vessel through the map view, or if you save and reload the game.

When i load the vessel i sometimes see a single frame with the uninflated pod, which might be related.

My current workaround is to only save the game with the kerbal outside the craft.

Link to comment
Share on other sites

6 hours ago, ToasterOvenHotTub said:

Yeah, i am having the same problem. It happens if i load a game/vessel with a kerbal inside the pod. The portrait returns if you switch to another vessel within physics range, and then switch back again.

It does not return if you switch to a vessel through the map view, or if you save and reload the game.

When i load the vessel i sometimes see a single frame with the uninflated pod, which might be related.

My current workaround is to only save the game with the kerbal outside the craft.

I didn't think of that workaround.  Thanks, that's good to know.  Although after that terrible experience, I've essentially sworn off using those in the future.:rolleyes: 

Link to comment
Share on other sites

5 hours ago, MerlinsMaster said:

I didn't think of that workaround.  Thanks, that's good to know.  Although after that terrible experience, I've essentially sworn off using those in the future.:rolleyes: 

If you want a good escape pod mod, I would suggest the REKT Escape Pods mod (It's fully compatible with USI-LS).

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...