Dr. Jet

[1.5.x]Dr. Jet's Chop Shop v0.11.4.3 (20.10.2018)

Recommended Posts

Someone suggested to make SSP Mk2 compatible with 1.25m designs. Now it is. 

zKniSKc.jpg

Will put that into next patch.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

Pushed that manned rover from dev thread into new release. 

s36KHGU.png

v 0.9 (should be 1.1 compatible, but cannot test it)

Parts: 

- New manned rover derived from rugged rover. Fully functional RPM compatible IVA.
- SSP Mk2 now has optional connectors to fit both 2.5m and 1.25m designs.

- Rugged Rover internal composition revised - it actually had more space for batteries. 1600 charge now (was 800).
- SP-RR-1 revised - now produce 5.5 e/s at Kerbin (was 4.5).

 

Bugfixes:
- Ven's Stock Revamp compatibility (use Ven's probeRoverBody model when available).
- Impeller animation is binded to FXModuleAnimateThrottle. No more spinning while engine is offline.
- Some other minor bugfixes.

 

P.S. Pushed that to SpaceDock, though uncertain if CKAN version will migrate correctly.

P.P.S. Feedback both here and in Dev Thread will significantly speed up any upcoming updates.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

Testing 1.1 compatibility. 

So far... 

  • RasterPropMonitor works partially (with new manned pod). No transparent windows, no MFD spawn in IVA. Other props work fine. -> Must migrate to JSIAdvTransparentPod module.
  • Shaders look... different. Particularly KSP/Specular wich gave my parts metallic look rather then dull grey... Will need to study new shaders perhaps.
  • Wheels on RuggedRover and Manned Rugged Rover show "Wheel blocked: yes" no matter what. Dunno what that means, but they don't respond neither for steering nor for throttle. I believe it's some stupid collider changes for TR2-L wheels. Yes. It's a BUG. Not on my side though. 
  • New wheel physics are AWFUL. Not that it has a direct impact on my mod, but since I'm providing rover parts... 
  • Crashed TWICE  directly from VAB when trying to add STOCK pieces to craft... And it wrote no log to find why... (ksp_x64.exe build 1230)
  • Buzzer had it's wheels disabled too, but that is easily fixed by re-placing them.

Other parts and crafts work fine. 

So... It's mostly compatible.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

RPM MFD issue was on RMP side. Update to new version to fix it. 

MRR transparent windows are fixed simply by changing "name = JSITransparentPod" to "name = JSIAdvTransparentPod" in config.

Shaders... still need to be investigated...

Share this post


Link to post
Share on other sites

Minor compatibility patch 0.9.0.1

  • Fixed MRR transparency problem for new version of RPM
  • Implemented new (KSP 1.1) gimbal system for deployable skycranes. Gimbal increased to 7 degrees but it won't turn "inside" and burn your payload anymore.
Edited by Dr. Jet

Share this post


Link to post
Share on other sites

RGHczMK.png

If you see THIS - it's a bug. Presumably on RPM side again.  Stock "Internal Overlay" is not yet supported by ChopShop, so it shouldn't look like that.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

roverBodyXL/probeRoverBodyXL seems not to be stock, at least the patch on PimpMyRover fails to load because of missing model and such.

Beside this, its a great mod! :thumbsup:

Edited by emerald

Share this post


Link to post
Share on other sites
8 hours ago, emerald said:

roverBodyXL/probeRoverBodyXL seems not to be stock, at least the patch on PimpMyRover fails to load because of missing model and such.

Beside this, its a great mod! :thumbsup:

My best guess is that you have Ven's Stock Part Revamp installed... and it has updated after my patch... and Ven's model for rover body is somewhere else... again.

If it's not the case - give me that log string - which file is not found?

Edited by Dr. Jet

Share this post


Link to post
Share on other sites
Quote

(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

PartLoader: Compiling Part 'Squad/Parts/Command/probeRoverBody/probeRoverBody/roverBodyXL'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 64)

NullReferenceException: Object reference not set to an instance of an object
  at KSPUtil.PrintModuleName (System.String moduleName) [0x00000] in <filename unknown>:0 
  at ModuleResource.Load (.ConfigNode node) [0x00000] in <filename unknown>:0 
  at ModuleReactionWheel.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0 
  at PartModule.Load (.ConfigNode node) [0x00000] in <filename unknown>:0 
  at Part.AddModule (.ConfigNode node) [0x00000] in <filename unknown>:0 
  at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0 
  at PartLoader+<CompileParts>c__Iterator4A.MoveNext () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

NullReferenceException: Object reference not set to an instance of an object
  at PartLoader.GetDatabaseConfig (.Part p) [0x00000] in <filename unknown>:0 
  at PartLoader.GetDatabaseConfig (.Part p, System.String nodeName) [0x00000] in <filename unknown>:0 
  at DragCubeSystem.LoadDragCubes (.Part p) [0x00000] in <filename unknown>:0 
  at Part+<Start>c__Iterator25.MoveNext () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)
 

%MODULE[ModuleReactionWheel]
{
	%PitchTorque = 20
	%YawTorque = 5
	%RollTorque = 20

	%RESOURCE
	{
		%rate = 2.0
	}
}

Resource name is missing, adding it fixes the error (I've misread the error message before :o).

Share this post


Link to post
Share on other sites

Minor compatibility patch 0.9.0.2

  • Changed MRR IVA model to work properly with both RPM and stock "Internal Overlay". Thanks, JPLRepo.

P.S. "Internal Overlay" now looks even better than RPM transparency. Weird but true.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites
diff -urNp pmr_StockRoverXL.cfg.orig pmr_StockRoverXL.cfg
--- pmr_StockRoverXL.cfg.orig   2016-04-24 17:06:58.855518761 +0200
+++ pmr_StockRoverXL.cfg        2016-04-24 17:07:29.509135538 +0200
@@ -37,6 +37,7 @@ manufacturer = Dr. Jet's Chop Shop
 
        %RESOURCE
        {
+               %name = ElectricCharge
                %rate = 2.0
        }
 }

This fixes the NRE.

(I don't have Ven's Stock Revamp installed.)

Share this post


Link to post
Share on other sites

I'm liking the inline chutes, but i couldn't figure out why an aircraft in career wouldn't launch with them out of the SPH. And then I realized, the inline chutes arbitrarily add 8-10m to the aircraft length?! I looked through the cfgs and couldn't find anything directly associated with that. where is size addition calculated?

Share this post


Link to post
Share on other sites
On 30.04.2016 at 11:14 AM, Venusgate said:

I'm liking the inline chutes, but i couldn't figure out why an aircraft in career wouldn't launch with them out of the SPH. And then I realized, the inline chutes arbitrarily add 8-10m to the aircraft length?! I looked through the cfgs and couldn't find anything directly associated with that. where is size addition calculated?

Bug confirmed. Most likely Unity animation issue, will look into that case.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

Yep. It was an animation glitch... Will have to rebuild all chutes. 

While I'm repairing chutes... any suggestions on their TechTree placement balance? 

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

I use SETI, but I suppose if I weren't, I'd start with the size 0 inline in tier 1, put base and 1tons in tier 4, 2tons in tier 5, and 5tons in tier 6.

Share this post


Link to post
Share on other sites

Greetings Dr. Jet! I've been playing around in the VAB with your lovely mod and poking its configs for a bit, and I have some feedback. If you're open to some suggestions, lavish praise and some mild critques, read on! If not that's cool too, just know that you've created some cool pieces.:)

Some stuff:

  • Is it intentional to give your remote tech enabled antenna a required minimum omni range of 100,000 Km (Mode0OmniRange = 100000) or a packet resource cost of 1? As I understand it, the antenna won't function unless you're 100,000 Km away from HQ and then you can send back data really inexpensively. I've toyed with the idea of making a custom Communotron 16 like that, but haven't yet; just curious if it's intentional or not.
  • I like the...let's call it the "Rover Reorientation Patch" - I've been looking for something that reorients rovers for mechjeb usability. Two things about it: It adds an SAS module to the rover, when I believe it already has one, and it seems to be missing a closing "}" at the very bottom in the part about the VenRevamp patch.
  • LeadBallast Weight - thank you for checking for CRP! Unfortunately, (I have CRP, but not Real Fuels), I don't get the option to tweak the quantity in the VAB. I checked the CRP definition and I think the issue is that, while it's set to "isTweakable = true" it's also set to "isVisible = false" which I think defeats the entire endeavour. Not sure on this one. RoverDude, in his SubPack, uses the resource "Lead" for ballast, which is both tweakable and visible (and in CRP), but it has a different flowmode and transfermode than I think you want (ALL_VESSEL & PUMP respectively).
  • Soil Sampler: You mentioned you were familiar with DMagic's Soil Analyzer in IR. I've tried using that, but had problems with the plugin (which is a different plugin from DMScienceAnimate incidentally). There is also the Science Sampler Drill from BahaD's EPL pack from back in something like 0.24 that works exactly like your's does, but is an auger/drill. I don't know if there is a way to get ModuleAnimateGeneric to respect animation speed in the VAB (I know Firespitter does, and it's "animSpeed = #" which might be the same), but it would be a nice feature, as currently your Sampler plays incredibly fast and it's hard to gauge where it will contact the ground.
  • Chutes - I really like this idea! (For some reason I'm seeing Real Chutes modules in them, even though I don't have the mod installed at the moment. I suspect that's a problem on my end though (adding a patch for that mod though would be awesome, I don't think I saw one). Could make the bases TweakScale-able? Also, the description mentions they are crew passable, but they aren't listed in the CLS patch as passable (or at all).
  • Space plane parts are amazing (one thing though - on the Wide Tricoupler: there is a sort of stretched blurry seam running the length of the inner tube on either side of the black accent)
  • Smart solar panels - awesome, although I only seem to have two, and the titles are different from what they are in the configs (not a major issue; was going to mention the dummy 'Extend Panel' Action but apparently you know about that already). A nitpick would be consistent color choice for solar panels, but that's cosmetic.
  • Lil Buzzer (a seam down the back by the way) - is there an analog in another part pack I can compare this to? I compared it to the SXT eFan and RoverDude's AES Micro Ducted Fan (he has a lot of fans if you're looking for references) and the results were a bit...well I should say I don't fully know how to read the curves, but this fan seems to be a bit of an odd duck, yeah? Again, I know you don't want to use Firespitter's, which is perfectly understandable (even though it is a great plugin). If you're looking for other ideas, you could check out KAX or WBI's Micro Jet from I think his Buffalo pack.
  • Skycrane is super slick! I also really like the internals of the Rugged Rover (and the transparent glass).
  • Colors - I really like your color choices. My biggest complaint of the pack, and it's pretty minor, is that some of the colors come across too bold (saturated I think is the technical term) and others come across too muted. Mainly the blues are very blue and the whites very white (contrast the saturated LTS white vs the stockish Space Plane parts white). Not as big of a deal on solar panels or "hazard yellow," just a general thing. If that's a design choice, then disregard comment.

That about sums it up. Your parts show a lot of creativity. Overall, I'm a fan.:)

Cheers.

 

Edited by Deimos Rast

Share this post


Link to post
Share on other sites
9 hours ago, Venusgate said:

I use SETI, but I suppose if I weren't, I'd start with the size 0 inline in tier 1, put base and 1tons in tier 4, 2tons in tier 5, and 5tons in tier 6.

SETI supports my mod, thus uses independant re-location of parts, I was talking about stock tree.

9 hours ago, Deimos Rast said:

Greetings Dr. Jet! I've been playing around in the VAB with your lovely mod and poking its configs for a bit, and I have some feedback. If you're open to some suggestions, lavish praise and some mild critques, read on! If not that's cool too, just know that you've created some cool pieces.:)

Some stuff:

  • Is it intentional to give your remote tech enabled antenna a required minimum omni range of 100,000 Km (Mode0OmniRange = 100000) or a packet resource cost of 1? As I understand it, the antenna won't function unless you're 100,000 Km away from HQ and then you can send back data really inexpensively. I've toyed with the idea of making a custom Communotron 16 like that, but haven't yet; just curious if it's intentional or not.
  • I like the...let's call it the "Rover Reorientation Patch" - I've been looking for something that reorients rovers for mechjeb usability. Two things about it: It adds an SAS module to the rover, when I believe it already has one, and it seems to be missing a closing "}" at the very bottom in the part about the VenRevamp patch.
  • LeadBallast Weight - thank you for checking for CRP! Unfortunately, (I have CRP, but not Real Fuels), I don't get the option to tweak the quantity in the VAB. I checked the CRP definition and I think the issue is that, while it's set to "isTweakable = true" it's also set to "isVisible = false" which I think defeats the entire endeavour. Not sure on this one. RoverDude, in his SubPack, uses the resource "Lead" for ballast, which is both tweakable and visible (and in CRP), but it has a different flowmode and transfermode than I think you want (ALL_VESSEL & PUMP respectively).
  • Soil Sampler: You mentioned you were familiar with DMagic's Soil Analyzer in IR. I've tried using that, but had problems with the plugin (which is a different plugin from DMScienceAnimate incidentally). There is also the Science Sampler Drill from BahaD's EPL pack from back in something like 0.24 that works exactly like your's does, but is an auger/drill. I don't know if there is a way to get ModuleAnimateGeneric to respect animation speed in the VAB (I know Firespitter does, and it's "animSpeed = #" which might be the same), but it would be a nice feature, as currently your Sampler plays incredibly fast and it's hard to gauge where it will contact the ground.
  • Chutes - I really like this idea! (For some reason I'm seeing Real Chutes modules in them, even though I don't have the mod installed at the moment. I suspect that's a problem on my end though (adding a patch for that mod though would be awesome, I don't think I saw one). Could make the bases TweakScale-able? Also, the description mentions they are crew passable, but they aren't listed in the CLS patch as passable (or at all).
  • Space plane parts are amazing (one thing though - on the Wide Tricoupler: there is a sort of stretched blurry seam running the length of the inner tube on either side of the black accent)
  • Smart solar panels - awesome, although I only seem to have two, and the titles are different from what they are in the configs (not a major issue; was going to mention the dummy 'Extend Panel' Action but apparently you know about that already). A nitpick would be consistent color choice for solar panels, but that's cosmetic.
  • Lil Buzzer (a seam down the back by the way) - is there an analog in another part pack I can compare this to? I compared it to the SXT eFan and RoverDude's AES Micro Ducted Fan (he has a lot of fans if you're looking for references) and the results were a bit...well I should say I don't fully know how to read the curves, but this fan seems to be a bit of an odd duck, yeah? Again, I know you don't want to use Firespitter's, which is perfectly understandable (even though it is a great plugin). If you're looking for other ideas, you could check out KAX or WBI's Micro Jet from I think his Buffalo pack.
  • Skycrane is super slick! I also really like the internals of the Rugged Rover (and the transparent glass).
  • Colors - I really like your color choices. My biggest complaint of the pack, and it's pretty minor, is that some of the colors come across too bold (saturated I think is the technical term) and others come across too muted. Mainly the blues are very blue and the whites very white (contrast the saturated LTS white vs the stockish Space Plane parts white). Not as big of a deal on solar panels or "hazard yellow," just a general thing. If that's a design choice, then disregard comment.

That about sums it up. Your parts show a lot of creativity. Overall, I'm a fan.:)

Cheers.

 

  • It's not a "minimum", it's an "off" setting. While antenna is stowed it still catches signal up to 100 km (enough to reach 50 km altitude where you usually deploy fairings and stuff).
  • Another typo? Will check it. 
  • Hm-m-m... Have checked it with RF but not CRP... Already have an idea how to fix.
  • Plays fast in VAB? Really don't know how to fix - plenty of mod parts have the same problem. Main animation is quite slow and comprehensible. On the other hand, it actually DOES NOT have to hit the ground like Dmagic parts, only landed state is counted, since it's stock science module. Aligning it right serves just cosmetic reasons.
  • Well, patch for RealChutes is possible, but why? RC already have inline chutes, and they are way better than mine. My chutes were made for those who don't want to install RC, but do want to balance return stage parachuting. The only reason would be that CLS-passable part since RC inline chutes are not passable... But you can just use an RC-supporting para-dock part from Sum-Dum or Ven's Revamp.
  • Backside of using stock textures. Will look into that but no promises.
  • You see 2 of 3 if you have TweakScale. It's a part of de-cluttering patch. Smaller one will be tweakscale-able.
  • "A bit of an odd duck" seems too english for me to understand. :blush: Is it "underpowered" or "overpowered"? When I was tweaking this impeller by try-and-fail (I guess it was the first non-Firespitter electric propeller in KSP), main goal was to make it flyable on all 4 stock atmospheric planets. If you have better curves for it, I will implement them.
  • I suck at texturing. Really. And all parts that looked like metal in 1.0.5 (partly saving me from shame) now look... strange.

Share this post


Link to post
Share on other sites

Found the root of evil for Counterweight part. ModuleManager has changed some features. It appears that nice unintrusive %RESOURCE_DEFINITION{} solution won't work anymore...

Strangely you was the very first to notice, as problem exists since KSP 1.0.5 at least (checked old build) and is visible even with CRP installed (but not visible with RealFuels).

I won't bundle heresy (CRP contains goddamned "Karbonite" and "Karborundum"), so the only solution left is dumb alphabetical overriding. It shouldn't break anything, since resource is a direct copy from CRP... hopefully...

Also it appears that "LeadBallast" is only tweakable now with RealFuels interface, but not with stock one... so I will use "Lead".

BTW, parachutes are almost ready. Some final checks for actual balance and I will update. 

Share this post


Link to post
Share on other sites

Turns out the issue with my parachutes was FAR actually - I had uninstalled Realchutes, but forgot about FAR's versions for RealChutes (RealChutesLite) that installed itself.

And I figured out the solarpanel tweakscale thing; I did a number of ninja edits to the posts.

By "bit of an odd duck" I was trying to say "I have no idea what to make of this engine please explain slowly" :D

If you want an analog of an engine that does just what you're thinking of, Wild Blue Industries JetWing runs on the custom resource Atmosphere, which is basically IntakeAir, but allows Angel-125 to define which planets it runs on. It's a part of the "WBI Tools" section of his mods (the resource handling / definition) and it's defined as Kerbin, Laythe, Eve and Duna. A copy can be found at his github page here.

 

Share this post


Link to post
Share on other sites

Patch 0.9.0.3 is out.

  • Fixed Unity animations for all chute parts that made "Engineer's Report" to improperly estimate vehicle size. Thanks to Venusgate for reporting this bug.
  • Added forgotten drogue chute.
  • Fixed Counterweight part to be tweakable again. Thanks to Deimos Rast for repoting this bug. (Hopefully this will NOT lead to problems with CRP other then small noncritical warning in log.)
  • Fixed a couple of typos and leftovers for stock rover body fixing patch.
10 minutes ago, Deimos Rast said:

Turns out the issue with my parachutes was FAR actually - I had uninstalled Realchutes, but forgot about FAR's versions for RealChutes (RealChutesLite) that installed itself.

And I figured out the solarpanel tweakscale thing; I did a number of ninja edits to the posts.

By "bit of an odd duck" I was trying to say "I have no idea what to make of this engine please explain slowly" :D

If you want an analog of an engine that does just what you're thinking of, Wild Blue Industries JetWing runs on the custom resource Atmosphere, which is basically IntakeAir, but allows Angel-125 to define which planets it runs on. It's a part of the "WBI Tools" section of his mods (the resource handling / definition) and it's defined as Kerbin, Laythe, Eve and Duna. A copy can be found at his github page here.

 

Well... impeller is working as it is. No need to set exact planets as it depends on atmospheric pressure. No pressure = no atmosphere = no thrust (at least it was so when I last checked). But you are right, thrust curves are weird. It should have much higher thrust in Eve's "souposphere" and much lower thrust at thin Duna's "ether", though atmCurve seems being set properly.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

any idea how to get the wheels on the manned rover working? if i put stock wheels if keeps swerving off to one side when driving...

Share this post


Link to post
Share on other sites
2 hours ago, Phers said:

any idea how to get the wheels on the manned rover working? if i put stock wheels if keeps swerving off to one side when driving...

It's a Squad/Unity united bug. Though Squad looks happy with what they did to wheel clipping and they didn't even marked that issue as a bug

I already tried a "layer 26 workaround", but it sucks. Anything you place on surface of rover will BLOCK the TR-2L wheels. And even if not - while riding around your wheels will suddenly stuck at some moment, rendering rover flying high.

gSsoS1q.png

Tried to find a "clipping-safe" offset. Oddest weirdness, as the clipping itself.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites

Can someone help me figure out how to get the RTGs to latch onto the nodes on the RTG rover body?

Share this post


Link to post
Share on other sites
1 hour ago, drhay53 said:

Can someone help me figure out how to get the RTGs to latch onto the nodes on the RTG rover body?

Turn them before attaching. Then if you STILL have troubles press and hold ALT key while snapping to disable surface attachment - like with a spaceplane payload.

Share this post


Link to post
Share on other sites

I have an issue, dunno if related.

To be able to use DirectX 11 I unfortunately had to get rid off RVE/EVE/Scatterer - so Earth is cloudless but what ever...

That is all I changed! I deleted

PartDatabase.cfg
Physics.cfg
GameData\ModuleManager.ConfigCache
GameData\ModuleManager.ConfigSHA
GameData\ModuleManager.Physics
GameData\ModuleManager.TechTree

started, it worked, better fps, yeah, went to VAB, wanted to load my last craft and then ...

"Contains locked or invalid parts"

Clicked on Load ...

"... the following parts missing:
AeroBlister2"

?? :angry:

Why?

The mod is there, the files are there, there is also the GameData\ChopShop\Structural\Blisters\blister2.cfg, but its entry is missing inside the ModuleManager.ConfigCache ...

The log (game still running):

https://www.dropbox.com/s/soruhacfvgug22k/2016-05-17-1%20Missing%20parts%20but%20files%20exist%20-%20AeroBlister2%20etc.7z?dl=0

It says
 

Config(!PART[AeroBlister2]:NEEDS[TweakScale]:FINAL) ChopShop/ModuleManager/TweakScale/!PART[AeroBlister2]:NEEDS[TweakScale]:FINAL

but I was able to attach them two days ago WITHOUT TweakScale in GameData.

Now TweakScale (v2.2.11.2) IS in GameData.

Could that be the culprit?

 

Edit:

I loaded the .craft with UltraEdit, deleted the parts and everything related to blister2 and saved it as "a variant" to be able to load it NOW.
Let's see how far I can go ...

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.